Списки управления доступом

Red Hat Enterprise Linux 4: Руководство по системному администрированию
Назад Вперёд

Глава 14. Списки управления доступом

С файлами и каталогами связаны наборы разрешений для владельца файла, группы, связанной с файлом и всеми остальными пользователями системы. Однако эти наборы разрешений имеют ограничения. Например, нельзя настроить разные разрешения для разных пользователей. Поэтому были реализованы Списки управления доступом (Access Control Lists, ACL).

Ядро Red Hat Enterprise Linux 4 обеспечивает поддержку ACL для файловой системы ext3 и экспортируемых файловых систем NFS. Списки ACL также работают в файловых системах ext3, доступных через Samba.

Помимо поддержки в ядре, реализация ACL также требует установки пакета acl. В нём содержатся утилиты для добавления, изменения, удаления и получения данных ACL.

Команды cp и mv копируют и перемещают все списки ACL, связанные с файлами и каталогами.

14.1. Монтирование файловых систем

Прежде чем можно будет использовать ACL для файла или каталога, необходимо смонтировать раздел, содержащий этот файл или каталог, с поддержкой ACL. Если это локальная файловая система ext3, её можно смонтировать с помощью следующей команды:

mount -t ext3 -o acl <device-name> <partition>

Например:

mount -t ext3 -o acl /dev/VolGroup00/LogVol02 /work

Если же раздел описан в файле /etc/fstab, в запись этого раздела можно включить параметр acl:

LABEL=/work      /work       ext3    acl        1 2

Если файловая система ext3 сделана доступной через Samba и в ней включена поддержка ACL, Samba распознаёт ACL, так как она скомпилирована с параметром --with-acl-support. Для монтирования раздела Samba и обращения к нему никаких особенных флагов указывать не нужно.

14.1.1. NFS

По умолчанию, если файловая система, экспортируемая NFS-сервером, поддерживает ACL и NFS-клиент может прочесть ACL, клиентская система работает с ACL.

Чтобы при настройке сервера отключить поддержку ACL в NFS-ресурсах, включите параметр no_acl в файл /etc/exports. Чтобы отключить поддержку ACL в NFS-ресурсе при монтировании его клиентом, монтируйте его, передав параметр no_acl в командой строке или указав в файле /etc/fstab.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Назначение ACL для доступа


Настройка проверки подлинности

Назад Вперёд

Глава 27. Настройка проверки подлинности

Когда пользователь регистрируется в системе Red Hat Enterprise Linux, система должна проверить сочетание имени и пароля пользователя, или проверить подлинность существуюшего и активного пользователя. Бывает, что данные для проверки пользователя находятся на локальном компьютере, а бывает, что система проверяет подлинность, обращаясь к базе данных пользователей на удалённом компьютере.

Средство Конфигурация аутентификации (Authentication Configuration Tool) предоставляет графический интерфейс для настройки подсистем NIS, LDAP и Hesiod для получения сведений о пользователях, а также настройки LDAP, Kerberos и SMB в качестве протоколов проверки подлинности.

Замечание | Замечание
 | Если во время установки или с помощью средства Настройка уроня безопасности (Security Level Configuration Tool) вы включили высокий или средний уровень безопасности, механизмы проверки подлинности по сети, включая NIS и LDAP, не будут работать с брандмауэром.

В этой главе не рассматриваются тонкости всевозможных видов проверки подлиности. Она рассказывает о том, как настроить их с помощью средства Конфигурация аутентификации (Authentication Configuration Tool). За дополнительной информацией об опредёлённых видах проверки подлинности обратитесь к Справочному руководству по Red Hat Enterprise Linux.

Чтобы запустить графическую версию Конфигурации аутентификации (Authentication Configuration Tool) с рабочего стола, выберите в Главном меню (Main Menu) (на панели) => Системные параметры (System Settings) => Аутентификация (Authentication) или введите команду system-config-authentication в приглашении оболочки (например, в XTerm или терминале среды GNOME). Чтобы запустить текстовую версию, выполните в приглашении оболочки от имени root команду authconfig.

Важно | Важно
 | Внесённые изменения вступают в силу сразу после выхода из программы.

27.1. Информация пользователя

На вкладе Информация пользователя (User Information) определяются несколько параметров. Чтобы включить параметр, щёлкните пустой флажок, расположенный рядом. Чтобы отключить параметр, щёлкните расположенный рядом флажок, чтобы снять его. Нажмите кнопку Ok, чтобы выйти из программы и сохранить изменения.

Рисунок 27-1. Информация пользователя

Настраиваемые параметры описываются в следующем списке:

  • Включить поддержку NIS (Enable NIS Support) — Отметьте этот флажок, чтобы настроить систему в качестве NIS-клиента, который подключается к NIS-серверу для проверки имени и пароля. Нажмите кнопку Настроить NIS (Configure NIS), чтобы определить домен и сервер NIS. Если сервер NIS не определён, демон пытается найти его, используя широковещательные запросыt.

    Чтобы этот вариант работал, должен быть установлен пакет ypbind. Если поддержка NIS включена, службы portmap и ypbind запускаются и настраиваются на запуск при загрузке системы.

  • Включить поддержку LDAP (Enable LDAP Support) —Отметьте этот флажок, чтобы настроить систему для получения информации пользователей через LDAP. Нажмите кнопку Настроить LDAP (Configure LDAP), чтобы указать Базовый DN для поиска в LDAP (LDAP Search Base DN) b LDAP-сервер (LDAP Server). Если выбран вариант Использовать TLS для шифрования соединения (Use TLS to encrypt connections), для шифрования паролей, передаваемых серверу LDAP, используется протокол TLS.

    Чтобы этот вариант работал, должен быть установлен пакет openldap-clients.

    За дополнительными сведениями о LDAP обратитесь к Справочному руководству по Red Hat Enterprise Linux.

  • Включить поддержку Hesiod (Enable Hesiod Support) — Установите этот флажок, чтобы настроить систему для получения информации, в том числе, информации пользователей, из удалённой базы данных Hesiod.

    Для этого должен быть установлен пакет hesiod.

  • Winbind — Выберите этот флажок, чтобы настроить систему для подключения к Windows Active Directory или контроллеру домена Windows. Это позволяет получать данные пользователей, а также настроить параметры проверки подлинности сервера.

  • Кэшировать информацию о пользователе (Cache User Information) — Установите этот флажок, чтобы включить демон кэша сервера имён (nscd) и настроить его запуск во время загрузки.

    Чтобы этот вариант работал, должен быть установлен пакет nscd.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Проверка подлинности


Автоматизация задач

Назад Вперёд

Глава 35. Автоматизация задач

В Linux вы можете настроить автоматический запуск заданий в опредёлённый период времени, в определённый день или в момент, когда средняя нагрузка системы опускается ниже заданного значения. В Red Hat Enterprise Linux предварительно настроены важные системные задачи для поддержания актуального состояни системы. Например, база данных slocate, используемая командой locate, обновляется ежедневно. Системный администратор может использовать автоматизацию для выполнения периодического резервного копирования, наблюдения за системой, запуска собственных сценариев и т. д.

В Red Hat Enterprise Linux включены несколько утилит автоматизации задач: cron, at и batch.

35.1. Cron

Cron — это демон, который можно использовать для назначения запуска повторяющихся заданий по расписанию, задаваемого по времени, дню месяца, месяцу, дню недели и неделям.

Cron подразумевает, что система работает непрерывно. Если система не была включена в момент, на который была назначено задание, оно не будет выполнено. За информацией о назначении одноразовых заданий, обратитесь к разделу 35.2 Задания at и batch.

Для использования службы cron, необходимо, чтобы был установлен RPM-пакет vixie-cron и работала служба crond. Чтобы определить, установлени ли этот пакет, выполните команду rpm -q vixie-cron. Чтобы определить, работает ли служба, воспользуйтесь командой /sbin/service crond status.

35.1.1. Настройка заданий cron

Основной файл конфигурации cron, /etc/crontab, содержит следующие строки:

SHELL=/bin/bash
PATH=/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=root
HOME=/

# run-parts
01 * * * * root run-parts /etc/cron.hourly
02 4 * * * root run-parts /etc/cron.daily
22 4 * * 0 root run-parts /etc/cron.weekly
42 4 1 * * root run-parts /etc/cron.monthly

Первые четыре строки — это переменные, настраивающие окружение, в котором будут работать задачи cron. Переменная SHELL сообщает системе, какую оболочку использовать (в данном примере это оболочка bash), а переменная PATH определяет пути, используемые при выполнении команд. Результат выполнения задач cron будет выслан по электронной почте пользователю, определённому в переменной MAILTO. Если в качестве значения переменной MAILTO задана пустая строка (MAILTO=""), электронные письма не отправляются. Переменная HOME задаёт домашний каталог, используемый при выполнении команд или сценариев.

Каждая строка в файле /etc/crontab представляет отдельное задание и имеет следующий формат:

minute   hour   day   month   dayofweek   command

  • minute — любое целое число от 0 до 59

  • hour — любое целое от 0 до 23

  • day — любое целое от 1 до 31 (день должен быть допустимым, если задан месяц)

  • month — любое целое от 1 до 12 (или краткое название месяца, например, jan, feb и т. д.)

  • dayofweek — любое целое от 0 до 7, где 0 или 7 обозначает воскресенье (или краткое название дня недели, например, sun или mon)

  • command — выполняемая команда (это может команда вроде ls /proc >> /tmp/proc или команда, запускающая дополнительный сценарий)

Для любых указанных выше параметров можно использовать звездочку (*), что означает все допустимые значения. Например, если поставить звёздочку в значении месяца, команда будет выполняться каждый месяц в день, определённый другими параметрами.

Дефис (-) между целыми числами обозначает диапазон чисел. Например, 1-4 обозначает набор целых чисел 1, 2, 3 и 4.

Последовательность значений, разделенных запятыми (,), обозначает список. Например, перечисление 3, 4, 6, 8 обозначает четыре указанных целых числа.

Прямая косая черта (/) используется для определения шага значений. Число в диапазоне может быть пропущено, если после диапазона указать /<целое>. Например, значение поля минут 0-59/2, определяет, что будет пропущена каждая вторая минута. В качестве шага значений также может быть указана звёздочка. Например, чтобы запускать задание раз в три месяца, в поле месяца можно использовать значение */3

Любые строки, начинающиеся с символа решетки (#), являются комментариями и не обрабатываются.

Как показывает пример файла /etc/crontab, сценарий run-parts запускает сценарии в каталогах /etc/cron.hourly/, /etc/cron.daily/, /etc/cron.weekly/ и /etc/cron.monthly/ каждый час, день, неделю, месяц соответственно. Файлы в этих каталогах должны быть сценариями оболочки.

Если задание cron нужно выполнить по расписанию, но не ежечасно, ежедневно, еженедельно или ежемесячно, его можно добавить в каталог /etc/cron.d. Все файлы в этом каталоге имеют тот же синтаксис, что и /etc/crontab. Примеры заданий показаны в примере 35-1.

# записывает данные об использовании памяти в системе каждый понедельник
# в 3:30 в файл /tmp/meminfo
30 3 * * mon cat /proc/meminfo >> /tmp/meminfo
# запускает специальный сценарий каждый день каждого месяца в 4:10
10 4 1 * * /root/scripts/backup.sh

Пример 35-1. Пример заданий crontab

Другие пользователи (не root) также могут настраивать задачи cron, используя программу crontab. Все созданные пользователями файлы crontab хранятся в каталоге /var/spool/cron/ и выполняются от имени создавшего их пользователя. Чтобы создать файл crontab для пользователя, войдите в систему под его именем и введите команду crontab -e, чтобы отредактировать его файл crontab с помощью редактора, указанного в переменной окружения VISUAL или EDITOR. Этот файл имеет тот же формат, что и /etc/crontab. При записи изменений файла crontab этот файл сохраняется под названием /var/spool/cron/username, в соответствии с именем пользователя.

Демон cron проверяет наличие изменений в файле /etc/crontab, каталоге /etc/cron.d/ и каталоге /var/spool/cron/ каждую минуту. Если обнаруживаются какие-либо изменения, они загружаются в память. Таким образом, демон не нуждается в перезапуске при изменении файла crontab.

35.1.2. Управление доступом к cron

Для ограничения доступа к cron используются файлы /etc/cron.allow и /etc/cron.deny. Формат списков управления доступом в обоих файлах прост — в каждой строке файла указывается одно имя пользователя. Пробельные символы в этих файлах не допускаются. Перезапускать демон cron (crond) после изменения файлов управления доступом не требуется. Файлы управления доступом обрабатываются каждый раз, когда пользователь пытается добавить или удалить задание cron.

Пользователь root может использовать cron, вне зависимости от того, какие пользователи перечислены в файлах управления доступом.

Если файл cron.allow существует, использовать cron разрешено только перечисленным в нём пользователям, а файл cron.deny игнорируется.

Если cron.allow не существует, пользователям, перечисленным в cron.deny, использовать cron не разрешается.

35.1.3. Запуск и остановка службы

Чтобы запустить службу cron, выполните команду /sbin/service crond start. Чтобы остановить её, выполните команду /sbin/service crond stop. Рекомендуется настроить запуск этой службы при загрузке системы. За подробными инструкциями по настройка автоматического запуска службы cron при загрузке системы обратитесь к главе 20 Управление доступом к службам.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Задания at и batch


Основная настройка брандмауэра

Назад Вперёд

Глава 19. Основная настройка брандмауэра

Так же, как настоящий брандмауэр в здании защищает его от распространения огня, компьютерный брандмауэр пытается защитить ваш компьютер от проникновения компьютерных вирусов и вторжения неавторизованных пользователей. Брандмауэр устанавливается между вашим компьютером и сетью. Он определяет, к каким службам вашего компьютера могут обращаться удалённые пользователи. Правильно настроенный брандмауэр может сделать вашу систему более безопасной. Брандмауэр рекомендуется настраивать в любой системе Red Hat Enterprise Linux, подключенной к Интернету.

19.1. Средство настройки уровня безопасности

Во время установки Red Hat Enterprise Linux диалог Настройка брандмауэра (Firewall Configuration) предлагал вам возможность включить основной брандмауэр, а также разрешить доступ к определённым устройствам, службам и портам.

После установки вы можете измените эти параметры с помощью средства Настройка уровня безопасности (Security Level Configuration Tool).

Чтобы запустить это приложение, выберите в Главном меню (Main Menu) (на панели) => Системные параметры (System Settings) => Уровень безопасности (Security Level) или введите команду system-config-network в приглашении оболочки (например, в XTerm или терминале среды GNOME).

Рисунок 19-1. Настройка уровня безопасности

Замечание | Замечание
 | Программа Настройка уровня безопасности настраивает только основные параметры брандмауэра. Если для вашей системы необходимы более сложные правила, обратитесь к Справочному руководству по Red Hat Enterprise Linux, где рассматривается настройка правил iptables.

19.1.1. Включение и отключение брандмауэра

Выберите одни из следующих вариантов:

  • Выключить брандмауэр (Disable firewall) — При отключении брандмауэра разрешается полный доступ к вашей системе и проверка безопасности не производится. Проверка безопасности подразумевает отказ в доступе к определённым службам. Этот вариант следует выбирать, только если вы работаете в закрытой сети (не в Интернете) или планируете настроить брандмауэр позже.

    Предупреждение Предупреждение

    Если у вас уже был настроен брандмауэр или вы определяли свои правила брандмауэра в файле /etc/sysconfig/iptables, выбор варианта Выключить брандмауэр (Disable firewall) и сохранение изменений нажатием OK приводит к удалению этого файла.

  • Включить брандмауэр (Enable firewall) — В этом режиме система отклоняет входящие подключения, кроме тех, что отвечают на исходящие запросы, как, например, ответы DNS или DHCP.. Если необходим доступ к службам, запущенным на этом компьютере, вы можете разрешить эти службы в брандмауэре.

    Если ваша система подключена к Интернет, и вы не планируете запуск серверных приложений, это самый безопасный выбор.

19.1.2. Доверенные службы

Список Доверенные службы (Trusted services) позволяет выбрать службы, подключения к которым могут проходить через брандмауэр.

WWW (HTTP)

Протокол HTTP используется Apache (и другими веб-серверами) для передачи веб-содержимого. Если вы планируете сделать ваш веб-сервер общедоступным, отметьте этот пункт. Установка этого параметра не требуется для локального просмотра или создания веб-страниц. Чтобы ваш компьютер выполнял роль веб-сервера, у вас должен быть установлен пакет httpd.

Включение WWW (HTTP) не открывает порт HTTPS, SSL-версии HTTP.

FTP

Протокол FTP используется для передачи файлов между компьютерами в сети. Если вы планируете сделать ваш FTP-сервер общедоступным, отметьте этот пункт. Чтобы этот выбор имел смысл, должен быть установлен пакет vsftpd.

SSH

Безопасная оболочка (Secure SHell, SSH) — это набор средств для подключения и выполнения команд на удалённом компьютере. Чтобы разрешить удалённый доступ к компьютеру через SSH, отметьте этот пункт. Чтобы вы могли удалённо обращаться к своему компьютеру, используя инструменты SSH, на компьютере должен быть установлен пакет openssh-server.

Telnet

Telnet — это протокол для входа на удалённые компьютеры. Соединения telnet не шифруются и не обеспечивают защиты от перехвата сетевых пакетов. Разрешать входящие telnet-соединения не рекомендуется. Чтобы доступ через Telnet был разрешён, у вас должен быть установлен пакет telnet-server.

Почта (Mail) (SMTP)

Чтобы разрешить доставку входящей почты через брандмауэр (чтобы к вашему компьютеру могли подключаться удалённые узлы, доставляющие почту), отметьте этот пункт. Вам не нужно включать его, если вы получаете почту на сервере вашего Интернет-провайдера, используя протокол POP3 или IMAP или программу fetchmail. Обратите внимание, неправильно настроенный SMTP-сервер может быть использован в качестве источника рассылки спама.

19.1.3. Доверенные устройства

Определив Доверенные устройства (Trusted Devices) вы разрешаете полный доступ к вашей системе с этих устройств; они исключаются из правил брандмауэра. Например, если вы работаете в локальной сети, и подключаетесь к Интернету через модемное PPP-соединение, вы можете отметить eth0 и разрешить весь трафик, приходящий из локальной сети. Пометив eth0 как доверенное устройство, вы разрешаете весь трафик, приходящий через Ethernet, тогда как интерфейс ppp0 остаётся защищённым. Чтобы ограничить трафик интерфейса, оставьте его неотмеченным.

Вы можете заметить устройство sit0 в разделе Доверенные устройства (Trusted devices). Его название расшифровывается как Simple Internet Transition (простое преобразование Интернета), а его роль состоит во вложении трафика IPv6 в трафик IPv4. В правилах простого брандмауэра это устройство можно игнорировать и оставить недоверенным.

Важно | Важно
 | Не рекомендуется назначать Доверенным устройство, подключенное к сетям общего пользования, таким как Интернет.

19.1.4. Другие порты

В программе Настройка уровня безопасности (Security Level Configuration Tool) есть раздел Другие порты (Other ports), в котором можно определить свои IP-порты, которые должны считаться доверенными в iptables. Например, чтобы разрешить прохождение через брандмауэр протоколов NFS, IRC и протокола печати через Интернет (Internet Printing Protocol, IPP), в раздел Другие порты (Other ports) нужно добавить:

2049:tcp,194:tcp,631:tcp

19.1.5. Сохранение параметров

Нажмите OK, чтобы сохранить изменения и включить или отключить брандмауэр. Если выбран вариант Включить брандмауэр (Enable firewall), назначенные параметры преобразуются в команды iptables и сохраняются в файле /etc/sysconfig/iptables. Также запускается сама служба iptables, чтобы брандмауэр активизировался сразу после сохранения назначенных параметров. Если выбран вариант Отключить брандмауэр (Disable firewall), файл /etc/sysconfig/iptables удаляется, а служба iptables сразу останавливается.

Выбранные параметры также сохраняются в файле /etc/sysconfig/system-config-securitylevel, чтобы настройки можно было восстановить при следующем запуске приложения. Не редактируйте этот файл вручную.

И хотя брандмауэр активизируется сразу, служба iptables не настраивается для автоматического запуска при загрузке. Подробнее об этом рассказывается в разделе 19.2 Активизация службы iptables.

Назад | Начало | Вперёд
Сохранение и восстановление сетевых параметров | Вверх | Активизация службы iptables


Доступ к консоли

Назад Вперёд

Глава 28. Доступ к консоли

Когда обычные пользователи (не root) регистрируются на компьютере локально, им предоставляется два вида специальных разрешений:

  1. Они могут запускать определённые программы, выполнение которых в противном случае запрещено.

  2. Они могут получать доступ к определённым файлам (обычно, это специальные файлы устройств, используемые при обращении к дискетам, приводам CD-ROM, и так далее), к которым они не могут получить доступ, подключившись удалённо.

Так как на одном компьютере существует множество консолей, зарегистрироваться локально могут одновременно несколько пользователей, один из них должен по сути «выиграть гонку» для получения доступа к файлам. Этими файлами владеет первый пользователь, зарегистрировавшийся на консоли. Когда этот пользователь выходит из системы, ими будет владеть следующий вошедший пользователь.

Но при этом любому пользователю, вошедшему в систему на консоли, разрешено запускать программы, выполняющие действия, обычно разрешённые только пользователю root. Если используется система X, к таким действиям относятся и пункты меню в графическом интерфейсе пользователя. По умолчанию, в число программ, доступных на консоли, входят halt, poweroff и reboot.

28.1. Запрет отключения с помощью [Ctrl]-[Alt]-[Del]

По умолчанию в файле /etc/inittab определяется, что ваша система будет остановлена и перезагружена при нажатии на консоли комбинации клавиш [Ctrl]-[Alt]-[Del]. Чтобы полностью отключить эту возможность, закомментируйте следующую строку в файле /etc/inittab, поставив знак решётки (#) в начале строки:

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

С другой стороны, вы можете разрешить определённым пользователям (не root) выключать систему с консоли, используя [Ctrl]-[Alt]-[Del]. Эту привилегию можно дать определённым пользователям, выполнив следующие действия:

  1. Добавьте параметр -a в показанную выше строку файла /etc/inittab, чтобы она выглядела так:

    ca::ctrlaltdel:/sbin/shutdown -a -t3 -r now

    Флаг -a указывает команде shutdown проверять файл /etc/shutdown.allow.

  2. Создайте файл shutdown.allow в каталоге /etc. Файл shutdown.allow должен содержать имена пользователей, которым позволено выключать систему, используя [Ctrl]-[Alt]-[Del]. Файле shutdown.allow представляет собой список имён пользователей, по одному в строке, и выглядит примерно так:

    stephen
jack
sophie

В этом примере файла shutdown.allow пользователям stephen, jack и sophie разрешается отключать систему с консоли, используя сочетание клавиш [Ctrl]-[Alt]-[Del]. Когда пользователь нажимает эти клавиши, команда shutdown -a в файле /etc/inittab проверяет, присутствует ли пользователь, зарегистрированный на виртуальной консоли, в файле /etc/shutdown.allow (или это root). Если это так, отключение системы продолжается; в противном случае на консоль выводится сообщение об ошибке.

За дополнительными сведениями о shutdown.allow обратитесь к странице man shutdown.

Назад | Начало | Вперёд
Настройка системы | Вверх | Запрещение доступа к программам консоли


Настройка даты и времени

Назад Вперёд

Глава 29. Настройка даты и времени

Средство Свойства даты/времени (Time and Date Properties Tool) позволяет пользователю изменить системные дату и время, определить часовой пояс, используемый системой, и настроить демон протокола сетевого времени (Network Time Protocol, NTP), синхронизирующий часы компьютера с сервером времени.

Чтобы использовать это средство, вы должны работать в системе X Window и иметь права root. Запустить это приложение можно тремя способами:

  • На рабочем столе выбрать в меню Приложения (Applications) (на панели) => Системные параметры (System Settings) => Дата и время (Date & Time)

  • На рабочем столе щёлкнуть правой кнопкой панель инструментов и выбрать Установить дату и время (Adjust Date and Time).

  • Ввести команду system-config-date, system-config-time или dateconfig в приглашении оболочки (например, в XTerm или терминале среды GNOME).

29.1. Свойства даты и времени

Как показано на рисунке 29-1, на первой вкладке появившегося окна настраивается дата и время системы.

Рисунок 29-1. Свойства даты и времени

Чтобы изменить дату, воспользуйтесь стрелками слева и справа от названия месяца для выбора месяца, стрелками слева и справа от года для выбора года и щёлкните день недели, чтобы выбрать другой день. Изменения вступают в силу после нажатия кнопки OK.

Чтобы изменить время, воспользуйтесь стрелками вверх и вниз рядом с полями Час (Hour), Минута (Minute) и Секунда (Second) в разделе Время (Time). Изменения вступают в силу после нажатия кнопки OK.

Нажатие кнопки OK приводит к применению всех внесённых изменений даты, времени, настроек демона NTP и параметров часового пояса. Это также приводит к завершению программы.

Назад | Начало | Вперёд
Группа floppy | Вверх | Свойства сетевого протокола времени (NTP)


Протокол динамической конфигурации узлов (DHCP)

Назад Вперёд

Глава 24. Протокол динамической конфигурации узлов (DHCP)

Протокол динамической конфигурации узлов (Dynamic Host Configuration Protocol, DHCP) — сетевой протокол для автоматического назначения параметров TCP/IP клиентским компьютерам. Каждый клиент DHCP соединяется с выделенным DHCP-сервером, который возвращает ему параметры сети, включая IP-адрес, адреса шлюза и DNS-серверов.

24.1. Зачем использовать DHCP?

DHCP очень полезен для автоматического определения конфигурации сетевых интерфейсов клиентов. Настраивая клиентский компьютер, администратор может использовать DHCP, вместо того, чтобы вводить вручную IP-адрес, маску сети, адреса шлюза и DNS-серверов. Клиент получает всю эту информацию с DHCP-сервера. DHCP также полезен, если администратор желает изменить IP-адреса большого числа компьютера. Вместо того, чтобы перенастраивать все компьютеры, он может изменить на сервере всего лишь один файл конфигурации DHCP для нового набора IP-адресов. Если адреса DNS-серверов в организации меняются, изменения вносятся только на DHCP-сервере, а не на всех клиентах DHCP. Изменения вступают в силу сразу после перезапуска сети на клиентских компьютерах (или перезагрузки этих компьютеров).

Кроме того, если портативный компьютер настроен на использование DHCP, он может перемещаться из офиса в офис без изменений конфигурации, если в этих офисах есть DHCP-серверы, позволяющие ему соединяться с сетью.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Настройка DHCP-сервера


Реализация дисковых квот

Назад Вперёд

Глава 13. Реализация дисковых квот

Дисковое пространство можно ограничивать, внедряя дисковые квоты, которые позволяют уведомить системного администратора о том, что пользователь занял слишком много места на диске или раздел заполнился.

Дисковые квоты можно настраивать как для отдельных пользователей, так и для групп. Такая гибкость позволяет отвести каждому пользователю небольшую квоту для «личных» файлов (например, электронной почты и отчётов), а проектам, над которыми они работают, дать больше места (если для каждого проекта создана отдельная группа).

Кроме этого, квоты можно назначать не только для того, чтобы управлять количеством занятых блоков на диске, но и числом дескрипторов inode (структур данных, содержащих информацию о файлах в файловых системах UNIX). Так как дескрипторы inode используются для хранения информации. связанной с файлами, это позволяет определять число файлов, которые можно создать.

Чтобы вы могли внедрить дисковые квоты, у вас должен быть установлен RPM-пакет quota. За дополнительными сведениями об установке RPM-пакетов обратитесь к части III Управление пакетами.

13.1. Настройка дисковых квот

Чтобы внедрить дисковые квоты, выполните следующие действия:

  1. Включите квоты в файловой системе, отредактировав файл /etc/fstab.

  2. Перемонтируйте файловую систему (системы).

  3. Создайте файлы базы данных квот и постройте таблицу использования диска.

  4. Назначьте политики квот.

Каждое из этих действий рассматривается подробнее в следующих разделах.

13.1.1. Включение квот

Воспользуйтесь текстовым редактором и отредактируйте файл /etc/fstab от имени root. Добавьте в описание файловых систем, в которых требуется включить квоты, параметр usrquota и/или grpquota:

/dev/VolGroup00/LogVol00 /         ext3    defaults        1 1
LABEL=/boot              /boot     ext3    defaults        1 2
none                     /dev/pts  devpts  gid=5,mode=620  0 0
none                     /dev/shm  tmpfs   defaults        0 0
none                     /proc     proc    defaults        0 0
none                     /sys      sysfs   defaults        0 0
/dev/VolGroup00/LogVol02 /home     ext3    defaults,usrquota,grpquota  1 2
/dev/VolGroup00/LogVol01 swap      swap    defaults        0 0
.
.
.

В этом примере для файловой системы /home включаются квоты и для пользователей, и для групп.

Замечание | Замечание
 | В следующих примерах предполагается, что при установке Red Hat Enterprise Linux был создан отдельный раздел /home. Хотя это и не идеально, корневой раздел (/) (раздел, по умолчанию создаваемый программой установкой) также может использоваться для назначения политик квот в файле /etc/fstab.

13.1.2. Перемонтирование файловых систем

Добавив параметр usrquota и/или grpquota, размонтируйте все файловые системы, записи которых вы изменили в fstab. Если файловая система не используется никакими процессами, примените один из следующих способов:

  • Выполните команду umount, а за ней команду mount, чтобы перемонтировать файловую систему.

  • Выполните команду mount -o remount /home, чтобы перемонтировать файловую систему.

Если ваша файловая система в данный момент используется, проще всего будет перемонтировать её, перезагрузив систему.

13.1.3. Создание файлов базы данных квот

После того, как все файловые системы, в которых включены квоты, перемонтированы, система может работать с дисковыми квотами. Однако, сам файловая система ещё не готова к поддержке квот. Следующим действием должен быть запуск команды quotacheck.

Команда quotacheck проверяет файловые системы, в которых включены квоты, и строит таблицу текущего использования диска в файловых системах. Затем эта таблица используется для обновления системной копии данных об использовании диска. Кроме этого, обновляются файлы дисковых квот в файловой системе.

Чтобы создать в файловой системе файлы квот (aquota.user и aquota.group), воспользуйтесь параметром -c команды quotacheck. Например, если для файловой системы /home включены квоты пользователей и групп, создайте эти файлы в каталоге /home:

quotacheck -cug /home

Параметр -c показывает, что файлы квот следует создать для всех файловых систем, в которых включены квоты, параметр -u выполняет проверку квот пользователей, а параметр -g — проверку квот групп.

Если параметры -u и -g не указаны, создаётся только файл квот пользователей. Если указан только параметр -g, создаётся только файл квот групп.

После того как эти файлы будут созданы, запустите следующую команду, чтобы построить таблицу текущего использования диска в файловых системах, в которых включены квоты:

quotacheck -avug

Используемые параметры описаны ниже:

  • a — Проверяет все локально смонтированные файловые системы, в которых включены квоты

  • v — Выводит подробную информацию о процессе проверке квот

  • u — Проверяет информацию о дисковых квотах пользователей

  • g — Проверяет информацию о дисковых квотах групп

После завершения работы quotacheck, файлы квот, соответствующие включённым квотам (пользователей и/или групп) заполняются данными о каждой локально смонтированной файловой системе с включёнными квотами, как, например /home.

13.1.4. Назначение квот на уровне пользователей

Последний этап назначения дисковых квот выполняется с помощью команды edquota.

Чтобы настроить квоты для пользователя, выполните от имени root в приглашении оболочки следующую команду:

edquota username

Выполните это действие для каждого пользователя, которому нужно назначить квоту. Например, если в /etc/fstab включена квота для /home partition (/dev/VolGroup00/LogVol02) и выполняется команда edquota testuser, в редакторе, выбранном в системе как редактор по умолчанию, вы увидите:

Disk quotas for user testuser (uid 501):
  Filesystem                blocks     soft     hard    inodes   soft   hard
  /dev/VolGroup00/LogVol02  440436        0        0     37418      0      0

Замечание | Замечание
 | Команда edquota использует текстовый редактор, определённый в переменной окружения EDITOR. Чтобы сменить этот редактор, укажите в переменной окружения EDITOR в вашем файле ~/.bash_profile полный путь к предпочитаемому редактору.

В первом столбце указывается название файловой системы, для которой включена квота. Во втором столбце показано, сколько блоков использует пользователь в данный момент. В следующих двух столбцах показано мягкое и жёсткое ограничение на число блоков для пользователя в данной файловой системе. В столбце inodes показано, сколько дескрипторов inodes использует пользователь. В следующих двух столбцах показано мягкое и жёсткое ограничение на число inode для пользователя в данной файловой системе.

Жёсткий предел определяет абсолютный максимальный объём дискового пространства, которое может быть выделено пользователю. Если этот предел достигнут, получить дополнительное дисковое пространство невозможно.

Мягкий предел определяет также максимальный объём дискового дискового пространства. Однако, в отличие от жёсткого предела, мягкий предел может быть превышен в течение некоторого времени. Это время называется периодом отсрочки. Период отсрочки можно задавать в секундах, минутах, часах, днях, неделях или месяцах.

Если одно из этих значений равно 0, предел не устанавливается. Определите требуемые пределы в текстовом редакторе. Например:

Disk quotas for user testuser (uid 501):
  Filesystem                blocks     soft     hard   inodes   soft   hard
  /dev/VolGroup00/LogVol02  440436   500000   550000    37418      0      0

Чтобы проверить, установились ли квоты для пользователя, выполните команду:

quota testuser

13.1.5. Назначение квот на уровне групп

Квоты можно также назначать на уровне групп. Например, чтобы назначить квоту группе devel (к этому моменту группа уже должна существовать), выполните следующую команду:

edquota -g devel

Эта команда выводит существующую квоту этой группы в текстовом редакторе:

Disk quotas for group devel (gid 505):
  Filesystem                blocks    soft     hard    inodes    soft    hard
  /dev/VolGroup00/LogVol02  440400       0        0     37418       0       0

Измените пределы, сохраните файл, и настройте квоты.

Чтобы проверить, установились ли квоты группы, выполните команду:

quota -g devel

13.1.6. Назначение квот на уровне файловой системы

Чтобы назначить квоты на уровне файловой системы, для которой они включены, выполните команду:

edquota -t

Как и в случае с другими командами edquota, при этом в текстовом редакторе будет показаны текущие квоты для файловой системы:

Grace period before enforcing soft limits for users:
Time units may be: days, hours, minutes, or seconds
  Filesystem                       Block grace period  Inode grace period
  /dev/mapper/VolGroup00-LogVol02       7days                7days

Измените период отсрочки для блоков или inode, сохраните изменения в файле и выйдите из текстового редактора.

Назад | Начало | Вперёд
Управление разделами LVM | Вверх | Управление дисковыми квотами


Управление дисковым хранилищем

Назад Вперёд

Глава 12. Управление дисковым хранилищем

Введение в различные методы........

12.1. Стандартные разделы в parted

У многих пользователей возникает необходимость просмотреть существующую таблицу разделов, изменить размер разделов, удалить разделы или добавить разделы, используя свободное место или дополнительные жёсткие диски. Все эти задачи позволяет выполнить утилита parted. В этой главе описывается, как выполнять системные задачи с помощью parted.

Если вы хотите посмотреть, как используется дисковое пространство, или наблюдать за использованием диска, обратитесь к разделу 40.3 Файловые системы.

Чтобы использовать утилиту parted, вы должны установить пакет parted. Чтобы запустить parted, введите в приглашении оболочки от имени root команду parted /dev/sda, где /dev/sda — имя устройства, которое вы хотите настроить. На экране появляется приглашение (parted). Введите help, чтобы получить список доступных команд.

Если вы хотите создать, удалить или изменить размер раздела, это устройство должно не использоваться (разделы не должны быть смонтированы, а пространство подкачки включено). Не следует изменять таблицу разделов, когда она используется, так как ядро не сможет корректно среагировать на изменения. Из-за несоответствия смонтированных разделов и таблицы разделов может произойти запись в неверный раздел, что приведёт к перезаписи ваших данных. Легче всего выполнить это условие, загрузив систему в режиме восстановления. Инструкции по загрузке в режиме восстановления описаны в главе 5 Основы восстановления системы. Получив предложение смонтировать файловые системы, ответьте Пропустить (Skip).

Если же никакие разделы вашего диска не задействованы (системными процессами, которые используют или блокируют файловую систему, не позволяя размонтировать её), вы можете размонтировать их, выполнив команду umount, и выключить пространство подкачки на этом диске с помощью команды swapoff.

В таблице 12-1 приведён список часто используемых команд parted. В следующем далее разделе некоторые из них рассматривают подробнее.

Команда | Описание
check minor-num | Выполняет простую проверку файловой системы
cp from to | Копирует файловую систему из одного раздела в другой, вмето from и to указываются младшие номера разделов
help | Выводит список доступных команд
mklabel label | Назначает метку диска для раздела
mkfs minor-num file-system-type | Создаёт файловую систему типа file-system-type
mkpart part-type fs-type start-mb end-mb | Делает раздел, не создавая новую файловую систему
mkpartfs part-type fs-type start-mb end-mb | Делает раздел и создаёт указанную файловую систему
move minor-num start-mb end-mb | Перемещает раздел
name minor-num name | Назначает имя раздела (только для меток диска Mac и PC98)
print | Выводит таблицу разделов
quit | Завершает работу parted
rescue start-mb end-mb | Восстанавливает потерянный раздел с start-mb на end-mb
resize minor-num start-mb end-mb | Изменяет размер раздела с start-mb на end-mb
rm minor-num | Удаляет раздел
select device | Выбирает другое устройство для настройки
set minor-num flag state | Устанавливает флаг для раздела; state может иметь значение «on» или «off»

Таблица 12-1. Команды parted

12.1.1. Просмотр таблицы разделов

Запустив parted, введите следующую команду, чтобы просмотреть таблицу разбиения разделов:

print

Вы увидите подобную таблицу:

Disk geometry for /dev/sda: 0.000-8678.789 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031    101.975  primary   ext3        boot
2        101.975   5098.754  primary   ext3
3       5098.755   6361.677  primary   linux-swap
4       6361.677   8675.727  extended
5       6361.708   7357.895  logical   ext3

Disk geometry for /dev/hda: 0.000-9765.492 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031    101.975  primary   ext3        boot
2        101.975    611.850  primary   linux-swap
3        611.851    760.891  primary   ext3
4        760.891   9758.232  extended              lba
5        760.922   9758.232  logical   ext3

В первой строке показывается размер диска, во второй — тип метки диска, а за ними выводится таблица разделов.

В столбце Minor этой таблицы показан номер раздела. Например, разделу с младшим номером 1 соответствует /dev/sda1. Значения Start (Начало) и End (Конец) задаются в мегабайтах. В столбце Type(Тип) может быть указано primary(основной), extended (расширенный) или logical(логический). В столбце Filesystem указывается тип файловой системы, это может быть ext2, ext3, fat16, fat32, hfs, jfs, linux-swap, ntfs, reiserfs, hp-ufs, sun-ufs или xfs. В столбце Flags показываются флаги, установленные для этого раздела. Это может быть boot (загрузочный), root (загрузочный), swap (подкачка), hidden (скрытый), raid, lvm или lba.

В данном примере младший номер 1 указывает на файловую систему /boot/, младший номер 2 — на корневую файловую систему (/), номер 3 — на раздел подкачки, а номер 5 — на файловую систему /home/.

Подсказка | Подсказка
 | Чтобы выбрать другое устройство, не запуская parted ещё раз, воспользуйтесь командой select, в параметрах которой укажите имя устройства, например, /dev/sda. Сделав это, вы сможете просмотреть или изменить таблицу разделов другого устройства.

12.1.2. Создание раздела

Предупреждение | Предупреждение
 | Не пытайтесь создавать разделы на устройствах, которые используются.

Прежде чем создать раздел, загрузитесь в режиме восстановления (или размонтируйте все разделы и отключите пространства подкачки, расположенные на этом устройстве).

Запустите parted как показано ниже, где /dev/sda — устройство, на котором вы хотите создать раздел:

parted /dev/sda

Просмотрите текущую таблицу разделов, чтобы определить достаточно ли свободного места:

print

Если свободного места не хватает, вы можете изменить размер существующего раздела. Подробнее об этом рассказывается в разделе разделе 12.1.4 Изменение размера раздела.

12.1.2.1. Создание раздела

Просмотрите таблицу разделов и определите точки начала и конца нового раздела, а также его тип. На одном устройстве можно создать только четыре основных раздела (без расширенных). Если вам нужно больше четырёх разделов, вы можете создать три основных раздела, один расширенный, и в нём множество логических разделов. За общей информацией о разделах диска обратитесь к приложению Знакомство с дисковыми разделами в Руководстве по установке Red Hat Enterprise Linux.

Например, чтобы создать основной раздел с файловой системой ext3, расположенный на жёстком диске в пределах от 1024 до 2048 Мбайт, введите следующую команду:

mkpart primary ext3 1024 2048

Подсказка | Подсказка
 | Если вы примените вместо неё команду mkpartfs, после создания раздела в нём будет создана файловая система. Однако parted не поддерживает создание файловой системы ext3. Таким образом, если вы хотите создать файловую систему ext3, воспользуйтесь mkpart и создайте файловую систему с помощью mkfs, как было описано ранее. Утилита mkpartfs работает для файловых систем, имеющих тип linux-swap.

Изменения вступают в силу сразу после нажатия клавиши [Enter], поэтому проверьте команду, прежде чем её выполнять.

Создав раздел, воспользуйтесь командой print, чтобы убедиться в том, что он появился в таблице разбиения с правильным типом раздела, типом файловой системы и размером. Также запомните младший номер нового размера, чтобы вы могли пометить его. Кроме этого, следует просмотреть результат команды

cat /proc/partitions

, чтобы убедиться в том, что ядро распознало новый раздел.

12.1.2.2. Форматирование раздела

В созданном разделе всё ещё нет файловой системы. Создайте её:

/sbin/mkfs -t ext3 /dev/sda6

Предупреждение | Предупреждение
 | Форматирование раздела навсегда удаляет данные, существовавшие в этом разделе.

12.1.2.3. Назначение метки раздела

Затем назначьте разделу метку. Например, если новый раздел называется /dev/sda6 и вы хотите пометить его как /work, выполните:

e2label /dev/sda6 /work

По умолчанию программа установки использует в качестве метки точку монтирования, чтобы метка была уникальной. Вы же можете использовать любую метку, какую захотите.

12.1.2.4. Создание точки монтирования

Создайте точку монтирования, выполнив от имени root:

mkdir /work

12.1.2.5. Добавление в /etc/fstab

Внесите новый раздел в файл /etc/fstab, отредактировав этот файл от имени root. Новая строка должна выглядеть примерно так:

LABEL=/work           /work                 ext3    defaults        1 2

Первый столбец должен содержать указание LABEL=, за которым вы указываете метку, назначенную разделу. Второй столбец должен содержать точку монтирования нового раздела, а в следующем столбце должен указываться тип файловоуй системы (например, ext3 или swap). Если вам нужна дополнительная информация о синтаксисе, обратитесь к странице руководства, выполнив man fstab.

Если в четвёртом столбце указано слово defaults («по умолчанию»), раздел будет монтироваться при загрузке. Чтобы смонтировать раздел без перезагрузки, введите от имени root следующую команду:

mount /work

12.1.3. Удаление раздела

Предупреждение | Предупреждение
 | Не пытайтесь удалять разделы на устройствах, которые используются.

Прежде чем удалять раздел, загрузитесь в режиме восстановления (или размонтируйте все разделы и отключите пространства подкачки, расположенные на этом устройстве).

Запустите parted как показано ниже, где /dev/sda — устройство, на котором вы хотите удалить раздел:

parted /dev/sda

Просмотрите текущую таблицу разделов, чтобы определить номер удаляемого раздела:

print

Удалите раздел с помощью команды rm. Например, удалить раздел номер 3 можно так:

rm 3

Изменения вступают в силу сразу после нажатия клавиши [Enter], поэтому проверьте команду, прежде чем её выполнять.

Удалив раздел, выполните команду print и убедитесь в том, что он удалён из таблицы разделов. Кроме этого, следует просмотреть результат команды

cat /proc/interrupts

, чтобы убедиться в том, что ядро увидело, что раздел удалён.

Последнее, что нужно сделать — удалить запись о нём из файла /etc/fstab. Найдите строку, в которой описывается удалённый раздел и удалите её из файла.

12.1.4. Изменение размера раздела

Предупреждение | Предупреждение
 | Не пытайтесь изменять размер разделов на устройствах, которые используются.

Прежде чем изменять размер раздела, загрузитесь в режиме восстановления (или размонтируйте все разделы и отключите пространства подкачки, расположенные на этом устройстве).

Запустите parted как показано ниже, где /dev/sda — устройство, на котором вы хотите изменить размер раздела:

parted /dev/sda

Просмотрите текущую таблицу разделов, чтобы определить младший номер изменяемого раздела, а также точки начала и конца раздела:

print

Предупреждение | Предупреждение
 | Новый размер раздела не должен быть меньше объёма используемого в нем пространства.

Чтобы изменить размер раздела, воспользуйтесь командой resize, в аргументах которой укажите младший номер раздела, а также точки начала и конца раздела (в мегабайтах). Например:

resize 3 1024 2048

Изменив размер, выполните команду print, чтобы проверить, что размер раздела изменился корректно, раздел имеет правильный тип раздела и тип файловой системы.

Перезагрузив систему в обычном режиме, выполните команду df, чтобы убедиться в том, что раздел был смонтирован и его размер изменён.

Назад | Начало | Вперёд
Перемещение пространства подкачки | Вверх | Управление разделами LVM


Бездисковые окружения

Назад Вперёд

Глава 4. Бездисковые окружения

В некоторых сетях требуется использовать множество компьютеров с одинаковой конфигурацией. Также требуется, чтобы можно было легко перегружать, обновлять эти компьютеры и управлять еми. Одно из решений — использовать бездисковые окружения, в которых большая часть операционной системы, возможно, доступная только на чтение, и разделяемая клиентами, находится на центральном сервере. Для остальной части операционной системы отдельными клиентам на центральном сервере могут быть выделены их собственные каталоги, которые должны быть доступны на чтение/запись. При каждой загрузке клиента, он подключает большую часть ОС с NFS-сервера в режиме только чтение, а другой каталог в режиме чтение/запись. У каждого клиента есть собственный каталог, доступный на чтение/запись, так что один клиент может не затрагивать других.

Чтобы настроить Red Hat Enterprise Linux для запуска бездисковых клиентов необходимо выполнить следующие действия:

  1. Установить Red Hat Enterprise Linux на одном компьютере, чтобы затем эти файлы можно было скопировать на NFS-сервер. (Подробнее об этом рассказывается в Руководстве по установке Red Hat Enterprise Linux.) Также необходимо установить все программные пакеты, которые будет использоваться клиентами, и пакет busybox-anaconda.

  2. Создать каталог для NFS-сервера, в котором будет содержаться бездисковое окружение, к примеру /diskless/i386/RHEL4-AS/. Например:

    mkdir -p /diskless/i386/RHEL4-AS/

    Этот каталог называется бездисковым каталогом.

  3. Создать в этом каталоге подкаталог с именем root/:

    mkdir -p /diskless/i386/RHEL4-AS/root/

  4. Скопировать Red Hat Enterprise Linux с клиентского компьютера на сервер, используя rsync. Например:

    rsync -a -e ssh installed-system.example.com:/ /diskless/i386/RHEL4-AS/root/

    Продолжительнось этой операции зависит от скорости сетевого соединения, а также размера файловой системы компьютера, где была установлена система. В зависимости от этих факторов, выполнение этой операции может занять значительное время.

  5. Запустить tftp-сервер, как описывалось в разделе 4.1 Запуск tftp-сервера.

  6. Настроить DHCP-сервер, как описывается в разделе 4.2 Настройка DHCP-сервер.

  7. Завершить создание бездискового окружения, как описывается в разделе 4.4 Завершение настройки бездискового окружения.

  8. Настроить бездисковых клиентов, как описывается в разделе 4.5 Добавление узлов.

  9. Настроить на всех бездисковых клиентов PXE-загрузку и загрузить их.

4.1. Запуск tftp-сервера

Проверьте, установлен ли на DHCP-сервере пакет tftp-server, выполнив команду rpm -q tftp-server. Если он отсутствует, установите его с компакт-дисков Red Hat Enterprise Linux или из сети Red Hat Network. За дополнительными сведениями об установке RPM-пакетов обратитесь к части III Управление пакетами.

tftp — это служба, работающая на базе xinetd; чтобы запустить её, выполните следующие команды:

/sbin/chkconfig --level 345 xinetd on
/sbin/chkconfig --level 345 tftp on

Эти команды настраивают немедленный запуск служб tftp и xinetd, а также запуск во время загрузки на уровнях выполнения 3, 4 и 5.

Назад | Начало | Вперёд
Выполнение PXE-установки | Вверх | Настройка DHCP-сервера


Файловая система ext3

Назад Вперёд

Глава 6. Файловая система ext3

Файловой системой по умолчанию в Red Hat Enterprise Linux является журналируемая файловая система ext3.

6.1. Возможности ext3

Файловая система ext3 по сути является усовершенствованной версией файловой системы ext2. Эти усовершенствования предоставляют следующие преимущества:

Доступность

В случае неожиданного отключения питания или сбоя системы (так называемого некорректного отключения системы) каждую смонтированную файловую систему ext2 необходимо проверять на целостность с помощью программы e2fsck. Это длительный процесс, который может значительно замедлить загрузку системы, особенно при больших дисках с большим количеством файлов. И пока проверка не закончится, данные на дисках будут недоступны.

Журналирование, выполняемое файловой системой ext3, означает, что такая проверка файловой системы после некорректного отключения системы более не требуется. Проверка целостности в ext3 выполняется только в очень редких случаях, при отказе оборудования, например, при сбое жёсткого диска. Время восстановления файловой системы ext3 после некорректного отключения системы не зависит от размера файловой системы или числа файлов, оно зависит от размера журнала, используемого для поддержки целостности. На восстановление при стандартном размере журнала уходит около секунды, в зависимости от скорости компьютера.

Целостность данных

Файловая система ext3 надёжно обеспечивает целостность данных в случае некорректного отключения системы. Файловая система ext3 позволяет вам выбрать тип и уровень защиты ваших данных. По умолчанию тома ext3 обеспечивают высокий уровень целостности данных с учётом состояния файловой системы.

Скорость

Несмотря на то, что некоторые данные записываются неоднократно, в большинстве случаев ext3 работает быстрее, чем ext2, так как журналирование ext3 позволяет оптимизировать перемещение головки жёсткого диска. Вы можете оптимизировать скорость, выбирая из трёх режимов журналирования, но учтите, что это влияет на уровень целостности данных.

Лёгкий переход

Вы можете легко перейти от ext2 к ext3 и получить преимущества стабильной журналируемой файловой системы без переформатирования. Чтобы узнать, как это сделать, обратитесь к разделу 6.3 Переход к файловой системе ext3.

В следующих разделах вы пройдёте по этапам создания и настройки разделов ext3. Если у вас есть разделы ext2, пропустите разделы разбиения и форматирования и сразу обратитесь к разделу 6.3 Переход к файловой системе ext3.

Назад | Начало | Вперёд
Файловые системы | Вверх | Создание файловой системы ext3


Средство «Управление пакетами»

Назад Вперёд

Глава 16. Средство «Управление пакетами»

Во время установки системы устанавливается стандартный набор программных пакетов. Так как разные люди используют свои компьютеры по-разному, у пользователей может возникнуть желание установить или удалить пакеты после установки системы. Все эти действия позволяет выполнить средство Управление пакетами (Package Management Tool).

Для запуска приложения Управление пакетами необходима система X Window. Чтобы его запустить, выберите в главном меню Приложения (Applications) (на панели) => Системные параметры (System Settings) => Установка/Удаление приложений (Add/Remove Applications) или введите в приглашении оболочки system-config-packages.

То же приложение запускается автоматически, когда вы вставляете в компьютер первый компакт-диск Red Hat Enterprise Linux CD.

Рисунок 16-1. Управление пакетами

Интерфейс этого приложения похож на тот, что вы использовали для выбора отдельных пакетов во время установки. Пакеты разделены по группам пакетов, которые содержат список стандартных пакетов и дополнительных пакетов, разделяющих общую функциональность. Например, группа Графический Интернет (Graphical Internet) содержит браузер, почтового клиента и другие графические программы для подключения к Интернету. Стандартные пакеты можно удалить, удалив только всю группу пакетов. Дополнительные пакеты — это необязательные пакеты, которые можно выбрать для установки или удаления, если выбрана группа пакетов.

Основное окно программы показывает список групп пакетов. Если флажок рядом с группой пакетов установлен, это означает, что пакеты этой группы установлены. Чтобы просмотреть список отдельных пакетов, составляющих группу, щёлкните расположенную рядом ссылку Сведения (Details). Если флажок рядом с отдельным пакетом отмечен, это означает, что пакет установлен.

16.1. Установка пакетов

Чтобы установить стандартные пакеты из группы пакетов, которая в данный момент не установлена, поставьте флажок рядом с этой группой пакетов. Чтобы настроить список устанавливаемых пакетов в этой группе, щёлкните расположенную рядом ссылку Сведения (Details). Вы увидите список стандартных и дополнительных пакетов, показанный на рисунке 16-2. Щёлкните название пакета, и в нижней части окна вы увидите, сколько места на диске необходимо для установки этого пакета. Поставив флажок рядом с пакетом, вы, тем самым, помечаете его для установки.

Вы также можете выбрать отдельные пакеты из уже установленных групп пакетов, щёлкнув ссылку Сведения и отметив дополнительные пакеты, которые ещё не установлены.

Рисунок 16-2. Выбор отдельных пакетов

Выбрав группы пакетов и отдельные пакеты для установки, нажмите в главном оке кнопку Обновить (Update). В окне кратких сведений выводится информация о пакетах, в частности, число устанавливаемых пакетов, объём диска, требуемый для установки пакетов, а также все зависимости пакетов. Если пакет зависит от других, они автоматически будут добавлены в список устанавливаемых пакетов. Нажмите кнопку Показать сведения (Show Details), чтобы просмотреть полный список устанавливаемых пакетов.

Рисунок 16-3. Краткие сведения об установке пакета

Нажмите Продолжить (Continue), чтобы начать процесс установки. После завершения установки появляется сообщение Обновление завершено (Update Complete).

Подсказка | Подсказка
 | Если вы используете для управления файлами и каталогами на своём компьютере Наутилус (Nautilus), вы также можете использовать его для установки пакетов. В Наутилусе нужно просто перейти в каталог, содержащий RPM-пакет (обычно файл пакета имеет расширение .rpm) и дважды щёлкнуть значок RPM.
Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Удаление пакетов


Настройка безопасного HTTP-сервера Apache

Назад Вперёд

Глава 26. Настройка безопасного HTTP-сервера Apache

26.1. Введение

В этой главе представлена основная информация о применении сервера HTTP-Apache с модулем безопасности mod_ssl, использующим библиотеку OpenSSL и сопутствующие инструменты. Совокупность этих трёх компонентов в этой главе называется безопасным веб-сервером или просто безопасным сервером.

Модуль mod_ssl —- модуль безопасности для HTTP-сервера Apache. Модуль mod_ssl использует средства, разработанные в рамках проекта OpenSSL, для добавления очень важной функции Apache — способности шифровать передаваемые данные. Напротив, при использования обычного протокола HTTP, обмен данными между обозревателем и веб-сервером происходит открытым текстом, и эти данные могут быть кем-либо перехвачены и прочитаны во время пересылки по маршруту.

Данная глава не является полной и исчерпывающей документацией по любой из этих программ. Где это возможно, в этом руководстве приводятся ссылки на соответствующие ресурсы, в которых вы сможете найти более глубокую документацию по этим темам.

Эта глава покажет вам, как установить эти программы. Вы также сможете узнать, какие действия необходимо предпринять, чтобы сгенерировать закрытый ключ и запрос сертификата, как сгенерировать ваш собственный, подписанный вами сертификат, а также о том, как установить сертификат для использования с вашим безопасным веб-сервером.

Конфигурация mod_ssl описывается в файле /etc/httpd/conf.d/ssl.conf. Чтобы этот файл загрузился, и как следствие, работал mod_ssl, в файле /etc/httpd/conf/httpd.conf должен присутствовать оператор Include conf.d/*.conf. В стандартном файле конфигурации HTTP-сервера он по умолчанию присутствует.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Обзор пакетов, связанных с безопасностью


Настройка HTTP-сервера Apache

Назад Вперёд

Глава 25. Настройка HTTP-сервера Apache

В Red Hat Enterprise Linux представлен HTTP-сервер Apache версии 2.0. Если вы хотите перенести существующий файл конфигурации вручную, обратитесь за подробностями к руководству по переходу на другую версию /usr/share/doc/httpd-<ver>/migration.html или к Справочному руководству Red Hat Enterprise Linux.

Если вы настраивали HTTP-сервер Apache с помощью средства Настройка сервера HTTP (HTTP Configuration Tool) в предыдущих версиях Red Hat Enterprise Linux и затем выполняли обновление, вы можете преобразовать файл конфигурации в новый формат для версии 2.0 также с помощью средства Настройка сервера HTTP. Запустите Настройка сервера HTTP, внесите какие-либо в конфигурацию и сохраните его. Файл конфигурации будет сохранён в формате, совместимом с версией 2.0.

Для использования средства Настройка сервера HTTP должны быть установлены RPM-пакеты httpd и system-config-httpd. Также для этого необходима система X Window и права пользователя root. Чтобы запустить это приложение, выберите в Главном меню (Main Menu) => Системные параметры => Настройка сервера => HTTP или введите команду system-config-httpd в приглашении оболочки (например, в XTerm или терминале среды GNOME).

С помощью программы Настройка сервера HTTP вы можете настроить файл конфигурации HTTP-сервера Apache /etc/httpd/conf/httpd.conf. Она не использует старые файлы конфигурации, такие как srm.conf или access.conf; оставьте их пустыми. В графическом интерфейсе вы можете настраивать разные параметры, например, виртуальные узлы, атрибуты протоколирования и максимальное количество соединений.

С помощью Настройки сервера HTTP можно настраивать только модули, включённые в состав Red Hat Enterprise Linux. Если установлены дополнительные модули, настроить с помощью этой программы их нельзя.

Внимание | Внимание
 | Не изменяйте файл конфигурации /etc/httpd/conf/httpd.conf, если хотите использовать эту программу. Программа Настройка сервера HTTP создаёт этот файл, когда вы сохраняете изменения и выходи из программы. Если вы хотите добавить дополнительные модули или параметры настройки, не поддерживаемые в Настройке сервера HTTP, вы не сможете использовать этот инструмент.

Ниже перечислены основные этапы настройки HTTP-сервера Apache, с помощью средства Настройка сервера HTTP:

  1. Определить основные параметры на вкладке Основные (Main).

  2. Перейти на вкладку Виртуальные узлы (Virtual Hosts) и настроить параметры по умолчанию.

  3. На вкладке Виртуальные узлы (Virtual Hosts) настроить виртуальный узел по умолчанию (Default Virtual Host).

  4. Чтобы сервер обслуживал несколько URL или виртуальных узлов, добавьте дополнительные виртуальные узлы.

  5. Настроить параметры сервера на вкладке Сервер (Server).

  6. Определить настройки соединений на вкладке Настройка быстродействия (Perfomance Tuning).

  7. Скопировать все необходимые файлы в каталоги DocumentRoot и cgi-bin.

  8. Выйдите из приложения и сохраните изменения параметров.

25.1. Основные параметры

На вкладке Основные (Main) настраиваются основные параметры сервера.

Рисунок 25-1. Основные параметры

Введите полностью определённое имя домена, которое вы имеете право использовать, в текстовой области Имя сервера (Server Name). Эта параметр соответствует указанию ServerName в файле httpd.conf. Указание ServerName определяет имя веб-сервера. Оно используется при создании перенаправляющих URL. Если вы не определите имя сервера, веб-сервер попытается получить его из IP-адреса вашего компьютера. Имя сервера не обязательно должно быть доменным именем, полученным из IP-адреса сервера. Например, вы можете назначить серверу имя www.example.com, хотя реальным DNS-именем сервера будет foo.example.com.

Введите электронный адрес человека, занимающегося поддержкой этого Web сервера в текстовом поле Электронный адрес вебмастера (Webmaster email address). Эта параметр соответствует указанию ServerAdmin в файле httpd.conf. Если страницы, выводимые в случае ошибки сервера, будут содержать этот адрес, пользователи смогут сообщить о проблеме администратору сервера. Значение параметра по умолчанию: root@localhost.

В области Доступные адреса (Available Addresses) укажите порты, в которых сервер принимает входящие запросы. Этот параметр соответствует указанию Listen в httpd.conf. По умолчанию Red Hat настраивает HTTP-сервер Apache так, что для не защищённых веб-соединений используется порт 80.

Нажмите кнопку Add (Добавить) чтобы определить дополнительные порты, принимающие запросы. На экране появится окно, показанное на рисунке 25-2. Вы можете выбрать вариант Ожидать соединения на всех адресах (Listen to all addresses), чтобы сервер принимал запросы в определенном ранее порту по всем адресам, или явно указать в поле Адрес (Address) IP-адрес, к которому сервер будет принимать подключения. Вы можете задать только один IP-адрес для каждого порта. Чтобы указать несколько IP-адресов с одним номером порта, создайте запись для каждого IP-адреса. Если это возможно, для предотвращения ошибки поиска записей DNS, используйте вместо имени IP-адрес. Обратитесь к странице http://httpd.apache.org/docs-2.0/dns-caveats.html за дополнительным сведениями по вопросам, связанным с DNS и Apache.

Ввод в поле Адрес (Address) символа звёздочки (*) аналогичен выбору Ожидать соединения на всех адресах (Listen to all addresses). При нажатии кнопки Изменить (Edit) в разделе Доступные адреса (Available Addresses) появляется то же окно, что и при нажатии кнопки Добавить (Add), за исключением того, что поля уже заполнены значениями для данной записи. Чтобы удалить запись, выберите её и нажмите кнопку Удалить (Delete).

Подсказка | Подсказка
 | Если вы настроите сервер на обработку подключений к портам с номерами ниже 1024, для его запуска потребуются привилегии root. Для портов 1024 и выше, httpd может запускаться от имени обычного пользователя.

Рисунок 25-2. Доступные адреса

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Параметры по умолчанию


Введение

Добро пожаловать в Руководство по системному администрированию Red Hat Enterprise Linux.

Руководство по системному администрированию Red Hat Linux содержит информацию о том, как настроить вашу систему Red Hat Linux, чтобы она удовлетворяла вашим требованиям. Если вы ищете документацию, детально описывающую различные задачи настройки вашей системы, это руководство — именно то, что вам нужно. В этом руководстве обсуждается много дополнительных тем, например:

  • Настройка сетевого адаптера (NIC)

  • Выполнение установки Kickstart

  • Настройка разделяемых ресурсов Samba

  • Управление программным обеспечением с помощью RPM

  • Получение информации о вашей системе

  • Обновление ядра вашей системы

Это руководство разделено на следующие главные категории:

  • Информация об установке

  • Справочник по файловым системам

  • Управление пакетами

  • Настройка сети

  • Настройка системы

  • Мониторинг системы

В этом руководстве подразумевается, что вы владеете основными понятиями о системе Red Hat Linux. За справочной информацией об установке Red Hat Enterprise Linux обращайтесь к Руководству по установке Red Hat Enterprise Linux. Более общие сведения о системном администрировании вы найдёте во Введении в системное администрирование Red Hat Enterprise Linux. Если вам нужна более подробная документация, в частности, обзор файловых систем, обратитесь к Справочному руководству по Red Hat Enterprise Linux. Если вам нужна информация о безопасности, обратитесь к Руководству по безопасности Red Hat Enterprise Linux.

1. Изменения в этом руководстве

Это руководство было переработано для облегчения понимания и приведено в соответствие с последними возможностями Red Hat Enterprise Linux 4. В частности, произошли следующие изменения:

Обновлены главы Модули ядра и Обновление ядра вручную

В главы Модули ядра и Обновление ядра вручную включены обновлённые сведения, касающиеся ядра 2.6. Особая благодарность Арджану ван-де-Вену (Arjan van de Ven) за большую помощь в завершении этой главы.

Обновлённая глава Сетевая файловая система (NFS)

Глава Сетевая файловая система (NFS) была пересмотрена и переработана так, что в неё вошло описание NFSv4. Особая благодарность Стиву Диксону (Steve Dickson) за то, что он сделал, помогая завершить эту статью.

Обновлённая глава OProfile

Глава OProfile была пересмотрена и переработана, так что в неё вошла обновлённая информация, относящаяся к ядру 2.6. Особая благодарность Виллу Кохену (Will Cohen) за то, что он сделал, помогая завершить эту статью.

Обновлённая глава Система X Window

Глава Система X Window была пересмотрена так, что в неё вошла информация о выпуске X11R6.8, выпущенном командой X.Org.

Прежде чем изучать это руководство, вам следует ознакомиться с содержимым Руководства по установке Red Hat Enterprise Linux, в котором рассматриваются вопросы установки, Введением в системное администрирование Red Hat Enterprise Linux, где рассматриваются основные понятия администрирования, Руководством по системному администрированию Red Hat Enterprise Linux, где приводятся общие инструкции по настройке и Руководством по безопасности Red Hat Enterprise Linux, где приведены инструкции по безопасности. Данное руководство содержит информацию по темам для продвинутых пользователей.

Эти руководства в форматах HTML, PDF и RPM находятся на диске Red Hat Enterprise Linux Documentation и в Интернете по адресу http://www.redhat.com/docs/.

Замечание | Замечание
 | Хотя в этом руководстве, насколько это возможно, отражена самая последняя информация, обратитесь к Замечаниям к версии Red Hat Enterprise Linux за информацией, не доступной на момент выхода нашего руководства. Замечания к версии можно найти на первом компакт-диске Red Hat Enterprise Linux, в Интернете, по адресу http://www.redhat.com/docs/, или после установки, в каталоге /usr/share/doc/redhat-release-4<product>/, где <product> обозначает редакцию: AS, ES, WS или Desktop.
Назад | Начало | Вперёд
Red Hat Enterprise Linux 4 |  | Информация, связанная с особенностями архитектуры


Обновление ядра вручную

Назад Вперёд

Глава 37. Обновление ядра вручную

Ядро, включённое в Red Hat Enterprise Linux, модифицировано командой разработчиков ядра Red Hat с целью обеспечить его целостность и совместимость с поддерживаемым оборудованием. Прежде чем Red Hat выпустит ядро, оно должно пройти набор серьёзных проверок качества.

Ядра Red Hat Enterprise Linux распространяются в формате RPM, поэтому их легко можно обновить и проверить, используя Агент обновлений Red Hat (Red Hat Update Agent) или команду up2date. Агент обновлений Red Hat автоматически обращается к серверам Red Hat Network и определяет, какие пакеты, включая ядро, требует обновления в вашей системе. Эта глава будет полезна только тем, кому нужно обновлять пакеты ядра вручную, не используя команду up2date.

Предупреждение | Предупреждение
 | Пожалуйства заметьте, что создание собственного ядра не подддерживается командой глобальной сервисной поддержки Red Hat (Red Hat Global Services Support) и по этой причине не освещается в этом руководстве.

Подсказка | Подсказка
 | Компания Red Hat настоятельно рекомендует устанавливать обновлённые ядра с помощью up2date.

За дополнительной информацией о Red Hat Network, Агенте обновления Red Hat и up2date, обратитесь к главе 17 Red Hat Network.

37.1. Обзор пакетов ядра

Red Hat Enterprise Linux содержит следующие пакеты ядра (некоторые могут быть неприменимы на вашей платформе):

  • kernel — Содержит ядро и следующие ключевые функции:

    • Поддержка одного процессора на компьютерах x86 и Athlon (может работать и в многопроцессорном компьютере, но использоваться будет только один процессор)

    • Поддержка нескольких процессоров на всех остальных платформах

    • На компьютерах x86 используются только первые 4 Гбайта ОЗУ, на компьютерах x86 с объёмом ОЗУ больше 4 Гбайт применяйте пакет kernel-hugemem

  • kernel-devel — Содержит файлы заголовков ядра и файлы makefile, необходимые для сборки модулей, зависящих от пакета kernel.

  • kernel-hugemem (только для компьютеров i686) — Помимо возможностей, включённых в пакете kernel, предоставляет следующие возможности кофнфигурации:

    • Поддержка более 4 Гбайт ОЗУ (до 64 Гбайт на платформе x86)

      Замечание Замечание

      Пакет kernel-hugemem требуется в конфигурациях, где объём памяти превышает 16 Гбайт.

    • Расширение физических адресов (Physical Address Extension, PAE ) или 3 уровень управления страницами для процессоров x86, поддерживающих PAE

    • Поддержка нескольких процессоров

    • Разделение по 4 ГБайта — На платформе x86 ядру отводится 4 ГБайта виртуального адресного пространства и почти 4 ГБайта каждому пользовательскому процессу

  • kernel-hugemem-devel — Содержит файлы заголовков и файлы makefiles, необходимые для сборки модулей, зависящих от пакета kernel-hugemem.

  • kernel-smp — Содержит ядро для многопроцессорных компьютеров. Обладает следующими ключевыми функциями:

    • Поддержка нескольких процессоров

    • Поддержка более 4 Гбайт ОЗУ (до 16 Гбайт на платформе x86)

    • Расширение физических адресов (Physical Address Extension, PAE ) или 3 уровень управления страницами для процессоров x86, поддерживающих PAE

  • kernel-smp-devel — Содержит файлы заголовков и файлы makefiles, необходимые для сборки модулей, зависящих от пакета kernel-smp package.

  • kernel-utils — Содержит утилиты, которым могут использоваться для управления ядром или оборудованием компьютера.

  • kernel-doc — Содержит файлы документации из исходных кодов ядра. В этих файлах документированы различные блоки ядра Linux и включённые в него драйверы устройств. Установив этот пакет, вы получите справочную информацию о параметрах, которые можно передать модулям ядра Linux во время загрузки.

    По умолчанию эти файлы помещаются в каталог /usr/share/doc/kernel-doc-<version>/.

Замечание | Замечание
 | Пакет kernel-source ликвидирован и заменён RPM-пакетом, который можно получить только из сети Red Hat Network. Этот пакет *.src.rpm затем должен быть пересобран локально, с помощью команды rpmbuild. За дополнительными сведениями о получении и установке пакета с исходным кодом ядра обратитесь к замечаниям к последней выпущенной версии, включающим все обновления, опубликованным по адресу https://www.redhat.com/docs/manuals/enterprise/.
Назад | Начало | Вперёд
Анализ файлов журналов | Вверх | Подготовка к обновлению


Модули ядра

Назад Вперёд

Глава 38. Модули ядра

Ядро Linux имеет модульную структуру. При загрузке в память загружается только минимальное резидентное ядро. После этого, если пользователь вызывает функцию, отсутствующую в резидентном ядре, нужный модуль ядра, иногда называемый драйвером, динамически загружается в память.

Во время установки системы происходит определение оборудования компьютера. В зависимости от обнаруженного оборудования и заданных пользователем параметров системы, программа установки решает, какие модули необходимо загружать при загрузке. Программа установки прозрачно для вас настраивает механизм динамической загрузки.

Если после установки добавляется новое оборудование и для него требуется модуль ядра, систему необходимо настроить, чтобы загружался этот модуль ядра. Когда система загружается с новым оборудованием, запускается программа Kudzu, определяет, поддерживается ли это оборудование и настраивает модуль для него. Указать этот модуль также можно вручную, отредактировав файл конфигурации модуля /etc/modprobe.conf.

Замечание | Замечание
 | Модули видеоплат, используемые для отображения интерфейса X Window, включены в пакет xorg-X11, а не в kernel; таким образом, эта глава на них не распространяется.

Например, если в компьютере установлен сетевой адаптер SMC EtherPower 10 PCI, файл конфигурации модуля содержит следующую строку:

alias eth0 tulip

Если в компьютер устанавливается вторая такая же сетевая плата, добавьте в файл /etc/modules.conf следующую строку:

alias eth1 tulip

Алфавитный список модулей ядра и список оборудования, поддерживаемого этими модулями, вы можете найти в Справочном руководстве по Red Hat Enterprise Linux.

38.1. Управление модулями ядра

Набор команд для управления модулями ядра доступен, если установлен пакет module-init-tools. С помощью этих команд можно определить, был ли модуль успешно загружен, или попробовать различные модули с новым оборудованием.

Команда /sbin/lsmod выводит список загруженных в данный момент модулей. Например:

Module                  Size  Used by
nfs                   218437  1
lockd                  63977  2 nfs
parport_pc             24705  1
lp                     12077  0
parport                37129  2 parport_pc,lp
autofs4                23237  2
i2c_dev                11329  0
i2c_core               22081  1 i2c_dev
sunrpc                157093  5 nfs,lockd
button                  6481  0
battery                 8901  0
ac                      4805  0
md5                     4033  1
ipv6                  232833  16
ohci_hcd               21713  0
e100                   39493  0
mii                     4673  1 e100
floppy                 58481  0
sg                     33377  0
dm_snapshot            17029  0
dm_zero                 2369  0
dm_mirror              22957  2
ext3                  116809  2
jbd                    71257  1 ext3
dm_mod                 54741  6 dm_snapshot,dm_zero,dm_mirror
ips                    46173  2
aic7xxx               148121  0
sd_mod                 17217  3
scsi_mod              121421  4 sg,ips,aic7xxx,sd_mod

В первом столбце каждой строки указывается название модуля, во втором — его размер, а в третьем показывается, сколько раз он использовался.

Команда /sbin/lsmod выводит меньше информацию, и прочитать её проще, чем просмотреть /proc/modules.

Чтобы загрузить модуль ядра, выполните команду /sbin/modprobe, указав в параметрах название модуля ядра. По умолчанию modprobe пытается загрузить модуль из подкаталогов /lib/modules/<kernel-version>/kernel/drivers/. Для модулей разных типов предназначены разные подкаталоги, например, подкаталог net/ содержит драйверы сетевых плат. Некоторые модули ядра имеют зависимости, это значит что перед ними должны быть загружены другие модули. Команда /sbin/modprobe проверяет эти зависимости и загружает необходимые модули, прежде чем загрузить указанный модуль.

Например, команда

/sbin/modprobe e100

загружает все модули, от которых зависит модуль e100, а затем указанный модуль.

Чтобы по мере того, как /sbin/modprobe выполняет команды, они выводились на экран, воспользуйтесь параметром -v. Например:

/sbin/modprobe -v e100

В результате на экран выводится примерно следующее:

/sbin/insmod /lib/modules/2.6.9-5.EL/kernel/drivers/net/e100.ko
Using /lib/modules/2.6.9-5.EL/kernel/drivers/net/e100.ko
Symbol version prefix 'smp_'

Для загрузки модулей ядра также есть команда /sbin/insmod, однако она не разрешает зависимости. Таким образом, рекомендуется использовать команду /sbin/modprobe.

Чтобы выгрузить модули ядра, воспользуйтесь командой /sbin/rmmod, указав в параметрах имя модуля. Команда rmmod выгружает модули, только если они не используются непосредственно и не зависят от других используемых модулей.

Например, команда

/sbin/rmmod e100

выгружает модуль ядра e100.

Другой полезной командой управления модулями ядра является modinfo. Используйте команду /sbin/modinfo, чтобы просмотреть информацию о модуле ядра. Общий синтаксис приведён ниже:

/sbin/modinfo [options] <module>

Эта команда, в частности, принимает параметр -d, показывающий краткое описание модуля, и -p, перечисляющий параметры, поддерживаемые модулем. За полным списком параметров обратитесь к странице руководства modinfo (man modinfo).

Назад | Начало | Вперёд
Проверка загрузчика | Вверх | Статическая загрузка модулей


Настройка клавиатуры

Назад Вперёд

Глава 30. Настройка клавиатуры

Программа установки позволяет пользователям выбрать раскладку клавиатуры в своей системе. Чтобы сменить раскладку клавиатуры после установки, воспользуйтесь средством Настройки клавиатуры (Keyboard Configuration Tool).

Чтобы запустить Настройки клавиатуры (Keyboard Configuration Tool), выберите в меню Приложения (Applications) (на панели) => Системные параметры (System Settings) => Клавиатура (Keyboard) или введите в приглашении оболочки команду system-config-keyboard.

Рисунок 30-1. Настройки клавиатуры

Выберите раскладку клавиатуры из списка (например, U.S. English) и нажмите OK. Чтобы изменения вступили в силу, вы должны завершить сеанс работы в графической среде и снова зайти в неё.

Назад | Начало | Вперёд
Выбор часового пояса | Вверх | Настройка мыши


Установка при помощи Kickstart

Назад Вперёд

Глава 1. Установка при помощи Kickstart

1.1. Что такое Kickstart-установка?

Многие системные администраторы предпочитают выполнять автоматическую инсталляцию для установки Red Hat Enterprise Linux на свои компьютеры. Для удовлетворения таких потребностей Red Hat предлагает kickstart-установку. Используя kickstart, системный администратор может создать файл, содержащий ответы на все вопросы, задаваемые программой установки Red Hat Enterprise Linux.

Файлы Kickstart могут располагаться на одном сервере и загружаться компьютерами во время установки системы. Этот способ установки позволяет использовать один файл kickstart для установки Red Hat Enterprise Linux на нескольких компьютерах, что делает его идеальным для сетевых и системных администраторов.

Kickstart позволяет пользователям автоматизировать установку Red Hat Enterprise Linux.

Назад | Начало | Вперёд
Вопросы, касающиеся установки | Вверх | Как выполнить Kickstart-установку?


Файлы журналов

Назад Вперёд

Глава 36. Файлы журналов

Файлы журналов — это файлы, содержащие сообщения о системе, включая ядро, а также о работающих в ней службах и приложениях. Для разной информации предназначены разные файлы журналов. Например, есть стандартный файл журнала системы, файл журнала исключительно для сообщений безопасности и файл журнала для заданий cron.

Файлы журналов могут быть очень полезны при решении возникающих в системе проблем, например, когда вы пытаетесь загрузить драйвер ядра или ищете сообщения о попытках несанкционированного доступа к системе. Эта глава рассказывает, где найти файлы журналов, как их просмотреть, и что искать в этих файлов.

Некоторые файлы журналов контролируются демоном syslogd. Список сообщений, контролируемых демоном syslogd, можно найти в файле конфигурации /etc/syslog.conf.

36.1. Расположение файлов журналов

Большинство файлов журналов располагается в каталоге /var/log/. Файлы журналов некоторых приложений, например, httpd и samba размещаются в отдельных подкаталогах /var/log/.

Вы также можете встретить в каталоге журналов множество файлов, имя которых включает число. Они создаются при циклической смене файлов журналов. Файлы журналов меняются, чтобы они не становились слишком большими. Пакет logrotate содержит задание cron, автоматически меняющее файлы журналов в соответствии с файлом конфигурации /etc/logrotate.conf и файлами конфигурации в каталоге /etc/logrotate.d/. По умолчанию, смена файлов происходит каждую неделю, а предыдущие файлы журналов хранятся четыре недели.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Просмотр файлов журналов


Настройка LVM

Назад Вперёд

Глава 8. Настройка LVM

LVM можно настроить в процессе графической или текстовой установки, а также во время установки kickstart. Чтобы создать свою собственную конфигурацию LVM после установки, вы можете воспользоваться утилитами из пакета lvm, но нижеприведённые инструкции ориентированы на выполнение этой задачи во время установки с помощью Disk Druid.

Предварительно ознакомьтесь с LVM, прочитав главу 7 Диспетчер логических томов (LVM). Настройка LVM включает в себя следующие этапы:

  • Создание физических томов из жёстких дисков.

  • Создание групп томов из физических томов.

  • Создание логических томов из групп томов и назначение логическим томам точек монтирования.

Замечание | Замечание
 | Хотя ниже описываются действия, выполняемые во время графической установки, то же самое можно проделать в процессе установки в текстовом режиме.

В следующих примерах используются два SCSI-диска объёмом 9,1 Гбайт (/dev/sda and /dev/sdb). Эти примеры показывают, как во время установки создать простую конфигурацию с одной группой томов LVM и соответствующих логических томов.

8.1. Автоматическое разбиение диска

В диалоге Настройка разбиения диска (Disk Partitioning Setup) выберите вариант Автоматическое разбиение (Automatically partition).

В Red Hat Enterprise Linux для разбиения дисков по умолчанию используется LVM. Если вы не хотите использовать LVM, или вам нужны разделы RAID, разбить диск потребуется вручную, с помощью Disk Druid.

Автоматически созданная конфигурация имеет следующие свойства:

  • Раздел /boot/ располагается в отдельном разделе вне LVM. В следующем примере это первый раздел первого диска (/dev/sda1). Загрузочные разделы не могут располагаться на физических томах LVM.

  • Создаётся одна группа LVM-томов (VolGroup00), располагающаяся на всех выбранных дисках и занимающая всё остальное пространство. В следующем примере в эту группу томов включается оставшаяся часть первого диска (/dev/sda2) и весь второй диск (/dev/sdb1).

  • Затем из созданной группы томов создаются два логических тома (LogVol00 и LogVol01). В этом примере автоматически вычисляется размер, необходимый для подкачки LogVol01, а оставшееся пространство выделяется для корневой файловой системы, LogVol00.

Рисунок 8-1. Автоматическая настройка LVM с двумя SCSI-дисками

Замечание Замечание

Если вы намерены включить квоты, возможно, будет лучше изменить параметры автоматической конфигурации и добавить другие точки подключения, например, /home/ или /var/, так, в каждой файловой системе существует своя конфигурация квот.

В большинстве случаев стандартного автоматического разбиения LVM вполне достаточно, но в сложных случаях может потребоваться изменить или вручную настроить таблицы разбиения LVM.

Замечание | Замечание
 | Если в будущем вы планируете нарастить объём памяти, оставьте свободное место в группе томов, это позволит вам легко расширить логический том, отведённый для подкачки. В этом случае также нужно изменить автоматическую конфигурацию LVM, чтобы зарезервировать место для будущего роста.
Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Разбиение LVM вручную


Диспетчер логических томов (LVM)

Назад Вперёд

Глава 7. Диспетчер логических томов (LVM)

7.1. Что такое LVM?

LVM — это метод распределения пространства жёсткого диска по логическим томам, размер которых можно легко менять, в отличие от разделов.

С LVM пространство жёсткого диска или набора дисков распределяется по физическим томам. Физический том не может располагаться более чем на одном диске.

Физические тома собираются в группы логических томов, за исключением раздела /boot/. Раздел /boot/ не может находиться в группе логических томов, так как в этом случае загрузчику не удастся его прочитать. Если корневой раздел (/) находится на логическом томе, создайте отдельный раздел /boot/ вне группы томов.

Так как физический том не может находиться на нескольких дисках, чтобы разместить данные на нескольких дисках, на каждом из них создаются один или несколько физических томов.

Рисунок 7-1. Группа логических томов

Группа логических томов разделяется на логические тома, которым назначаются точки подключения (например, /home и /) и типы файловых систем (например, ext2 и ext3). Когда ёмкость «разделов» исчерпывается, можно увеличить его размер, добавив к логическому тому свободное пространство из группы логических томов. Когда в компьютер устанавливается новый жёсткий диск, его можно добавить в группу логических томов и расширить разделы, являющиеся логическими томами.

Рисунок 7-2. Логические тома

С другой стороны, если в системе были созданы разделы с файловой системой ext3, жёсктий диск разбивается на разделы определённого размера. И если раздел заполняется, увеличить размер раздела не просто. Даже если переместить раздел на другой жёсткий диск, придётся создать в исходном дисковое пространстве другой раздел или не использовать его.

Поддержку LVM должно обеспечивать ядро, и ядро Red Hat скомпилировано с LVM.

Чтобы узнать, как настроить LVM в процессе установки, обратитесь к разделу 8 Настройка LVM.

Назад | Начало | Вперёд
Возврат к файловой системе ext2 | Вверх | Что такое LVM2?


Настройка мыши

Назад Вперёд

Глава 31. Настройка мыши

Программа установки позволяет пользователям определить тип мыши, подключенной к компьютеру. Чтобы настроить в системе мышь другого типа, воспользуйтесь средством Настройки мыши (Mouse Configuration Tool).

Чтобы запустить Настройки мыши (Mouse Configuration Tool), введите команду system-config-mouse в приглашении оболочки (например, в XTerm или терминале GNOME). Если вы работаете не в системе X Window, запустится текстовая версия программы.

Рисунок 31-1. Выбор мыши

Выберите другой тип мыши для системы. Если нужная модель в списке отсутствует, выберите один из вариантов Generic (Стандартная), в зависимости от количества кнопок мыши и её интерфейса. Если вы не находите точного соответствия, выберите стандартную мышь, наиболее похожую на вашу.

Встроенные указывающие устройства, например, сенсорная панель на ноутбуке, обычно имеют интерфейс PS/2.

Ко всем типам мышей в скобках добавляется PS/2, serial или USB. Так указывается порт мыши.

Порт мыши PS/2 выглядит примерно так: .

Последовательный порт мыши выглядит примерно так: .

USB-порт мыши выглядит примерно так: .

Подсказка | Подсказка
 | Чтобы работало кнопка прокрутки, выберите пункт Generic - Wheel Mouse (Стандартная мышь с колёсиком) и укажите подходящий порт.

Кнопка прокрутки на мыши с колёсиком может использоваться как средняя кнопка мыши для вырезания и вставки текста, а также выполнения других функций средней кнопки. Если у мыши всего две кнопки, отметьте флажок Эмулировать третью (Emulate 3 buttons), чтобы использовать двухкнопочную мышь как трёхкнопочную. Когда этот флажок установлен, одновременное нажатие двух кнопок мыши имитирует нажатие средней кнопки мыши.

Если выбран последовательный порт, нажмите кнопку Последовательные устройства (Serial devices) для выбора подходящего номера последовательного устройства мыши, например /dev/ttyS0.

Нажмите OK, чтобы сохранить новый тип мыши. Выбранные параметры записываются в файл /etc/sysconfig/mouse и служба консольной мыши gpm перезапускается. Изменения также сохраняются в файле конфигурации системы X Window /etc/X11/xorg.conf; однако изменения типа мыши не применяют автоматически в текущем сеансе X. Чтобы задействовать новый тип мыши, завершите работу в графической среде и зайдите в неё снова.

Подсказка | Подсказка
 | Чтобы изменить порядок кнопок мыши для левши выберите в главном меню Приложения (Applications) (на панели) => Параметры (Preferences) => Мышь (Mouse) и отметьте флажок Настроить мышь под левую руку (Left-handed mouse).
Назад | Начало | Вперёд
Настройка клавиатуры | Вверх | Настройка системы X Window


Настройка сети

Назад Вперёд

Глава 18. Настройка сети

Чтобы комьютеры общались с другими компьютерами, они должны быть подключены к сети. Для этого операционная система должна распознать плату сетевого интерфейса (например, Ethernet, ISDN-модем или Token Ring) и настроить интерфейс для подключения к сети.

Программа Настройка сети (Network Administration Tool) позволяет настроить следующие типы сетевых интерфейсов:

  • Ethernet

  • ISDN

  • модем

  • xDSL

  • Token Ring

  • CIPE

  • беспроводные устройства.

С её помощью также можно настраивать подключения IPsec, управлять параметрами DNS и файлом /etc/hosts, в котором хранятся дополнительные сопоставления имён узлов и IP-адресов.

Чтобы использовать программу Настройка сети, вы должны иметь привилегии root. Чтобы запустить это приложение, выберите в Главном меню (Main Menu) (на панели) => Системные параметры (System Settings) => Сеть (Network) или введите команду system-config-network в приглашении оболочки (например, в XTerm или терминале среды GNOME). Если работает система X, эта команда запускает графическую версию программы, в противном случае — текстовую.

Чтобы использовать версию для командной строки, выполните от имени root команду system-config-network-cmd --help и познакомьтесь с её параметрами.

Рисунок 18-1. Настройка сети

Если вы предпочитаете непосредственно редактировать файлы конфигурации, обратитесь к Справочному руководству по Red Hat Enterprise Linux за информацией об их расположении и содержании.

Подсказка | Подсказка
 | Просмотрите список оборудования, совместимого с Red Hat (http://hardware.redhat.com/hcl/), чтобы определить, поддерживает ли Red Hat Enterprise Linux ваше оборудование.

18.1. Обзор

Чтобы настроить сетевое подключение с помощью средства Настройка сети (Network Administration Tool), выполните следующие действия:

  1. Добавьте сетевое устройство, связанное с физическим аппаратным устройством.

  2. Если этого устройства нет в списке оборудования, добавьте его.

  3. Настройте имя узла и параметры DNS.

  4. Определите все узлы, которые нельзя найти через DNS.

В этой главе все эти действия обсуждаются для всех типов сетевых подключений.

Назад | Начало | Вперёд
Сетевая конфигурация | Вверх | Установка Ethernet-подключения


Сетевая файловая система (NFS)

Назад Вперёд

Глава 22. Сетевая файловая система (NFS)

Сетевая файловая система (Network File System, NFS) позволяет обращаться к файлам, находящихся на компьютерах в сети, так, как если бы они располагались локально. Система Red Hat Enterprise Linux может быть и NFS-сервером, и NFS-клиентом, и это означает, что она может экспортировать файловые системы и монтировать файловые системы, экспортированные другими компьютерами.

22.1. Зачем использовать NFS?

NFS применяется для разделения каталогов или файлов между несколькими пользователями одной сети. Например, группа пользователей, работающих с одним проектом, может иметь доступ к файлам этого проекта, используя разделяемый каталог файловой системы NFS (обычно он называется общим каталогом NFS), смонтированный в каталог /myproject. Чтобы обратиться к общим файлам, пользователь переходит в каталог /myproject на своём компьютере. Ему не нужно вводить пароли или запоминать специальные команды. Пользователи работаёт так же, как если бы каталог находился на их локальных компьютерах.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Монтирование файловых систем NFS


OpenSSH

Назад Вперёд

Глава 21. OpenSSH

OpenSSH — это свободная реализация с открытыми исходными текстами протоколов безопасной оболочки (Secure SHell, SSH). Она заменяет telnet, ftp, rlogin, rsh и rcp набором сетевых инструментов, защищённых шифрованием. OpenSSH поддерживает версии 1.3, 1.5 и 2 протокола SSH. Начиная с версии OpenSSH версии 2.9, стандартным является используется протокол версии 2, в котором по умолчанию используются ключи RSA.

21.1. Зачем использовать OpenSSH?

Используя инструменты OpenSSH, вы усиливаете защиту своего компьютера. Все данные, передаваемые инструментами OpenSSH, включая пароли, шифруются, тогда как Telnet и ftp передают пароли и всю остальную информацию открытым текстом. Такая информация может быть перехвачена, пароли рассекречены, и ваша система может быть скомпрометирована злоумышленником, воспользовавшимся одним из перехваченным паролей . Чтобы избежать таких проблем безопасности, везде, где это возможно, следует использовать набор инструментов OpenSSH.

Ещё одной причиной использовать OpenSSH является то, что переменная DISPLAY автоматически перенаправляется на клиентский компьютер. Другими словами, если вы запускаете на локальном компьютере X Window и подключаетесь к удалённому компьютеру, выполнив команду ssh, то, запущенная на том компьютере программа, использующая X, будет отображаться на вашем локальном компьютере. Это удобно, если вы предпочитаете графические инструменты администратора, но не всегда имеете физический доступ к вашему серверу.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Настройка сервера OpenSSH


OProfile

Назад Вперёд

Глава 41. OProfile

OProfile — это средство мониторинга производительности системы, оказывающее минимальное влияние на её работу. Эта программа использует встроенные в процессор аппаратные возможности мониторинга производительности и собирает сведения о ядре и исполняемых модулях, в частности, статистику использования памяти, число обращений к кэшу второго уровня и полученных аппаратных прерываний. Чтобы использовать это средство в Red Hat Enterprise Linux, вы должны установить RPM-пакет oprofile.

Многие процессоры обладают специальными аппаратными возможности для мониторинга производительности. Они позволяют отслеживать определённые события (например, отсутствие запрашиваемых данных в кэше). Эти аппаратные средства обычно представлены в виде одного или нескольких счётчиков, увеличивающихся, когда происходит определённое событие. Когда значение счётчика доходит до предела, вызывается прерывание, что позволяет управлять детализацией мониторинга производительности (и связанными накладными расходами) .

OProfile использует эти аппаратные средства (или их замену с использованием таймера, где они отсутствуют) для проведения выборки данных производительности в момент, когда счётчик вызывает прерывание. Выбранные данные периодически записываются на диск, а затем они могут использоватся для формирования отчётов о производительности на уровне системы или приложений.

OProfile — полезное средство, но используя его, вы должны знать о некоторых ограничениях:

  • Использование общих библиотек — Выборки, выполненные в коде общих библиотек не сопоставляются с конкретным приложением, если не используется параметр --separate=library.

  • Показатели производительности могут быть неточны — Когда регистр мониторинга производительности вызывает обработчик, выполняющий выборку, обработка прерывания может быть не точной, как при исключении деления на ноль. Так как процессор может исполнять инструкции не по порядку, выборка может зафиксироваться для соседней инструкции.

  • opreport неправильно сопоставляет выборки с внутренними (inline) функциями — для определения функции, к которой относится адрес, opreport использует простую оценку диапазона адресов. Выборки, выполненные во внутренней функции, сопоставляются не с ней, а с функцией, включающей эту внутреннюю функцию.

  • OProfile накапливает данные нескольких запусков — OProfile — профилировщик уровня системы и рассчитан на неоднократный запуск и завершение процессов. Таким образом выборки, полученные при разных запусках, накапливаются. Чтобы очистить выборки предыдущих запусков, воспользуйтесь командой opcontrol --reset.

  • Не решает проблемы, связанные не только с процессором — Программа OProfile ориентирована на поиск проблем, область которых ограничена процессором. OProfile не определяет процессы, которые простаивают, ожидая снятия блокировки или какого-то другого события (например, пока устройство ввода/вывода закончит операцию).

41.1. Обзор инструментов

В таблице 41-1 представлен краткий обзор средств, включённых в пакет oprofile.

Команда | Описание
op_help | Выводит список имеющихся событий процессора, а также краткое описание каждого.
op_import | Преобразует файлы базы данных с выборками в формат данной системы из другого двоичного формата. Используйте эту возможность для анализа базы данных с выборками, созданной на другой платформе.
opannotate | Выдаёт прокомментированный исходный код приложения, если оно было скомпилировано с отладочными символами. За подробностями обратитесь к разделу 41.5.3 Использование opannotate.
opcontrol | Определяет множество собираемых данных. За подробностями обратитесь к разделу 41.2 Настройка OProfile.
opreport | Выдаёт отчёт по собранным данным. За подробностями обратитесь к разделу 41.5.1 Использование opreport.
oprofiled | Запускается в виде демона и периодически записывает выборки данных на диск.

Таблица 41-1. Команды OProfile

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Настройка OProfile


Настройка принтера

Назад Вперёд

Глава 34. Настройка принтера

Средство Настройка принтера (Printer Configuration Tool) позволяет пользователям настраивать принтеры. Оно помогает управлять файлом конфигурации принтера, каталогами очереди печати и фильтрами печати.

В Red Hat Enterprise Linux 4 используется система печати CUPS. Если система была обновлена с предыдующей версии Red Hat Enterprise Linux, в которой использовалась CUPS, настроенные очереди сохраняются в процессе обновления.

Для использования средства Настройка принтера (Printer Configuration Tool) требуются привилегии root. Чтобы запустить это приложение, выберите в главном меню Приложения (Applications) (на панели) => Системные параметры (System Settings) => Печать (Printing) или введите команду system-config-printer. Эта команда автоматически определяет, какая версия (графическая или текстовая) программы должна запускаться, в зависимости от того, была ли команда запущена в графической среде или в текстовой консоли.

Чтобы принудительно запустить средство Настройка принтера как текстовое приложение, выполните в приглашении оболочки команду system-config-printer-tui.

Важно | Важно
 | Не изменяйте файл /etc/printcap и файлы в каталоге /etc/cups/. При каждом запуске или перезапуске демона печати (cups) динамически создаются новые файлы конфигурации. Эти файлы также создаются динамически, когда с помощью средства Настройка принтера (Printer Configuration Tool) вносятся какие-либо изменения.

Рисунок 34-1. Настройка принтера

Вы можете настроить очереди печати следующих типов:

  • Локальный принтер (Locally-connected) — принтер, подключенный непосредственно к компьютеру через параллельный или USB-порт.

  • Сетевой принтер CUPS (Networked CUPS) (IPP) — принтер, к которому можно обратиться по TCP/IP-сети через протокол печати через Интернет (Internet Printing Protocol, IPP) (например, это может быть принтер, подключенный к другому компьютеру с системой Red Hat Enterprise Linux, в которой работает CUPS).

  • Сетевой принтер UNIX (Networked UNIX) (LPD) — принтер, подключенный к другой системе UNIX, к которой можно обратиться по сети TCP/IP (например, принтер, подключенный к другому компьютеру с системой Red Hat Enterprise Linux, в которой работает LPD).

  • Сетевой принтер Windows (Networked Windows) (SMB) — принтер, подключенный к другому компьютеру, разделяющему принтер в сети SMB (например, принтер, подключенный к компьютеру с системой Microsoft Windows™).

  • Сетевой принтер Novell (NCP) — принтер, подключенный к другому компьютеру, использующему сетевую технологию Novell NetWare.

  • Сетевой принтер JetDirect (Networked JetDirect) — принтер, подключаемый непосредственно к сети, а не к какому-либо компьютеру.

Важно | Важно
 | Когда вы добавляете новую очередь печати или изменяете существующие, вы должны применить изменения, чтобы они вступили в силу.

Нажатие кнопки Применить (Apply) приводит к сохранению сделанных изменений и перезапуску демона печати. Изменения не попадут в файл конфигурации, пока не будет перезапущен демон печати. Вы также можете выполнить Действие (Action) => Применить (Apply).

34.1. Добавление локального принтера

Чтобы добавить локальный принтер, например, подключенный к параллельному или USB-порту вашего компьютера, нажмите кнопку Создать (New) в основном окне программы Настройка принтера (Printer Configuration Tool), чтобы вызвать окно, показанное на рисунке 34-2. Нажмите Вперёд (Forward) для продолжения.

Рисунок 34-2. Добавление принтера

В показанном на рисунке 34-3 окне введите уникальное имя принтера в текстовом поле Имя (Name). Имя принтера не может содержать пробелы и должно начинаться с буквы. Имя принтера может содержать буквы, цифры, символы минус (-) и подчёркивания (_). По своему усмотрению введите короткое описание принтера, которое может содержать пробелы.

Рисунок 34-3. Определение имени очереди

После нажатия Вперёд (Forward) появляется рисунок 34-4. Выберите вариант Локальный принтер (Locally-connected) в меню Выберите тип очереди (Select a queue type), а затем определите устройство. Устройство обычно называется /dev/lp0, если это принтер с параллельным интерфейсом, или /dev/usb/lp0, если с USB-интерфейсом. Если список устройств пуст, нажмите кнопку Повторное сканирование устройств (Rescan devices), чтобы просканировать подключенные устройства, или нажмите кнопку Нестандартное устройство (Custom device), чтобы указать его вручную. Нажмите Вперёд (Forward) для продолжения.

Рисунок 34-4. Добавление локального принтера

Затем определите тип принтера. За подробными инструкциями обратитесь к разделу 34.7 Выбор модели принтера и завершение настройки.

Назад | Начало | Вперёд
Дополнительная информация | Вверх | Добавление принтера IPP


Установка по сети с применением PXE

Назад Вперёд

Глава 3. Установка по сети с применением PXE

Red Hat Enterprise Linux позволяет выполнять установку по сети с использованием протоколов NFS, FTP и HTTP. Сетевую установку можно запустить с загрузочного компакт-диска, загрузочного флэш-накопителя, или указав параметр загрузки askmethod при использовании первого CD Red Hat Enterprise Linux. Помимо этого, если в компьютере, на который будет устанавливаться система, есть сетевая плата, поддеживающая предзагрузочную среду исполнения (Pre-Execution Environment, PXE), его можно настроить так, что он загрузится, используя файлы, размещённые не на локальном носителе (например, CD-ROM), а в другой сетевой системе.

При сетевой установке с применением PXE сетевая плата клиент с PXE отправляет широковещательный запрос информации DHCP. DHCP-сервер выдаёт клиенту IP-адрес и другие сетевые параметры, в частности, сервер имён, IP-адрес или имя tftp-сервера (предоставляющего файлы, необходимые для запуска программы установки), а также размещение файлов на tftp-сервере. Всё это возможно благодаря загрузчику PXELINUX, входящего в пакет syslinux.

Чтобы подготовиться к PXE-установки необходимо выполнить следующие действия:

  1. Настроить на сетевом сервере (NFS, FTP, HTTP) экспорт дерева каталогов установки.

  2. Настроить на tftp-сервере файлы, необходимые для PXE-загрузки.

  3. Определить, каким узлам разрешена загрузка с применением PXE.

  4. Запустить службу tftp.

  5. Настроить DHCP.

  6. Загрузить клиента и начать установку.

3.1. Настройка сетевого сервера

Прежде всего настройте на NFS, FTP или HTTP-сервере экспорт всего дерева каталогов установки той версии и редакции Red Hat Enterprise Linux, которая будет устанавливаться. За подробными указаниями обратитесь к разделу Подготовка к сетевой установке Руководства по установке Red Hat Enterprise Linux.

Назад | Начало | Вперёд
Сохранение файла | Вверх | Настройка PXE-загрузки


Массив независимых дисков с избыточностью (RAID)

Назад Вперёд

Глава 9. Массив независимых дисков с избыточностью (RAID)

9.1. Что такое RAID?

Основная идея создания RAID массива состоит в объединении сравнительно небольших и недорогих дисков в массив для достижения производительности и отказоустойчивости, не достижимых для одного большого и дорогого диска. Этот массив дисков с точки зрения компьютера выглядит как одна логическая единица или устройство.

RAID — это способ распределения информации по нескольким дискам. RAID использует технологии, такие как чередование (RAID уровня 0), зеркалирование (RAID уровня 1) и чередование с чётностью (RAID уровня 5) для достижения избыточности, сокращения задержек и/или увеличения скорости чтения и записи дисков, а также для улучшения возможностей восстановления в случае отказа дисков.

Основная идея RAID заключается в том, что данные можно распределить по дискам в массиве определённым образом. При этом данные сначала разбиваются на блоки одинакового размера (обычно 32 или 64 Кбайта, хотя могут использоваться и другие размеры). Каждый блок записывается на жёсткий диск RAID-массива в соответствии с уровнем используемого RAID-массива. Когда необходимо прочитать данные, выполняется обратное действие, при этом создаётся впечатление, что несколько дисков представляют собой один большой диск.

Назад | Начало | Вперёд
Разбиение LVM вручную | Вверх | Кто должен использовать RAID?


Настройка Kickstart

Назад Вперёд

Глава 2. Настройка Kickstart

Программа Настройка Kickstart (Kickstart Configurator) позволяет вам создать файл kickstart, используя графический интерфейс, поэтому вам не обязательно заучивать правильный синтаксис этого файла.

Чтобы использовать программу Настройка Kickstart вы должны запустить систему X Window. Чтобы запустить Настройку Kickstart, выберите в основном меню Приложения (Applications) (на панели) => Система (System Tools) => Kickstart или введите команду /usr/sbin/system-config-kickstart.

После того, как вы создадите файл kickstart, вы в любой момент можете выбрать в меню Файл (File) => Предварительный просмотр (Preview) и просмотреть текущие параметры.

Чтобы начать работу с существующим файлом kickstart, выполните Файл (File) => Открыть файл (Open) и выберите нужный файл.

2.1. Базовая конфигурация

Рисунок 2-1. Базовая конфигурация

Выберите в меню Основной язык (Default Language) язык, который будет использоваться при установке и станет языком по умолчанию, используемым после установки

Выберите в меню Клавиатура (Keyboard) тип клавиатуры.

Выберите в меню Мышь (Mouse) вашу мышь. Если вы выберете Мышь отсутствует (No Mouse), мышь настроена не будет. Если выбран пункт Определить тип мыши (Probe for Mouse), программа установки пытается определить мышь автоматически. Автоопределение работает для большинства современных мышей.

Если к вашему компьютеру подключена двухкнопочная мышь, можно эмулировать трехкнопочную, установив флажок Эмулировать три кнопки (Emulate 3 Buttons). Если этот флажок установлен, одновременное нажатие левой и правой кнопки воспринимается как нажатие средней кнопки мыши.

В меню Часовой пояс (Time Zone) выберите часовой пояс, в котором будет работать система. Чтобы настроить систему на использование UTC, выберите Системные часы используют UTC (Use UTC clock).

Введите в текстовом поле Пароль root (Root Password) требуемый пароль пользователя root. Введите тот же пароль в текстовое поле Повторите пароль (Confirm Password). Подтверждение нужно для того, чтобы убедиться, что, набирая пароль, вы не ошиблись, и не получилось так, что вы не будете знать его после завершения установки. Чтобы сохранить в файле зашифрованный пароль, установите флажок Зашифровать пароль root (Encrypt root password). Если вы выберете этот вариант, при сохранении файла введённый вами пароль в открытом виде будет зашифрован и записан в файл kickstart. Не следует вводить уже зашифрованный пароль и одновременно включать его шифрование. Так как файл kickstart это обычный текстовый файл, который можно легко прочитать, рекомендуется использовать шифрование пароля.

Чтобы установить помимо языка, выбранного в выпадающем меню Основной язык (Default Language), другие языки, отметьте их в списке Поддержка языков (Language Support). Язык, выбранный в меню Основной язык (Default Language), используется по умолчанию после установки, однако его можно сменить и после установки с помощью средства Выбор языка (Language Configuration Tool) (system-config-language).

В меню Целевая архитектура (Target Architecture) указывается, дистрибутив какой аппаратной архитектуры используется при установке.

Флажок Перезагрузить систему после установки (Reboot system after installation) определяет, что система будет перезагружена после завершения установки.

Kickstart-установка по умолчанию выполняется в графическом режиме. Чтобы изменить это поведение и использовать текстовый режим, отметьте флажок Текстовый режим установки (Perform installation in text mode).

Вы также можете выполнить kickstart-установку в интерактивном режиме. В этом режиме программа установки использует все параметры, определённые в файле kickstart, но при этом позволяет вам просмотреть их на каждом экране, до перехода к следующему. Чтобы перейти к следующему экрану, согласившись с настройками или изменив их, вы должны нажать кнопку Далее (Next). Чтобы выбрать такую установку, отметьте флажок Выполнить установку в интерактивном режиме (Perform installation in interactive mode).

Назад | Начало | Вперёд
Начало установки при помощи Kickstart | Вверх | Метод установки


Управление пользователями и группами

Назад Вперёд

Глава 33. Управление пользователями и группами

Программа Менеджер пользователей (User Manager) позволяет вам просматривать, изменять, создавать и удалять локальных пользователей и группы.

Чтобы вы могли использовать Менеджер пользователей (User Manager), у вас должна работать система X Window, должен быть установлен RPM-пакет system-config-users, и вы должны иметь права root. Чтобы запустить Менеджер пользователей с рабочего стола выберите в меню Приложения (Applications) (на панели) => Системные параметры (System Settings) => Пользователи и группы (Users & Groups). Или введите в приглашении оболочки (например, в XTerm или терминале GNOME) команду system-config-users.

Рисунок 33-1. Менеджер пользователей

Чтобы просмотреть список всех локальных пользователей в системе, перейдите на вкладку Пользователи (Users). Чтобы просмотреть список всех локальных групп, перейдите на вкладку Группы (Groups).

Чтобы найти определённого пользователя или группу, введите первые несколько символов имени в поле Фильтр поиска (Search filter). Нажмите [Enter] или кнопку Применить фильтр (Apply filter). На экран выводится отфильтрованный список.

Чтобы отсортировать пользователей или группы по имени, щёлкните заголовок столбца имён. Пользователи и группы будут отсортированы по этому столбцу.

В Red Hat Enterprise Linux коды пользователей, меньшие 500, зарезервированы для системных пользователей. По умолчанию Менеджер пользователей не показывает системных пользователей. Чтобы просмотреть всех пользователей, включая системных, снимите в выпадающем меню Свойства (Preferences) флажок Не показывать системных пользователей и группы (Filter system users and groups).

33.1. Создание нового пользователя

Чтобы добавить нового пользователя, нажмите кнопку Добавить пользователя (Add User). На экране появится окно, показанное на рисунке 33-2. Введите в соответствующие поля имя входа и полное имя нового пользователя. Введите пароль пользователя в поля Пароль (Password) и Подтвердите пароль (Confirm Password). Пароль должен состоять минимум из шести символов.

Подсказка | Подсказка
 | Чем длиннее пароль пользователя, тем сложнее будет взломщику угадать его, чтобы затем использовать для доступа к учётной записи пользователя без разрешения. Также рекомендуется не использовать в качестве пароля слова из словаря, а включать в пароль сочетание букв, цифр и специальных символов.

Выберите оболочку для входа в систему. Если вы не знаете, какую оболочку выбрать, согласитесь с предложенным значением /bin/bash. Домашним каталогом пользователя по умолчанию будет /home/username/. Вы можете перенести домашний каталог пользователя в специально созданный каталог, или вовсе не создавать домашний каталог, сняв флажок Создать домашний каталог (Create home directory).

Если вы решили создать домашний каталог, стандартные файлы конфигурации копируются из каталога /etc/skel/ в новый домашний каталог.

В Red Hat Enterprise Linux используется схема с личной группой пользователя (User Private Group, UPG). Схема UPG не вносит ничего нового и не меняет стандартный способ UNIX работы с группами; она предлагает новое соглашение. При создании нового пользователя, по умолчанию, будет создана группа с таким же именем. Если вы не хотите создавать эту группу, снимите флажок Создать частную группу для пользователя (Create a private group for the user).

Чтобы указать код пользователя явно, отметьте флажок Указать ID пользователя вручную (Specify user ID manually). Если этот флажок не установлен, новому пользователю назначается следующий свободный код, начиная с 500. В Red Hat Enterprise Linux коды пользователей, меньшие 500, зарезервированы для системных пользователей.

Нажмите OK, чтобы создать пользователя.

Рисунок 33-2. Новый пользователь

Чтобы определить дополнительные свойства пользователя, например, срок действия пароля, добавив пользователя, измените его свойства. За дополнительной информацией обратитесь к разделу 33.2 Изменение свойств пользователя.

Чтобы добавить пользователя в другие группы, перейдите на вкладку Пользователь (User), выберите пользователя и нажмите кнопку Свойства (Properties). В окне Свойства пользователя (User Properties) выберите вкладку Группы (Groups). Выберите группы, членом которых вы хотите сделать пользователя, определите основную группу пользователя и нажмите OK.

Назад | Начало | Вперёд
Настройки дисплея с двумя мониторами | Вверх | Изменение свойств пользователя


Основы восстановления системы

Назад Вперёд

Глава 5. Основы восстановления системы

Если в работе системы возникают проблемы, существуют способы их исправить. Однако, эти способы требуют от вас достаточно хорошего понимания системы. В этой главе описывается, как загрузиться в режиме восстановления, монопольном и аварийном режиме, чтобы исправить систему, используя собственные знания.

5.1. Распространённые проблемы

Необходимость загрузиться в одном из этих режимов может возникнуть в одной из следующих ситуаций:

  • Вы не можете загрузить Red Hat Enterprise Linux обычным образом (на уровне выполнения 3 или 5).

  • Вы столкнулись с программными или аппаратными проблемами и хотите достать несколько важных файлов с жёсткого диска компьютера.

  • Вы забыли пароль root.

5.1.1. Вы не можете загрузить Red Hat Enterprise Linux

Эта проблема часто возникает в результате установки другой операционной системы после установки Red Hat Enterprise Linux. Некоторые другие операционные системы предполагают что никакие операционные системы на компьютере не установлены, и переписывают главную загрузочную запись (Master Boot Record, MBR), до этого содержащую загрузчик GRUB. Если загрузчик был переписан таким образом, вы не сможете загрузить Red Hat Enterprise Linux, пока не попадёте в режим восстановления и не перенастроите загрузчик.

Другая распространенная проблема возникает, если вы с помощью инструмента разбиения диска измените после установки размер раздела или создадите новый раздел, используя свободное место, и это повлияет на порядок ваших разделов. Если номер раздела вашего каталога / изменяется, загрузчик может не найти его, чтобы смонтировать этот раздел. Чтобы исправить эту проблему, загрузитесь в режиме восстановления и измените файл /boot/grub/grub.conf.

За указаниями по переустановке загрузчика GRUB в окружении восстановления обратитесь к разделу 5.2.1 Переустановка загрузчика.

5.1.2. Аппаратные/Программные проблемы

В эту категорию входят самые разные ситуации. Например, это может быть отказ жёстких дисков или указание неверного ядра или корневого устройства в файле конфигурации загрузчика. В любой из этих ситуаций вы не сможете загрузить Red Hat Enterprise Linux. Однако, если вы загрузитесь в одном из режимов восстановления системы, вы сможете решить проблему или как минимум сделать копии ваших самых важных файлов.

5.1.3. Пароль пользователя root

Что делать, если вы забыли пароль root? Сменить его на другой, загрузившись в режиме восстановления или в монопольном режиме и воспользовавшись командой passwd.

Назад | Начало | Вперёд
Загрузка узлов | Вверх | Загрузка в режиме восстановления


Red Hat Network

Назад Вперёд

Глава 17. Red Hat Network

Сеть Red Hat Network — это Интернет-решение для управления одной или несколькими системами Red Hat Enterprise Linux. Все сообщения о нарушениях безопасности (Security Alerts), исправленных ошибках (Bug Fix Alerts) и улучшениях (Enhancement Alerts) (вместе называемые «Сообщения об ошибках» (Errata Alerts)) можно получить непосредственно с сайта Red Hat, воспользовавшись отдельным приложением Агент обновлений Red Hat (Red Hat Update Agent), или с сайта RHN по адресу http://rhn.redhat.com/.

Рисунок 17-1. Ваш профиль в RHN

Red Hat Network экономит ваше время, рассылая вам почтовые сообщения о выпуске обновлённых пакетов. Вам не нужно искать в Интернете обновлённые пакеты или сообщения о нарушениях безопасности. Кроме этого, по умолчанию Red Hat Network устанавливает пакеты. Вам не нужно изучать работу с RPM или заботиться о разрешении зависимостей программных пакетов, всё это делает RHN.

В число возможностей Red Hat Network входят:

  • Сообщения об ошибках — Благодаря им вы узнаете о нарушениях безопасности, исправленных ошибках и улучшениях, имеющих отношения к системам вашей сети

    Рисунок 17-2. Сообщения об ошибках, затрагивающих вашу систему

  • Автоматическкие уведомления по почте — Когда появляется сообщение об ошибке, связанной с вашей системой, вы получаете по почте уведомление об этом

  • Запланированное исправление ошибок — Доставка исправлений по расписанию

  • Установка пакетов — Запланированная установка пакетов на одну или несколько систем одним нажатием клавиши

  • Агент обновления Red Hat — С помощью Агента обновлений Red Hat (Red Hat Update Agent) вы можете загрузить последние пакеты программ, выпущенные для вашей системы (и по желанию установить их)

  • Сайт Red Hat Network — Управление множеством систем, загрузка отдельных пакетов и выполнение действий по расписанию, например, исправление ошибок через защищённое соединение браузера с любого компьютера

Внимание Внимание

Прежде чем зарегистрировать свою систему в Red Hat Network, вы должны активизировать свой продукт Red Hat Enterprise Linux, чтобы ваша систем была подписана на нужные службы. Чтобы активизировать свой продукт, зайдите на страницу:

http://www.redhat.com/apps/activate/

Активизировав продукт, зарегистрируйте его в сети Red Hat Network, чтобы получать исправления ошибок. В процессе регистрации будет собрана информация о вашей системе, необходимая для того, чтобы уведомлять вас об обновлениях. Например, происходит компиляция списка пакетов, установленных в системе, чтобы вы узнавали только об обновлениях, имеющих отношение к вашей системе.

После первой перезагрузке Setup Agent (Помощник по настройке) предлагает вам зарегистрироваться. Если вы не сделаете этого, вы сможете запустить регистрацию позже, выбрав в главном меню Приложения (Applications) (на панели) => Система (System Tools) => Red Hat Network. Также вы можете выполнить в приглашении оболочки команду up2date.

Рисунок 17-3. Регистрация в RHN

После регистрации вы можете начать получение обновлений одним из следующих способов:

  • Выбрав в главном меню Приложения (Applications) (на панели) => Система (System Tools) => Red Hat Network

  • Выполнив в приглашении оболочки команду up2date.

  • Воспользовавшись сайтом RHN: https://rhn.redhat.com/

За более подробными инструкциями обратитесь к документации, опубликованной по адресу:

http://www.redhat.com/docs/manuals/RHNetwork/

Подсказка | Подсказка
 | В Red Hat Enterprise Linux включёна Утилита оповещения об обновлениях в RHN (Средство уведомлений о событиях) — удобный значок на панели, показывающий уведомления о выходе обновления системы Red Hat Enterprise Linux.
Назад | Начало | Вперёд
Удаление пакетов | Вверх | Сетевая конфигурация


Управление пакетами с помощью RPM

Назад Вперёд

Глава 15. Управление пакетами с помощью RPM

Менеджер пакетов Red Hat (Red Hat Package Manager, RPM) - это открытая система управления пакетами, доступная всем, и работающая в Red Hat Enterprise Linux, а также других системах Linux и UNIX. Red Hat, Inc. приветствует использование технологии RPM другими производителями для собственных продуктов. RPM распространяется в соответствии с условиями GPL.

RPM предоставляет конечному пользователю возможность легко обновлять систему. Установка, удаление и обновление RPM-пакетов выполняется с помощью коротких команд. RPM ведёт базу данных установленных пакетов и их файлов, поэтому вы можете задавать сложные запросы и выполнять проверку системы. Если вы предпочитаете графический интерфейс, воспользуйтесь средством Управление пакетами (Package Management Tool), выполняющим многие команды RPM. За подробностями обратитесь к главе 16 Средство управление пакетами.

При обновлениях RPM обращается с вашими файлы конфигурации аккуратно, так, чтобы вы никогда не потеряли свои собственные настройки, чего нельзя добиться, работая с обычными файлами .tar.gz.

Разработчику RPM позволяет из исходного текста программы получить пакеты исходных текстов и исполняемого кода, предназначенные для конечных пользователей. Этот процесс достаточно прост и управляется одним файлом или, возможно, дополнительно выпущенными исправлениями. Это чёткое разделение первоначальных исходных кодов, исправлений и инструкций по сборке пакета облегчает поддержку пакета по мере выхода новых версий программного обеспечения.

Замечание | Замечание
 | Так как RPM вносит в вашу систему изменения, вы должны иметь права root, чтобы установить, удалить или обновить RPM пакет.

15.1. Цели разработки RPM

Чтобы понять, как использовать RPM, полезно понять цели разработки RPM:

Возможность обновления

Используя RPM, вы можете обновлять отдельные компоненты вашей системы, без полной переустановки. Когда вы получаете новый выпуск операционной системы, основанной на RPM (например, Red Hat Enterprise Linux), вовсе не обязательно переустанавливать её на компьютере (что приходится делать с операционными системами, основанными на других системах пакетов). RPM позволяет разумно и полностью автоматически обновить систему, сохраняя при этом её работоспособность. Файлы конфигурации, включенные в пакеты, сохраняются во время обновления, поэтому ваши настройки не будут потеряны. Для обновления пакета не используются какие-либо специальные файлы обновлений, так как один RPM пакет используется и для установки, и для обновления пакета в системе.

Мощные запросы

В RPM заложены мощные возможности выполнения запросов. Вы можете выполнить поиск пакетов или определенного файла во всей базе данных. Вы также можете легко определить, к какому пакету относится файл, и откуда был получен пакет. Файлы, включенные в RPM-пакет, находятся в сжатом архиве, имеющем специальный двоичный заголовок, содержащий полезную информацию о пакете и его содержимом, что позволяет вам легко анализировать отдельные пакеты.

Проверка целостности системы

Другая мощная возможность — способность проверять целостность пакетов. Если вас волнует, что вы удалили важный файл какого-то пакета, просто проверьте целостность пакета. Вы увидите сообщения о всех несоответствиях. После этого вы можете переустановить пакет, если необходимо. Все изменённые вами файлы конфигурации во время переустановки будут сохранены.

Первоначальные исходные тексты

Важной целью проекта была возможность использования «первоначальных» исходных текстов программного продукта, распространяемых его разработчиками. В RPM содержатся оригинальные исходные тексты программного обеспечения наряду с выпущенными исправлениями, а также детальные инструкции по построению пакетов. Это очень важная возможность по нескольким причинам. Например, если выходит новая версия программы, вам не обязательно начинать её компиляцию с самого начала. Вы можете посмотреть на исправление, чтобы понять, какие действия может потребоваться выполнить. Используя эту технологию, можно легко увидеть все параметры компиляции, а также все внесённые изменения, необходимые для правильной сборки программного продукта.

Может показаться, что сохранение первоначальных исходных текстов важно только для разработчиков, однако, в результате это приводит к улучшению качества программного обеспечения для конечных пользователей.

Назад | Начало | Вперёд
Управление пакетами | Вверх | Использование RPM


Samba

Назад Вперёд

Глава 23. Samba

Samba использует протокол SMB для предоставление в общее пользование сетевых файлов и принтеров. В число операционных систем, поддерживающих этот протокол, входят системы Microsoft Windows, OS/2 и Linux.

В ядро Red Hat Enterprise Linux 4 встроена поддержка списков управления доступом (Access Control List, ACL) для файловых систем ext3. Если сервер Samba предоставляет в общий доступ файловую систему ext3, в которой включены ACL, и в ядро клиентской системы может читать ACL с файловых систем ext3, клиент автоматически распознаёт и использует ACL.

23.1. Зачем использовать Samba?

Служба Samba полезна, если в сети присутствуют и Windows, и Linux-компьютеры. Samba позволяет разделять файлы и принтеры между всеми компьютерами сети. Чтобы разделять файлы только между компьютерами Linux, используйте NFS, как описывается в главе 22 Сетевая файловая система (NFS). Чтобы разделять принтеры только между компьютерами Linux, не обязательно использовать Samba; обратитесь к разделу 34 Настройка принтера.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Настройка сервера Samba


Управление доступом к службам

Назад Вперёд

Глава 20. Управление доступом к службам

Поддержка безопасности вашей системы Red Hat Linux чрезвычайно важна, и один из способов её обеспечить — аккуратно управлять доступом к системым службом. Иногда необходимо открыть доступ к некоторым службам вашей системы (например, httpd, если у вас работает веб-сервер). Однако, если вам не нужно предоставлять службу клиентам, следует отключить её, чтобы уменьшить степень воздействия на систему программ, эксплуатирующих возможные ошибки.

Существует несколько различных способов управления доступом к системным службам. Выбирайте подходящий способ, учитывая особенности службы, конфигурацию системы и уровень ваших знаний Linux.

Самый простой способ запретить доступ к службе — отключить её. Запускать и останавливать службы, управляемые xinetd, а также службы в иерархии /etc/rc.d/init.d (также называемые службами SysV) можно с помощью трёх различных приложений:

  • Средство Настройка служб (Services Configuration Tool) — графическое приложение, отображающее описание каждой службы, тип запуска при загрузки системы (для уровней выполнения 3, 4, и 5), и позволяющее запускать, останавливать или перезапускать службы.

  • ntsysv — текстовое приложение, позволяющее определить службы, запускаемые при загрузке системы для каждого уровня выполнения. С помощью этой программы не могут быть запущены, остановлены или перезапущены не-xinetd службы.

  • chkconfig — программа командной строки, позволяющая включать и отключать службы для различных уровней выполнения. С помощью этой утилиты не могут быть запущены, остановлены или перезапущены не-xinetd службы.

Использовать эти средства проще, чем альтернативный способ — редактировать множество ссылок, расположенных в каталогах: /etc/rc.d вручную или изменять файлы настроек xinetd в /etc/xinetd.d.

Другой способ управления доступом к системным службам — использовать iptables для настройки IP-брандмауэра. Если вы новичок в Linux, вам следует понять, что iptables может оказаться для вас не лучшим решением. Настройка iptables может быть непростой задачей, её лучше выполнять опытным системным администраторам Linux.

С другой стороны, преимуществом использования iptables является гибкость. Например, если вам нужны особые правила, разрешающие доступ определённых узлов к определённым службам, вы сможете определить их в iptables. Обратитесь к Справочному руководству по Red Hat Enterprise Linux и Руководству по безопасности Red Hat Enterprise Linux за дополнительной информацией об iptables.

Если же вам нужна утилита для назначения простых правил доступа к вашему домашнему компьютеру и/или вы мало знакомы с Linux, попробуйте средство Настройка уровня безопасности (Security Level Configuration Tool) (system-config-securitylevel), с помощью которого вы можете выбрать уровень безопасности для своей системы, так же, как и в диалоге Настройка брандмауэра (Firewall Configuration) во время установки системы.

За дополнительными сведениями обратитесь к главе 19 Основная настройка брандмауэра. Если вам нужны более точные правила брандмауэра, обратитесь к разделу iptables Справочного руководства по Red Hat Enterprise Linux.

20.1. Уровни выполнения

Для того чтобы суметь правильно настроить доступ к службам, вы должны понимать, что такое уровни выполнения Linux. Уровень выполнения — это состояние или режим, который определяется службами, перечисленными в каталоге /etc/rc.d/rc<x>.d, где <x> — номер уровня выполнения.

Существуют следующие уровни выполнения:

  • 0 — Останов

  • 1 — Режим одного пользователя

  • 2 — Не используется (определяется пользователем)

  • 3 — Полный многопользовательский режим

  • 4 — Не используется (определяется пользователем)

  • 5 — Полный многопользовательский режим (с графическим экраном входа в систему)

  • 6 — Перезагрузка

Если вы используете текстовый экран входа, вы работаете в уровне выполнения 3. Если вы используете графический экран, вы работаете в уровне выполнения 5.

Уровень выполнения по умолчанию может быть изменён в файле /etc/inittab, который содержит в начале строку, подобную следующей:

id:5:initdefault:

Подставьте вместо числа в этой строке требуемый уровень выполнения. Изменения не вступают в силу до перезапуска системы.

Чтобы изменить уровень выполнения немедленно, выполните команду telinit, добавив номер уровня выполнения. Чтобы использовать эту команду, вы должны быть пользователем root. Команда telinit не меняет файл /etc/inittab, она меняет только текущий уровень выполнения. После перезагрузки система по-прежнему будет загружать уровень выполнения, указанный в файле /etc/inittab.

Назад | Начало | Вперёд
Активизация службы iptables | Вверх | TCP-оболочки


Настройка программного RAID-массива

Назад Вперёд

Глава 10. Настройка программного RAID-массива

Программный RAID можно настроить в процессе графической или текстовой установки, а также во время установки kickstart. В этой главе обсуждается настройка программного RAID во время установки, с использованием программы Disk Druid.

Предварительно прочитайте главу 9 Массив независимых дисков с избыточностью (RAID), чтобы узнать о RAID и отличиях между аппаратными и программными RAID-массивами, а также различиях между уровнями RAID 0, 1 и 5. Настройка RAID включает в себя следующие этапы:

  • Применение разделов программного RAID к физическим жёстким дискам.

    Если вы хотите разместить загрузочный раздел (/boot/) в разделе RAID, это должен быть раздел RAID 1.

  • Создание RAID-устройств разделов программного RAID.

  • Необязательно: Настройка LVM для устройств RAID. За дополнительными сведениями о настройке LVM после создания RAID-массива обратитесь к разделу 8 Настройка LVM.

  • Создание файловых систем для устройств RAID.

Замечание | Замечание
 | Хотя ниже описываются действия, выполняемые во время графической установки, то же самое можно проделать в процессе установки в текстовом режиме. Настройку программного RAID необходимо выполнять в Disk Druid вручную во время установки.

В следующих примерах используются два SCSI-диска объёмом 9,1 Гбайт (/dev/sda and /dev/sdb). Эти примеры показывают, как создать простую конфигурацию RAID 1, настроив несколько устройств RAID.

В диалоге Настройка разбиения диска (Disk Partitioning Setup) выберите вариант Ручное разбиение программой Disk Druid (Manually partition with Disk Druid).

10.1. Создание разделов RAID-массивов

В обычной ситуации вы будете иметь дело с новыми, неформатированными дисками. На рисунке 10-1 оба диска показаны как неформатированные, без информации о разделах, .

Рисунок 10-1. Два чистых диска, готовых к настройке

  1. В Disk Druid выберите RAID, чтобы открыть диалог создания программного RAID.

  2. Выберите Создать раздел программного RAID (Create a software RAID partition), чтобы создать раздел RAID, как показано на рисунке 10-2. Заметьте, что никакие другие параметры RAID (например, точка монтирования) не доступны, пока не будут разделы и устройства RAID.

    Рисунок 10-2. Параметры раздела RAID

  3. Раздел программного RAID должен располагаться на одном диске. В списке Доступные устройства (Allowable Drives) выберите устройство, на котором будет создан RAID. Если у вас несколько дисков, автоматически выбираются все, и сначала вы должны снять отметки со всех, кроме одного.

    Рисунок 10-3. Добавление раздела RAID

  4. Введите размер, который вы хотите задать для раздела.

  5. Выберите вариант Фикс. размер (Fixed size) и явно задайте размер раздела, или Заполнить всё пространство до (Мбайт) (Fill all space up to (MB)) и введите предел размера раздела, или Занять всё доступное пространство (Fill to maximum allowable size), чтобы он занял всё доступное пространство на жёстком диске. Если вы хотите сделать растущим более одного раздела, такие тома разделы между собой свободное пространство на диске.

  6. Отметьте Сделать первичным разделом (Force to be a primary partition), если хотите, чтобы был создан основной раздел. Основным разделом считается один из первых четырёх разделов на жёстком диске. Если флажок не установлен, создаваемый раздел будет логическим. Если на этом компьютере уже установлены другие операционные системы, возможно, этот флажок следует снять. За дополнительными сведениями о различиях между основными и логическими/расширенными разделами, обратитесь к приложениям Руководства по установке Red Hat Enterprise Linux.

  7. Нажмите OK, чтобы вернуться к основному окну.

Повторяйте эти действия, создавая столько разделов, сколько необходимо для построения вашего RAID-массива. Обратите внимание, не обязательно все разделы должны располагаться на массивах RAID. Например, вы можете сделать программный RAID-массив только для раздела /boot/, а корневой раздел (/), /home/ и раздел подкачки разместить в обычных файловых системах. На рисунке 10-4 показано, как было выделено место для RAID 1 (для /boot/). Тепперь можно создавать устройство RAID и точку монтирования:

Рисунок 10-4. Разделы RAID 1 готовы, остаётся создать устройство и точку монтирования

Назад | Начало | Вперёд
Уровни RAID-массивов и линейный RAID | Вверх | Создание устройств RAID и точек монтирования


Пространство подкачки

Назад Вперёд

Глава 11. Пространство подкачки

11,1. Что такое пространство подкачки?

Пространство подкачки используется в Linux, когда вся физическая память (ОЗУ) заполнена. Если вашей системе нужны дополнительные ресурсы, а оперативной памяти не хватает, неактивные страницы перемещаются из памяти в пространство подкачки. Хотя пространство подкачки может помочь на компьютерах с небольшим объёмом ОЗУ, не следует считать его заменой дополнительной памяти. Пространство подкачки размещается на жёстких дисках, скорость которых гораздо ниже, чем оперативной памяти.

Пространством подкачки может быть выделенный раздел подкачки (что рекомендуется), файл подкачки или комбинация файлов и разделов подкачки.

Размер пространства подкачки следует выбирать равным двум объёмам оперативной памяти, при её объёме до 2 Гбайт. Если же у вас больше 2 Гбайт оперативной памяти, к размеру файла подкачки следует прибавить объём ОЗУ сверх 2 Гбайт. Размер пространства подкачки не должен быть меньше 32 Мбайт.

Согласно этой простой формуле, компьютеру с 2 Гбайтами физической памяти следует выделить 4 Гбайт для подкачки, а компьютеру с 3 Гбайтами для подкачки следует отвести 5 Гбайт.

Замечание | Замечание
 | К сожелению, выбор объёма пространства подкачки для Red Hat Enterprise Linux — это скорее искусство, чем наука, поэтому каких-то чётких правил здесь нет. Определяя размер пространства подкачки следует принимать во внимание наиболее часто используемые приложения.

Важно Важно

Файловые системы и тома LVM2, отведённые для пространства подкачки., не могут использоваться в процессе изменения. В частности, пространство подкачки нельзя назначить никаким системным процессам, а также его нельзя распределить и использовать в ядре. Чтобы определить размер пространства подкачки и где оно находится, воспользуйтесь командами free и cat /proc/swaps.

Чтобы изменить настройку пространства подкачки, правильнее всего будет загрузить систему в режиме восстановления и следовать инструкциям (по каждому сценарию), приведённым в продолжении этой главы. Инструкции по загрузке в режиме восстановления описаны в главе 5 Основы восстановления системы. Получив предложение смонтировать файловые системы, ответьте Пропустить (Skip).

Назад | Начало | Вперёд
Создание устройств RAID и точек монтирования | Вверх | Добавление пространства подкачки


Настройка агента доставки почты (MTA)

Назад Вперёд

Глава 39. Настройка агента доставки почты (MTA)

Агент доставки почты (Mail Transport Agent, MTA) — это ключевое звено в процессе доставки почты. Почтовый агент пользователя (Mail User Agent, MUA) — это программа, используемая для чтения и составления электронных писем (примерами таких программ являются Evolution, Mozilla Mail, Thunderbird и Mutt). Когда пользователь отправляет письмо из своей почтовой программы, это письмо передаётся агенту доставки, который пересылает его через другие агенты, пока оно не доходит до адресата.

Деже если пользователь не планирует отправлять почту в своей системе, тем не менее некоторые автоматизированные задачи или системные программы могут использовать команду /bin/mail, чтобы отправлять почту с информационными сообщениями локальному пользователю root.

Red Hat Enterprise Linux 4 предоставляет три агента доставки: Sendmail, Postfix и Exim. Если установлены все три агента, по умолчанию используется sendmail. Программа Переключатель службы доставки почты (Mail Transport Agent Switcher) позволяет назначить sendmail, postfix или exim агентом доставки по умолчанию.

Чтобы вы могли использовать текстовую версию программы Переключатель службы доставки почты, должен быть установлен RPM-пакет system-switch-mail. Если же вы хотите использовать графическую версию, вы также должны установить пакет system-switch-mail-gnome. За дополнительными сведениями об установке RPM-пакетов обратитесь к части III Управление пакетами.

Чтобы запустить Переключатель служб доставки почты (Mail Transport Agent Switcher), выберите в главном меню Приложения (Applications) (на панели) => More Preferences (Preferences) => Дополнительные параметры (More Preferences) => Переключатель служб доставки почты (Mail Transport Agent Switcher) или введите команду system-switch-mail в приглашении оболочки (например, в XTerm или терминале GNOME).

Эта программа автоматически определяет, работает ли система X Window. Если X работает, программа запускается в графическом режиме, как показывает рисунок 39-1. В противном случае она запускается в текстовом режиме. Чтобы принудительно запустить Переключатель служб доставки почты (Mail Transport Agent Switcher) в текстовом режиме, воспользуйтесь командой system-switch-mail-nox.

Рисунок 39-1. Переключатель служб доставки почты

Когда вы меняете агента и нажимаете OK, для выбранного почтового демона настраивается автозапуск при загрузке системы, а остальные демоны почты отключаются, так что они не будут запускаться автоматически. При этом выбранный почтовый демон запускается, а другие демоны останавливаются, таким образом, изменения вступают в силу немедленно.

За дополнительными сведениями о почтовых протоколах и агентах доставки обратитесь к Справочному руководству по Red Hat Enterprise Linux.

Назад | Начало | Вперёд
Дополнительные ресурсы | Вверх | Мониторинг системы


Сбор информации о системе

Назад Вперёд

Глава 40. Сбор информации о системе

Прежде чем как вы узнаете о том, как настраивать вашу систему, вы должны узнать о том, как собирать важную информацию о ней. Например, вам следует знать, как определить объём свободной памяти или свободного места на диске, как жёсткий диск разбит на разделы, и какие процессы работают в системе. В этой главе рассматривается получение такого рода информации в системе Red Hat Enterprise Linux с помощью простых команд и нескольких простых программ.

40.1. Системные процессы

Команда ps ax показывает список работающих в системе процессов, включая процессы, принадлежащие другим пользователям. Чтобы просмотреть также и владельцев этих процессов, выполните команду ps aux. Этот список является статическим; другими словами, это снимок состояния системы в момент выполнения команды. Если вы хотите, чтобы список работающих процессов постоянно обновлялся, воспользуйтесь командой top, описанной ниже.

Команда ps может вывести много информации. Чтобы она задержалась на экране, вы можете пропустить её через команду less:

ps aux | less

Вы можете выполнить команду ps в сочетании с командой grep, чтобы проверить, работает ли какой-то определённый процесс. Например, чтобы определить, работает ли Emacs, выполните следующую команду:

ps ax | grep emacs

Команда top показывает список работающих в данный момент процессов и важную информацию о них, включая использование ими памяти и процессора. Этот список интерактивно формируется в реальном времени. Пример работы команды top показан ниже:

top - 14:01:42 up 9 days, 23:48,  4 users,  load average: 0.10, 0.13, 0.07
Tasks:  96 total,   2 running,  94 sleeping,   0 stopped,   0 zombie
Cpu(s):  2.3% us,  0.3% sy,  0.0% ni, 95.4% id,  2.0% wa,  0.0% hi,  0.0% si
Mem:    645712k total,   613184k used,    32528k free,   176124k buffers
Swap:  1310712k total,        0k used,  1310712k free,   226136k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
10456 root      14  -1 31408  17m 4828 S  2.3  2.7 158:16.98 X
18110 root      16   0  3032 1052  840 R  0.7  0.2   0:00.07 top
    1 root      16   0  3036  560  480 S  0.0  0.1   0:00.98 init
    2 root      34  19     0    0    0 S  0.0  0.0   0:00.10 ksoftirqd/0
    3 root       5 -10     0    0    0 S  0.0  0.0   0:00.07 events/0
    4 root       5 -10     0    0    0 S  0.0  0.0   0:00.01 khelper
    5 root      15 -10     0    0    0 S  0.0  0.0   0:00.00 kacpid
   17 root       5 -10     0    0    0 S  0.0  0.0   0:00.00 kblockd/0
   18 root      15   0     0    0    0 S  0.0  0.0   0:00.00 khubd
   27 root      20   0     0    0    0 S  0.0  0.0   0:00.00 pdflush
   28 root      15   0     0    0    0 S  0.0  0.0   0:01.96 pdflush
   30 root      12 -10     0    0    0 S  0.0  0.0   0:00.00 aio/0
   29 root      16   0     0    0    0 S  0.0  0.0   0:01.98 kswapd0
  103 root      25   0     0    0    0 S  0.0  0.0   0:00.00 kseriod
  173 root      23   0     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_0
  174 root      15   0     0    0    0 S  0.0  0.0   0:00.00 ahc_dv_0
  177 root      20   0     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_1

Чтобы выйти из программы top, нажмите клавишу [q].

В таблице 40-1 приведены полезные интерактивные команды, которые можно использовать в top. За дополнительнымии сведениями обратитесь к странице руководства man top(1).

Команда | Описание
[Пробел] | Немедленно обновить содержимое экрана
[h] | Вывести справку о программе
[k] | Уничтожить процесс. Программа запрашивает у вас код процесса и сигнал, который будет ему послан.
[n] | Изменить число отображаемых процессов. Вам предлагается ввести число.
[u] | Сортировать по имени пользователя.
[M] | Сортировать по объёму используемой памяти.
[P] | Сортировать по загрузке процессора.

Таблица 40-1. Интерактивные команды top

Если вы предпочитаете использовать графический интерфейс top, вы можете использовать Системный монитор (GNOME System Monitor). Чтобы запустить его с рабочего стола, выберите в главном меню Приложения (Applications) (на панели) => Система (System Tools) => Системный монитор (System Monitor) или введите gnome-system-monitor в приглашении оболочки (например, в XTerm). Перейдите на вкладку Список процессов (Process Listing).

Системный монитор (GNOME System Monitor) позволяет вам найти процесс в списке работающих процессов, а также просмотреть список всех, ваших или активных процессов.

Чтобы узнать о процессе больше, выберите его и нажмите кнопку Больше информации (More Info). Сведения о процессе выводятся в нижней части окна.

Чтобы остановить процесс, выберите его и нажмите кнопку Завершить процесс (End Process). Эта функция может пригодиться для процессов, не отвечающих на запросы пользователя.

Чтобы отсортировать информацию в определённом столбце, шёлкните заголовок этого столбца. Столбец, по которому отсортирована информация, выделяется тёмно-серым цветом.

Рисунок 40-1. Системный монитор

Назад | Начало | Вперёд
Мониторинг системы | Вверх | Использование памяти


Настройка системы X Window

Назад Вперёд

Глава 32. Настройка системы X Window

Во время установки настраиваются параметры монитора, видеоплаты и дисплея компьютера. Чтобы изменить в системе эти параметры, воспользуйтесь средством Параметры дисплея (X Configuration Tool).

Чтобы запустить программу Параметры дисплея (X Configuration Tool), выберите в меню Приложения (Applications) (на панели) => Системные параметры (System Settings) => Дисплей (Display) или введите в приглашении оболочки команду system-config-display. Если вы работаете не в системе X Window, для выполнения этой программы запускается минимальная версия X.

Изменив какие-либо параметры, выйдите из графической среды и вернитесь в ней, чтобы они вступили в силу.

32.1. Настройки дисплея

Вкладка Дисплей (Display) позволяет пользователю настраивать разрешение и глубину цвета. Дисплей монитора состоит из маленьких точек или пикселов. Количество одновременно отображаемых на экране называется разрешением. Например, разрешение 1024x768 означает, что используется 1024 пикселов по горизонтали и 768 пикселов по вертикали. Чем больше числа, определяющие разрешение, тем больше изображений монитор может показать одновременно. Например, чем выше разрешение, тем меньше значки на рабочем столе и тем больше их помещается на экране.

Глубина цвета дисплея определяет количество цветов, которые можно отобразить. Чем выше глубина цвета, тем больше цветовых оттенков.

Рисунок 32-1. Настройки дисплея

Назад | Начало | Вперёд
Настройка мыши | Вверх | Настройки оборудования дисплея


Выходные сведения

Эти руководства написаны в формате DocBook SGML v4.1. Файлы в форматах HTML и PDF получены с помощью специальных стилей DSSSL и специально разработанных сценариев jade. Файлы DocBook SGML создавались с использованием редактора Emacs с помощью режима PSGML.

Рисунки, привлекающие внимание (замечание, подсказка, важно, внимание и предупреждение), создал Гаретт Лесаж (Garrett LeSage) . Они могут свободно распространяться в составе документации Red Hat.

В команду документации продукта Red Hat входят:

Сандра Мур (Sandra A. Moore) — Главный автор, осуществляющий поддержку Руководства по установке Red Hat Enterprise Linux для платформ x86, Itanium™, AMD64 и Intel® Extended Memory 64 Technology (Intel® EM64T), Руководства по установке Red Hat Enterprise Linux для платформы IBM® POWER, Руководства по установке Red Hat Enterprise Linux для платформ IBM® S/390® и IBM® eServer™ zSeries®

Джон Ха (John Ha) — Главный автор, осуществляющий поддержку документации Настройка и управление кластером в Red Hat Cluster Suite; соавтор, осуществляющий поддержку Руководства по безопасности Red Hat Enterprise Linux, кроме этого он поддерживает расширенные стили и сценарии DocBook

Эдвард Бэйли (Edward C. Bailey) — Главный автор, осуществляющий поддержку Введения в системное администрирование Red Hat Enterprise Linux, Замечании к версии; соавтор Руководства по установке Red Hat Enterprise Linux для платформ x86, Itanium™, AMD64 и Intel® Extended Memory 64 Technology (Intel® EM64T)

Карстен Вэйд (Karsten Wade) — Главный автор, осуществляющий поддержку Руководства по Red Hat SELinux, соавтор Руководства по системному администрированию Red Hat Enterprise Linux

Андриус T. Бенокрайтис (Andrius T. Benokraitis) — Главный автор, осуществляющий поддержку Справочного руководства по Red Hat Enterprise Linux; соавтор, осуществляющий поддержку Руководства по безопасности Red Hat Enterprise Linux; соавтор Введения в системное администрирование Red Hat Enterprise Linux

Пол Кеннеди (Paul Kennedy) — Главный автор, осуществляющий поддержку Руководства администратора Red Hat GFS; соавтор документации Настройка и управление кластером в Red Hat Cluster Suite

Марк Джонсон — Главный автор, осуществляющий поддержку Руководства по развёртыванию Red Hat Desktop, соавтор документации Red Hat Network

Мелисса Голдин (Melissa Goldin) — Главный автор, осуществляющий поддержку Руководства по освоению Red Hat Enterprise Linux шаг за шагом, соавтор документации Red Hat Network

Люси Рингланд (Lucy Ringland) — редактор документации Red Hat Enterprise Linux.

В команду перевода документации продукта Red Hat входят:

Аманприт Синх Алам (Amanpreet Singh Alam) — перевод на пенджабский

Жан-Поль Обри (Jean-Paul Aubry) — перевод на французский

Дэвид Бэрзилэй (David Barzilay) — перевод на бразильский португальский

Руна Бхаттачарджи (Runa Bhattacharjee) — перевод на бенгальский

Честер Ченг (Chester Cheng) — перевод на китайский с традиционным написанием

Верена Фуерер (Verena Fuehrer) — перевод на немецкий

Кайото Хэшида (Kiyoto Hashida) — перевод на японский

Н. Джайраджа (N. Jayaradha) — перевод на тамильский

Мишель Джайин Ким (Michelle Jiyeen Kim) — перевод на корейский

Йелица Лауз (Yelitza Louze) — перевод на испанский

Норико Мицумото (Noriko Mizumoto) — перевод на японский

Анкткумар Рамешчандра Пател (Ankitkumar Rameshchandra Patel) — перевод на гуджарати

Раджеш Ранджан (Rajesh Ranjan) — перевод на хинди

Нэдин Рихтер (Nadine Richter) — перевод на немецкий

Одрю Симонс (Audrey Simons) — перевод на французский

Франческо Валенте (Francesco Valente) — перевод на итальянский

Сара Вон (Sarah Wang) — перевод на китайский с упрощённым написанием

Бэн Хун-Пинь Ву (Ben Hung-Pin Wu) — перевод на китайский с традиционным написанием

Тонгджи Тони Фу (Tongjie Tony Fu) — перевод на китайский с упрощённым написанием

Мануэль Оспина — перевод на испанский

Назад | Начало
Предметный указатель |


Index

Symbols

/dev/oprofile/, Understanding /dev/oprofile/
/dev/shm, File Systems
/etc/auto.master, Mounting NFS File Systems using autofs
/etc/cups/, Printer Configuration
/etc/exports, Exporting NFS File Systems
/etc/fstab, Converting to an ext3 File System, Mounting NFS File Systems using /etc/fstab
/etc/fstab file
enabling disk quotas with, Enabling Quotas
/etc/hosts, Managing Hosts
/etc/httpd/conf/httpd.conf, Apache HTTP Server Configuration
/etc/printcap, Printer Configuration
/etc/sysconfig/dhcpd, Starting and Stopping the Server
/proc/ directory, Installed Documentation
/var/spool/cron, Configuring Cron Tasks

A

Access Control Lists
see ACLs
ACLs
access ACLs, Setting Access ACLs
additional resources, Additional Resources
archiving with, Archiving File Systems With ACLs
default ACLs, Setting Default ACLs
getfacl, Retrieving ACLs
mounting file systems with, Mounting File Systems
mounting NFS shares with, NFS
on ext3 file systems, Access Control Lists
retrieving, Retrieving ACLs
setfacl, Setting Access ACLs
setting
access ACLs, Setting Access ACLs
with Samba, Access Control Lists
activating your subscription, Activate Your Subscription
adding
group, Adding a Group
user, Command Line Configuration
Apache HTTP Server
see HTTP Configuration Tool
additional resources, Additional Resources
related books, Related Books
securing, An Overview of Certificates and Security
APXS, An Overview of Security-Related Packages
at, At and Batch
additional resources, Additional Resources
authconfig
see Authentication Configuration Tool
authentication, Authentication Configuration
Authentication Configuration Tool, Authentication Configuration
authentication, Authentication
Kerberos support, Authentication
LDAP support, Authentication
MD5 passwords, Authentication
shadow passwords, Authentication
SMB support, Authentication
Winbind, Authentication
command line version, Command Line Version
user information, User Information
cache, User Information
Hesiod, User Information
LDAP, User Information
NIS, User Information
Winbind, User Information
autofs, Mounting NFS File Systems using autofs
/etc/auto.master, Mounting NFS File Systems using autofs
Automated Tasks, Automated Tasks

B

batch, At and Batch
additional resources, Additional Resources
boot media, Preparing to Upgrade
boot partition, Creating the /boot/ Partition
booting
emergency mode, Booting into Emergency Mode
rescue mode, Booting into Rescue Mode
single-user mode, Booting into Single-User Mode

C

CA
see secure server
chage command
forcing password expiration with, Password Aging
chkconfig, chkconfig
color depth, Display Settings
command line options
printing from, Managing Print Jobs
configuration
console access, Console Access
NFS, Network File System (NFS)
console
making files accessible from, Making Files Accessible From the Console
console access
configuring, Console Access
defining, Defining the Console
disabling, Disabling Console Program Access
enabling, Enabling Console Access for Other Applications
conventions
document, Document Conventions
copying and pasting text
when using X, Copying and Pasting Text With X
Cron, Automated Tasks
additional resources, Additional Resources
configuration file, Configuring Cron Tasks
example crontabs, Configuring Cron Tasks
user-defined tasks, Configuring Cron Tasks
crontab, Configuring Cron Tasks
CtrlAltDel
shutdown, disabling, Disabling Shutdown Via CtrlAltDel
CUPS, Printer Configuration

D

date configuration, Time and Date Properties
dateconfig
see Time and Date Properties Tool
devel package, An Overview of Security-Related Packages
df, File Systems
DHCP, Dynamic Host Configuration Protocol (DHCP)
additional resources, Additional Resources
client configuration, Configuring a DHCP Client
command line options, Starting and Stopping the Server
connecting to, Configuring a DHCP Client
dhcpd.conf, Configuration File
dhcpd.leases, Starting and Stopping the Server
dhcrelay, DHCP Relay Agent
diskless environment, Configuring the DHCP Server, Configuring the DHCP Server
global parameters, Configuration File
group, Configuration File
options, Configuration File
PXE installations, Configuring the DHCP Server, Configuring the DHCP Server
reasons for using, Why Use DHCP?
Relay Agent, DHCP Relay Agent
server configuration, Configuring a DHCP Server
shared-network, Configuration File
starting the server, Starting and Stopping the Server
stopping the server, Starting and Stopping the Server
subnet, Configuration File
dhcpd.conf, Configuration File
dhcpd.leases, Starting and Stopping the Server
dhcrelay, DHCP Relay Agent
disk quotas, Implementing Disk Quotas
additional resources, Additional Resources
assigning per file system, Assigning Quotas per File System
assigning per group, Assigning Quotas per Group
assigning per user, Assigning Quotas per User
disabling, Enabling and Disabling
enabling, Configuring Disk Quotas, Enabling and Disabling
/etc/fstab, modifying, Enabling Quotas
creating quota files, Creating the Quota Database Files
quotacheck, running, Creating the Quota Database Files
grace period, Assigning Quotas per User
hard limit, Assigning Quotas per User
management of, Managing Disk Quotas
quotacheck command, using to check, Keeping Quotas Accurate
reporting, Reporting on Disk Quotas
soft limit, Assigning Quotas per User
disk storage
see disk quotas
parted
see parted
diskless environment, Diskless Environments
adding hosts, Adding Hosts
DHCP configuration, Configuring the DHCP Server, Configuring the DHCP Server
Network Booting Tool, Finish Configuring the Diskless Environment
NFS configuration, Configuring the NFS Server
overview, Diskless Environments
display
settings for X, Display Settings
documentation
finding installed, Impressing Your Friends with RPM
drag and drop, Using the Mouse
DSA keys
generating, Generating a DSA Key Pair for Version 2
DSOs
loading, An Overview of Security-Related Packages
du, File Systems
Dynamic Host Configuration Protocol
see DHCP

E

e2fsck, Reverting to an ext2 File System
e2label, Labeling the Partition
emergency mode, Booting into Emergency Mode
Ethernet connection
see network configuration
exim, Mail Transport Agent (MTA) Configuration
expiration of password, forcing, Password Aging
exporting NFS file Systems, Exporting NFS File Systems
exports, Exporting NFS File Systems
ext2
reverting from ext3, Reverting to an ext2 File System
ext3
converting from ext2, Converting to an ext3 File System
creating, Creating an ext3 File System
features, Features of ext3

F

feedback, Send in Your Feedback
file systems, File Systems
ext2
see ext2
ext3
see ext3
LVM
see LVM
NFS
see NFS
findsmb, Command Line
firewall configuration
see Security Level Configuration Tool
floppy group, use of, The floppy Group
free, Memory Usage
ftp, Why Use OpenSSH?

G

getfacl, Retrieving ACLs
GNOME Print Manager, Managing Print Jobs
change printer settings, Managing Print Jobs
GNOME System Monitor, System Processes
gnome-system-monitor, System Processes
GnuPG
checking RPM package signatures, Checking a Package's Signature
group configuration
adding groups, Adding a New Group
additional information, Additional Information
filtering list of groups, User and Group Configuration
groupadd, Adding a Group
modify groups for a user, Adding a New User
modify users in groups, Modifying Group Properties
modifying group properties, Modifying Group Properties
viewing list of groups, User and Group Configuration
groups
see group configuration
floppy, use of, The floppy Group

H

hardware
viewing, Hardware
Hardware Browser, Hardware
Hardware RAID
see RAID
hesiod, User Information
HTTP Configuration Tool
directives
see HTTP directives
error log, Logging
modules, Apache HTTP Server Configuration
transfer log, Logging
HTTP directives
DirectoryIndex, Site Configuration
ErrorDocument, Site Configuration
ErrorLog, Logging
Group, Server Settings
HostnameLookups, Logging
KeepAlive, Performance Tuning
KeepAliveTimeout, Performance Tuning
Listen, Basic Settings
LogFormat, Logging
LogLevel, Logging
MaxClients, Performance Tuning
MaxKeepAliveRequests, Performance Tuning
Options, Site Configuration
ServerAdmin, Basic Settings
ServerName, Basic Settings
TimeOut, Performance Tuning
TransferLog, Logging
User, Server Settings
httpd, Apache HTTP Server Configuration
hwbrowser, Hardware

I

information
about your system, Gathering System Information
insmod, Kernel Module Utilities
installation
kickstart
see kickstart installations
LVM, LVM Configuration
PXE
see PXE installations
software RAID, Software RAID Configuration
Internet connection
see network configuration
introduction, Introduction
IPsec
host-to-host, Host-to-Host Connection
network-to-network, Network-to-Network (VPN) Connection
ipsec-tools, Host-to-Host Connection, Network-to-Network (VPN) Connection
iptables, Activating the iptables Service
ISDN connection
see network configuration

K

Kerberos, Authentication
kernel
downloading, Downloading the Upgraded Kernel
large memory support, Overview of Kernel Packages
modules, Kernel Modules
multiple processor support, Overview of Kernel Packages
upgrading, Manually Upgrading the Kernel
kernel modules
/etc/rc.modules, Persistent Module Loading
listing, Kernel Module Utilities
loading, Kernel Module Utilities
persistent loading, Persistent Module Loading
unload, Kernel Module Utilities
keyboard
configuring, Keyboard Configuration
Keyboard Configuration Tool, Keyboard Configuration
keyboards, Keyboard Configuration
configuration, Keyboard Configuration
kickstart
how the file is found, Starting a Kickstart Installation
Kickstart Configurator, Kickstart Configurator
%post script, Post-Installation Script
%pre script, Pre-Installation Script
authentication options, Authentication
basic options, Basic Configuration
boot loader, Boot Loader Options
boot loader options, Boot Loader Options
Display configuration, Display Configuration
firewall configuration, Firewall Configuration
installation method selection, Installation Method
interactive, Basic Configuration
keyboard, Basic Configuration
language, Basic Configuration
language support, Basic Configuration
mouse, Basic Configuration
network configuration, Network Configuration
package selection, Package Selection
partitioning, Partition Information
software RAID, Creating Software RAID Partitions
preview, Kickstart Configurator
reboot, Basic Configuration
root password, Basic Configuration
encrypt, Basic Configuration
saving, Saving the File
SELinux configuration, SELinux Configuration
text mode installation, Basic Configuration
time zone, Basic Configuration
kickstart file
%include, Kickstart Options
%post, Post-installation Script
%pre, Pre-installation Script
auth, Kickstart Options
authconfig, Kickstart Options
autopart, Kickstart Options
autostep, Kickstart Options
bootloader, Kickstart Options
CD-ROM-based, Creating Kickstart Boot Media
clearpart, Kickstart Options
cmdline, Kickstart Options
creating, Kickstart Options
device, Kickstart Options
diskette-based, Creating Kickstart Boot Media
driverdisk, Kickstart Options
firewall, Kickstart Options
firstboot, Kickstart Options
flash-based, Creating Kickstart Boot Media
format of, Creating the Kickstart File
halt, Kickstart Options
include contents of another file, Kickstart Options
install, Kickstart Options
installation methods, Kickstart Options
interactive, Kickstart Options
keyboard, Kickstart Options
lang, Kickstart Options
langsupport, Kickstart Options
logvol, Kickstart Options
mouse, Kickstart Options
network, Kickstart Options
network-based, Making the Kickstart File Available on the Network, Making the Installation Tree Available
options, Kickstart Options
partitioning examples, Advanced Partitioning Example
package selection specification, Package Selection
part, Kickstart Options
partition, Kickstart Options
post-installation configuration, Post-installation Script
poweroff, Kickstart Options
pre-installation configuration, Pre-installation Script
raid, Kickstart Options
reboot, Kickstart Options
rootpw, Kickstart Options
selinux, Kickstart Options
shutdown, Kickstart Options
skipx, Kickstart Options
text, Kickstart Options
timezone, Kickstart Options
upgrade, Kickstart Options
volgroup, Kickstart Options
what it looks like, Creating the Kickstart File
xconfig, Kickstart Options
zerombr, Kickstart Options
kickstart installations, Kickstart Installations
CD-ROM-based, Creating Kickstart Boot Media
diskette-based, Creating Kickstart Boot Media
file format, Creating the Kickstart File
file locations, Making the Kickstart File Available
flash-based, Creating Kickstart Boot Media
installation tree, Making the Installation Tree Available
LVM, Kickstart Options
network-based, Making the Kickstart File Available on the Network, Making the Installation Tree Available
starting, Starting a Kickstart Installation
from a boot CD-ROM, Starting a Kickstart Installation
from CD-ROM #1 with a diskette, Starting a Kickstart Installation

L

LDAP, User Information, Authentication
loading kernel modules, Kernel Modules
log files, Log Files
see also Log Viewer
description, Log Files
examining, Examining Log Files
locating, Locating Log Files
rotating, Locating Log Files
syslogd, Log Files
viewing, Viewing Log Files
Log Viewer
alerts, Examining Log Files
filtering, Viewing Log Files
log file locations, Viewing Log Files
refresh rate, Viewing Log Files
searching, Viewing Log Files
logical volume, What is LVM?, Creating the LVM Logical Volumes
logical volume group, What is LVM?
Logical Volume Manager
see LVM
logrotate, Locating Log Files
lpd, Printer Configuration
lsmod, Kernel Module Utilities
lspci, Hardware
LVM, Logical Volume Manager (LVM)
additional resources, Additional Resources
configuring LVM during installation, LVM Configuration
explanation of, What is LVM?
installing
automatic partitioning, Automatic Partitioning, Manual LVM Partitioning
creating a logical volume, Creating the LVM Logical Volumes
creating physical volumes, Creating the LVM Physical Volumes
creating the boot partition, Creating the /boot/ Partition
creating volume groups, Creating the LVM Volume Groups
logical volume, What is LVM?, Creating the LVM Logical Volumes
logical volume group, What is LVM?
LVM tools and utilities, LVM Partition Management
physical extent, Creating the LVM Volume Groups
physical volume, What is LVM?, Creating the LVM Physical Volumes
volume groups, Creating the LVM Volume Groups
with kickstart, Kickstart Options
LVM2
explanation of, What is LVM2?

M

Mail Transport Agent
see MTA
Mail Transport Agent Switcher, Mail Transport Agent (MTA) Configuration
starting in text mode, Mail Transport Agent (MTA) Configuration
Mail User Agent, Mail Transport Agent (MTA) Configuration
Master Boot Record, Unable to Boot into Red Hat Enterprise Linux
reinstalling, Reinstalling the Boot Loader
MD5 passwords, Authentication
memory usage, Memory Usage
mkfs, Formating the Partition
mkpart, Making the Partition
modem connection
see network configuration
modprobe, Kernel Module Utilities
modprobe.conf, Kernel Modules
monitor
settings for dual head, Dual Head Display Settings
settings for X, Display Hardware Settings
mounting
NFS file systems, Mounting NFS File Systems
mouse
how to use, Using the Mouse
MTA
setting default, Mail Transport Agent (MTA) Configuration
switching with Mail Transport Agent Switcher, Mail Transport Agent (MTA) Configuration
MUA, Mail Transport Agent (MTA) Configuration

N

neat
see network configuration
Network Administration Tool
see network configuration
Network Booting Tool, PXE Boot Configuration
pxeboot, Command Line Configuration
pxeos, Command Line Configuration
using with diskless environments, Finish Configuring the Diskless Environment
using with PXE installations, PXE Boot Configuration
network configuration
device aliases, Device Aliases
DHCP, Establishing an Ethernet Connection
Ethernet connection, Establishing an Ethernet Connection
activating, Establishing an Ethernet Connection
IPsec, host-to-host, Host-to-Host Connection
IPsec, network-to-network, Network-to-Network (VPN) Connection
ISDN connection, Establishing an ISDN Connection
activating, Establishing an ISDN Connection
logical network devices, Working with Profiles
managing /etc/hosts, Managing Hosts
managing DNS Settings, Managing DNS Settings
managing hosts, Managing Hosts
modem connection, Establishing a Modem Connection
activating, Establishing a Modem Connection
overview, Overview
PPPoE connection, Establishing an xDSL Connection
profiles, Working with Profiles
activating, Working with Profiles
restoring from file, Saving and Restoring the Network Configuration
saving to file, Saving and Restoring the Network Configuration
static IP, Establishing an Ethernet Connection
token ring connection, Establishing a Token Ring Connection
activating, Establishing a Token Ring Connection
wireless connection, Establishing a Wireless Connection
activating, Establishing a Wireless Connection
xDSL connection, Establishing an xDSL Connection
activating, Establishing an xDSL Connection
Network Device Control, Working with Profiles
Network File System
see NFS
Network Time Protocol
see NTP
NFS
/etc/fstab, Mounting NFS File Systems using /etc/fstab
additional resources, Additional Resources
autofs
see autofs
command line configuration, Command Line Configuration
configuration, Network File System (NFS)
diskless environment, configuring for, Configuring the NFS Server
exporting, Exporting NFS File Systems
hostname formats, Hostname Formats
mounting, Mounting NFS File Systems
over TCP, Using TCP
starting the server, Starting and Stopping the Server
status of the server, Starting and Stopping the Server
stopping the server, Starting and Stopping the Server
NFS Server Configuration Tool, Exporting NFS File Systems
NIS, User Information
NTP
configuring, Network Time Protocol (NTP) Properties
ntpd, Network Time Protocol (NTP) Properties
ntpd, Network Time Protocol (NTP) Properties
ntsysv, ntsysv

O

O'Reilly & Associates, Inc., Related Books, Related Books
opannotate
see OProfile
opcontrol
see OProfile
OpenLDAP, User Information, Authentication
openldap-clients, User Information
OpenSSH, OpenSSH
additional resources, Additional Resources
client, Configuring an OpenSSH Client
scp, Using the scp Command
sftp, Using the sftp Command
ssh, Using the ssh Command
DSA keys
generating, Generating a DSA Key Pair for Version 2
generating key pairs, Generating Key Pairs
RSA keys
generating, Generating an RSA Key Pair for Version 2
RSA Version 1 keys
generating, Generating an RSA Key Pair for Version 1.3 and 1.5
server, Configuring an OpenSSH Server
/etc/ssh/sshd_config, Configuring an OpenSSH Server
starting and stopping, Configuring an OpenSSH Server
ssh-add, Configuring ssh-agent
ssh-agent, Configuring ssh-agent
with GNOME, Configuring ssh-agent with GNOME
ssh-keygen
DSA, Generating a DSA Key Pair for Version 2
RSA, Generating an RSA Key Pair for Version 2
RSA Version 1, Generating an RSA Key Pair for Version 1.3 and 1.5
OpenSSL
additional resources, Additional Resources
opreport
see OProfile
see OProfile
OProfile, OProfile
/dev/oprofile/, Understanding /dev/oprofile/
additional resources, Additional Resources
configuring, Configuring OProfile
separating profiles, Separating Kernel and User-space Profiles
events
sampling rate, Sampling Rate
setting, Setting Events to Monitor
monitoring the kernel, Specifying the Kernel
opannotate, Using opannotate
opcontrol, Configuring OProfile
--no-vmlinux, Specifying the Kernel
--start, Starting and Stopping OProfile
--vmlinux=, Specifying the Kernel
opreport, Using opreport
on a single executable, Using opreport on a Single Executable
oprofiled, Starting and Stopping OProfile
log file, Starting and Stopping OProfile
op_help, Setting Events to Monitor
overview of tools, Overview of Tools
reading data, Analyzing the Data
saving data, Saving Data
starting, Starting and Stopping OProfile
unit mask, Unit Masks
oprofiled
see OProfile
oprof_start, Graphical Interface
op_help, Setting Events to Monitor

P

Package Management Tool, Package Management Tool
installing packages, Installing Packages
removing packages, Removing Packages
packages
dependencies, Unresolved Dependency
determining file ownership with, Impressing Your Friends with RPM
finding deleted files from, Impressing Your Friends with RPM
freshening with RPM, Freshening
installing, Installing
with Package Management Tool, Installing Packages
locating documentation for, Impressing Your Friends with RPM
obtaining list of files, Impressing Your Friends with RPM
preserving configuration files, Upgrading
querying, Querying
querying uninstalled, Impressing Your Friends with RPM
removing, Uninstalling
with Package Management Tool, Removing Packages
tips, Impressing Your Friends with RPM
upgrading, Upgrading
verifying, Verifying
pam_smbpass, Encrypted Passwords
pam_timestamp, Enabling Console Access for Other Applications
parted, Standard Partitions using parted
creating partitions, Creating a Partition
overview, Standard Partitions using parted
removing partitions, Removing a Partition
resizing partitions, Resizing a Partition
selecting device, Viewing the Partition Table
table of commands, Standard Partitions using parted
viewing partition table, Viewing the Partition Table
partition table
viewing, Viewing the Partition Table
partitions
creating, Creating a Partition
formating
mkfs, Formating the Partition
labeling
e2label, Labeling the Partition
making
mkpart, Making the Partition
removing, Removing a Partition
resizing, Resizing a Partition
viewing list, Viewing the Partition Table
password
aging, Password Aging
forcing expiration of, Password Aging
PCI devices
listing, Hardware
physical extent, Creating the LVM Volume Groups
physical volume, What is LVM?, Creating the LVM Physical Volumes
pixels, Display Settings
postfix, Mail Transport Agent (MTA) Configuration
PPPoE, Establishing an xDSL Connection
Pre-Execution Environment, PXE Network Installations
printconf
see printer configuration
printer configuration, Printer Configuration
adding
CUPS (IPP) printer, Adding an IPP Printer
IPP printer, Adding an IPP Printer
JetDirect printer, Adding a JetDirect Printer
local printer, Adding a Local Printer
LPD printer, Adding a Remote UNIX (LPD) Printer
Novell NetWare (NCP) printer, Adding a Novell NetWare (NCP) Printer
Samba (SMB) printer, Adding a Samba (SMB) Printer
cancel print job, Managing Print Jobs
command line options, Command Line Configuration
add a printer, Adding a Local Printer
remove a printer, Removing a Local Printer
restore configuration, Saving the Configuration File
save configuration, Saving the Configuration File
setting default printer, Setting the Default Printer
CUPS, Printer Configuration
default printer, Modifying Existing Printers
delete existing printer, Modifying Existing Printers
driver options, Driver Options
Effective Filter Locale, Driver Options
GhostScript pre-filtering, Driver Options
Media Source, Driver Options
Page Size, Driver Options
Prerender Postscript, Driver Options
edit driver, Printer Driver
edit existing printer, Modifying Existing Printers
exporting settings, Saving the Configuration File
GNOME Print Manager, Managing Print Jobs
change printer settings, Managing Print Jobs
importing settings, Saving the Configuration File
IPP printer, Adding an IPP Printer
JetDirect printer, Adding a JetDirect Printer
local printer, Adding a Local Printer
managing print jobs, Managing Print Jobs
modifying existing printers, Modifying Existing Printers
networked CUPS (IPP) printer, Adding an IPP Printer
notification icon, Managing Print Jobs
Novell NetWare (NCP) printer, Adding a Novell NetWare (NCP) Printer
printing from the command line, Managing Print Jobs
remote LPD printer, Adding a Remote UNIX (LPD) Printer
rename existing printer, Queue Name
Samba (SMB) printer, Adding a Samba (SMB) Printer
save configuration to file, Saving the Configuration File
sharing, Sharing a Printer
allowed hosts, Sharing a Printer
system-wide options, Sharing a Printer
test page, Printing a Test Page
text-based application, Printer Configuration
viewing print spool, Managing Print Jobs
viewing print spool, command line, Managing Print Jobs
Printer Configuration Tool
see printer configuration
printtool
see printer configuration
processes, System Processes
ps, System Processes
PXE, PXE Network Installations
PXE installations, PXE Network Installations
adding hosts, Adding PXE Hosts
boot message, custom, Adding a Custom Boot Message
configuration, PXE Boot Configuration
DHCP configuration, Configuring the DHCP Server, Configuring the DHCP Server
Network Booting Tool, PXE Boot Configuration
overview, PXE Network Installations
performing, Performing the PXE Installation
setting up the network server, Setting up the Network Server
pxeboot, Command Line Configuration
pxeos, Command Line Configuration

Q

quotacheck, Creating the Quota Database Files
quotacheck command
checking quota accuracy with, Keeping Quotas Accurate
quotaoff, Enabling and Disabling
quotaon, Enabling and Disabling

R

racoon, Host-to-Host Connection, Network-to-Network (VPN) Connection
RAID, Redundant Array of Independent Disks (RAID)
configuring software RAID during installation, Software RAID Configuration
explanation of, What is RAID?
Hardware RAID, Hardware RAID versus Software RAID
installing
creating the boot partition, Creating the RAID Partitions
creating the mount points, Creating the RAID Devices and Mount Points
creating the RAID devices, Creating the RAID Devices and Mount Points
creating the RAID partitions, Creating the RAID Partitions
level 0, RAID Levels and Linear Support
level 1, RAID Levels and Linear Support
level 4, RAID Levels and Linear Support
level 5, RAID Levels and Linear Support
levels, RAID Levels and Linear Support
reasons to use, Who Should Use RAID?
Software RAID, Hardware RAID versus Software RAID
RAM, Memory Usage
rcp, Using the scp Command
Red Hat Network, Red Hat Network
Red Hat Package Manager
see RPM
Red Hat RPM Guide, Related Books
Red Hat Update Agent, Red Hat Network
registering your subscription, Activate Your Subscription
rescue mode
definition of, Booting into Rescue Mode
utilities available, Booting into Rescue Mode
resize2fs, Reverting to an ext2 File System
resolution, Display Settings
RHN
see Red Hat Network
rmmod, Kernel Module Utilities
RPM, Package Management with RPM
additional resources, Additional Resources
book about, Related Books
checking package signatures, Checking a Package's Signature
dependencies, Unresolved Dependency
design goals, RPM Design Goals
determining file ownership with, Impressing Your Friends with RPM
documentation with, Impressing Your Friends with RPM
file conflicts
resolving, Conflicting Files
finding deleted files with, Impressing Your Friends with RPM
freshen, Freshening
freshening packages, Freshening
GnuPG, Checking a Package's Signature
graphical interface, Package Management Tool
installing, Installing
with Package Management Tool, Installing Packages
md5sum, Checking a Package's Signature
preserving configuration files, Upgrading
querying, Querying
querying for file list, Impressing Your Friends with RPM
querying uninstalled packages, Impressing Your Friends with RPM
tips, Impressing Your Friends with RPM
uninstalling, Uninstalling
with Package Management Tool, Removing Packages
upgrading, Upgrading
using, Using RPM
verifying, Verifying
website, Useful Websites
RSA keys
generating, Generating an RSA Key Pair for Version 2
RSA Version 1 keys
generating, Generating an RSA Key Pair for Version 1.3 and 1.5
runlevel 1, Booting into Single-User Mode
runlevels, Runlevels

S

Samba, Samba
additional resources, Additional Resources
configuration, Configuring a Samba Server, Command Line Configuration
default, Configuring a Samba Server
smb.conf, Samba
encrypted passwords, Encrypted Passwords
findsmb, Command Line
graphical configuration, Graphical Configuration
adding a share, Adding a Share
configuring server settings, Configuring Server Settings
managing Samba users, Managing Samba Users
list of active connections, Starting and Stopping the Server
pam_smbpass, Encrypted Passwords
reasons for using, Why Use Samba?
share
connecting to via the command line, Command Line
connecting to with Nautilus, Connecting to a Samba Share
mounting, Mounting the Share
smbclient, Command Line
starting the server, Starting and Stopping the Server
status of the server, Starting and Stopping the Server
stopping the server, Starting and Stopping the Server
syncing passwords with passwd, Encrypted Passwords
with Windows NT 4.0, 2000, ME, and XP, Encrypted Passwords
scp
see OpenSSH
secure server
accessing, Accessing The Server
books, Related Books
certificate
authorities, Types of Certificates
choosing a CA, Types of Certificates
creation of request, Generating a Certificate Request to Send to a CA
moving it after an upgrade, Using Pre-Existing Keys and Certificates
pre-existing, Using Pre-Existing Keys and Certificates
self-signed, Creating a Self-Signed Certificate
test vs. signed vs. self-signed, Types of Certificates
testing, Testing The Certificate
connecting to, Accessing The Server
explanation of security, An Overview of Certificates and Security
installing, Apache HTTP Secure Server Configuration
key
generating, Generating a Key
packages, An Overview of Security-Related Packages
port numbers, Accessing The Server
providing a certificate for, An Overview of Certificates and Security
security
explanation of, An Overview of Certificates and Security
upgrading from, Using Pre-Existing Keys and Certificates
URLs, Accessing The Server
URLs for, Accessing The Server
websites, Useful Websites
security, Controlling Access to Services
security level
see Security Level Configuration Tool
Security Level Configuration Tool
enabling and disabling, Enabling and Disabling the Firewall
iptables service, Activating the iptables Service
saving, Saving the Settings
setting custom ports, Other Ports
trusted devices, Trusted Devices
trusted services, Trusted Services
sendmail, Mail Transport Agent (MTA) Configuration
services
controlling access to, Controlling Access to Services
Services Configuration Tool, Services Configuration Tool
setfacl, Setting Access ACLs
Setup Agent
via Kickstart, Kickstart Options
sftp
see OpenSSH
shadow passwords, Authentication
shutdown
disablingCtrlAltDel , Disabling Shutdown Via CtrlAltDel
single-user mode, Booting into Single-User Mode
SMB, Samba, Authentication
smb.conf, Samba
smbclient, Command Line
smbstatus, Starting and Stopping the Server
Software RAID
see RAID
ssh
see OpenSSH
ssh-add, Configuring ssh-agent
ssh-agent, Configuring ssh-agent
with GNOME, Configuring ssh-agent with GNOME
star, Archiving File Systems With ACLs
striping
RAID fundamentals, What is RAID?
subscription registration, Activate Your Subscription
swap space, Swap Space
creating, Adding Swap Space
expanding, Adding Swap Space
explanation of, What is Swap Space?
file
creating, Creating a Swap File, Removing a Swap File
LVM2
creating, Creating an LVM2 Logical Volume for Swap
extending, Extending Swap on an LVM2 Logical Volume
reducing, Reducing Swap on an LVM2 Logical Volume
removing, Removing an LVM2 Logical Volume for Swap
moving, Moving Swap Space
recommended size, What is Swap Space?
removing, Removing Swap Space
syslogd, Log Files
system analysis
OProfile
see OProfile
system information
file systems, File Systems
/dev/shm, File Systems
gathering, Gathering System Information
hardware, Hardware
memory usage, Memory Usage
processes, System Processes
currently running, System Processes
system recovery, Basic System Recovery
common problems, Common Problems
forgetting the root password, Root Password
hardware/software problems, Hardware/Software Problems
reinstalling the boot loader, Reinstalling the Boot Loader
unable to boot into Red Hat Enterprise Linux, Unable to Boot into Red Hat Enterprise Linux
system-config-authentication
see Authentication Configuration Tool
system-config-date
see Time and Date Properties Tool
system-config-display
see X Configuration Tool
system-config-httpd
see HTTP Configuration Tool
system-config-keyboard, Keyboard Configuration
system-config-kickstart
see Kickstart Configurator
system-config-mouse
see Mouse Configuration Tool
system-config-netboot, PXE Boot Configuration
system-config-network
see network configuration
system-config-network-cmd, Network Configuration, Working with Profiles, Saving and Restoring the Network Configuration
system-config-packages
see Package Management Tool
system-config-printer
see printer configuration
system-config-securitylevel
see Security Level Configuration Tool
system-config-time
see Time and Date Properties Tool
system-config-users
see user configuration and group configuration
system-logviewer
see Log Viewer
system-switch-mail
see Mail Transport Agent Switcher
system-switch-mail-nox
see Mail Transport Agent Switcher

T

TCP wrappers, TCP Wrappers
telinit, Runlevels
telnet, Why Use OpenSSH?
tftp, PXE Network Installations, Starting the tftp Server, Start the tftp Server
time configuration, Time and Date Properties
synchronize with NTP server, Network Time Protocol (NTP) Properties
time zone configuration, Time Zone Configuration
timetool
see Time and Date Properties Tool
token ring connection
see network configuration
top, System Processes
tune2fs
converting to ext3 with, Converting to an ext3 File System
reverting to ext2 with, Reverting to an ext2 File System

U

user configuration
adding users, Adding a New User
adding users to groups, Modifying User Properties
additional information, Additional Information
changing full name, Modifying User Properties
changing home directory, Modifying User Properties
changing login shell, Modifying User Properties
changing password, Modifying User Properties
command line configuration, Command Line Configuration
passwd, Adding a User
useradd, Adding a User
filtering list of users, User and Group Configuration
locking user accounts, Modifying User Properties
modify groups for a user, Adding a New User
modifying users, Modifying User Properties
password
forcing expiration of, Password Aging
password expiration, Modifying User Properties
setting user account expiration, Modifying User Properties
viewing list of users, User and Group Configuration
User Manager
see user configuration
useradd command
user account creation using, Command Line Configuration
users
see user configuration

V

VeriSign
using existing certificate, Using Pre-Existing Keys and Certificates
video card
settings for dual head, Dual Head Display Settings
settings for X, Display Hardware Settings
volume group, What is LVM?
volume groups, Creating the LVM Volume Groups

W

Windows
file and print sharing, Samba
Windows 2000
connecting to shares using Samba, Encrypted Passwords
Windows 98
connecting to shares using Samba, Encrypted Passwords
Windows ME
connecting to shares using Samba, Encrypted Passwords
Windows NT 4.0
connecting to shares using Samba, Encrypted Passwords
Windows XP
connecting to shares using Samba, Encrypted Passwords

X

X Configuration Tool
display settings, Display Settings
dual head display settings, Dual Head Display Settings
hardware settings, Display Hardware Settings
X Window System
configuration, X Window System Configuration
xDSL connection
see network configuration
xinetd, xinetd

Y

ypbind, User Information
Prev | Home | Next
Additional Resources |  | Colophon


Red Hat Enterprise Linux 4

Руководство по системному администрированию

Copyright © 2005 Red Hat, Inc.
Перевод © 2005 Инвента

Инвента
Большой Черкасский пер., 15
Москва, 109012
Россия

тел. +7 (495) 775-8777
факс.+7 (495) 927-0981
Электронная почта: info@rhd.ru, info@inventa.ru
Веб-сайт: www.rhd.ru, www.inventa.ru

Замечание: данный перевод осуществлен компанией Инвента. Компания Red Hat, Inc не несет ответственности за любые ошибки и неточности перевода.

ISBN: N/A
Содержание
Введение
1. Изменения в этом руководстве
2. Информация, связанная с особенностями архитектуры
3. Соглашения, принятые в документе
4. Активизация подписки
4.1. Ввод данных учётной записи Red Hat
4.2. Ввод номера подписки
4.3. Подключение системы
5. Использование мыши
6. Копирование и вставка текста в среде X
7. Будущие изменения
7.1. Нам нужны ваши отзывы!
I. Вопросы, касающиеся установки
1. Установка при помощи Kickstart
1.1. Что такое Kickstart-установка?
1.2. Как выполнить Kickstart-установку?
1.3. Создание файла Kickstart
1.4. Параметры Kickstart
1.5. Выбор пакетов
1.6. Сценарий, выполняемый до установки
1.7. Сценарий, выполняемый после установки
1.8. Обеспечение доступности файла Kickstart
1.9. Обеспечение доступности дерева каталогов установки
1.10. Начало установки при помощи Kickstart
2. Настройка Kickstart
2.1. Базовая конфигурация
2.2. Метод установки
2.3. Параметры загрузчика
2.4. Информация о разделах
2.5. Настройка сети
2.6. Проверка подлинности
2.7. Настройка брандмауэра
2.8. Настройка дисплея
2.9. Выбор пакетов
2.10. Сценарий, выполняемый до установки
2.11. Сценарий, выполняемый после установки
2.12. Сохранение файла
3. Установка по сети с применением PXE
3.1. Настройка сетевого сервера
3.2. Настройка PXE-загрузки
3.3. Добавление PXE-узлов
3.4. Запуск tftp-сервера
3.5. Настройка DHCP-сервера
3.6. Добавление своего сообщения загрузки
3.7. Выполнение PXE-установки
4. Бездисковые окружения
4.1. Запуск tftp-сервера
4.2. Настройка DHCP-сервера
4.3. Настройка NFS-сервера
4.4. Завершение настройки бездискового окружения
4.5. Добавление узлов
4.6. Загрузка узлов
5. Основы восстановления системы
5.1. Распространённые проблемы
5.2. Загрузка в режиме восстановления
5.3. Загрузка в монопольном режиме
5.4. Загрузка в аварийном режиме
II. Файловые системы
6. Файловая система ext3
6.1. Возможности ext3
6.2. Создание файловой системы ext3
6.3. Переход к файловой системе ext3
6.4. Возврат к файловой системе ext2
7. Диспетчер логических томов (LVM)
7.1. Что такое LVM?
7.2. Что такое LVM2?
7.3. Дополнительные ресурсы
8. Настройка LVM
8.1. Автоматическое разбиение диска
8.2. Разбиение LVM вручную
9. Массив независимых дисков с избыточностью (RAID)
9.1. Что такое RAID?
9.2. Кто должен использовать RAID?
9.3. Сравнение аппаратных и программных RAID-массивов
9.4. Уровни RAID-массивов и линейный RAID
10. Настройка программного RAID-массива
10.1. Создание разделов RAID-массивов
10.2. Создание устройств RAID и точек монтирования
11. Пространство подкачки
11.1. Что такое пространство подкачки?
11.2. Добавление пространства подкачки
11.3. Удаление пространства подкачки
11.4. Перемещение пространства подкачки
12. Управление дисковым хранилищем
12.1. Стандартные разделы в parted
12.2. Управление разделами LVM
13. Реализация дисковых квот
13.1. Настройка дисковых квот
13.2. Управление дисковыми квотами
13.3. Дополнительные ресурсы
14. Списки управления доступом
14.1. Монтирование файловых систем
14.2. Назначение ACL для доступа
14.3. Назначение ACL по умолчанию
14.4. Получение ACL
14.5. Архивация файловых систем с ACL
14.6. Совместимость с ранними системами
14.7. Дополнительные ресурсы
III. Управление пакетами
15. Управление пакетами с помощью RPM
15.1. Цели разработки RPM
15.2. Использование RPM
15.3. Проверка подписи пакета
15.4. Удивите друзей возможностями RPM
15.5. Дополнительные ресурсы
16. Средство «Управление пакетами»
16.1. Установка пакетов
16.2. Удаление пакетов
17. Red Hat Network
IV. Сетевая конфигурация
18. Настройка сети
18.1. Обзор
18.2. Установка Ethernet-подключения
18.3. Установка ISDN-подключения
18.4. Установка модемного подключения
18.5. Установка xDSL-подключения
18.6. Установка подключения Token Ring
18.7. Установка беспроводного подключения
18.8. Управление параметрами DNS
18.9. Управление узлами
18.10. Работа с профилями
18.11. Псевдонимы устройств
18.12. Установка IPsec-подключения
18.13. Сохранение и восстановление сетевых параметров
19. Основная настройка брандмауэра
19.1. Средство настройки уровня безопасности
19.2. Активизация службы iptables
20. Управление доступом к службам
20.1. Уровни выполнения
20.2. TCP-оболочки
20.3. Средство «Настройка служб»
20.4. ntsysv
20.5. chkconfig
20.6. Дополнительные ресурсы
21. OpenSSH
21.1. Зачем использовать OpenSSH?
21.2. Настройка сервера OpenSSH
21.3. Настройка клиента OpenSSH
21.4. Дополнительные ресурсы
22. Сетевая файловая система (NFS)
22.1. Зачем использовать NFS?
22.2. Монтирование файловых систем NFS
22.3. Экспорт файловых систем NFS
22.4. Дополнительные ресурсы
23. Samba
23.1. Зачем использовать Samba?
23.2. Настройка сервера Samba
23.3. Подключение к общему ресурсу Samba
23.4. Дополнительные ресурсы
24. Протокол динамической конфигурации узлов (DHCP)
24.1. Зачем использовать DHCP?
24.2. Настройка DHCP-сервера
24.3. Настройка DHCP-клиента
24.4. Дополнительные ресурсы
25. Настройка HTTP-сервера Apache
25.1. Основные параметры
25.2. Параметры по умолчанию
25.3. Параметры виртуальных узлов
25.4. Параметры сервера
25.5. Настройка быстродействия
25.6. Сохранение ваших настроек
25.7. Дополнительные ресурсы
26. Настройка безопасного HTTP-сервера Apache
26.1. Введение
26.2. Обзор пакетов, связанных с безопасностью
26.3. Обзор сертификатов и безопасности
26.4. Использование существующих ключей и сертификатов
26.5. Виды сертификатов
26.6. Генерация ключа
26.7. Формирование запроса к центру сертификации на получение сертификата
26.8. Самостоятельное формирование сертификата
26.9. Проверка сертификата
26.10. Обащение к серверу
26.11. Дополнительные ресурсы
27. Настройка проверки подлинности
27.1. Информация пользователя
27.2. Проверка подлинности
27.3. Версия для командной строки
V. Настройка системы
28. Доступ к консоли
28.1. Запрет отключения с помощью [Ctrl]-[Alt]-[Del]
28.2. Запрещение доступа к программам консоли
28.3. Определение консоли
28.4. Предоставление доступа к файлам с консоли
28.5. Разрешение доступа с консоли к другим приложениям
28.6. Группа floppy
29. Настройка даты и времени
29.1. Свойства даты и времени
29.2. Свойства сетевого протокола времени (NTP)
29.3. Выбор часового пояса
30. Настройка клавиатуры
31. Настройка мыши
32. Настройка системы X Window
32.1. Настройки дисплея
32.2. Настройки оборудования дисплея
32.3. Настройки дисплея с двумя мониторами
33. Управление пользователями и группами
33.1. Создание нового пользователя
33.2. Изменение свойств пользователя
33.3. Создание новой группы
33.4. Изменение свойств группы
33.5. Использование командной строки
33.6. Объяснение процесса
33.7. Дополнительная информация
34. Настройка принтера
34.1. Добавление локального принтера
34.2. Добавление принтера IPP
34.3. Добавление удалённого принтера UNIX (LPD)
34.4. Добавление принтера Samba (SMB)
34.5. Добавление принтера Novell NetWare (NCP)
34.6. Добавление принтера JetDirect
34.7. Выбор модели принтера и завершение настройки
34.8. Печать пробной страницы
34.9. Изменение параметров установленных принтеров
34.10. Сохранение файла конфигурации
34.11. Использование командной строки
34.12. Управление заданиями печати
34.13. Предоставление общего доступа к принтеру
34.14. Дополнительные ресурсы
35. Автоматизация задач
35.1. Cron
35.2. Задания at и batch
35.3. Дополнительные ресурсы
36. Файлы журналов
36.1. Расположение файлов журналов
36.2. Просмотр файлов журналов
36.3. Добавление файла журнала
36.4. Анализ файлов журналов
37. Обновление ядра вручную
37.1. Обзор пакетов ядра
37.2. Подготовка к обновлению
37.3. Загрузка обновлённого ядра
37.4. Выполнение обновления
37.5. Проверка образа начального RAM-диска
37.6. Проверка загрузчика
38. Модули ядра
38.1. Управление модулями ядра
38.2. Статическая загрузка модулей
38.3. Дополнительные ресурсы
39. Настройка агента доставки почты (MTA)
VI. Мониторинг системы
40. Сбор информации о системе
40.1. Системные процессы
40.2. Использование памяти
40.3. Файловые системы
40.4. Оборудование
40.5. Дополнительные ресурсы
41. OProfile
41.1. Обзор инструментов
41.2. Настройка OProfile
41.3. Запуск и остановка OProfile
41.4. Сохранение данных
41.5. Анализ данных
41.6. Изучение /dev/oprofile/
41.7. Пример использования
41.8. Графический интерфейс
41.9. Дополнительные ресурсы
Предметный указатель
Выходные сведения
Вперёд
Введение


Выполнение PXE-установки

Назад Глава 3. Установка по сети с применением PXE Вперёд

3.7. Выполнение PXE-установки

За информацией о том, как настроить сетевую плату с поддержкой PXE, чтобы загрузиться из сети, обратитесь к документации по сетевой плате. Порядок настройки может быть разным для разных плат.

Когда компьютер загрузит программу установки, обратитесь к Руководству по установке Red Hat Enterprise Linux.

Назад | Начало | Вперёд
Добавление своего сообщения загрузки | Вверх | Бездисковые окружения


Файловые системы

Назад Вперёд

II. Файловые системы

Понятие Файловая система относится к файлам и каталогам, хранящимся на компьютере. Файловые системы могут иметь разные форматы (типы файловых систем). Эти форматы определяют, каким образом хранятся файлы и каталоги. Некоторые типы файловых систем хранят резервные копии данных, а другие оптимизируют скорость доступа к жёсткому диску. В этой части обсуждаются типы файловой системы ext3.

Содержание
6. Файловая система ext3
7. Диспетчер логических томов (LVM)
8. Настройка LVM
9. Массив независимых дисков с избыточностью (RAID)
10. Настройка программного RAID-массива
11. Пространство подкачки
12. Управление дисковым хранилищем
13. Реализация дисковых квот
14. Списки управления доступом
Назад | Начало | Вперёд
Загрузка в аварийном режиме |  | Файловая система ext3


Вопросы, касающиеся установки

Назад Вперёд

I. Вопросы, касающиеся установки

В Руководстве по системному администрированию Red Hat Enterprise Linux рассматривается установка Red Hat Enterprise Linux и разрешение некоторых основных проблем, возникающих после неё. Однако это руководство не затрагивает расширенные варианты установки. В этой части документации представлены инструкции по установке kickstart (техника автоматической установки) и всем связанным средствам. Чтобы выполнить какие-либо из этих расширенных задач установки, используйте эту часть вместе с Руководством по установке Red Hat Enterprise Linux.

Содержание
1. Установка при помощи Kickstart
2. Настройка Kickstart
3. Установка по сети с применением PXE
4. Бездисковые окружения
5. Основы восстановления системы
Назад | Начало | Вперёд
Будущие изменения |  | Установка при помощи Kickstart


Сетевая конфигурация

Назад Вперёд

IV. Сетевая конфигурация

В начале этой части рассматривается настройка сети, а затем обсуждаются темы, связанные с сетью, в частности разрешение удалённых подключений, общий доступ к файлам и каталогам по сети и настройка веб-сервера.

Содержание
18. Настройка сети
19. Основная настройка брандмауэра
20. Управление доступом к службам
21. OpenSSH
22. Сетевая файловая система (NFS)
23. Samba
24. Протокол динамической конфигурации узлов (DHCP)
25. Настройка HTTP-сервера Apache
26. Настройка безопасного HTTP-сервера Apache
27. Настройка проверки подлинности
Назад | Начало | Вперёд
Red Hat Network |  | Настройка сети


Управление пакетами

Назад Вперёд

III. Управление пакетами

Всё программное обеспечение системы Red Hat Enterprise Linux разделено на RPM-пакеты, которые можно устанавливать, обновлять или удалять. В этой части документации рассказывается, как управлять RPM-пакетами в системе Red Hat Enterprise Linux, применяя инструменты для графического окружения и командной строки.

Содержание
15. Управление пакетами с помощью RPM
16. Средство «Управление пакетами»
17. Red Hat Network
Назад | Начало | Вперёд
Дополнительные ресурсы |  | Управление пакетами с помощью RPM


Настройка системы

Назад Вперёд

V. Настройка системы

В число обязанностей системного администратора входит настройка системы для различных задач, разных типов пользователей и аппаратных конфигураций. Этот раздел рассказывает о том, как настроить систему Red Hat Enterprise Linux.

Содержание
28. Доступ к консоли
29. Настройка даты и времени
30. Настройка клавиатуры
31. Настройка мыши
32. Настройка системы X Window
33. Управление пользователями и группами
34. Настройка принтера
35. Автоматизация задач
36. Файлы журналов
37. Обновление ядра вручную
38. Модули ядра
39. Настройка агента доставки почты (MTA)
Назад | Начало | Вперёд
Версия для командной строки |  | Доступ к консоли


Мониторинг системы

Назад Вперёд

VI. Мониторинг системы

В круг обязанностей системных администраторов также входит наблюдение за производительностью систем. Red Hat Enterprise Linux предлагает средства, помогающие администраторам выполнять эти задачи.

Содержание
40. Сбор информации о системе
41. OProfile
Назад | Начало | Вперёд
Настройка агента доставки почты (MTA) |  | Сбор информации о системе


Определение консоли

Назад Глава 28. Доступ к консоли Вперёд

28.3. Определение консоли

Модуль pam_console.so определяет разрешения пользователей, работающих на системной консоли, используя файл /etc/security/console.perms. Синтаксис файл очень гибкий; вы можете редактировать файл по своему усмотрению. Однако, в стандартном файле содержится подобная строка:

<console>=tty[0-9][0-9]* vc/[0-9][0-9]* :[0-9]\.[0-9] :[0-9]

Когда пользователи регистрируются, они подключаются к именованного терминала некоторого вида, либо это сервер X, например :0 или mymachine.example.com:1.0, либо устройство вроде /dev/ttyS0 или /dev/pts/2. В строке по умолчанию определяется, что локальными считаются локальные виртуальные консоли и локальные сервера X, но если вы хотите, чтобы терминал, подключаемый к порту /dev/ttyS1, также был локальным, измените эту строку следующим образом:

<console>=tty[0-9][0-9]* vc/[0-9][0-9]* :[0-9]\.[0-9] :[0-9] /dev/ttyS1
Назад | Начало | Вперёд
Запрещение доступа к программам консоли | Вверх | Предоставление доступа к файлам с консоли


Разрешение доступа с консоли к другим приложениям

Назад Глава 28. Доступ к консоли Вперёд

28.5. Разрешение доступа с консоли к другим приложениям

Чтобы предоставить пользователям консоли доступ к другим приложениям, нужно сделать немного больше.

Прежде всего, учтите, что подобный доступ с консоли возможен только к приложениям, размещённым в каталогах /sbin/ и /usr/sbin/, поэтому приложение, которое вы хотите запускать, должно располагаться в одном из них. Проверив это, выполните следующие действия:

  1. Создайте ссылку с названием вашего приложения, например, foo, указывающую на приложение /usr/bin/consolehelper:

    cd /usr/bin
ln -s consolehelper foo

  2. Создайте файл /etc/security/console.apps/foo:

    touch /etc/security/console.apps/foo

  3. Создайте файл конфигурации PAM для службы foo в каталоге /etc/pam.d/. Легче всего начать, скопировав файл конфигурации PAM для службы halt и отредактировав его по своему усмотрению:

    cp /etc/pam.d/halt /etc/pam.d/foo

Теперь при запуске программы /usr/bin/foo будет вызвана утилита consolehelper, которая проверит подлинность пользователя с помощью /usr/sbin/userhelper. Чтобы проверить подлинность пользователя, consolehelper запрашивает пароль пользователя, если /etc/pam.d/foo является копией файла /etc/pam.d/halt (в противном случае эта утилита выполняет то, что указано в /etc/pam.d/foo) а затем запускает /usr/sbin/foo с правами root.

В файле конфигурации PAM приложение можно настроить, чтобы модуль pam_timestamp запоминал (или кэшировал) результат успешной проверки подлинности. Если при запуске приложения предоставлены правильные сведения для проверки подлинности (пароль root), создаётся файл временной метки. По умолчанию результат успешной проверки подлинности кэшируется в течение пяти минут. В этом временном интервале любое приложение, настроенное на использование pam_timestamp и запущенное в том же сеансе, автоматически регистрируется под именем этого пользователя — вводить пароль root повторно не требуется.

Этот модуль включён в пакет pam. Чтобы эта функция работала, файл конфигурации PAM в etc/pam.d/ должен содержать следующие строки:

auth sufficient /lib/security/pam_timestamp.so
session optional /lib/security/pam_timestamp.so

Первая строка, начинающаяся с auth, должна идти после остальных строк auth sufficient, а строка, начинающаяся с session, должна идти после остальных строк session optional.

Если для приложения, настроенного на использование pam_timestamp и запущенного из Главного меню (Main Menu) (на панели), проверка подлинности проходит успешно, в области уведомлений графической среды GNOME или KDE отображается значок [image] . Когда срок кэширования результата проверки подлинности истекает (по умолчанию через пять минут), значок исчезает.

Пользователь может также отменить кэширование результатов проверки подлинности, щёлкнув значок и выбрав соответствующий пункт меню.

Назад | Начало | Вперёд
Предоставление доступа к файлам с консоли | Вверх | Группа floppy


Предоставление доступа к файлам с консоли

Назад Глава 28. Доступ к консоли Вперёд

28.4. Предоставление доступа к файлам с консоли

В файле /etc/security/console.perms есть подобные строки:

<floppy>=/dev/fd[0-1]* \
         /dev/floppy/* /mnt/floppy*
<sound>=/dev/dsp* /dev/audio* /dev/midi* \
        /dev/mixer* /dev/sequencer \
        /dev/sound/* /dev/beep \
    /dev/snd/*
<cdrom>=/dev/cdrom* /dev/cdroms/* /dev/cdwriter* /mnt/cdrom*

Если необходимо, вы можете добавить в этот раздел свои строки. Убедитесь в том, что добавляемые вами строки относятся к соответствующему устройству. Например, вы можете добавить следующую строку:

<scanner>=/dev/scanner /dev/usb/scanner*

(Конечно же, вы должны убедиться в том, что /dev/scanner на самом деле сканер, а не, скажем, жёсткий диск.)

Это первое действие. Затем нужно определить, что разрешено делать с этим файлами. Найдите в последнем разделе файла /etc/security/console.perms подобные строки:

<console> 0660 <floppy> 0660 root.floppy
<console> 0600 <sound>  0640 root
<console> 0600 <cdrom>  0600 root.disk

и добавьте следующую строку:

<console> 0600 <scanner> 0600 root

Теперь, когда вы будете регистрироваться на консоли, вы станете владельцем устройства /dev/scanner и получите разрешения 0600 (чтение и запись разрешены только вам). Когда вы выйдите из системы, устройством будет владеть root и по-прежнему иметь разрешения 0600 (и тогда чтение и запись будут разрешены только root).

Назад | Начало | Вперёд
Определение консоли | Вверх | Разрешение доступа с консоли к другим приложениям


Запрещение доступа к программам консоли

Назад Глава 28. Доступ к консоли Вперёд

28.2. Запрещение доступа к программам консоли

Чтобы запретить доступ пользователей к программам консоли, выполните от имени root следующую команду:

rm -f /etc/security/console.apps/*

В окружениях, где консоль защищена разными способами (установлены пароли в BIOS и загрузчике системы, комбинация [Ctrl]-[Alt]-[Delete] отключена, кнопки питания и перезагрузки отключены и т.д.), наверное, вы не захотите, чтобы любой пользователь консоли мог запустить программы poweroff, halt и reboot, по умолчанию доступные с консоли.

Чтобы лишить пользователей этой возможности, выполните от имени root следующие команды:

rm -f /etc/security/console.apps/poweroff
rm -f /etc/security/console.apps/halt
rm -f /etc/security/console.apps/reboot
Назад | Начало | Вперёд
Доступ к консоли | Вверх | Определение консоли


Группа floppy

Назад Глава 28. Доступ к консоли Вперёд

28.6. Группа floppy

Если по какой-либо причине доступ к консоли вам не подходит, но вы хотите дать своим пользователям, не имеющим прав root, доступ к дисководу вашего компьютера, это можно сделать с помощью группы floppy. Добавьте пользователя(ей) в группу floppy с помощью предпочитаемого вами средства. Например, можно воспользоваться командой gpasswd для добавления в группу floppy пользователя fred следующим образом:

gpasswd -a fred floppy

После этого пользователь fred сможет получить с консоли доступ к дисководу компьютера.

Назад | Начало | Вперёд
Разрешение доступа с консоли к другим приложениям | Вверх | Настройка даты и времени


Дополнительные ресурсы

Назад Глава 14. Списки управления доступом Вперёд

14.7. Дополнительные ресурсы

За дополнительными сведениями обратитесь к следующим ресурсам.

14.7.1. Установленная документация

  • Страница man acl — Описание ACL

  • Страница man getfacl — Рассказывает о том, как получить списки управления доступом к файлам

  • Страница man setfacl — Рассказывает о том, как установить списки управления доступом к файлам

  • Страница man star — Подробно рассказывает об утилите star и её многочисленных параметрах

14.7.2. Полезные сайты

  • http://acl.bestbits.at/ — Сайт, посвящённый ACL

Назад | Начало | Вперёд
Совместимость с ранними системами | Вверх | Управление пакетами


Архивация файловых систем с ACL

Назад Глава 14. Списки управления доступом Вперёд

14.5. Архивация файловых систем с ACL

Предупреждение | Предупреждение
 | Команды tar и dump не архивируют ACL.

Существует утилита star, похожая на tar тем, что она может делать архивы файлов, однако некоторые её параметры отличаются. Список наиболее часто используемых параметров представлен в таблице 14-1. За списком всех параметров обратитесь к странице man star. Для использования этой утилиты требуется установить пакет star.

Параметр | Описание
-c | Создаёт файл архива
-n | Отключает извлечение файлов, используется в сочетании с -x для просмотра списка извлекаемых файлов.
-r | Заменяет файлы в архиве. Файлы записываются в конец архива, заменяя любые файлы с тем же путём и именем.
-t | Выводит содержимое файла архива.
-u | Обновляет файл архива. Файлы записываются в конец архива, если их ещё не было в архиве или если они новее, чем файлы с тем же именем в архиве. Этот параметр работает только если архив представляет собой файл или незаблокированную ленту, которую можно стирать.
-x | Извлекает файлы из архива. Если используется с ключом -U и файл в архиве старее, чем соответствующий файл в файловой системе, такой файл не извлекается.
-help | Выводит наиболее важные параметры.
-xhelp | Выводит менее важные параметры.
-/ | Оставляет ведущую косую черту в имени файла при извлечении файлов из архива. По умолчанию она убирается.
-acl | При создании архива или извлечении файлов, архивирирует или восстанавливает все ACL, связанные с файлами или каталогами.

Таблица 14-1. Параметры командной строки star

Назад | Начало | Вперёд
Получение ACL | Вверх | Совместимость с ранними системами


Совместимость с ранними системами

Назад Глава 14. Списки управления доступом Вперёд

14.6. Совместимость с ранними системами

Если хотя бы для одного из файлов данной файловой системы установлен ACL, файловая система имеет атрибут ext_attr. Этот атрибут можно увидеть, выполнив следующую команду:

tune2fs -l <filesystem-device>

Файловая система с атрибутом ext_attr может быть смонтирована в старых ядрах, но эти ядра не применяют установленные в ACL разрешения.

Проверить файловую систему с атрибутом ext_attr можно с помощью утилиты e2fsck версии 1.22 или выше, включённой в пакет e2fsprogs (который входит в состав Red Hat Enterprise Linux 2.1 и 4). Другие версии не будут её проверять.

Назад | Начало | Вперёд
Архивация файловых систем с ACL | Вверх | Дополнительные ресурсы


Получение ACL

Назад Глава 14. Списки управления доступом Вперёд

14.4. Получение ACL

Чтобы получить список существующих ACL, связанных с файлом и каталогом, воспользуйтесь командой getfacl:

getfacl <filename>

В результате вы увидите что-то подобное:

# file: file
# owner: andrius
# group: andrius
user::rw-
user:smoore:r--
group::r--
mask::r--
other::r--

Если вы указали каталог, и с ним связан ACL по умолчанию, он также отображается следующим образом:

# file: file
# owner: andrius
# group: andrius
user::rw-
user:smoore:r--
group::r--
mask::r--
other::r--
default:user::rwx
default:user:andrius:rwx
default:group::r-x
default:mask::rwx
default:other::r-x
Назад | Начало | Вперёд
Назначение ACL по умолчанию | Вверх | Архивация файловых систем с ACL


Назначение ACL для доступа

Назад Глава 14. Списки управления доступом Вперёд

14.2. Назначение ACL для доступа

Существуют два типа ACL: ACL для доступа и ACL по умолчанию. ACL для доступа — это список управления доступом для заданного файла или каталога. ACL по умолчанию может быть связан только с каталогом, и если файл в этом каталоге не имеет ACL для доступа, он использует правила, определённые в ACL по умолчанию, связанном с каталогом. ACL по умолчанию являются необязательными.

Списки ACL можно настроить:

  1. На уровне пользователей

  2. На уровне групп

  3. С помощью маски эффективных прав

  4. Для пользователй, не включённых в группу данного файла

Утилита setfacl устанавливает ACL файлов и каталогов. Передайте ей параметр -m, чтобы добавить или удалить ACL файла или каталога:

setfacl -m <rules> <files>

Формат правил (<rules>) описывается ниже. В одной команде можно указывать несколько правил, разделяя их запятыми.

u:<uid>:<perms>

Назначает ACL для доступа заданному пользователю. Здесь можно указать имя или код пользователя. Это может быть любой пользователь, допустимый в данной системе.

g:<gid>:<perms>

Назначает ACL для доступа заданной группе. Здесь можно указать имя или код группы. Это может быть любая группа, допустимая в данной системе.

m:<perms>

Назначает маску эффективных прав. Маска — это объединение всех разрешений группы-владельца и всех записей пользователй и групп.

o:<perms>

Назначает ACL для доступа пользователям, не включённым в группу файла.

Пробелы не учитываются. Вместо (<perms>) необходимо указать сочетание символов r, w и x, обозначающих чтение (read), запись (write) и execute (исполнение) соответственно.

Если с файлом или каталогом уже связан ACL, и выполняется команда setfacl, в этот ACL добавляются новые правила или изменяются существующие.

Например, чтобы назначить разрешения на чтение и запись пользователю andrius, выполните:

setfacl -m u:andrius:rw /project/somefile

Чтобы удалить все разрешения, данные пользователю, группе или всем остальным, используйте параметр -x и не указывайте никаких разрешений:

setfacl -x <rules> <files>

Например, чтобы удалить все разрешения, данные пользователю с кодом 500, выполните:

setfacl -x u:500 /project/somefile
Назад | Начало | Вперёд
Списки управления доступом | Вверх | Назначение ACL по умолчанию


Назначение ACL по умолчанию

Назад Глава 14. Списки управления доступом Вперёд

14.3. Назначение ACL по умолчанию

Чтобы назначить ACL по умолчанию, добавьте перед правилом d: и укажите вместо имени файла каталог.

Например, чтобы назначить каталогу /share/ ACL по умолчанию, разрешающий чтение и запись пользователям, не включённым в группу файла (ACL доступа к отдельному файлу можете переопределить это разрешение):

setfacl -m d:o:rx /share
Назад | Начало | Вперёд
Назначение ACL для доступа | Вверх | Получение ACL


Информация, связанная с особенностями архитектуры

Назад Введение Вперёд

2. Информация, связанная с особенностями архитектуры

Если не отмечено обратное, вся информация, содержащаяся в этом руководстве, применима только к процессорам x86 и процессорам, реализующим технологии AMD64 и Intel® Extended Memory 64 Technology (Intel® EM64T). За информацией, предназначенной для вашей архитектуры, обратитесь к Руководству по установке Red Hat Enterprise Linux.

Назад | Начало | Вперёд
Введение | Вверх | Соглашения, принятые в документе


Проверка подлинности

Назад Глава 27. Настройка проверки подлинности Вперёд

27.2. Проверка подлинности

Вкладка Проверка подлинности (Authentication) позволяет настроить сетевые способы проверки подлинности. Чтобы включить параметр, щёлкните пустой флажок, расположенный рядом. Чтобы отключить параметр, щёлкните расположенный рядом флажок, чтобы снять его.

Рисунок 27-2. Проверка подлинности

Настраиваемые параметры описываются ниже:

  • Включить поддержку Kerberos (Enable Kerberos Support) — Отметьте этот флажок, чтобы включить проверку подлинности Kerberos. Нажмите кнопку Настроить Kerberos (Configure Kerberos), чтобы настроить:

    • Область (Realm) — Определяет область сервера Kerberos. Область — это сеть, в которой применяется Kerberos, и которая включает в себя один или несколько серверов KDC и, возможно, большое множество клиентов.

    • KDC — Определяет центр распределения ключей (Key Distribution Center, KDC), то есть сервер, выдающий ключи Kerberos.

    • Сервера управления (Admin Servers) — Определяет административные серверы, на которых работает kadmind.

    Чтобы этот вариант работал, должны быть установлены пакеты krb5-libs и krb5-workstation. За дополнительными сведениями о Kerberos обратитесь к Справочному руководству по Red Hat Enterprise Linux.

  • Включить поддержку LDAP (Enable LDAP Support) — Отметьте этот флажок, чтобы приложения, поддерживающие PAM, использовали для проверки подлинности LDAP. Нажмите кнопку Настроить LDAP (Configure LDAP), чтобы определить следующее:

    • Использовать TLS для шифрования соединений (Use TLS to encrypt connections) — Использовать протокол TLS для шифрования паролей, пересылаемых серверу LDAP.

    • Базовый DN для поиска в LDAP (LDAP Search Base DN) — Получает информацию о пользователе по его распознаваемому имени (Distinguished Name, DN).

    • Сервер LDAP (LDAP Server) — Определяет IP-адрес сервера LDAP.

    Чтобы этот вариант работал, должен быть установлен пакет openldap-clients. За дополнительной информацией о LDAP обратитесь к Справочному руководству по Red Hat Enterprise Linux.

  • Использовать скрытые пароли (Use Shadow Passwords) — Установите этот флажок, чтобы сохранить пароли в виде скрытых паролей, в файле /etc/shadow вместо /etc/passwd. Скрытые пароли по умолчанию включаются во время установки и их настоятельно рекомендуется использовать для усиления защиты системы.

    Чтобы этот вариант работал, должен быть установлен пакет shadow-utils. За дополнительными сведениями о скрытых паролях обратитесь к главе Пользователи и группы в Справочном руководстве по Red Hat Enterprise Linux.

  • Включить поддержку SMB (Enable SMB Support) — Этот параметр настраивает PAM на проверку подлинности пользователей с использованием SMB. Нажмите кнопку Настроить SMB (Configure SMB), чтобы настроить:

    • Рабочая группа (Workgroup) — Определяет название используемой рабочей группы SMB.

    • Контроллеры домена (Domain Controllers) — Определяет имена используемых контроллеров домена SMB.

  • Winbind — Выберите этот флажок, чтобы настроить систему для подключения к Windows Active Directory или контроллеру домена Windows. Это позволяет получать данные пользователей, а также настроить параметры проверки подлинности сервера.

  • Использовать пароли MD5 (Use MD5 Passwords) — Установите этот флажок, чтобы включить пароли MD5, что позволяет использовать пароли длиной до 256 символов, вместо паролей длиной в восемь символов или короче. Этот параметр включается во время установки по умолчанию и его настоятельно рекомендуется использовать для усиления защиты.

Назад | Начало | Вперёд
Настройка проверки подлинности | Вверх | Версия для командной строки


Версия для командной строки

Назад Глава 27. Настройка проверки подлинности Вперёд

27.3. Версия для командной строки

Программу Конфигурация аутентификации (Authentication Configuration Tool) можно также запустить как утилиту командной строки без графического интерфейса. Версию для командной строки можно использовать в сценарии настройки или kickstart. Параметры настройки проверки кратко описаны в таблице 27-1.

Подсказка | Подсказка
 | Описание этих параметров также можно найти на странице man authconfig или выполнив в приглашении оболочки authconfig --help.
Параметр | Описание
--enableshadow | Включает скрытые пароли
--disableshadow | Отключает скрытые пароли
--enablemd5 | Включает пароли MD5
--disablemd5 | Отключает пароли MD5
--enablenis | Включает NIS
--disablenis | Отключает NIS
--nisdomain=<domain> | Определяет домен NIS
--nisserver=<server> | Определяет сервер NIS
--enableldap | Включает LDAP для получения информации пользователей
--disableldap | Отключает использование LDAP для получения информации пользователей
--enableldaptls | Включает использование TLS с LDAP
--disableldaptls | Отключает использование TLS с LDAP
--enableldapauth | Включает LDAP для проверки подлинности
--disableldapauth | Отключает использование LDAP для проверки подлинности
--ldapserver=<server> | Определяет сервер LDAP
--ldapbasedn=<dn> | Определяет базовое распознаваемое имя (DN) LDAP
--enablekrb5 | Включает Kerberos
--disablekrb5 | Отключает Kerberos
--krb5kdc=<kdc> | Определяет сервер KDC для Kerberos
--krb5adminserver=<server> | Определяет сервер администрирования Kerberos
--krb5realm=<realm> | Определяет область Kerberos
--enablekrb5kdcdns | Включает использование DNS для поиска KDC-серверов Kerberos
--disablekrb5kdcdns | Отключает использование DNS для поиска KDC-серверов Kerberos
--enablekrb5realmdns | Включает использование DNS для поиска областей Kerberos
--disablekrb5realmdns | Отключает использование DNS для поиска областей Kerberos
--enablesmbauth | Включает SMB
--disablesmbauth | Отключает SMB
--smbworkgroup=<workgroup> | Определяет рабочую группу SMB
--smbservers=<server> | Определяет серверов SMB
--enablewinbind | Включает winbind для получения информации пользователей по умолчанию
--disablewinbind | Отключает использование winbind для получения информации пользователей по умолчанию
--enablewinbindauth | Включает winbindauth для проверки подлинности по умолчанию
--disablewinbindauth | Отключает использование winbindauth для проверки подлинности по умолчанию
--smbsecurity=<user|server|domain|ads> | Режим безопасности для модулей Samba и winbind
--smbrealm=<STRING> | Область по умолчанию, используемая модулями Samba и winbind, в режиме security=ads
--smbidmapuid=<lowest-highest> | Диапазон UID, который winbind назначает пользователям домена или ADS
--smbidmapgid=<lowest-highest> | Диапазон GID, который winbind назначает пользователям домена или ADS
--winbindseparator=<\> | Символ, отделяющий имя домена от имени пользователя в именах winbind, если параметр winbindusedefaultdomain не включён
--winbindtemplatehomedir=</home/%D/%U> | Домашний каталог для пользователей winbind
--winbindtemplateprimarygroup=<nobody> | Группа, которая будет основной для пользователей winbind
--winbindtemplateshell=</bin/false> | Оболочка входа в систему по умолчанию для пользователей winbind
--enablewinbindusedefaultdomain | Настраивает winbind так, что пользователи, в имени которых не указан домен, будут считаться доменными
--disablewinbindusedefaultdomain | Настраивает winbind так, что пользователи, в имени которых не указан домен, не будут считаться доменными
--winbindjoin=<Administrator> | Включает систему в домен winbind или область ADS от имени пользователя Administrator
--enablewins | Включает WINS для разрешения имён узлов
--disablewins | Отключает использование WINS для разрешения имён узлов
--enablehesiod | Включает Hesiod
--disablehesiod | Отключает Hesiod
--hesiodlhs=<lhs> | Определяет LHS для Hesiod
--hesiodrhs=<rhs> | Определяет RHS для Hesiod
--enablecache | Включает nscd
--disablecache | Отключает nscd
--nostart | Не запускает или останавливает службы portmap, ypbind и nscd, даже если они настроены
--kickstart | Не выводит пользовательский интерфейс
--probe | Проверяет и выводить сетевые параметры по умолчанию

Таблица 27-1. Параметры командной строки

Назад | Начало | Вперёд
Проверка подлинности | Вверх | Настройка системы


Дополнительные ресурсы

Назад Глава 35. Автоматизация задач Вперёд

35.3. Дополнительные ресурсы

Чтобы узнать больше о настройке автоматизированных задач, обратитесь к следующим ресурсам.

35.3.1. Установленная документация

  • Страница man cron — Обзор службы cron.

  • Разделы 1 и 5 страниц man crontab — В разделе 1 содержится описание файла crontab. В разделе 5 описывается формат этого файла и приведены несколько примеров записей.

  • /usr/share/doc/at-<version>/timespec содержит более подробную информацию об указании времени в заданиях cron.

  • Страница man at — Описывает команды at и batch и их параметры командной строки.

Назад | Начало | Вперёд
Задания at и batch | Вверх | Файлы журналов


Задания at и batch

Назад Глава 35. Автоматизация задач Вперёд

35.2. Задания at и batch

Тогда как cron используется для назначения повторяющихся задач, команда at используется для назначения одноразового задания на заданное время, а команда batch — для назначения одноразовых задач, которые должны выполняться, когда загрузка системы становится меньше 0,8.

Чтобы использовать at или batch, необходимо, чтобы был установлен RPM-пакет at и запущена служба atd. Чтобы узнать, установлен ли этот пакет, выполните команду rpm -q at. Чтобы определить, работает ли служба, воспользуйтесь командой /sbin/service atd status.

35.2.1. Настройка заданий at

Чтобы назначить выполнение разового задания в определённое время, введите команду at time, где time — время выполнения команды.

Параметр time может быть следующим:

  • формат ЧЧ:ММ — например, 04:00 обозначает четыре часа ночи. Если указанное время уже прошло, задание выполняется в это же время на следующий день.

  • midnight — обозначает полночь.

  • noon — обозначает полдень.

  • teatime — обозначает 4 часа дня (время чаепития).

  • формат «название-месяца день год» — например, строка «January 15 2002» обозначает 15 января 2002 года. Указывать год не обязательно.

  • Форматы ММДДГГ, ММ/ДД/ГГ или ММ.ДД.ГГ — например, 011502 также обозначает 15 января 2002 г.

  • now + время — время задаётся в минутах, часах, днях или неделях. Например, строка «now + 5 days» обозначает, что команда должна быть выполнена в это же время, но через пять дней.

Сначала должно буть указано время, а за ним можно указать необязательную дату. За дополнительной информацией о формате времени, обратитесь к текстовому файлу /usr/share/doc/at-<version>/timespec.

После ввода команды at с аргументом, указывающим время, выводится приглашение at>. Введите команду, которая должна быть выполнена, а затем нажмите [Enter] и [Ctrl]-[D]. Вы можете указать несколько команд, нажимая клавишу [Enter] после ввода каждой команды. Когда вы наберёте все команды, нажмите [Enter] чтобы перейти на пустую строку, а затем нажмите [Ctrl]-[D]. Вы также можете ввести в этом приглашении сценарий оболочки, нажимая [Enter] в конце каждой строки сценария, и нажав [Ctrl]-[D] в пустой строке, чтобы выйти из программы. Если введён сценарий, для его исполнения используется оболочка, указанная в переменной окружения пользователя SHELL, оболочка пользователя для входа в систему или /bin/sh (в зависимости от того, какая будет найдена первой).

Если заданные команды или сценарий выводит сообщения на стандартное устройство вывода, эти сообщения пересылаются пользователю по электронной почте.

Чтобы просмотреть запланированные задания, выполните команду atq. За дополнительными сведениями обратитесь к разделу 35.2.3 Просмотр запланированных заданий.

Доступ к команде at можно ограничить. За дополнительной информацией об этом обратитесь к разделу 35.2.5 Управление доступом к at и batch.

35.2.2. Настройка заданий batch

Для выполнения разовой задачи, когда средняя загрузка опускается ниже 0,8, используйте команду batch.

После ввода команды batch появляется приглашение at>. Введите команду, которая должна быть выполнена, а затем нажмите [Enter] и [Ctrl]-[D]. Вы можете указать несколько команд, нажимая клавишу [Enter] после ввода каждой команды. Когда вы наберёте все команды, нажмите [Enter] чтобы перейти на пустую строку, а затем нажмите [Ctrl]-[D]. Вы также можете ввести в этом приглашении сценарий оболочки, нажимая [Enter] в конце каждой строки сценария, и нажав [Ctrl]-[D] в пустой строке, чтобы выйти из программы. Если введён сценарий, для его исполнения используется оболочка, указанная в переменной окружения пользователя SHELL, оболочка пользователя для входа в систему или /bin/sh (в зависимости от того, какая будет найдена первой). Заданный набор команд будет выполнен, как только средняя загрузка опустится ниже 0,8.

Если заданные команды или сценарий выводит сообщения на стандартное устройство вывода, эти сообщения пересылаются пользователю по электронной почте.

Чтобы просмотреть запланированные задания, выполните команду atq. За дополнительными сведениями обратитесь к разделу 35.2.3 Просмотр запланированных заданий.

Доступ к команде batch можно ограничить. За дополнительной информацией об этом обратитесь к разделу 35.2.5 Управление доступом к at и batch.

35.2.3. Просмотр запланированных заданий

Чтобы просмотреть запланированные задания at и batch, используйте команду atq. Команда atq показывает список запланированных заданий, выводя каждое задание в отдельной строке. В конце строки указывается номер задания, дата, час, класс задания и имя пользователя. Пользователи могут просматривать только собственные задания. Если команду atq выполняет пользователь root, она выводит все задания всех пользователей.

35.2.4. Дополнительные параметры командной строки

В число дополнительных параметров командой строки at и batch входят:

Параметр | Описание
-f | Команды и сценарий оболочки не вводятся в приглашении, а считываются из файла.
-m | При завершении задания пользователю отправляется почтовое сообщение.
-v | Выводит время, на которое запланировано задание.

Таблица 35-1. Параметры командной строки at и batch

35.2.5. Управление доступом к at и batch

Файлы /etc/at.allow и /etc/at.deny позволяют ограничить доступ к командам at и batch. Формат списков управления доступом в обоих файлах прост — в каждой строке файла указывается одно имя пользователя. Пробельные символы в этих файлах не допускаются. Перезапускать демон at (atd) после изменения файлов управления доступом не требуется. Файлы управления доступом обрабатываются каждый раз, когда пользователь пытается выполнить команды at и batch.

Пользователь root всегда может выполнять команды at and batch, вне зависимости от файлов управления доступом.

Если файл at.allow существует, использовать at и batch разрешено только перечисленным в нём пользователям, а файл at.deny игнорируется.

Если файл at.allow не существует, пользователям, перечисленным в at.deny, использовать at и batch не разрешается.

35.2.6. Запуск и остановка службы

Чтобы запустить службу at, выполните команду /sbin/service atd start. Чтобы остановить её, выполните команду /sbin/service atd stop. Рекомендуется настроить запуск этой службы при загрузке системы. За подробными инструкциями по настройка автоматического запуска службы cron при загрузке системы обратитесь к главе 20 Управление доступом к службам.

Назад | Начало | Вперёд
Автоматизация задач | Вверх | Дополнительные ресурсы


Активизация службы iptables

Назад Глава 19. Основная настройка брандмауэра Вперёд

19.2. Активизация службы iptables

Правила брандмауэра действуют только при запущенной службе iptables. Чтобы запустить её вручную, выполните следующую команду:

    /sbin/service iptables restart

Чтобы служба запускалась при загрузке системы, выполните команду:

    /sbin/chkconfig --level 345 iptables on

Служба ipchains не включена в состав Red Hat Enterprise Linux. Однако, если служба ipchains установлена (например, служба ipchains была установлена ранее, а потом система была обновлена), служба ipchains не должна активироваться одновременно со службой iptables. Чтобы отключить службу ipchains и запретить её запуск при загрузке, выполните следующие две команды:

    /sbin/service ipchains stop /sbin/chkconfig
      --level 345 ipchains off

Включать или отключать службы iptables и ipchains также можно с помощью средства Настройка служб (Services Configuration Tool).

Назад | Начало | Вперёд
Основная настройка брандмауэра | Вверх | Управление доступом к службам


Проверка подписи пакета

Назад Глава 15. Управление пакетами с помощью RPM Вперёд

15.3. Проверка подписи пакета

Если вы хотите удостовериться в том, что пакет не был испорчен или повреждён, проверьте только сумму md5, выполнив в командной строке следующую команду (замените <rpm-file> именем файла RPM-пакета):

rpm -K --nosignature <rpm-file>

На экране появляется сообщение <rpm-file>: md5 OK. Это короткое сообщение означает, что файл не был поврежден во время загрузки. Чтобы увидеть более подробное сообщение, замените в этой команде -K на -Kvv.

С другой стороны, насколько вы доверяете разработчику, создавшему пакет? Если пакет подписан GnuPG-ключом разработчика, вы узнаете, что разработчик именно тот, за кого себя выдаёт.

RPM-пакет может быть подписан с помощью программы Gnu на защите конфиденциальности (Privacy Guard, GnuPG), что поможет вам убедиться в том, что загруженный пакет заслуживает доверия.

GnuPG — это программа для безопасного обмена информацией; она является полной и бесплатной заменой технологии шифрования PGP — программы для обеспечения конфиденциальности. Используя GnuPG, вы можете проверять подлинность документов, а также зашифровывать/расшифровывать передаваемые и принимаемые данные. GnuPG также может проверять и расшифровывать файлы PGP 5.x.

По умолчанию GnuPG устанавливается при установке системы. Поэтому вы можете сразу воспользоваться GnuPG для проверки любых пакетов, полученных от Red Hat. Но сначала вы должны импортировать открытый ключ Red Hat.

15.3.1. Импорт ключей

Чтобы проверять пакеты Red Hat, вы должны импортировть GPG-ключ Red Hat. Для этого введите в приглашении оболочки следующую команду:

rpm --import /usr/share/rhn/RPM-GPG-KEY

Чтобы просмотреть список всех ключей, используемых для проверки RPM, выполните команду:

rpm -qa gpg-pubkey*

Ключ Red Hat в этом списке будет выглядеть так:

gpg-pubkey-db42a60e-37ea5438

Чтобы узнать о конкретном ключе больше, выполните rpm -qi, добавив в конце результат предыдущей команды, например:

rpm -qi gpg-pubkey-db42a60e-37ea5438

15.3.2. Проверка подписи пакетов

Чтобы, загрузив GnuPG-ключ создателя пакета, проверить GnuPG-подпись этого пакета, выполните следующую команду (замените <rpm-file> именем файла RPM-пакета):

rpm -K <rpm-file>

Если всё проходит хорошо, появляется следующее сообщение md5 gpg OK. Это значит, что подпись пакета была проверена и она не испорчена.

Назад | Начало | Вперёд
Использование RPM | Вверх | Удивите друзей возможностями RPM


Свойства сетевого протокола времени (NTP)

Назад Глава 29. Настройка даты и времени Вперёд

29.2. Свойства сетевого протокола времени (NTP)

Как показано на рисунке 29-2, вторая вкладка предназначена для настройки NTP.

Рисунок 29-2. Свойства NTP

Демон протокола сетевого времени (Network Time Protocol, NTP) синхронизирует системные часы с удалённым сервером или источником времени (например, спутником). Это приложение позволяет вам настроить демон NTP для синхронизации часов системы с удалённым сервером. Чтобы включить эту возможность, отметьте флажок Разрешить синхронизацию времени (Enable Network Time Protocol). При этом станет доступно выпадающее меню Сервер (Server). Вы можете выбрать один из серверов, предлагаемых в меню, или ввести в этом меню имя своего сервера. Ваша система не начнёт синхронизацию времени с NTP-сервером, пока вы не нажмёте OK. Когда вы нажмёте OK, конфигурация будет сохранена и запустится демон NTP (или перезапустится, если он уже работает).

Нажатие кнопки OK приводит к применению всех внесённых изменений даты, времени, настроек демона NTP и параметров часового пояса. Это также приводит к завершению программы.

Назад | Начало | Вперёд
Настройка даты и времени | Вверх | Выбор часового пояса


Выбор часового пояса

Назад Глава 29. Настройка даты и времени Вперёд

29.3. Выбор часового пояса

Как показано на рисунке 29-3, в третьей вкладке окна настраивается часовой пояс системы.

Чтобы настроить часовой пояс системы, перейдите на вкладку Часовой пояс (Time Zone). Часовой пояс можно изменить, воспользовавшись интерактивной картой или выбрав нужный часовой пояс из списка под картой. Использовать карту очень легко, просто щёлкните город, представляющий нужный часовой пояс. На карте появляется красный X, при этом выбранный пояс отражается в списке под картой. Нажмите OK, чтобы сохранить изменения и выйти из программы.

Рисунок 29-3. Свойства часового пояса

Если часы вашего компьютера установлены по Гринвичу (UTC), установите флажок Системные часы используют UTC (System clock uses UTC). UTC расшифровывается как Universal Time, Coordinated (универсальное координированное время), также известно как мировое время по Гринвичу (Greenwich mean time, GMT). Другие часовые поясы определяются разницей между местным и мировым временем.

Назад | Начало | Вперёд
Свойства сетевого протокола времени (NTP) | Вверх | Настройка клавиатуры


Дополнительные ресурсы

Назад Глава 24. Протокол динамической конфигурации узлов (DHCP) Вперёд

24.4. Дополнительные ресурсы

Информацию о параметрах настройки, не освященных здесь, можно найти в следующих источниках.

24.4.1. Установленная документация

  • Страница man dhcpd — Содержит описание работы демона DHCP.

  • Страница man dhcpd.conf — Объясняет, как настроить файл конфигурации DHCP; включает несколько примеров.

  • Страница man dhcpd.leases — Объясняет, как настроить файл DHCP аренды; содержит несколько примеров.

  • Страница man dhcp-options — Показывает синтаксис параметров DHCP в файле dhcpd.conf; включает несколько примеров.

  • Страница man dhcrelay — Рассказывает об агенте ретрансляции DHCP и его параметрах.

  • /usr/share/doc/dhcp-<version>/ — Содержит файлы примеров, файлы README и замечания к данной версии службы DHCP.

Назад | Начало | Вперёд
Настройка DHCP-клиента | Вверх | Настройка HTTP-сервера Apache


Настройка DHCP-клиента

Назад Глава 24. Протокол динамической конфигурации узлов (DHCP) Вперёд

24.3. Настройка DHCP-клиента

Прежде чем приступить к настройке DHCP-клиента, убедитесь в том, что ядро распознаёт сетевую плату. Большинство плат определяются во время процесса установки, при этом в ядре системы для платы настраивается нужный модуль. Если плата добавляется после установки, Kudzu [1] должна распознать его и предложить настроить соответствующий модуль ядра. Проверьте список совместимого оборудования, доступный по адресу: http://hardware.redhat.com/hcl/. Если сетевая плата не была настроена программой установки или Kudzu, но вы знаете, какой модуль ядра ей соответствует, обратитесь к главе 38 Модули ядра за сведениями о загрузке модулей ядра.

Чтобы настроить DHCP-клиента вручную, включите поддержку сети в файле /etc/sysconfig/network и отредактируйте файлы конфигурации каждого сетевого устройства в каталоге /etc/sysconfig/network-scripts. В этом каталоге каждому устройству должен соответствовать файл конфигурации с именем ifcfg-eth0, где eth0 — название сетевого устройства.

Файл /etc/sysconfig/network должен содержать следующую строку:

NETWORKING=yes

Если вы хотите, чтобы сеть запускалась при загрузке, переменная NETWORKING должна иметь значение yes.

Файл /etc/sysconfig/network-scripts/ifcfg-eth0 должен содержать следующие строки:

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

Для каждого устройства, для которого настраивается DHCP, необходим файл конфигурации.

В число других параметров сценария сети входят:

  • DHCP_HOSTNAME — Используйте этот параметр, если DHCP-сервер требует, чтобы клиент сообщил имя узла, прежде чем он получит IP-адрес. (Демон DHCP-сервера в Red Hat Enterprise Linux это не поддерживает.)

  • PEERDNS=<answer>, где <answer> принимает значения:

    • yes — Изменить файл /etc/resolv.conf в соответствии с информацией, полученной с сервера. Если используется DHCP, по умолчанию действует значение yes.

    • no — Не изменять файл /etc/resolv.conf.

  • SRCADDR=<address>, где <address> — указанный IP-адрес источника исходящих пакетов.

  • USERCTL=<answer>, где <answer> принимает значения:

    • yes — Управлять этим устройством могут пользователи помимо root.

    • no — Управлять этим устройством может только пользователь root.

Если вы предпочитаете графический интерфейс, обратитесь к главе 18 Настройка сети за подробностями использования средства Настройка сети (Network Administration Tool), чтобы настроить для сетевого интерфейса использование DHCP.

Подсказка | Подсказка
 | Расширенная настройка параметров DHCP-клиентов, таких как временные параметры протокола, требования и запросы аренды, поддержка динамической DNS, псевдонимы, а также широкий набор значений для переопределения, добавления или дополнения конфигурации клианта, обратитесь к страницам man dhclient and dhclient.conf.

Замечания

[1]

Kudzu — это средство, определения оборудования, которое запускается при загрузке системы и определяет, какое оборудование было добавлено или убрано из системы.

Назад | Начало | Вперёд
Настройка DHCP-сервера | Вверх | Дополнительные ресурсы


Настройка DHCP-сервера

Назад Глава 24. Протокол динамической конфигурации узлов (DHCP) Вперёд

24.2. Настройка DHCP-сервера

Чтобы настроить DHCP-сервер, необходимо создать файл конфигурации /etc/dhcpd.conf. Пример конфигурации можно найти в файле /usr/share/doc/dhcp-<version>/dhcpd.conf.sample.

DHCP также использует файл /var/lib/dhcp/dhcpd.leases для хранения базы данных с информацией об аренде клиентов. За дополнительной информацией обратитесь к разделу 24.2.2 База данных аренды.

24.2.1. Файл конфигурации

Настройка DHCP-сервера начинается с создания файл конфигурации, содержащего сетевую информацию для клиентов. В файле могут быть описаны глобальные для всех клиентов параметры, а также параметры отдельных клиентских компьютеров.

Файл конфигурации может содержать дополнительные символы табуляции и пустые строки, облегчающие форматирование. Ключевые слова не чувствительны к регистру, а строки, начинающиеся с символа решетки (#), являются комментариями.

В настоящее время реализованы две схемы обновления DNS — режим непосредственного обновления DNS (ad-hoc) и не утверждённый пока предварительный режим взаимодействия DHCP-DNS (interim). Если/когда комитет по техническому развитию Интернета (Internet Engineering Task Force, IETF) включит эти механизмы в процесс стандартизации, появится третий режим — стандартный способ обновления DNS. DHCP-сервер должен быть настроен на использование одной из двух существующей схем. Версия 3.0b2pl11 и предыдущие версии используют непосредственный режим; однако, он является устаревшим. Чтобы сохранить прежнее поведение, добавьте в начало файла конфигурации следующую строку:

ddns-update-style ad-hoc;

Чтобы использовать рекомендуемый режим, добавьте в начало файла конфигурации следующую строку:

ddns-update-style interim;

За подробными сведениями о различных режимах обратитесь к странице man dhcpd.conf.

В файле конфигурации существуют два типа операторов:

  • Параметры — Определяют, как выполнять задачу, выполнять ли её вообще, или какие сетевые параметры передаются клиенту.

  • Объявления — Описывают топологию сети, клиентов, предоставляют адреса для клиентов, или сопоставляют группу параметров группе объявлений.

Некоторые параметры должны начинаться с ключевого слова option, которое показывает, что они необязательны. Такие параметры определяют необязательные переменные DHCP; тогда как другие параметры определяют значения, являющиеся обязательными или управляющие поведением DHCP сервера.

Параметры (включая необязательные), объявленные перед разделом, заключенным в фигурные скобки ({ }), считаются глобальными. Глобальные параметры действуют во всех разделах, следующих ниже.

Важно | Важно
 | Если файл конфигурации изменён, изменения не вступают в силу до перезапуска демона DHCP с помощью команды: service dhcpd restart.

Подсказка | Подсказка
 | Вместо того, чтобы менять файл конфигурации DHCP и каждый раз перезапустить службу, можно воспользоваться командой omshell, предоставляющий способ интерактивного подключения, запроса и изменения конфигурации DHCP-сервера. Благодаря omshell, можно вносить все изменения при работающем сервере. За дополнительными сведениями об omshell обратитесь к странице man omshell.

На Example 24-1 параметры routers, subnet-mask, domain-name, domain-name-servers и time-offset используются для всех следующих ниже объявлений host.

Кроме этого, можно объявить параметр subnet (подсеть);объявление subnet должно включаться в описание каждой подсети. В противном случае DHCP-сервер не запустится.

В этом примере определяются глобальные параметры каждого DHCP-клиента в подсети и диапазон (range). Клиенты получают IP-адреса из указанного диапазона.

subnet 192.168.1.0 netmask 255.255.255.0 {
        option routers                  192.168.1.254;
        option subnet-mask              255.255.255.0;

        option domain-name              "example.com";
        option domain-name-servers       192.168.1.1;

        option time-offset              -18000;     # Eastern Standard Time

    range 192.168.1.10 192.168.1.100;
}

Пример 24-1. Объявление подсети

Все подсети, находящиеся в одной физической сети, должны быть описаны в объявлении shared-network, как показано в примере 24-2. Параметры, находящиеся внутри объявления shared-network, но снаружи закрытого объявления subnet, считаются глобальными. Вместо name в объявлении shared-network следует указывать описательное название сети, например, «test-lab», описывающее все подсети в среде тестовой лаборатории.

shared-network name {
    option domain-name              "test.redhat.com";
    option domain-name-servers      ns1.redhat.com, ns2.redhat.com;
    option routers                  192.168.0.254;
    дополнительные параметры общей сети EXAMPLE
    subnet 192.168.1.0 netmask 255.255.252.0 {
        параметры подсети
        range 192.168.1.1 192.168.1.254;
    }
    subnet 192.168.2.0 netmask 255.255.252.0 {
        параметры подсети
        range 192.168.2.1 192.168.2.254;
    }
}

Пример 24-2. Объявление общей сети

Как показано в примере 24-3, объявление group может использоваться для сопоставления глобальных параметров группе объявлений. Например, можно группировать общие сети, подсети и узлы.

group {
   option routers                  192.168.1.254;
   option subnet-mask              255.255.255.0;

   option domain-name              "example.com";
   option domain-name-servers       192.168.1.1;

   option time-offset              -18000;     # Eastern Standard Time

   host apex {
      option host-name "apex.example.com";
      hardware ethernet 00:A0:78:8E:9E:AA;
      fixed-address 192.168.1.4;
   }

   host raleigh {
      option host-name "raleigh.example.com";
      hardware ethernet 00:A1:DD:74:C3:F2;
      fixed-address 192.168.1.6;
   }
}

Пример 24-3. Объявление группы

Чтобы настроить DHCP-сервер, выдающий в аренду динамические IP-адреса внутри подсети, измените пример 24-4 в соответствии со своими параметрами. Здесь определены время аренды по умолчанию, максимальное время аренды и значения сетевых параметров клиентов. В этом примере параметр range определяет, что клиентам назначаются IP-адреса из диапазона 192.168.1.10 — 192.168.1.100.

default-lease-time 600;
max-lease-time 7200;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
option routers 192.168.1.254;
option domain-name-servers 192.168.1.1, 192.168.1.2;
option domain-name "example.com";

subnet 192.168.1.0 netmask 255.255.255.0 {
   range 192.168.1.10 192.168.1.100;
}

Пример 24-4. Параметер range

Чтобы выдать клиенту IP-адрес, исходя из MAC-адреса его сетевой платы, используйте параметр hardware ethernet внутри объявления host. Показанное на примере 24-5 объявление host apex определяет, что сетевая карта с MAC адресом 00:A0:78:8E:9E:AA всегда получает в аренду IP-адрес 192.168.1.4.

Обратите внимание, также можно использовать необязательный параметр host-name для назначения клиенту имени узла.

host apex {
   option host-name "apex.example.com";
   hardware ethernet 00:A0:78:8E:9E:AA;
   fixed-address 192.168.1.4;
}

Пример 24-5. Назначение постоянного IP-адреса с помощью DHCP

Подсказка Подсказка

Представленный здесь пример файла конфигурации можно использовать как отправную точку, и добавлять в него дополнительные параметрыt. Чтобы скопировать его в подходящее размещение, воспользуйтесь следующей командой:
cp /usr/share/doc/dhcp-<version-number>/dhcpd.conf.sample /etc/dhcpd.conf
(где <version-number> — номер версии DHCP).

Полный список параметров, объявлений и их предназначение вы можете найти на странице man dhcp-options.

24.2.2. База данных аренды

В файле /var/lib/dhcp/dhcpd.leases на DHCP-сервере находится база данных аренды адресов DHCP-клиентами. Этот файл не следует изменять вручную. В эту базу автоматически вносится информация о DHCP-аренде для каждого только что выданного IP-адреса. Эта информация включает в себя продолжительность аренды адреса арендующим узлом, даты начала и конца аренды, а также MAC-адрес сетевой карты, который был использован для получения аренды.

В базе данных аренды указывается не местное время, а время по Гринвичу (GMT).

База данных аренды время от времени инициализируется, поэтому она не слишком велика. Сначала информация о всех известных арендах сохраняется во временной базе данных. Затем файл dhcpd.leases переименовывается в dhcpd.leases~ и временная база переписывается в файл dhcpd.leases.

Работа DHCP-демона может быть прервана или в системе может произойти сбой, после того как база данных аренды была переименована в резервный файл, но до того, как записался новый файл. В этом случае файл dhcpd.leases, необходимый для запуска службы, будет отсутствовать. Не создавайте новый файл аренды. Если вы сделаете это, все сведения о старых арендах будут потеряны, что приведёт к многочисленным проблемам. Правильным решением будет переименовать резервный файл dhcpd.leases~ в dhcpd.leases, а затем запустить службу.

24.2.3. Запуск и остановка сервера

Важно Важно

Если DHCP-сервер запускается впервые и файл dhcpd.leases не существует, сервер не сможет запуститься. Воспользуйтесь командой touch /var/lib/dhcp/dhcpd.leases, чтобы создать файл, если он не существует.

Если на том же компьютере работает BIND в качестве DNS-сервере, этот шаг не является обязательным, так как при запуске службы named файл dhcpd.leases проверяется автоматически.

Чтобы запустить службу DHCP, выполните команду: /sbin/service dhcpd start. Чтобы остановить службу DHCP, выполните команду /sbin/service dhcpd stop.

По умолчанию служба DHCP не запускается при загрузке. Чтобы настроить автоматический запуск демона при загрузке системы, обратитесь к главе 20 Управление доступом к службам за информацией об управлении службами.

Если к компьютеру подключено несколько сетевых интерфейсов, но DHCP-сервер должен работать только с одним из них, настройте DHCP-сервер так, чтобы он запускался только на этом устройстве. Отредактируйте файл /etc/sysconfig/dhcpd и добавьте имя интерфейса в список DHCPDARGS:

# Command line options here
DHCPDARGS=eth0

Это полезно, если на вашем компьютере с двумя сетевыми платами работает брандмауэр. Одна сетевая плата может быть настроена как DHCP-клиент для получения IP-адреса Интернета. Другая плата может быть использована DHCP-сервером для внутренней сети за брандмауэром. Указав, что только одна сетевая плата подключена к внутренней сети, вы сделаете систему более защищённой, так как пользователи не смогут подключаться к демону через Интернет.

Кроме этого в файле /etc/sysconfig/dhcpd можно указать и другие параметры командной строки:

  • -p <portnum> — Укажите номер UDP-порта, на котором должен работать демон dhcpd. По умолчанию используется порт 67. DHCP-сервер передаёт ответы DHCP-клиентам в порт с номером, большим чем указанный UDP-порт. Например, если используется порт 67, сервер принимает запросы клиентов в порту 67 и отвечает клиентам в порт 68. Если используется агент ретрансляции DHCP, здесь следует указывать порт, в котором принимает запросы агент ретрансляции DHCP. За подробностями обратитесь к разделу 24.2.4 Агент ретрансляции DHCP.

  • -f — Запустить демон как процесс переднего плана. Он используется в основном для отладки.

  • -d — Выводить сообщения демона DHCP-сервера в стандартное устройство ошибок. Он используется в основном для отладки. Если этот флаг не указан, сообщения записываются в файл /var/log/messages.

  • -cf <filename> — Определяет размещение файла конфигурации. По умолчанию он размещён в /etc/dhcpd.conf.

  • -lf <filename> — Определяет размещение файла базы данных аренды. Если файл базы данных уже существует, очень важно, чтобы при каждом запуске DHCP-сервера использовался один и тот же файл. Настоятельно рекомендуется использовать этот параметр только для отладки в не производственной среде. По умолчанию база данных размещается в /var/lib/dhcp/dhcpd.leases.

  • -q — Не выводить сообщение о правах копирования при запуске демона.

24.2.4. Агент ретрансляции DHCP

Агент ретрансляции DHCP(dhcrelay) позволяет вам ретранслировать DHCP и BOOTP-запросы из подсети, в которой нет DHCP-сервера в другую, или в несколько других подсетей с DHCP-серверами.

Когда DHCP клиент запрашивает информацию, агент ретрансляции DHCP пересылает запрос списку DHCP серверов, указанных при запуске агента. Когда DHCP сервер возвращает ответ, он отправляется либо широковещательно, либо направленно в сеть, из которой был получен первоначальный запрос.

Агент ретрансляции DHCP принимает DHCP-запросы на всех интерфейсах, если интерфейсы не определены явно в файле /etc/sysconfig/dhcrelay в указании INTERFACES.

Чтобы запустить агент ретрансляции DHCP, выполните команду service dhcrelay start.

Назад | Начало | Вперёд
Протокол динамической конфигурации узлов (DHCP) | Вверх | Настройка DHCP-клиента


Дополнительные ресурсы

Назад Глава 13. Реализация дисковых квот Вперёд

13.3. Дополнительные ресурсы

За дополнительной информацией о дисковых квотах обратитесь к следующим ресурсам.

13.3.1. Установленная документация

  • Страницы man quotacheck, edquota, repquota, quota, quotaon и quotaoff

13.3.2. Книги по этой теме

  • Руководство Введение в системное администрирование Red Hat Enterprise Linux (выпущенное компанией Red Hat, Inc.) размещено по адресу http://www.redhat.com/docs/ и на компакт-диске документации, знакомит начинающих системных администраторов Red Hat Enterprise Linux с основами управления дисковым хранилищем (включая дисковые квоты).

Назад | Начало | Вперёд
Управление дисковыми квотами | Вверх | Списки управления доступом


Управление дисковыми квотами

Назад Глава 13. Реализация дисковых квот Вперёд

13.2. Управление дисковыми квотами

Если квоты внедрены, они требуют определённого обслуживания — в основном оно заключается в наблюдении за тем, превышены ли квоты, и в обеспечении точности квот. Конечно, если пользователи часто выходят за установленные пределы или постоянно превышают свои мягкие пределы, системный администратор может поступить по-разному, в зависимости от того, кто эти пользователи, и сколько места необходимо им для работы. Администратор может подсказать пользователю, как использовать меньше места на диске, или, если это необходимо, увеличить квоту пользователя.

13.2.1. Включение и отключение

Вы можете отключить квоты, не сбрасывая их в 0. Чтобы выключить квоты для всех пользователей и групп, выполните следующую команду:

quotaoff -vaug

Если не один из параметров -u и -g не указан, отключаются только квоты пользователей. Если указан только параметр -g, отключаются только квоты групп.

Чтобы снова включить квоты, выполните с теми же параметрами команду quotaon.

Например, чтобы включить квоты пользователей и групп во всех файловых системах, выполните следующую команду:

quotaon -vaug

Чтобы включить квоты в определённой файловой системе, например, /home, выполните следующую команду:

quotaon -vug /home

Если не один из параметров -u и -g не указан, включаются только квоты пользователей. Если указан только параметр -g, включаются только квоты групп.

13.2.2. Создание отчётов по дисковым квотам

Для создания отчёта об использовании диска необходимо запустить утилиту repquota. Например, при выполнении команды repquota /home вы получите следующее:

*** Report for user quotas on device /dev/mapper/VolGroup00-LogVol02
Block grace time: 7days; Inode grace time: 7days
                        Block limits                File limits
User            used    soft    hard  grace    used  soft  hard  grace
----------------------------------------------------------------------
root      --      36       0       0              4     0     0
kristin   --     540       0       0            125     0     0
testuser  --  440400  500000  550000          37418     0     0

Чтобы просмотреть отчёт об использовании диска по всем (параметр -a) файловым системам, в которых включены квоты, выполните команду:

repquota -a

Хотя этот отчёт выглядит просто, некоторые моменты следует разъяснить. Символы --, выводимые после имени пользователя, позволяют быстро определить, какой предел был превышен (блоков или inode). Если мягкий предел превышен, вместо - появляется соответствующий +; при этом первый символ - представляет предел блоков, а второй — предел inode.

Столбцы grace обычно пустые. Если мягкий предел превышен, в этом столбце показывается время, оставшееся до завершения периода отсрочки. Если период отсрочки истёк, в этом столбце отображается none (нет).

13.2.3. Обеспечение точности квот

В случаях, когда файловая система не была размонтирована корректно (например, при сбое системы), необходимо запустить quotacheck. Однако, quotacheck можно запускать регулярно, даже если сбоя системы не было. Периодический запуск следующей команды позволяет поддерживать точность квот (параметры команды описаны в разделе 13.1.1 Включение квот):

quotacheck -avug

Периодически запускать её проще всего с помощью cron. Для этого от имени root выполните команду crontab -e, чтобы назначить периодическое выполнение quotacheck или поместите сценарий, запускающий quotacheck в один из следующих каталогов (используя тот, который больше вам подходит):

  • /etc/cron.hourly

  • /etc/cron.daily

  • /etc/cron.weekly

  • /etc/cron.monthly

Наиболее точную статистику по квотам можно получить, когда анализируемая файловая система не сильно загружена. Поэтому следует назначать запуск задачи cron на время, когда файловая системы (системы) обычно используется меньше всего. Если для разных файловых систем это имеет место в разное время, запускейте quotacheck для каждой файловой системы в своё время, назначив несколько заданий cron.

Обратитесь к главе 35 Автоматизированные задачи за дополнительными сведениями о настройке cron.

Назад | Начало | Вперёд
Реализация дисковых квот | Вверх | Дополнительные ресурсы


Управление разделами LVM

Назад Глава 12. Управление дисковым хранилищем Вперёд

12.2. Управление разделами LVM

Выполнив в приглашении оболочки команду lvm help, вы получите следующий список команд.

Команда | Описание
dumpconfig | Сбрасывает дамп активной конфигурации
formats | Показывает список доступных форматов метаданных
help | Выводит справочную информацию о командах
lvchange | Изменяет атрибуты логического тома (томов)
lvcreate | Создаёт логический том
lvdisplay | Выводит информацию о логическом томе
lvextend | Добавляет пространство в логический том
lvmchange | По причине использования сопоставителя устройств, эта команда является устаревшей
lvmdiskscan | Выводит список устройств, которые можно использовать как логические тома
lvmsadc | Собирает данные об активности
lvmsar | Создаёт отчёт об активности
lvreduce | Уменьшает размер логического тома
lvremove | Удаляет логический том(а) из системы
lvrename | Переименовывает логический том
lvresize | Изменяет размер логического тома
lvs | Выводит информацию о логических томах
lvscan | Выводит список всех логических томов во всех группах томов
pvchange | Изменяет атрибуты физического тома (томов)
pvcreate | Подготавливает физический том (тома) к использованию в LVM
pvdata | Выводите записанные на диск метаданные о физических томах (томе)
pvdisplay | Выводит различные атрибуты физического тома (томов)
pvmove | Перемещает блоки с одного физического тома на другой
pvremove | Удаляет LVM-метку (метки) с физического тома (томов)
pvresize | Изменяет размер физического тома, используемого группой томов
pvs | Выводит информацию о физических томах
pvscan | Выводит список всех физических томов
segtypes | Выводит список доступных типов сегментов
vgcfgbackup | Делает резервную копию конфигурации группы томов
vgcfgrestore | Восстанавливает резервную копию конфигурации группы томов
vgchange | Изменяет атрибуты группы томов
vgck | Проверяет целостность группы томов
vgconvert | Преобразует формат метаданных группы томов
vgcreate | Создаёт группу томов
vgdisplay | Выводит информацию о группе томов
vgexport | Удаляет регистрацию группы томов из системы
vgextend | Добавляет физические тома в группу томов
vgimport | Регистрирует экспортированную группу томов в системе
vgmerge | Объединяет группы томов
vgmknodes | Создаёт специальные файлы для устройств групп томов в /dev/
vgreduce | Удаляет физический том из группы томов
vgremove | Удаляет группу томов
vgrename | Переименовывает группу томов
vgs | Выводит информацию о группах томов
vgscan | Ищет все группы томов
vgsplit | Перемещает физические тома в новую группу томов
version | Выводит информацию о версии программы и драйвера

Таблица 12-2. Команды LVM

Назад | Начало | Вперёд
Управление дисковым хранилищем | Вверх | Реализация дисковых квот


Загрузка узлов

Назад Глава 4. Бездисковые окружения Вперёд

4.6. Загрузка узлов

Чтобы узнать, как настроить на компьютере загрузку через PXE, обратитесь к документации вашей PXE-платы.

Когда загружается бездисковый клиент, он подключает удалённый каталог root/ в бездисковый каталог в режиме только чтения. Он также монтирует свой отдельный каталог снимка в режиме чтения/записи. Затем он подключает все файли и каталоги, перечисленные в списках files и files.custom, выполняя команду mount -o bind поверх бездискового каталога, доступного только для чтения, чтобы позволить приложениям записывать в корневой каталог бездискового окружения, если есть такая необходимость.

Назад | Начало | Вперёд
Добавление узлов | Вверх | Основы восстановления системы


Настройка DHCP-сервера

Назад Глава 4. Бездисковые окружения Вперёд

4.2. Настройка DHCP-сервера

Если в вашей сети ещё нет DHCP-сервера, настройте его. Подробнее об этом можно узнать в главе 24 Протокол динамической настройки узлов (DHCP). Чтобы компьютеры, поддерживающие PXE, смогли выполнить PXE-загрузку, файл конфигурации должен содержать следующие строки:

allow booting;
allow bootp;
class "pxeclients" {
   match if substring(option vendor-class-identifier, 0, 9) = "PXEClient";
   next-server <server-ip>;
   filename "linux-install/pxelinux.0";
}

где вместо <server-ip> следует подставить IP-адрес tftp-сервера.

Назад | Начало | Вперёд
Бездисковые окружения | Вверх | Настройка NFS-сервера


Добавление узлов

Назад Глава 4. Бездисковые окружения Вперёд

4.5. Добавление узлов

У каждого бездискового клиента на NFS-сервере должен быть собственный каталог снимка, который будет использоваться как файловая система для чтения/записи. Создать эти каталоги снимков можно с помощью инструмента Настройки загрузки по сети (Network Booting Tool).

После выполнения действий, описанных в разделе 4.4 Завершение настройки бездискового окружения, появляется окно, в котором можно добавить узлы бездискового окружения. Нажмите кнопку Создать (New). В диалоге, показанном на рисунке 4-1, введите следующие сведения:

  • Имя узла или IP-адрес/подсеть (Hostname or IP Address/Subnet) — Укажите имя или IP-адрес компьютера, чтобы сделать его узлом для бездискового окружения. Введите подсеть, чтобы определить группу компьютеров.

  • Операционная система (Operating System) — Выберите бездисковое окружение для узла или подсети узлов.

  • Использовать последовательную консоль (Serial Console) — Отметьте этот флажок, чтобы выполнить установку через последовательный порт.

  • Название снимка (Snapshot name) — Укажите имя подкаталога, который будет использоваться для хранения всех данных узла, доступных на чтение/запись.

  • Адаптер Ethernet (Ethernet) — Выберите Ethernet-устройство узла, используемое для монтирования бездискового окружения. Если в компьютере всего одна Ethernet-плата, выберите eth0.

Параметр Файл Kickstart (Kickstart File) не важен. Он используется только при PXE-установке.

Рисунок 4-1. Добавление бездискового узла

В существующем подкаталоге snapshot/ внутри бездискового каталога создаётся подкаталог с именем, указанным в поле Название снимка (Snapshot name). Затем все файлы, перечисленные в списках snapshot/files и snapshot/files.custom копируются из каталога root/ в этот новый каталог.

Назад | Начало | Вперёд
Завершение настройки бездискового окружения | Вверх | Загрузка узлов


Завершение настройки бездискового окружения

Назад Глава 4. Бездисковые окружения Вперёд

4.4. Завершение настройки бездискового окружения

Чтобы вы могли использовать графическую версию инструмента Настройки загрузки по сети (Network Booting Tool), у вас должна работать система X Window, должен быть установлен RPM-пакет system-config-netboot и вы должны иметь права root. Чтобы запустить Настройку загрузку по сети (Network Booting Tool) с рабочего стола, выберите в главном меню Приложения (Applications) (на панели) => Системные параметры (System Settings) => Настройка сервера (Server Settings) => Служба загрузки по сети (Network Booting Service). Или введите команду system-config-netboot в приглашении оболочки (например, в XTerm или терминале среды GNOME).

Если вы запускаете Настройку загрузки по сети впервые, выберите в Помощнике первого запуска (First Time Druid) вариант Бездисковый (Diskless). В противном случае, выберите в выпадающем меню Настройка (Configure) => Бездисковый (Diskless) и нажмите Добавить (Add).

На экране появится мастер, который будет сопровождать вас в процессе настройки:

  1. Нажмите на первой странице Вперёд (Forward).

  2. На странице Идентификатор (Diskless Identifier) определите Имя (Name) и Описание (Description) бездискового окружения. Нажмите Вперёд (Forward).

  3. Введите IP-адрес или имя домена NFS-сервера, настроенного в разделе 4.3 Настройка NFS-сервера, а также путь к каталогу, экспортированному как бездисковое окружение. Нажмите Вперёд (Forward).

  4. Вы увидите список версий ядер, установленных в бездисковом окружении. Выберите версию ядра для загрузки в бездисковом компьютере.

  5. Нажмите Применить (Apply), чтобы завершить настройку.

После нажатия кнопки Применить (Apply) для выбранного ядра создаётся файл образа и бездисковое ядро. Эти файлы копируются в каталог PXE-загрузки /tftpboot/linux-install/<os-identifier>/. Каталог snapshot/ создаётся в том же каталоге, что и каталог root/ (например, /diskless/i386/RHEL4-AS/snapshot/), и в нём размещается файл files. Этот файл содержит список файлов и каталогов, которые должны быть доступны на запись/чтения всем бездисковым компьютерам. Не изменяйте этот файл. Если в этот список потребуется добавить дополнительные записи, создайте файл files.custom в одном каталоге с файлом files и внесите в него каждый дополнительный файл или каталог в отдельной строке.

Назад | Начало | Вперёд
Настройка NFS-сервера | Вверх | Добавление узлов


Настройка NFS-сервера

Назад Глава 4. Бездисковые окружения Вперёд

4.3. Настройка NFS-сервера

Доступная только на чтение общая часть операционной системы разделяется средствами NFS.

Настройте в NFS экспорт каталогов root/ и snapshot/, добавив их в файл /etc/exports. Например:

/diskless/i386/RHEL4-AS/root/     *(ro,sync,no_root_squash)
/diskless/i386/RHEL4-AS/snapshot/ *(rw,sync,no_root_squash)

Замените * именем узла в одном из форматов, описанных в разделе 22.3.2 Форматы имён узлов. Убедитесь в том, что указания имён узлов максимально точны, чтобы нежелательные системы не смогли обратиться к этим NFS-ресурсам.

Если служба NFS не работает, запустите её:

service nfs start

Если служба NFS уже запущена, перезагрузите файл конфигурации:

service nfs reload
Назад | Начало | Вперёд
Настройка DHCP-сервера | Вверх | Завершение настройки бездискового окружения


Возврат к файловой системе ext2

Назад Глава 6. Файловая система ext3 Вперёд

6.4. Возврат к файловой системе ext2

Так как файловая система ext3 относительно молода, некоторые дисковые утилиты до сих пор её не поддерживают. Например, у вас может возникнуть желание сжать раздел с помощью resize2fs, которая всё ещё не поддерживает ext3. В этом случае может потребоваться временно вернуть файловую систему ext2.

Чтобы возвратить старую систему, вы должны сначала отключить раздел, войдя в систему под именем root и набрав

umount /dev/mapper/VolGroup00-LogVol02

Затем смените тип файловой системы на ext2, введя от имени root следующие команды:

/sbin/tune2fs -O ^has_journal /dev/mapper/VolGroup00-LogVol02

Проверьте раздел на наличие ошибков, выполнив от имени root следующую команду:

/sbin/e2fsck -y /dev/mapper/VolGroup00-LogVol02

Затем снова смонтируйте раздел как файловую систему ext2, набрав:

mount -t ext2 /dev/mapper/VolGroup00-LogVol02 /mount/point

В показанной выше команде замените /mount/point точкой монтирования этого раздела.

Затем удалите файл .journal из корневого каталога раздела, перейдя в каталог, куда он смонтирован и набрав:

rm -f .journal

Теперь ваш раздел имеет формат ext2.

Если вы, чтобы ваш раздел и дальше оставался с файловой системой ext2 , не забудьте изменить файл /etc/fstab.

Назад | Начало | Вперёд
Переход к файловой системе ext3 | Вверх | Диспетчер логических томов (LVM)


Переход к файловой системе ext3

Назад Глава 6. Файловая система ext3 Вперёд

6.3. Переход к файловой системе ext3

Программа tune2fs может добавить журнал в существующую файловую систему ext2, не затрагивая данные, уже существующие в разделе. Если во время преобразования файловая система уже смонтирована, журнал можно увидеть как файл .journal в корневом каталоге файловой системы. Если файловая система не смонтирована, журнал скрыт и вообще не появляется в файловой системе.

Замечание | Замечание
 | По умолчанию программа установки Red Hat Enterprise Linux использует для всех разделов файловую систему ext3.

Чтобы преобразовать файловую систему ext2 в ext3, войдите в систему под именем root и введите

/sbin/tune2fs -j <file_system>

, где <file_system> — подходящая файловая система LVM2.

В корректной файловой системе LVM2 могут быть записи двух типов:

  • Отображённое устройство — Логический том в группе томов, например, /dev/mapper/VolGroup00-LogVol02.

  • Статическое устройство — Традиционный том хранилища, например, /dev/hdbX, где hdb — название устройства хранения и X — номер раздела.

Выполните команду df, чтобы вывести список смонтированных файловых систем.

В приведённых далее примерах команд используется следующее значение:

/dev/mapper/VolGroup00-LogVol02

Сделав это, не забудьте изменить тип раздела с ext2 на ext3 в файле /etc/fstab.

Если вы преобразуете корневую файловую систему, вы должны использовать для загрузки образ initrd (или диск в ОЗУ). Чтобы его создать, запустите программу mkinitrd. Чтобы получить сведения об использовании команды mkinitrd, введите man mkinitrd. Кроме этого, убедитесь в том, что в вашей конфигурации GRUB загружается initrd.

Если вы не внесёте это изменение, система будет загружаться по-прежнему, но вместо ext3 файловая система будет монтироваться как ext2.

Назад | Начало | Вперёд
Создание файловой системы ext3 | Вверх | Возврат к файловой системе ext2


Создание файловой системы ext3

Назад Глава 6. Файловая система ext3 Вперёд

6.2. Создание файловой системы ext3

Иногда возникает необходимость создать новую файловую систему ext3 после установки системы. Например, если вы поставили в компьютер новый диск, возможно, вам захочется разбить его и использовать файловую систему ext3.

Для создания файловой системы ext3 вы должны проделать следующее:

  1. Создать раздел с помощью parted или fdisk

  2. Отформатировать раздел в файловой системе ext3 с помощью mkfs

  3. Назначить разделу метку с помощью e2label

  4. Создать точку монтирования

  5. Добавить раздел в файл /etc/fstab.

Назад | Начало | Вперёд
Файловая система ext3 | Вверх | Переход к файловой системе ext3


Удаление пакетов

Назад Глава 16. Средство «Управление пакетами» Вперёд

16.2. Удаление пакетов

Чтобы удалить все пакеты, установленные в составе группы, снимите флажок, расположенный рядом с ней. Чтобы удалить отдельные пакеты, нажмите кнопку Сведения (Details), расположенную рядом с группой пакетов и снимите отметки отдельных пакетов.

Закончив выбор пакетов для удаления, нажмите в главном окне кнопку Обновить (Update). Программа вычисляет объём освобождаемого дискового пространства, а также зависимости программных пакетов. Если от пакетов, которые вы решили удалить, зависят другие, они будут автоматически добавлены в список удаляемых пакетов. Нажмите кнопку Показать сведения (Show Details), чтобы просмотреть полный список удаляемых пакетов.

Рисунок 16-4. Краткие сведения об удалении пакета

Нажмите Продолжить (Continue), чтобы начать процесс удаления. После завершения установки появляется сообщение Обновление завершено (Update Complete).

Подсказка | Подсказка
 | Вы можете объединить установку и удаление пакетов, выбрав пакеты или группы пакетов для установки/удаления, а затема нажав кнопку Обновить (Update). В появившемся окне Подготовка системы завершена (Completed System Preparation) будет показано число устанавливаемых и удаляемых пакетов.
Назад | Начало | Вперёд
Средство «Управление пакетами» | Вверх | Red Hat Network


Дополнительные ресурсы

Назад Глава 25. Настройка HTTP-сервера Apache Вперёд

25.7. Дополнительные ресурсы

Чтобы узнать больше о HTTP-сервере Apache, обратитесь к следующим источникам.

25.7.1. Установленная документация

  • /usr/share/docs/httpd-<version>/migration.html — Эта документация по переходу на новую версию Apache Migration HOWTO содержит список отличий версии 2.0 от 1.3, а также информацию о том, как вручную перенести файл конфигурации в новую версию.

25.7.2. Полезные сайты

  • http://www.apache.org — The Apache Software Foundation (Фонд программного обеспечения Apache).

  • http://httpd.apache.org/docs-2.0/ — Документация фонда программного обеспечения Apache по HTTP-серверу Apache версии 2.0, включающая Apache HTTP Server Version 2.0 User's Guide (Руководство пользователя HTTP-сервера Apache версии 2.0).

  • http://www.redhat.com/support/docs/apache.html — Команда поддержки Red Hat ведёт список полезных ссылок, посвящённых HTTP-серверу Apache.

  • http://www.redhat.com/support/docs/faqs/RH-apache-FAQ/book1.html — Собранная компанией Red Hat централизованная база знаний по Apache.

25.7.3. Книги по этой теме

  • Apache: The Definitive Guide (авторы Бен Лаури (Ben Laurie) и Питер Лаури (Peter Laurie), издательство O'Reilly & Associates, Inc).

  • Red Hat Enterprise Linux Reference Guide (издательство Red Hat, Inc.) — Это справочное руководство содержит инструкции по обновлению HTTP-сервера Apache с версии 1.3 до версии 2.0 вручную, дополнительные сведения об указаниях HTTP-сервера Apache и инструкции по подключению к нему модулей.

Назад | Начало | Вперёд
Сохранение ваших настроек | Вверх | Настройка безопасного HTTP-сервера Apache


Параметры по умолчанию

Назад Глава 25. Настройка HTTP-сервера Apache Вперёд

25.2. Параметры по умолчанию

Заполнив поля Имя сервера (Server Name), Электронный адрес вебмастера (Webmaster email address) и Доступные адреса (Available Addresses), перейдите на вкладку Виртуальные узлы (Virtual Hosts) и нажмите кнопку Изменить параметры по умолчанию (Edit Default Settings). На экране появится окно, показанное на рисунке 25-3. Определите в этом окне параметры вашего веб-сервера по умолчанию. Если вы добавите виртуальный узел, параметры, определённые для этого виртуального узла будут иметь приоритет. Для параметров, не определенных в настройках этого виртуального узла, будут использоваться значения по умолчанию.

25.2.1. Настройка сайта

Значения по умолчанию параметров Список страниц, искомых в каталоге (Directory Page Search List) и Страницы ошибок (Error Pages) подходят для большинства серверов. Если вы не разобрались в этих установках — не изменяйте их.

Рисунок 25-3. Настройка сайта

Записи, перечисленные в области Список страниц, искомых в каталоге (Directory Page Search List), соответствуют указанию DirectoryIndex. DirectoryIndex — это страница по умолчанию, которую возвращает сервер, когда пользователь запрашивает содержимое каталога, указав косую черту (/) в конце имени каталога.

Например, когда пользователь запрашивает страничку http://www.example.com/this_directory/, он получит либо страницу DirectoryIndex (если она существует), либо сформированный сервером список файлов в каталоге. Сервер попытается найти один из файлов, перечисленных в указании DirectoryIndex, и возвратит первый найденный. Если он не находит ни одного из этих файлов и параметр Options Indexes для запрашиваемого каталога установлен, сервер формирует и возвращает список содержащихся в нём файлов и каталогов в формате HTML.

Воспользуйтесь разделом Код ошибки (Error Code), чтобы в случае возникновения ошибки или проблемы HTTP-сервер Apache перенаправлял пользователя на локальный или внешний URL. Этот параметр соответствует указанию ErrorDocument. Если при попытке пользователя соединиться с HTTP-сервером Apache возникла проблема или ошибка, действием по умолчанию будет вывод короткого сообщения об ошибке, указанном в столбце Код ошибки (Error Code). Чтобы изменить это поведение по умолчанию, выберите код ошибки и нажмите кнопку Изменить (Edit). Выберите По умолчанию (Default), чтобы просмотреть короткое сообщение об ошибке по умолчанию. Выберите URL для перенаправления пользователя на внешний URL и введите его полностью, включая http://, в поле Местоположение (Location). Выберите Файл (File), чтобы перенаправить пользователя на внутренний URL и введите путь к файлу внутри корневого каталога документов веб-сервера. Путь к файлу должен начинаться с наклонной черты (/) и указываться относительно корневого каталога документов.

Например, чтобы перенаправить ошибку «404 Not Found» (документ не найден) на веб-страницу, созданную в файле с именем 404.html, скопируйте файл 404.html в DocumentRoot/../error/404.html. Здесь DocumentRoot — это определённый вами корневой каталог документов (Document Root) (по умолчанию — /var/www/html). Если в качестве размещения по умолчанию оставить корневой каталог документов, файл следует скопировать в /var/www/error/404.html. Затем выберите Файл (File) в качестве реакции на ошибку с кодом 404 - Not Found (не найдено) и введите /error/404.html в поле Местоположение (Location).

В меню Нижний колонтитул страницы сообщения об ошибке (Default Error Page Footer) вы можете выбрать один из следующих вариантов:

  • Показывать нижний колонтитул с электронным адресом (Show footer with email address) — В нижней части всех страниц с сообщением об ошибке будет выводиться нижний колонтитул по умолчанию, содержащий электронный адрес администратора веб-сайта, определённый указанием ServerAdmin. Обратитесь к разделу 25.3.1.1 Общие параметры за сведениями о настройке параметра ServerAdmin.

  • Показывать нижний колонтитул (Show footer) — В нижней части страницы будет выводиться только заданный нижний колонтитул по умолчанию.

  • Без нижнего колонтитула (No footer) — Нижний колонтитул не будет выводиться на страницах ошибок.

25.2.2. Ведение журнала

Вкладка Ведение журнала (Logging) используется для настройки параметров ведения журналов ошибок и передач данных.

По умолчанию сервер ведёт протокол передачи данных в файле /var/log/httpd/access_log, а протокол ошибок в /var/log/httpd/error_log.

Протокол передачи данных содержит список всех попыток обращения к веб-серверу. В нём фиксируется IP-адрес клиента, пытавшегося соединиться с сервером, дата и время этой попытки, а также имя файла на веб-сервере, к которому пытался обратиться клиент. Задайте полный путь и имя файла, в котором будет сохранена эта информация. Если полный путь и имя файла начинается не с косой черты (/), путь определяется относительно настроенного корневого каталога сервера. Этот параметр соответствует указанию TransferLog.

Рисунок 25-4. Ведение журнала

Вы можете определить особый формат протокола, установив флажок Установить шаблон журнала (Use custom logging facilities) и задав формат протокола в поле Шаблон журнала (Custom Log String). При этом будет определено указание LogFormat. За подробностями формата этого указания обратитесь к странице http://httpd.apache.org/docs-2.0/mod/mod_log_config.html#formats.

Протокол ошибок содержит список всех произошедших ошибок сервера. Задайте полный путь и имя файла, в котором будет сохранена эта информация. Если полный путь и имя файла начинается не с косой черты (/), путь определяется относительно настроенного корневого каталога сервера. Этот параметр соответствует указанию ErrorLog.

Используйте меню Уровень ведения журнала (Log Level) чтобы определить, насколько подробны будут сообщения об ошибках в протоколе. Этот параметр может принимать следующие значения (от наименее до наиболее подробного): emerg (аварийные ситуации), alert (тревожные ситуации), crit (критические), error (ошибки), warn (предупреждения), notice (уведомления), info or debug (информационные или отладочные сообщения). Этот параметр соответствует указанию LogLevel.

Значение, выбранное в меню Реверсивный поиск через DNS (Reverse DNS Lookup), определяет указание HostnameLookups. Выбрав Отключить реверсивный поиск (No Reverse Lookup), вы установите его значение равным «off». Выбрав Реверсивный поиск (Reverse Lookup), вы установите его значение равным «on». Выбрав Двойной реверсивный поиск (Double Reverse Lookup, вы установите значение «double».

Если вы выбрали Реверсивный поиск (Reverse Lookup), ваш сервер автоматически будет разрешать IP-адрес каждого соединения при запросе документа с веб-сервера. Разрешение IP-адресов означает, что сервер будет производить одно или несколько соединений с DNS, чтобы выяснить имя узла, соответствующее определенному IP-адресу.

Если вы выбрали Двойной реверсивный поиск (Double Reverse Lookup), ваш сервер будет выполнять двойной обратный поиск в DNS. Другими словами, для имени, полученного после обратного преобразования, будет выполнено прямое преобразование. По крайней мере один из IP-адресов при прямом преобразовании должен будет совпасть с адресом, обратное преобразование которого производилось.

Обычно вам следует установить этот параметр в значение Отключить реверсивный поиск (No Reverse Lookup), так как DNS-запросы дополнительно нагружают ваш сервер и могут снизить его производительность. Если ваш сервер загружен, влияние таких прямых и обратных преобразований может быть довольно заметным.

Обратные и двойные обратные преобразования также являются проблемой для Интернета в целом. Каждое отдельное соединение, устанавливаемое для поиска имени каждого узла, нагружает сеть. Поэтому, для выгоды вашего собственного Web сервера, а также всего Интернета, вам следует установить для этого параметра значение Отключить реверсивный поиск (No Reverse Lookup).

25.2.3. Переменные окружения

Вкладка Окружение (Environment) используется для настройки параметров, определяющих, передающих или сбрасывающих переменные сценариев CGI.

Иногда требуется изменить переменные окружения для сценариев CGI или страниц, включаемых на стороне сервера (Server-Side Include, SSI). HTTP-сервер Apache может использовать для настройки переменных окружения, передаваемых в сценарии CGI и страницы SSI, модуль mod_env. Указания для этого модуля и настраиваются на странице Переменные окружения (Environment Variables).

В разделе Установить для сценариев CGI (Set for CGI Scripts) задаются переменные окружения, передаваемые в сценарии CGI и страницы SSI . Например, чтобы для переменной окружения MAXNUM значение 50, нажмите кнопку Добавить (Add) в разделе Установить для сценария CGI (Set for CGI Script), показанном в разделе 25-5 и введите MAXNUM в текстовом поле Переменная окружения (Environment Variable) и 50 в текстовом поле Устанавливаемое значение (Value to set). Нажмите OK, чтобы добавить её в список. В разделе Установить для сценариев CGI (Set for CGI Scripts) настраивается указание SetEnv.

В разделе Передать сценариям CGI (Pass to CGI Scripts) определяются значения переменных окружения, передаваемые в сценарий при первом запуске сервера. Чтобы просмотреть переменные окружения, выполните в приглашении оболочки команду env. Нажмите кнопку Добавить (Add) в разделе Передать сценариям CGI (Pass to CGI Scripts) и введите в появившемся диалоговом окне имя переменной окружения. Нажмите OK, чтобы добавить её в список. В разделе Передать сценариям CGI (Pass to CGI Scripts) настраивается указание PassEnv.

Рисунок 25-5. Переменные окружения

Чтоб удалить переменную окружения, чтобы её значение не было передано в сценарий CGI и страницу SSI, воспользуйтесь разделом Сбросить для сценариев CGI (Unset for CGI Scripts). Нажмите кнопку Добавить (Add) в разделе Сбросить для сценариев CGI (Unset for CGI Scripts) и введите имя переменной окружения, которая должна быть сброшена. Нажмите OK, чтобы добавить её в список. Этому соответствует указание UnsetEnv.

Чтобы отредактировать переменную окружения, выберите её из списка и нажмите кнопку Изменить (Edit). Чтобы удалить запись из списка, выберите её и нажмите кнопку Удалить (Delete).

Чтобы узнать о переменных окружения HTTP-сервера Apache больше, обратитесь по следующему адресу:

http://httpd.apache.org/docs-2.0/env.html

25.2.4. Каталоги

Страница Каталог (Directories) на вкладке Быстродействие (Performance) настраиваются параметры определённых каталогов. Этой странице соответствует указание <Directory>.

Рисунок 25-6. Каталоги

Нажмите кнопку Изменить (Edit) в правом верхнем углу, чтобы определить Опции каталога по умолчанию (Default Directory Options) для всех каталогов, не указанных в списке Каталог (Directory), расположенном ниже. Выбранные вами параметры будут отражены в указании Options, включённом в указание <Directory>. Вы можете настроить следующие параметры:

  • ExecCGI — Выполнение сценариев CGI разрешено. Сценарии CGI не будут выполняться, если этот параметр не установлен.

  • FollowSymLinks — Переход по символьным ссылкам разрешён.

  • Includes — Использование включений (include) на стороне сервере разрешено.

  • IncludesNOEXEC — Использование включений (Include) разрешено, но команды #exec и #include в сценариях CGI запрещены.

  • Indexes — Если файл DirectoryIndex (например, index.html) в запрашиваемом каталоге не найден, результатом запроса будет форматированный список содержимого каталога.

  • Multiview — Поддержка множества видов страницы, в зависимости от её содержимого; этот параметр по умолчанию выключен.

  • SymLinksIfOwnerMatch — Переходить по символическим ссылкам, только если файл или каталог назначения имеет того же владельца, что и сама ссылка.

Чтобы задать параметры для определённых каталогов, нажмите кнопку Добавить (Add) рядом со списком Каталог (Directory). На экране появится окно, показанное на рисунке 25-7. В текстовом поле Каталог (Directory), в нижней части окна, введите имя каталога, параметры которого будут настроены. Выберите параметры в расположенном справа списке и настройте указание Order (Порядок) с помощью флажков, расположенных слева. Указание Order задаёт порядок, в котором обрабатываются разрешающие и запрешающие правила. В текстовых полях Список разрешений из файла (Allow hosts from) и Список запрещений из файла (Deny hosts from) вы можете указать следующее:

  • Разрешить всем узлам — Введите all(все) для разрешения доступа всем узлам.

  • Частичное имя домена — Разрешить доступ узлам, чьи имена совпадают с указанной строкой, или заканчиваются ей.

  • Точный IP-адрес — Разрешить доступ определенному IP-адресу.

  • Подсеть — Например, в виде 192.168.1.0/255.255.255.0

  • Определение сети CIDR — Например, 10.3.0.0/16

Рисунок 25-7. Настройки каталога

Если вы выберете Файлы .htaccess будут переопределять опции каталога (Let .htaccess files override directory options), указания в файле .htaccess будут иметь более высокий приоритет.

Назад | Начало | Вперёд
Настройка HTTP-сервера Apache | Вверх | Параметры виртуальных узлов


Сохранение ваших настроек

Назад Глава 25. Настройка HTTP-сервера Apache Вперёд

25.6. Сохранение ваших настроек

Если вы не хотите сохранять свои настройки HTTP-сервера, нажмите кнопку Отмена (Cancel) в правом нижнем углу окна Настройка сервера HTTP (HTTP Configuration Tool). Программа попросит вас подтвердить это решение. Если вы нажмёте кнопку Да (Yes), подтверждая этот выбор, ваши настройки не будут сохранены.

Если же вы хотите сохранить свои настройки HTTP-сервера, нажмите кнопку OK в правом нижнем углу окна Настройка HTTP-сервера (HTTP Configuration Tool). На экране появится диалоговое окно. Если вы ответите Да (Yes), ваши настройки будут сохранены в файле /etc/httpd/conf/httpd.conf. Помните, что при этом ваш первоначальный файл конфигурации будет заменён новым, с вашими настройками.

Если вы использовали средство Настройка сервера HTTP впервые, появится диалоговое окно, предупреждающее вас о том, что файл конфигурации был изменён вручную. Если программа Настройка сервера HTTP определила, что файл конфигураии httpd.conf был изменён вручную, она сохранит его под именем /etc/httpd/conf/httpd.conf.bak.

Важно | Важно
 | Сохранив установки, вы должны перезапустить демон httpd, выполнив команду service httpd restart. Чтобы выполнить эту команду, вы должны зарегистрироваться в системе под именем root.
Назад | Начало | Вперёд
Настройка быстродействия | Вверх | Дополнительные ресурсы


Параметры сервера

Назад Глава 25. Настройка HTTP-сервера Apache Вперёд

25.4. Параметры сервера

На вкладке Сервер (Server) вы можете определить основные параметры сервера. В большинстве случаев подходят значения этих параметров по умолчанию.

Рисунок 25-10. Настройка сервера

Значение параметра Файл блокировок (Lock File) соответствует указанию LockFile. Это указание определяет полный путь к файлу блокировок, используемому, если сервер скомпилирован с ключом USE_FCNTL_SERIALIZED_ACCEPT или с USE_FLOCK_SERIALIZED_ACCEPT. Этот файл должен располагаться на локальном диске. Изменять его этот параметр не следует, за исключением случая, когда каталог logs размещён на общем ресурсе NFS. В этом случае, значение по умолчанию должно быть заменено именем каталога на локальном диске, доступного на чтение только пользователю root.

Значение параметра Файл PID (PID File) соответствует указанию PidFile. Этот параметр задаёт файл, в который сервер записывает свой PID (идентификатор процесса). Этот файл должен быть доступен на чтение только пользователю root. В большинстве случаев изменять этот параметр не следует.

Значение параметра Каталог файлов Core (Core Dump Directory) соответствует указанию CoreDumpDirectory. HTTP-сервер Apache пытается перейти в этот каталог, прежде чем сбросить дамп памяти. По умолчанию используется значение ServerRoot. Однако, если пользователь, от имени которого запущен сервер, не имеет права записывать в этот каталог, дамп памяти сохранён не будет. В качестве значения параметра определите имя каталога, в который пользователь, от имени которого работает сервер, сможет записывать данные, если вы хотите собирать дампы памяти для отладки.

Параметр Пользователь (User) соответствует указанию User. Он устанавливает идентификатор пользователя (userid), используемый сервером для ответа на запросы. При этом настройки этого пользователя определяют права доступа сервера. Любые файлы, недоступные данному пользователю, будут также недоступны посетителям вашего сайта. По умолчанию параметр User имеет значение «apache».

Этот пользователь должен иметь привилегии, позволяющие получить доступ к файлам, которые должны быть видны во внешнем мире. Этот пользователь также будет владельцем всех процессов CGI, порождённых сервером. Не следует разрешать этому пользователю выполнение кода, не предназначенного для ответа на HTTP-запросы.

Предупреждение | Предупреждение
 | Если вы не абсолютно уверены, в том, что делаете, не задавайте для указания User значение «root». Использование «root» в качестве значения указания User создаёт огромные дыры в защите вашего веб-сервера.

В обычной ситуации родительский процесс httpd сначала запускается от имени root, но затем управление немедленно передаётся пользователю apache. Сервер должен запускаться от имени root, чтобы иметь возможность использовать порты с номерами ниже 1024. Такие порты зарезервированы для системного использования, поэтому не могут быть использованы никем, кроме root. Как только сервер подключился к своему порту, он передаёт управление процессом пользователю apache, до того, как будет принят какой-либо запрос на соединение.

Значение параметра Group соответствует указанию Group. Указание Group подобно указанию User. Указание Group определяет группу, от имени которой сервер отвечает на запросы. Группой по умолчанию также является «apache».

Назад | Начало | Вперёд
Параметры виртуальных узлов | Вверх | Настройка быстродействия


Настройка быстродействия

Назад Глава 25. Настройка HTTP-сервера Apache Вперёд

25.5. Настройка быстродействия

Перейдите на вкладку Настройка быстродействия (Performance Tuning), чтобы определить требуемое максимальное количество дочерних процессов сервера, а также параметры HTTP-сервера Apache для соединений пользователей. В большинстве случаев подходят значения этих параметров по умолчанию. Изменение этих параметров может повлиять на производительность вашего веб-сервера в целом.

Рисунок 25-11. Настройка быстродействия

Параметр Максимальное количество соединений (Max Number of Connections) определяет максимальное количество одновременных запросов пользователей, которое сможет обрабатывать сервер. Для каждого соединения создается один дочерний процесс httpd. После достижения максимального количество процессов никто больше не сможет соединиться с веб-сервером до тех пор, пока какой-либо из дочерних процессов не освободится. Вы не можете присвоить этому параметру значение, большее 256, без перекомпиляции Apache. Этот параметр соответствует указанию MaxClients.

Параметр Максимальное время соединения (Connection Timeout) определяет время (в секундах), в течение которого ваш сервер будет ждать приёма или передачи информации во время соединения. Точнее, Максимальное время соединения определяет, сколько ваш сервер будет ждать получения запроса GET, сколько он будет ждать получения TCP-пакетов в ответ на запросы POST или PUT и сколько будет ждать между подтверждениями (ACK) TCP-пакетов. По умолчанию, значение параметра Максимальное время соединения равно 300 секундам, что подходит в большинстве случаев. Этот параметр соответствует указанию TimeOut.

Параметр Максимальное количество запросов на соединение (Max requests per connection) определяет максимальное количество запросов, разрешённых в течение постоянного соединения. Значение по умолчанию (100) подходит в большинстве случаев. Этот параметр соответствует указанию MaxRequestsPerChild.

Если вы установите флажок Разрешать неограниченное количество запросов на соединение (Allow unlimited requests per connection), указание MaxKeepAliveRequests становится равным 0 и допускается неограниченное число запросов.

Если вы снимите флажок Разрешить постоянные подключения (Allow Persistent Connections), указание KeepAlive примет значение «false». Если же вы его установите, параметр KeepAlive примет значение «true», а указанию KeepAliveTimeout будет присвоено число, выбранное в поле Таймаут до следующего подключения (Timeout for next Connection). Это указание определяет время (в секундах), в течение которого сервер сохраняет соединение, ожидая последующего запроса после обработки текущего, и по истечении которого соединение будет закрыто. Как только очередной запрос получен, снова применяется значение Максимаольное время соединения (Connection Timeout).

Определение большого значения параметра Постоянные подключения (Persistent Connections) может замедлить работу сервера, в зависимости от количества пользователей, пытающихся к нему подключиться. Чем больше это значение, тем больше процессов будут ждать очередного запроса последнего подключенного клиента.

Назад | Начало | Вперёд
Параметры сервера | Вверх | Сохранение ваших настроек


Параметры виртуальных узлов

Назад Глава 25. Настройка HTTP-сервера Apache Вперёд

25.3. Параметры виртуальных узлов

Виртуальные узлы позволяют вам реализовывать разные серверы для разных IP-адресов, имен узлов или портов на одном и том же компьютере. Например, используя виртуальные узлы вы можете запустить сайты http://www.example.com и http://www.anotherexample.com на одном веб-сервере. Этот параметр соответствует указанию <VirtualHost> для виртуального узла по умолчанию и узлов, определяемых по IP-адресу. Он также соответствует указанию <NameVirtualHost> для виртуальных узлов, определяемых по доменному имени.

Указания, определённые для конкретного виртуального узла, относятся только к нему одному. Если указание определено для всего сервера с помощью кнопки Изменить параметры по умолчанию (Edit Default Settings) и не определено в настройках виртуального узла, в результате будет использован параметр по умолчанию. Например, вы можете определить значение параметра Электронный адрес вебмастера (Webmaster email address) на вкладке Основные (Main) и не задавать его отдельно для каждого виртуального узла.

Средство Настройка сервера HTTP (HTTP Configuration Tool) содержит виртуальный узел по умолчанию, как показано на рисунке 25-8.

Рисунок 25-8. Виртуальные узлы

Дополнительные сведения о виртуальных узлах представлены в документации к HTTP-серверу Apache и по адресу http://httpd.apache.org/docs-2.0/vhosts/.

25.3.1. Добавление и редактирование виртуальных узлов

Чтобы добавить виртуальный узел, перейдите на вкладку Виртуальные узлы (Virtual Hosts) и нажмите кнопку Добавить (Add). Вы также можете отредактировать виртуальный узел, выбрав его в списке и нажав кнопку Изменить (Edit).

25.3.1.1. Общие параметры

Настройки на вкладке Общие параметры (General Options) применяются только к виртуальному узлу, который вы настраиваете. Определите имя виртуального узла в текстовой области Название виртуального узла (Virtual Host Name). Это имя используется средством Настройка сервера HTTP для различения виртуальных узлов.

В поле Корневой каталог (Document Root Directory) задаётся имя каталога, содержащего корневой документ (например, index.html) виртуального узла. Этот параметр соответствует указанию DocumentRoot, размещённому внутри указания <VirtualHost>. По умолчанию DocumentRoot имеет значение /var/www/html.

Параметр Электронный адрес вебмастера (Webmaster email address) соответствует указанию ServerAdmin, помещённому внутрь директивы VirtualHost. Этот электронный адрес будет отображаться в нижнем колонтитуле страниц об ошибках, если вы решите отображать этот колонтитул с электронным адресом.

В разделе Информация об узле (Host Information) определите Виртуальный сервер по умолчанию (Default Virtual Host), Виртуальный узел с постоянным IP-адресом (IP based Virtual Host) или Виртуальный сервер с постоянным именем (Name based Virtual Host).

Виртуальный сервер по умолчанию

Вам следует настраивать только один виртуальный сервер по умолчанию (помните, что по умолчанию один настроен). Параметры виртуального узла по умолчанию используются, если запрашиваемый IP-адрес не относится к другому виртуальному узлу. Если виртуальный узел по умолчанию не определён, используются основные параметры сервера.

Виртуальный узел с постоянным IP-адресом

Если вы выберете вариант Виртуальный узел с постоянным IP-адресом (IP based Virtual Host), на экране появится окно для настройки указания <VirtualHost>, привязанного к IP-адресу сервера. Укажите этот адрес в поле IP-адрес (IP address). Чтобы указать несколько IP-адресов, разделите их пробелами. Указать порт можно, используя запись IP-адрес:порт. Используйте сочетание «двоеточие, звёздочка» (:*), чтобы задать для данного IP-адреса все порты. Введите имя сервера для виртуального узла в поле Название сервера узла (Server Host Name).

Виртуальный узел с постоянным именем

Если вы выберете вариант Виртуальный узел с постоянным именем (Name based Virtual Host), на экране появится окно для настройки указания NameVirtualHost, привязанного к имени узла сервера. Укажите адрес в поле IP-адрес (IP address). Чтобы указать несколько IP-адресов, разделите их пробелами. Указать порт можно, используя запись IP-адрес:порт. Используйте сочетание «двоеточие, звёздочка» (:*), чтобы задать для данного IP-адреса все порты. Введите имя сервера для виртуального узла в поле Название сервера узла (Server Host Name). В разделе Псевдонимы (Aliases) нажмите Добавить (Add), чтобы добавить псевдоним имени узла. Добавление здесь псевдонима приводит к добавлению указания ServerAlias внутрь указания NameVirtualHost.

25.3.1.2. SSL

Замечание | Замечание
 | Вы не сможете использовать виртуальные узлы, определяемые по имени, с SSL, так как SSL-согласование (когда обозреватель принимает защищенный сертификат веб-сервера) происходит до получения HTTP-запроса, определяющего имя соответствующего виртуального узла. Если вы планируете использовать виртуальные узлы, определяемые по имени, они будут работать только с не защищённым веб-сервером.

Рисунок 25-9. Поддержка SSL

Если в вашем HTTP-сервере Apache не настроена поддержка SSL, соединения между ним и его клиентами шифроваться не будут. Это подходит для сайтов, не содержащих личной или конфиденциальной информации. Например, сайт, распространяющий открытые исходные тексты программного обеспечения и документацию, очевидно, не нуждается в защите соединений. Напротив, коммерческие сайты, получающие информацию о кредитных картах, должны использовать поддержку SSL в Apache, чтобы шифровать соединения. Включение поддержки SSL в Apache означает, что будет использоваться модуль безопасности mod_ssl. Чтобы включить его в средстве Настройка сервера HTTP, вы должны разрешить доступ к порту 443 на вкладке Основные (Main) => Доступные адреса (Available Addresses). За подробностями обратитесь к разделу 25.1 Основные параметры. Затем, на вкладке Виртуальные узлы (Virtual Hosts) выделите имя виртуального узла, нажмите кнопку Изменить (Edit), выберите в расположенном слева меню SSL, а затем установите флажок Включить поддержку SSL (Enable SSL Support), как показано на рисунке 25-9. В разделе Конфигурация SSL (SSL Configuration) отображаются настройки с фиктивным цифровым сертификатом. Цифровой сертификат подтверждает подлинность вашего защищенного веб-сервера и идентифицирует сервер для браузеров клиентов. Вы должны приобрести свой собственный цифровой сертификат. Не используйте для своего сайта этот фиктивный сертификат. Информацию о приобретении CA цифрового сертификата вы можете найти в главе 26 Настройка безопасного HTTP-сервера Apache.

25.3.1.3. Дополнительные параметры виртуальных узлов

Параметры Конфигурация сайта (Site Configuration), Переменные окружения (Environment Variables) и Каталоги (Directories ) для виртуальных узлов аналогичны параметрам, которые вы задавали, нажимая кнопку Изменить параметры по умолчанию (Edit Default Settings), за исключением того, что текущие параметры определяются только для отдельных виртуальных узлов. Подробное описание этих параметров приведено в разделе 25.2 Параметры по умолчанию.

Назад | Начало | Вперёд
Параметры по умолчанию | Вверх | Параметры сервера


Соглашения, принятые в документе

Назад Введение Вперёд

3. Соглашения, принятые в документе

В данном руководстве вы встретите определённые слова, выделенные в тексте различными шрифтами, стилями, размерами. Такое оформление не случайно; разные слова отображаются одним стилем, когда они принадлежат определённой категории. Примеры слов, оформленных таким образом, приведены ниже:

команда

Так выглядят команды Linux (и, может быть, команды других операционных систем). Это оформление показывает, что вы должны ввести данное слово или фразу в командной строке и нажать [Enter] для выполнения команды. Иногда в команде присутствуют слова, оформленные стилем, отличным от принятого для них (например, имена файлов). В этих случаях они являются частью команды, и поэтому вся фраза оформляется этим стилем. Например:

Используйте команду cat testfile для просмотра содержимого файла с именем testfile, находящегося в текущем рабочем каталоге.

имя файла

Таким стилем оформлены имена файлов, названия каталогов, пути, названия RPM пакетов. Это оформление означает, что в вашей системе существует конкретный файл или каталог с таким именем. Примеры:

Файл .bashrc в вашем домашнем каталоге содержит используемые вами определения и псевдонимы оболочки bash.

Файл /etc/fstab содержит информацию о различных устройствах системы и файловых системах.

Установите RPM-пакет webalizer, если вы хотите использовать программу анализа журнала Web-сервера.

приложение

Такое оформление означает, что указанная программа — приложение конечного пользователя (в противоположность системному программному обеспечению). Например:

Используйте Mozilla для просмотра Web-содержимого.

[клавиша]

Таким стилем обозначаются клавиши на клавиатуре. Например:

Для автозавершения с помощью [Tab], введите начальные символы, затем нажмите клавишу [Tab]. На вашем экране отображается список файлов в каталоге, начинающихся с этих символов.

[комбинация]-[клавиш]

Таким стилем оформляются сочетания клавиш. Например:

Сочетание клавиш [Ctrl]-[Alt]-[Backspace] завершает ваш сеанс в графическом режиме и возвращает вас к графическому экрану входа или на консоль.

текст, отображаемый в графическом интерфейсе

Заголовок, слово, или фраза, выводимые в графическом экране или окне оформляются таким стилем. Текст с таким оформлением обозначает конкретный графический экран или элемент на графическом экране (например, текст, связанный с флажком или полем ввода). Пример:

Установите флажок Запрашивать пароль, если вы хотите, чтобы для отключения хранителя экрана требовался пароль.

верхний уровень меню в графическом экране или окне

Таким стилем оформляется слово, находящееся на верхнем уровне выпадающего меню. Если вы щёлкните это слово, на экране появится всё выпадающее меню. Например:

В меню Файл терминала GNOME пункт Создать вкладку позволяет вам открывать в одном окне несколько оболочек.

Указания ввести последовательность команд с помощью графического меню выглядят следующим образом:

Выберите в главном меню Приложения (Applications) (на панели) => Разработка (Programming) => Текстовый редактор Emacs (Emacs Text Editor) для запуска редактора Emacs.

кнопка в графическом экране или окне

Этим стилем оформляется название кнопки на графическом экране. Например:

Нажмите кнопку Назад для возврата к предыдущей Web-странице.

ответ компьютера

Этим стилем оформляется текст, выводимый в командной оболочке, в частности, сообщения об ошибках и результаты выполнения команд. Например:

Команда ls выводит на экран содержимое каталога. Например:

Desktop                about.html       logs          paulwesterberg.png
Mail                   backupfiles      mail          reports

Текст, выводимый на экран в ответ на команду (в данном случае — содержимое каталога), оформлен этим стилем.

приглашение

Таким стилем оформляется приглашение, указывающее, что компьютер ждёт от вас ввода каких-то команд или данных. Примеры:

$

#

[stephen@maturin stephen]$

leopard login:

ввод пользователя

Таким стилем оформляется текст, который пользователь вводит в командной строке или в поле ввода на графическом экране. В следующем примере так оформлено слово text:

Для загрузки вашей системы с программой установки в текстовом режиме, введите команду text в ответ на приглашение boot:.

<заменяемый>

Текст, используемый в примерах и выделенный этим стилем, должен быть заменён данными пользователя. В следующем примере, этим стилем оформлен текст <version-number>:

Исходный код ядра находится в каталоге /usr/src/kernels/<version-number>/, где <version-number> — версия и тип ядра, установленного в системе.

Кроме этого, для привлечения вашего внимания к определенной информации применяются различные приёмы. Эти элементы (перечисленные ниже по степени важности) помечаются как «замечание», «подсказка», «важно», «внимание» или «предупреждение». Например:

Замечание | Замечание
 | Помните, Linux чувствителен к регистру символов. Другими словами — роза это не РОЗА и не рОзА.

Подсказка | Подсказка
 | В каталоге /usr/share/doc содержится дополнительная документация пакетов, установленных в вашей системе.

Важно | Важно
 | Если вы измените файл настроек службы DHCP, изменения не вступят в силу до перезапуска DHCP демона.

Внимание | Внимание
 | Не выполняйте повседневные задачи от имени root — используйте учётную запись обычного пользователя, кроме тех случаев, когда для выполнения административных задач требуются права root.

Предупреждение | Предупреждение
 | Будьте осторожны, чтобы удалить только требуемые разделы. Удаление других разделов может привести к потере данных или выходу системы из строя.
Назад | Начало | Вперёд
Информация, связанная с особенностями архитектуры | Вверх | Активизация подписки


Копирование и вставка текста в среде X

Назад Введение Вперёд

6. Копирование и вставка текста в среде X

Копировать и вставлять текст с помощью мыши в системе X Window очень легко. Чтобы скопировать текст, щёлкните и обведите мышью текст, тем самым выделив его. Чтобы вставить текст, щёлкните среднюю кнопку мыши там, куда вы намерены его поместить.

Назад | Начало | Вперёд
Использование мыши | Вверх | Будущие изменения


Будущие изменения

Назад Введение Вперёд

7. Будущие изменения

Руководство по системному администрированию Red Hat Enterprise Linux выпускается согласно обязательствам Red Hat по обеспечению полезной и быстрой поддержки пользователей Red Hat Enterprise Linux. По мере выпуска новых инструментов и приложений это руководство будет расширено с тем, чтобы также включить информацию о них.

7.1. Нам нужны ваши отзывы!

Если вам попадётся ошибка в Руководстве по системнму администрированию Red Hat Enterprise Linux, или вы знаете, как сделать это руководство лучше, мы бы хотели узнать об этом! Пожалуйста, направляйте свои замечания в Bugzilla http://bugzilla.redhat.com/bugzilla/) относительно компонента rhel-sag.

Не забудьте упомянуть код этого руководства:

rhel-sag(EN)-4-HTML-RHI (2005-06-06T17:10U1)

Так мы сможем узнать, какой версией руководства вы пользуетесь.

Если у вас есть предложение по улучшению документации, попытайтесь описать его как можно более детально. Если вы обнаружили ошибку, пожалуйста, укажите номер раздела и часть окружающего текста, чтобы мы смогли быстрее её найти.

Назад | Начало | Вперёд
Копирование и вставка текста в среде X | Вверх | Вопросы, касающиеся установки


Использование мыши

Назад Введение Вперёд

5. Использование мыши

Система Red Hat Enterprise Linux рассчитана на использование трёхкнопочной мыши. Если у вас мышь с двумя кнопками, во время установки вам следует выбрать эмуляцию трёхкнопочной мыши. Если вы включите эмуляцию трёхкнопочной мыши, одновременное нажатие двух кнопок мыши будет эквивалентно нажатию третьей(средней) кнопки.

Если вы встречаете в этом документе указание щёлкнуть мышью что-то, это означает, что вы должны нажать левую кнопку мыши. Если вам нужно будет нажать среднюю или правую кнопку, это будет указано явно. (Это утверждение поменяется на противоположное, если вы настроите мышь для левши.)

Фраза «потянуть и отпустить» должно быть уже знакома вам. Если вы встречаете указание потянуть и отпустить объект на вашем рабочем столе, щёлкните его и не отпускайте кнопку мыши. Удерживая кнопку мыши, перетяните объект (передвинув мышь) в новое расположение. Достигнув заданного расположения, отпустите кнопку мыши, чтобы освободить объект.

Назад | Начало | Вперёд
Активизация подписки | Вверх | Копирование и вставка текста в среде X


Проверка загрузчика

Назад Глава 37. Обновление ядра вручную Вперёд

37.6. Проверка загрузчика

RPM-пакет kernel настраивает загрузчик для загрузки устанавливаемого ядра (за исключением IBM eServer iSeries). Однако, ядро, выбранное в загрузчике по умолчанию, не меняется.

Никогда не помешает проверить, правильно ли настроен загрузчик. Это очень важно. Если загрузчик настроен неправильно, компьютер не сможет загрузить Red Hat Enterprise Linux. Если это всё же произойдёт, загрузите компьютер с загрузочного носителя, созданного ранее и попробуйте настроить загрузчик ещё раз.

37.6.1. Компьютеры x86

Во всех компьютерах x86, включая и AMD64, в качестве загрузчика используется GRUB.

37.6.1.1. GRUB

Проверьте, содержится ли в файле /boot/grub/grub.conf раздел title с той же версией, что и версия только что установленного пакета kernel (или пакета kernel-smp или kernel-hugemem):

# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/hda2
#          initrd /initrd-version.img
#boot=/dev/hda
default=1
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Enterprise Linux (2.6.9-5.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-5.EL ro root=LABEL=/
        initrd /initrd-2.6.9-5.EL.img
title Red Hat Enterprise Linux (2.6.9-1.906_EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-1.906_EL ro root=LABEL=/
        initrd /initrd-2.6.9-1.906_EL.img

Если вы создавали отдельный раздел /boot, пути к ядру и образу initrd указываются относительно /boot.

Заметьте, что новое ядро не назначается ядром по умолчанию. Чтобы настроить в GRUB загрузку нового ядра по умолчанию, укажите в переменной default номер раздела, описывающего новое ядро. Нумерация начинается с 0. Например, если новое ядро описывается в первом разделе, назначьте переменной default значение 0.

Начните проверку нового ядра, перезагрузив компьютер и просмотрев выводимые сообщения, чтобы убедиться в том, что оборудование определено правильно.

37.6.2. Компьютеры Itanium

На компьютерах в качестве загрузчика применяется ELILO, который использует файл конфигурации /boot/efi/EFI/redhat/elilo.conf. Убедитесь в том, что этот файл содержит раздел image с версией только что установленного пакета kernel:

prompt
timeout=50
default=old

image=vmlinuz-2.6.9-5.EL
        label=linux
        initrd=initrd-2.6.9-5.EL.img
        read-only
        append="root=LABEL=/"
image=vmlinuz-2.6.9-1.906_EL
        label=old
        initrd=initrd-2.6.9-1.906.img
        read-only
        append="root=LABEL=/"

Заметьте, что новое ядро не назначается ядром по умолчанию. Чтобы ELILO загружал по умолчанию новое ядро, назначьте переменной default значение метки label раздела image, описывающего новое ядро.

Начните проверку нового ядра, перезагрузив компьютер и просмотрев выводимые сообщения, чтобы убедиться в том, что оборудование определено правильно.

37.6.3. Компьютеры IBM S/390 и IBM eServer zSeries

На компьютерах IBM S/390 и IBM eServer zSeries в качестве загрузчика применяетя z/IPL, использующий файл конфигурации /etc/zipl.conf. Убедитесь в том, что этот файл содержит раздел с версией только что установленного пакета ядра:

[defaultboot]
default=old
target=/boot/
[linux]
        image=/boot/vmlinuz-2.6.9-5.EL
        ramdisk=/boot/initrd-2.6.9-5.EL.img
        parameters="root=LABEL=/"
[old]
        image=/boot/vmlinuz-2.6.9-1.906_EL
        ramdisk=/boot/initrd-2.6.9-1.906_EL.img
        parameters="root=LABEL=/"

Заметьте, что новое ядро не назначается ядром по умолчанию. Чтобы настроить в z/IPL загрузку нового ядра по умолчанию, укажите в переменной default имя раздела, описывающего новое ядро. Имя раздела указывает в первой строке раздела и заключается в скобки.

Изменив файл конфигурации, запустите от имени root следующую команду, чтобы применить изменения:

/sbin/zipl

Начните проверку нового ядра, перезагрузив компьютер и просмотрев выводимые сообщения, чтобы убедиться в том, что оборудование определено правильно.

37.6.4. Компьютеры IBM eServer iSeries

Когда вы обновляете ядро, устанавливается файл /boot/vmlinitrd-<kernel-version>. Однако, вы должны воспользоваться командой dd, чтобы компьютер загружал новое ядро:

  1. От имени root выполните команду cat /proc/iSeries/mf/side, чтобы определить сторону по умолчанию (A, B или C).

  2. Также от имени root выполните ещё одну команду, <kernel-version> обозначает версию нового ядра, а <side> — сторону, показанную предыдущей командой:

    dd if=/boot/vmlinitrd-<kernel-version> of=/proc/iSeries/mf/<side>/vmlinux bs=8k

Начните проверку нового ядра, перезагрузив компьютер и просмотрев выводимые сообщения, чтобы убедиться в том, что оборудование определено правильно.

37.6.5. Компьютеры IBM eServer pSeries

На компьютерах IBM eServer pSeries systems в качестве загрузчика применяется YABOOT, который использует файл конфигурации /etc/aboot.conf. Убедитесь в том, что этот файл содержит раздел image с версией только что установленного пакета kernel:

boot=/dev/sda1
init-message=Welcome to Red Hat Enterprise Linux!
Hit <TAB> for boot options

partition=2
timeout=30
install=/usr/lib/yaboot/yaboot
delay=10
nonvram

image=/vmlinux--2.6.9-5.EL
        label=old
        read-only
        initrd=/initrd--2.6.9-5.EL.img
        append="root=LABEL=/"

image=/vmlinux-2.6.9-5.EL
        label=linux
        read-only
        initrd=/initrd-2.6.9-5.EL.img
        append="root=LABEL=/"

Заметьте, что новое ядро не назначается ядром по умолчанию. По умолчанию загружается ядро, описанное в первом разделе image. Чтобы сменить ядро по умолчанию, либо переместите соответствующую строфу image, чтобы она была первой, или добавьте параметр default, в котором укажите метку label строфы image, описывающей новое ядро.

Начните проверку нового ядра, перезагрузив компьютер и просмотрев выводимые сообщения, чтобы убедиться в том, что оборудование определено правильно.

Назад | Начало | Вперёд
Проверка образа начального RAM-диска | Вверх | Модули ядра


Загрузка обновлённого ядра

Назад Глава 37. Обновление ядра вручную Вперёд

37.3. Загрузка обновлённого ядра

Определить, есть ли для вашей системы обновлённое ядро, можно несколькими способами.

  • Security Errata (Ошибки, связанные с безопасностью) — За информацией об ошибках, связанныех с безопасностью, а также об обновления ядра, в которых исправлены эти ошибки обратитесь по следующему адресу:

    http://www.redhat.com/apps/support/errata/

  • Получая ежеквартальные обновления — За подробностями обратитесь к следующей странице:

    http://www.redhat.com/apps/support/errata/rhlas_errata_policy.html

  • Через сеть Red Hat Network — Загрузите и установите RPM-пакеты ядра. С помощью Red Hat Network можно загрузить последнее ядро, обновить ядро, если необходимо, создать образ начального RAM-диска, и настроить загрузчик для загрузки нового ядра. За дополнительной информацией обратитесь к http://www.redhat.com/docs/manuals/RHNetwork/.

Если вы использовали Red Hat Network для загрузки и установки обовлённого ядра, следуйте указаниям, приведённым в разделе 37.5 Проверка образа начального RAM-диска и разделе 37.6 Проверка загрузчика, только не меняйте ядро, загружаемое по умолчанию. Red Hat Network автоматически делает ядром по умолчанию ядро последней верии. Чтобы установить ядро вручную, перейдите к разделу 37.4 Выполнение обновления.

Назад | Начало | Вперёд
Подготовка к обновлению | Вверх | Выполнение обновления


Проверка образа начального RAM-диска

Назад Глава 37. Обновление ядра вручную Вперёд

37.5. Проверка образа начального RAM-диска

Если в вашем компьютере используется файловая система ext3, SCSI-контроллер или для ссылки на разделы в /etc/fstab используются метки, вам понадобится начальный RAM-диск. Начальный RAM диск позволяет модульному ядру получить доступ к модулям, которые могут понадобиться для загрузки, до того, как ядро получит доступ к устройству, где эти модули обычно располагаются.

В архитектурах, поддерживаемых Red Hat Enterprise Linux, за исключением IBM eServer iSeries, начальный RAM-диск можно сделать с помощью команды mkinitrd. Однако это действие выполняется автоматически, если ядро и связанные пакеты устанавливаются или обновляются посредством RPM-пакетов, распространяемых компанией Red Hat, Inc.; таким образом, делать это вручную не требуется. Чтобы проверить, был ли он создан, выполните команду ls -l /boot и убедитесь в том, что файл initrd-<version>.img находится на диске (его версия должна соответствовать версии только что установленного ядра).

На компьютерах iSeries файл начального RAM-диска и файл vmlinux собраны в одном файле, который создаётся командой addRamDisk. Это также выполняется автоматически, если ядро и связанные пакеты устанавливаются или обновляются посредством RPM-пакетов, распространяемых компанией Red Hat, Inc.; таким образом, делать это вручную не требуется. Чтобы проверить, был ли он создан, выполните команду ls -l /boot и убедитесь в том, что файл /boot/vmlinitrd-<kernel-version> находится на диске (его версия должна соответствовать версии только что установленного ядра).

После этого следует проверить, был ли настроен загрузчик для загрузки нового ядра. За подробными инструкциями обратитесь к разделу 37.6 Проверка загрузчика.

Назад | Начало | Вперёд
Выполнение обновления | Вверх | Проверка загрузчика


Дополнительные ресурсы

Назад Глава 38. Модули ядра Вперёд

38.3. Дополнительные ресурсы

За дополнительной информацией о модулях ядра и управлении ими, обратитесь к следующим ресурсам.

38.3.1. Установленная документация

  • Страница man lsmod — Описание команды и объяснение выводимой её информации.

  • Страница man insmod — Описание команды и список параметров командной строки.

  • Страница man modprobe — Описание команды и список параметров командной строки.

  • Страница man rmmod — Описание и список параметров командной строки.

  • Страница man modinfo — Описание и список параметров командной строки.

  • /usr/share/doc/kernel-doc-<version>/Documentation/kbuild/modules.txt — Инструкции по компиляции и использованию модулей ядра.

38.3.2. Полезные сайты

  • http://www.redhat.com/mirrors/LDP/HOWTO/Module-HOWTO/index.html — Linux Loadable Kernel Module HOWTO (Инструкции по загружаемым модулям ядра Linux) из проекта документации Linux.

Назад | Начало | Вперёд
Статическая загрузка модулей | Вверх | Настройка агента доставки почты (MTA)


Статическая загрузка модулей

Назад Глава 38. Модули ядра Вперёд

38.2. Статическая загрузка модулей

Модули ядра обычно загружается средством, запрашивающим их, с учётом правильности настроек в файле /etc/modprobe.conf. Однако иногда необходимо явно загружать модуль во время загрузки.

Red Hat Enterprise Linux во время загрузки проверяет существование файла /etc/rc.modules, содержащего различные команды для загрузки модулей. Указывать требуемые модули следует в файле rc.modules, а не в rc.local, так как rc.modules обрабатывается на ранней стадии загрузки.

Наример, выполнив следующие команды (от имени root), вы настроите загрузку модуля foo при загрузке системы:

# echo modprobe foo >> /etc/rc.modules
# chmod +x /etc/rc.modules

Подсказка | Подсказка
 | Этот подход не требуется для модулей сетевых и SCSI-интерфейсов, так как для них разработаны собственные специфические механизмы.
Назад | Начало | Вперёд
Модули ядра | Вверх | Дополнительные ресурсы


Выполнение обновления

Назад Глава 37. Обновление ядра вручную Вперёд

37.4. Выполнение обновления

Когда вы получите все необходимые пакеты, можно приступать к обновлению существующего ядра. В приглашении оболочки, запущенной от имени root, перейдите в каталог, содержащий RPM-пакеты ядра, и выполните следующие действия.

Важно | Важно
 | Настоятельно рекомендуется сохранить старое ядро на случай, если с новым возникнут проблемы.

Чтобы сохранить старое ядро, используйте аргумент -i команды rpm. Не используйте параметр -U, так как при этом будет переписано текущее установленное ядро, что создаст проблемы с загрузчиком. Выполните следующую команду (версия ядра может быть другой):

rpm -ivh kernel-2.6.9-5.EL.<arch>.rpm

Если ваш компьютер многопроцессорный, установите также пакеты kernel-smp (версия ядра может быть другой):

rpm -ivh kernel-smp-2.6.9-5.EL.<arch>.rpm

Для компьютера архитектуры i686 и объёмом ОЗУ больше 4 ГБайт, также установите пакет kernel-hugemem, предназначенный для архитектуры i686 (версия ядра может быть другой):

rpm -ivh kernel-hugemem-2.6.9-5.EL.i686.rpm

Теперь вы должны проверить, создался ли образ начального RAM-диска. За подробностями обратитесь к разделу 37.5 Проверка образа начального RAM-диска.

Назад | Начало | Вперёд
Загрузка обновлённого ядра | Вверх | Проверка образа начального RAM-диска


Подготовка к обновлению

Назад Глава 37. Обновление ядра вручную Вперёд

37.2. Подготовка к обновлению

Прежде чем обновлять ядро, выполните несколько действий, чтобы подстраховать себя. Прежде всего убедитесь в том, что у вас есть рабочий загрузочный носитель на случай возникновения проблемы. Если загрузчик не будет настроен правильно для загрузки нового ядра, компьютер не сможет загрузить Red Hat Enterprise Linux без рабочего загрузочного носителя.

Чтобы сделать, например, загрузочную дискету, войдите в систему под именем root и введите в приглашении оболочки следующую команду:

/sbin/mkbootdisk `uname -r`

Подсказка | Подсказка
 | Дополнительные параметры можно найти на странице man mkbootdisk. Также поддерживается использование для загрузочных носителей дисков CD-R, CD-RW и USB-накопителей, если это поддерживает BIOS компьютера.

Прежде чем продолжить, загрузите компьютер с этого загрузочного носителя, чтобы убедиться в его исправности.

Хотя можно надеяться, что этот носитель не потребуется, лучше сохранить его в безопасном месте на всякий случай.

Для того, чтобы определить установленные пакеты ядра, выполните в приглашении оболочки следующую команду:

rpm -qa | grep kernel

В результате вы увидите названия некоторых или всех следующих пакетов, в зависимости от архитектуры компьютера (номера версий и названия пакетов могут отличаться):

kernel-2.6.9-5.EL
kernel-devel-2.6.9-5.EL
kernel-utils-2.6.9-5.EL
kernel-doc-2.6.9-5.EL
kernel-smp-2.6.9-5.EL
kernel-smp-devel-2.6.9-5.EL
kernel-hugemem-devel-2.6.9-5.EL

Проанализировав этот список, определите, какие пакеты потребуется загрузить для обновления ядра. Для однопроцессорного компьютера требуется только пакет kernel. За описанием различных пакетов обратитесь к разделу 37.1 Обзор пакетов ядра.

Все пакеты ядра содержат в имени файла указание архитектуры, для которой предназначен пакет. Имя пакета имеет вид kernel-<variant>-<version>.<arch>.rpm, где <variant> — это может быть smp, utils и т.д. А <arch> обозначает архитектуру следующим образом:

  • x86_64 — архитектура AMD64

  • ia64 — архитектура Intel® Itanium™

  • ppc64 — архитектура IBM® eServer™ pSeries™

  • ppc64 — архитектура IBM® eServer™ iSeries™

  • s390 — архитектура IBM® S/390®

  • s390x — архитектура IBM® eServer™ zSeries®

  • Разновидности x86: ядра x86 оптимизированы для различных версий x86, в частности:

    • i686 — компьютеры с процессором Intel® Pentium® II, Intel® Pentium® III, Intel® Pentium® 4, AMD Athlon® и AMD Duron®

Назад | Начало | Вперёд
Обновление ядра вручную | Вверх | Загрузка обновлённого ядра


Создание файла Kickstart

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.3. Создание файла Kickstart

Файл kickstart представляет собой простой текстовый файл, содержащий список элементов, каждый из которых определяется ключевым словом. Вы можете создать его, отредактировав копию файла sample.ks, расположенного в каталоге RH-DOCS компакт-диска с документацией Red Hat Enterprise Linux, воспользовавшись приложением Настройка Kickstart (Kickstart Configurator), или написав его самостоятельно. Программа установки Red Hat Enterprise Linux также создаёт образец файла kickstart, исходя из параметров, использованных вами при установке. Этот файл имеет название /root/anaconda-ks.cfg. Вам потребуется отредактировать его в каком-либо текстовом редакторе, способном сохранять файлы в формате ASCII.

Прежде всего, учтите следующие замечания при создании своего файла kickstart:

  • Разделы должны указываться по порядку. Элементы внутри разделов не обязательно должны идти в каком-то порядке, если не указано обратное. Порядок разделов следующий:

    • Раздел команд — За списком параметров kickstart обратитесь к разделу 1.4 Параметры Kickstart. Обязательные параметры должны быть определены.

    • Раздел %packages — За подробностями обратитесь к разделу 1.5 Выбор пакетов.

    • Разделы %pre и %post — Эти два раздела могут следовать в любом порядке и обязательными не являются. За подробностями обратитесь к разделу 1.6 Сценарий, выполняемый до установки и разделу 1.7 Сценарий, выполняемый после установки.

  • Элементы, не отмеченные как обязательные, могут быть опущены.

  • Если обязательный параметр не будет определён, программа установки запросит ввод соответствующего параметра у пользователя, также как и во время обычной установки. Сразу после получения ответа установка продолжается без вмешательства пользователя (если снова не столкнётся с отсутствующим параметром).

  • Строки, начинающиеся с символа «#», воспринимаются как комментарии и не обрабатываются.

  • Для обновлений системы с помощью kickstart обязательными являются следующие параметры:

    • Язык

    • Языковая поддержка

    • Способ установки

    • Определение устройств (если устройство необходимо для выполнения установки)

    • Настройка клавиатуры

    • Ключевое слово upgrade

    • Настройка загрузчика

    Если при обновлении указываются какие-либо другие параметры, такие параметры игнорируются (обратите внимание, это также касается выбора пакетов).

Назад | Начало | Вперёд
Как выполнить Kickstart-установку? | Вверх | Параметры Kickstart


Как выполнить Kickstart-установку?

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.2. Как выполнить Kickstart-установку?

Kickstart-установку можно выполнить с помощью локального CD-ROM, локального жёсткого диска или используя NFS, FTP, HTTP.

Чтобы воспользоваться технологией kickstart, вы должны:

  1. Создать файл kickstart.

  2. Сделать загрузочный носитель и записать на него файл kickstart или обеспечить доступ к файлу kickstart по сети.

  3. Предоставить доступ к дереву каталогов установки.

  4. Запустить kickstart-установку.

Далее в этой главе перечисленные действия рассматриваются подробно.

Назад | Начало | Вперёд
Установка при помощи Kickstart | Вверх | Создание файла Kickstart


Обеспечение доступности дерева каталогов установки

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.9. Обеспечение доступности дерева каталогов установки

Установка kickstart должна иметь доступа к дереву каталогов установки. Дерево каталогов установки — это копия двоичных компакт-дисков Red Hat Enterprise Linux с тоже структурой каталогов.

Если вы выполняете установку с компакт-диска, прежде чем запускать установку kickstart, вставьте в компьютер CD-ROM Red Hat Enterprise Linux №1.

Если вы выполняете установку с жёсткого диска, разместите ISO-образы двоичных компакт-дисков Red Hat Enterprise Linux CD-ROM на жёстком диске компьютера.

Если вы выполняете установку по сети (NFS, FTP или HTTP), вы должны открыть доступ к дереву установки по сети. За подробностями обратитесь к разделу Подготовка к сетевой установке Руководства по установке Red Hat Enterprise Linux.

Назад | Начало | Вперёд
Обеспечение доступности файла Kickstart | Вверх | Начало установки при помощи Kickstart


Параметры Kickstart

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.4. Параметры Kickstart

В файл kickstart могут быть помещены следующие параметры. Если вы желаете создать файл kickstart в графическом интерфейсе, воспользуйтес программой Настройка Kickstart (Kickstart Configurator). За подробностями обратитесь к главе 2 Настройка Kickstart.

Замечание | Замечание
 | Если за параметром указан знак «равно» (=), после него должно быть указано значение. В приведённых примерах команд параметры, указанные в скобках ([]) являются необязательными аргументами.

autopart (необязательный)

Включает автоматическое создание разделов — корневой раздел (/) размером 1 Гбайт или более, раздел подкачки и загрузочный раздел, подходящий для вашей архитектуры. Переопределить размеры разделов по умолчанию можно с помощью указания part.

autostep (необязательный)

Похож на параметр interactive, за исключением того, что переход к следующему экрану происходит автоматически. Используется в основном для отладки.

auth или authconfig (обязательный)

Определяет в системе параметры проверки подлинности. Параметр похож на команду системы authconfig, которую можно запустить после установки. По умолчанию, пароли шифруются стандартно и не помещаются в тень.

--enablemd5

Включает шифрование паролей пользователй по алгоритму md5.

--enablenis

Включает поддержку NIS. По умолчанию, --enablenis использует домен, найденный в сети. Домен почти всегда следует указывать явно (с помощью --nisdomain=).

--nisdomain=

Имя домена NIS, используемое службами NIS.

--nisserver=

Сервер, который будет использоваться службами NIS (по умолчанию — широковещание).

--useshadow или --enableshadow

Включает использование скрытых паролей (в файле shadow).

--enableldap

Включает поддержку LDAP в /etc/nsswitch.conf, что позволяет вашему компьютеру получать информацию о пользователях (UID, домашний каталог, оболочка, и т.д.) из каталога LDAP. Чтобы использовать эту возможность, вы должны установить пакет nss_ldap. Вы также должны указать сервер и базовое распознаваемое имя (Distinguished Name, DN ) с помощью --ldapserver= и --ldapbasedn=.

--enableldapauth

Разрешает использовать LDAP в качестве метода проверки подлинности. Указывает модулю pam_ldap проводить проверку подлинности и смену паролей, используя каталог LDAP. Чтобы использовать эту возможность, вы должны установить пакет nss_ldap. Вы также должны указать сервер и базовое распознаваемое имя с помощью --ldapserver= и --ldapbasedn=.

--ldapserver=

Если вы указали либо --enableldap, либо --enableldapauth, с помощью этого параметра определите имя используемого LDAP-сервера. Этот параметр устанавливается в файле /etc/ldap.conf.

--ldapbasedn=

Если вы указали либо --enableldap, либо --enableldapauth, с помощью этого параметра определите DN узла, в котором находится информация пользователя в вашем дереве каталога LDAP. Этот параметр устанавливается в файле /etc/ldap.conf.

--enableldaptls

Разрешает использовать при обращении к серверу протокол безопасности на транспортном уровне (Transport Layer Security, TLS). Этот параметр позволяет посылать зашифрованные имена пользователей и пароли серверу LDAP до завершения проверки подлинности.

--enablekrb5

Разрешает использовать Kerberos 5 для проверки подлинности пользователей. Kerberos сам по себе «не знает» о домашних каталогах, кодах UID или оболочках пользователей. Если вы включаете Kerberos, вы должны сообщить о существовании учётных записей пользователей этому компьютеру, включив LDAP, NIS, Hesiod или воспользовавшись командой /usr/sbin/useradd. Если вы используете этот параметр, вы должны установить пакет pam_krb5.

--krb5realm=

Область Kerberos 5, к которой принадлежит ваш компьютер.

--krb5kdc=

Сервер (или сервера) KDC, обслуживающие эту область. Если в вашей области несколько серверов KDC, разделите их имена запятыми (,).

--krb5adminserver=

Сервер KDC в вашей области, также выполнящий процесс kadmind. Этот сервер обрабатывает смену паролей и другие административные запросы. Этот процесс должен быть запущен на главном сервере KDC, если у вас несколько таких серверов.

--enablehesiod

Разрешает использовать поддержку Hesiod для получения домашних каталогов пользователей, кодов UID, и оболочек. Дополнительная информация о настройке и использовании Hesiod в вашей сети находится в файле /usr/share/doc/glibc-2.x.x/README.hesiod, включенном в пакет glibc. Hesiod — это расширение DNS, в котором для хранения информации о пользователях, группах и других объектах используются записи DNS.

--hesiodlhs

Параметр Hesiod LHS («left-hand side», «левая сторона»), определяемый в /etc/hesiod.conf. Этот параметр используется библиотекой Hesiod для определения имени, с которым она при поиске информации обращается к DNS, так же как DN используется в LDAP-запросах.

--hesiodrhs

Параметр Hesiod RHS («right-hand side», «правая сторона»), определяемый в /etc/hesiod.conf. Этот параметр используется библиотекой Hesiod для определения имени, с которым она при поиске информации обращается к DNS, так же как DN используется в LDAP-запросах.

Подсказка Подсказка

Чтобы найти информацию о пользователе «jim», библиотека Hesiod ищёт jim.passwd<LHS><RHS>, а в результате рассчитывает получить запись TXT, похожую на запись в файле passwd (jim:*:501:501:Jungle Jim:/home/jim:/bin/bash). Запрос для групп составляется аналогично, с небольшим изменением: jim.group<LHS><RHS>.

Поиск пользователей и групп по уникальному номеру выполняется с помощью псевдонима CNAME «501.uid» для записи «jim.passwd», и «501.gid» для «jim.group». Обратите внимание, библиотека при определении имени не помещает точку [.] перед LHS и RHS, поэтому обычно вы должны начать LHS и RHS с точки.

--enablesmbauth

Включает проверку подлинности пользователей на сервере SMB (обычно это Samba или Windows сервер). Протокол проверки подлинности SMB сам по себе «не знает» о домашних каталогах, UID или оболочках пользователей. Если вы включаете SMB, вы должны сообщить о существовании учётных записей пользователей этому компьютеру, включив LDAP, NIS, Hesiod или воспользовавшись командой /usr/sbin/useradd. Чтобы использовать эту возможность, вы должны установить пакет pam_smb.

--smbservers=

Имя сервера(ов), используемых для проверки подлинности SMB. Указать имена нескольких серверов можно, разделив их имена запятыми (,).

--smbworkgroup=

Имя рабочей группы для серверов SMB.

--enablecache

Включает службу nscd. Служба nscd кэширует информацию о пользователях, группах и других объектах. Кэширование особенно полезно, если вы решите распределять информацию о пользователях и группах по сети, используя NIS, LDAP или hesiod.

bootloader (обязательный)

Определяет, как должен устанавливаться загрузчик GRUB. Этот параметр требуется и при установке, и при обновлении. В случае обновления, если GRUB не является текущим загрузчиком, загрузчик будет заменён на GRUB. Чтобы сохранить другие загрузчики, укажите bootloader --upgrade.

--append=

Определяет параметры ядра. Указать несколько параметров можно, разделив их запятыми. Например:

bootloader --location=mbr --append="hdd=ide-scsi ide=nodma"
--driveorder

Указывает, какое устройство стоит первым в последовательности загрузки в BIOS. Например:

bootloader --driveorder=sda,hda
--location=

Определяет, куда будет записана загрузочная запись. Разрешённые значения приведены ниже: mbr (по умолчанию — основная загрузочная запись), partition (загрузчик будет установлен в первый сектор раздела, содержащего ядро), или none (загрузчик не будет установлен).

--password=

Задаёт в качестве пароля загрузчика GRUB пароль, указанный в этом параметре. Это следует применять для ограничения доступа к оболочке GRUB, в которой ядру могут быть переданы определённые параметры.

--md5pass=

Похож на параметр --password=, отличие состоит в том, что пароль уже должен быть зашифрован.

--upgrade

Обновляет существующую конфигурацию загрузчика с сохранением старых записей. Этот параметр доступен только при обновлении.

clearpart (необязательный)

Удаляет разделы на диске, прежде чем создавать новые. По умолчанию разделы не удаляются.

Замечание Замечание

Если используется команда clearpart, команда --onpart не может применяться к тому же логическому разделу.

--all

Удаляет все разделы в системе.

--drives=

Определяет, на каких дисках следует удалить разделы. Например, следующая команда удаляет все разделы на первых двух дисках, подключенных к первичному IDE-контроллеру:

clearpart --drives=hda,hdb --all
--initlabel

Устанавливает метку диска, как принято по умолчанию в архитектуре вашего компьютера (например, msdos для x86 и gpt для Itanium). Это полезно сделать, чтобы программа установки не запрашивала, должна ли они инициализировать метку диска при установке на совершенно новый жёсткий диск.

--linux

Удаляет все разделы Linux.

--none (по умолчанию)

Не удаляет никакие разделы.

cmdline (необязательный)

Выполняет установку в полностью неинтерактивном режиме командной строки. Любой запрос взаимодействия приводит к прекращению установки. Этот режим полезен для систем S/390 с консолью x3270.

device (необязательный)

В большинстве компьютеров с шиной PCI программа установки автоматически корректно определяет Ethernet и SCSI-платы. На старых компьютерах и в некоторых конфигурациях PCI, тем не менее, установке kickstart потребуется помощь при определении соответствующих устройств. Команда device, указывающая программе установки подключить дополнительные модули, выглядит следующим образом:

device <type> <moduleName> --opts=<options>

<type>

замените на scsi или eth

<moduleName>

замените названием модуля ядра, который следует установить.

--opts=

Параметры, которые должны быть переданы модулю ядра. Обратите внимание, передать несколько параметров можно, заключив их в кавычки. Например:

--opts="aic152x=0x340 io=11"
driverdisk (необязательный)

Во время установки kickstart могут быть использованы дискеты с драйверами. Вы должны содержимое дискет с драйверами в корневой каталог раздела на жёстком диске компьютера. Затем, с помощью команды driverdisk, вы должны указать программе установки, где находится диск с драйверами.

driverdisk <partition> [--type=<fstype>]

Также можно указать сетевое расположение дискеты с драйверами:

driverdisk --source=ftp://path/to/dd.img
driverdisk --source=http://path/to/dd.img
driverdisk --source=nfs:host:/path/to/img

<partition>

раздел, содержащий диск с драйверами.

--type=

Тип файловой системы (например: vfat или ext2).

firewall (необязательный)

Этот параметр соответствует диалогу Настройка брандмауэра (Firewall Configuration) программы установки.

firewall --enabled|--disabled [--trust=] <device> [--port=]

--enabled

Отклоняет входящие подключения, кроме тех, что отвечают на исходящие запросы, такие, как ответы DNS или DHCP. Если необходим доступ к службам, запущенным на этом компьютере, вы можете разрешить эти службы в брандмауэре.

--disabled (отсутствует)

Никакие правила iptables не настраиваются.

--trust=

Межсетевой экран пропускает весь трафик, проходящий через указанное здесь устройство, например eth0. Указать несколько устройств можно следующим образом: --trust eth0 --trust eth1. НЕ ИСПОЛЬЗУЙТЕ список, разделённый через запятую: --trust eth0, eth1.

<incoming>

подставьте сюда название одной или нескольких служб, чтобы открыть к ним доступ через брандмауэр.

  • --ssh

  • --telnet

  • --smtp

  • --http

  • --ftp

--port=

Вы можете определить порты, обращения к которым должны проходить через межсетевой экран, в формате порт:протокол. Например, если вы хотите разрешить IMAP-доступ через межсетевой экран, укажите imap:tcp. Также можно явно указать числовой номер порта; например, чтобы пропустить UDP пакеты на порт 1234 через межсетевой экран, введите 1234:udp. Указать несколько портов можно, разделив их запятыми.

firstboot (необязательный)

Определяет, будет ли после первой загрузки системы запускаться Помощник по настройке (Setup Agent). Если параметр включён, должен быть установлен пакет firstboot. Если этот параметр не указан, считается, что он отключен.

--enable

Помощник по настройке запускается после первой перезагрузки системы.

--disable

Помощник по настройке не запускается после первой перезагрузки системы.

--reconfig

Разрешить запуск Помощника по настройке в режиме перенастройки. Этот режим помимо стандартных параметров конфигурации позволяет также изменить настройки мыши, клавиатуры, языковые параметры, пароль root, уровень безопасности, часовой пояс и настройки сети.

halt (необязательный)

Останавливает систему после успешного завершения установки. Это похоже на установку вручную, когда Anaconda выводит сообщение и ждёт, пока пользователь не нажмёт клавишу, и только затем перегружает компьютер. Если при установке kickstart не указан никакой метод завершения, по умолчанию выбирается режим reboot.

Параметр halt примерно соответствует команде shutdown -h.

Чтобы узнать о других методах завершения, обратитесь к параметрам kickstart poweroff, reboot и shutdown.

install (необязательный)

Определяет, что выполняется установка новой системы, а не обновление существующей. Этот параметр установлен по умолчанию. Для установки вы должны указать тип установки: с cdrom, harddrive, nfs или url (для установок по FTP ил HTTP). Команда install и команда метода установки должны располагаться на разных строках.

cdrom

Устаналивает систему с первого привода CD-ROM.

harddrive

Устанавливает систему с локального жёсткого диска, используя дистрибутив, расположенный в файловой системе vfat или ext2.

  • --partition=

    Раздел, в котором находится каталог установки (например, sdb2).

  • --dir=

    Каталог, содержащий подкаталог RedHat дерева установки.

Например:

harddrive --partition=hdb2 --dir=/tmp/install-tree
nfs

Выполняет установку с заданного NFS-сервера.

  • --server=

    Сервер, содержащий установочные файлы (имя или IP).

  • --dir=

    Каталог, содержащий подкаталог RedHat дерева установки.

Например:

nfs --server=nfsserver.example.com --dir=/tmp/install-tree
url

Устанавливает систему, используя дерево каталогов установки, доступное через FTP или HTTP.

Например:

url --url http://<server>/<dir>

или:

url --url ftp://<username>:<password>@<server>/<dir>
interactive (необязательный)

Использует во время установки информацию, определённую в файле kickstart, но допускает проверку и изменение заданных значений. В каждом диалоге программы установки вы будете наблюдать значения, полученные из файла kickstart. И вы можете либо согласиться с этими значениями, нажав Далее (Next), либо изменить их и нажать Далее (Next) для продолжения. Обратитесь к описанию команды autostep.

keyboard (обязательный)

Определяет тип клавиатуры компьютера. Ниже приведен список допустимых типов на компьютерах i386, Itanium и Alpha:

be-latin1, bg, br-abnt2, cf, cz-lat2, cz-us-qwertz, de,
de-latin1, de-latin1-nodeadkeys, dk, dk-latin1, dvorak, es, et,
fi, fi-latin1, fr, fr-latin0, fr-latin1, fr-pc, fr_CH, fr_CH-latin1,
gr, hu, hu101, is-latin1, it, it-ibm, it2, jp106, la-latin1, mk-utf,
no, no-latin1, pl, pt-latin1, ro_win, ru, ru-cp1251, ru-ms, ru1, ru2,
ru_win, se-latin1, sg, sg-latin1, sk-qwerty, slovene, speakup,
speakup-lt, sv-latin1, sg, sg-latin1, sk-querty, slovene, trq, ua,
uk, us, us-acentos

Этот список также содержится в файле /usr/lib/python2.2/site-packages/rhpl/keyboard_models.py, включённом в пакет rhpl.

lang (обязательный)

Определяет язык, используемый во время установки. Например, для установки английского языка файл kickstart должен содержать следующую строку:

lang en_US

Список допустимых кодов языков приведён в файле /usr/share/system-config-language/locale-list (в первом столбце каждой строки), содержащемся в пакете system-config-language.

langsupport (обязательный)

Определяет язык(и), устанавливаемый в системе. Коды языков используемые в параметре lang, используются также и в langsupport.

Чтобы установить один язык, укажите его. Например, чтобы установить и использовать французский язык (fr_FR), укажите:

langsupport fr_FR

--default=

Если устанавливается поддержка нескольких языков, необходимо выбрать язык по умолчанию.

Например, чтобы установить английский и французский языки, и использовать по умолчанию английский, выполните:

langsupport --default=en_US fr_FR

Если вы указываете --default с всего одним языком, устанавливаются все языки, а указанный язык становится языком по умолчанию.

logvol (необязательный)

Создаёт логический том для системы управления логическими томами (Logical Volume Management, LVM). Синтаксис команды следующий:

logvol <mntpoint> --vgname=<name> --size=<size> --name=<name> <options>

Параметры описываются ниже:

--noformat

Использует существующий логический том и не форматирует его.

--useexisting

Использует существующий логический том и переформатирует его.

Создавайте сначала раздел, затем группу логических томов, и, наконец, логический том. Например:

part pv.01 --size 3000
volgroup myvg pv.01
logvol / --vgname=myvg --size=2000 --name=rootvol

Подробный пример действия logvol вы найдёте в главе 1.4.1 Пример сложного разбиения.

mouse (обязательный)

Определяет настройки мыши для графического и текстового режимов. Дополнительные параметры:

--device=

Устройство, к которому подключена мышь (например, --device=ttyS0).

--emulthree

Параметр указывает, что одновременное нажатие левой и правой кнопки мыши воспринимается системой X Window как нажатие средней кнопки. Этот параметр следует использовать, если у вас мышь с двумя кнопками.

После этих параметров можно указать тип мыши, выбрав один из следующих:

alpsps/2, ascii, asciips/2, atibm, generic, generic3, genericps/2,
generic3ps/2, genericwheelps/2, genericusb, generic3usb, genericwheelusb,
geniusnm, geniusnmps/2, geniusprops/2, geniusscrollps/2, geniusscrollps/2+,
thinking, thinkingps/2, logitech, logitechcc, logibm, logimman,
logimmanps/2, logimman+, logimman+ps/2, logimmusb, microsoft, msnew,
msintelli, msintellips/2, msintelliusb, msbm, mousesystems, mmseries,
mmhittab, sun, none

Этот список можно найти в файле /usr/lib/python2.2/site-packages/rhpl/mouse.py, включённом в пакет rhpl.

Если аргументы команды mouse не указаны, или команда вовсе опущена, программа установки пытается выявить мышь автоматически. Это процедура работает для большинства современных мышей.

network (необязательный)

Определяет сетевую настройку компьютера. Если kickstart-установка не использует сеть (другими словами, установка выполняется не по FTP, HTTP или NFS), сеть не настраивается. Если сеть необходима для установки, но информация о настройке сети отсутствует в файле kickstart, программа установки предполагает, что установка может быть выполнена через интерфейс eth0 с динамическим IP-адресом (BOOTP/DHCP), и настраивает установленную систему на использование динамического IP-адреса. Параметр network определяет сетевые настройки для установки kickstart по сети, а также для установленной системы.

--bootproto=

Допускаются параметры dhcp, bootp и static.

По умолчанию выбран режим dhcp. Параметры bootp и dhcp работают одинаково.

В режиме DHCP для получения сетевой конфигурации используется DHCP-сервер. Как вы могли догадаться, в случае с BOOTP, для получения сетевых настроек подобным образом используется сервер BOOTP. Чтобы настроить компьютер на использование DHCP, укажите:

network --bootproto=dhcp

Чтобы настроить компьютер на получения сетевой конфигурации с помощью BOOTP, добавьте в файл kickstart следующую строку:

network --bootproto=bootp

В случае статической конфигурации вы должны определить в файле kickstart все необходимые сетевые параметры. Как и следует из имени, эти параметры являются статическими и используются как во время, так и после установки. Строка для статической настройки выглядит более сложной, так как вы должны задать все сетевые параметры в одной строке. Вы должны указать IP-адрес, маску сети, шлюз и сервер имён. Например: (Символ «\» показывает, что это следует воспринимать как одну строку):

network --bootproto=static --ip=10.0.2.15 --netmask=255.255.255.0 \
--gateway=10.0.2.254 --nameserver=10.0.2.1

Если вы используете статическую настройку, учтите два следующих ограничения:

  • Вся информация о статической конфигурации должна быть задана в одной строке; вы не может перенести её на другую строку, например, с помощью обратной косой черты.

  • Здесь вы можете указать только один сервер имен. Однако, если необходимо, вы можете определить дополнительные сервера имён, воспользовавшись разделом %post (описанным в разделе 1.7 Сценарий, выполняемый после установки).

--device=

Определяет Ethernet-устройство, используемое для установки. Заметьте, что параметр --device= будет действовать, только если файл kickstart расположен локально (например, в случае ks=floppy), так как иначе прогрмма установки уже будет использовать сеть для загрузки файла kickstart. Например:

network --bootproto=dhcp --device=eth0
--ip=

IP-адрес устанавливаемой системы.

--gateway=

IP-адрес шлюза по умолчанию.

--nameserver=

IP-адрес первичного сервера имён.

--nodns

DNS-сервер не настраивается.

--netmask=

Маска сети устанавливаемой системы.

--hostname=

Имя узла устанавливаемой системы.

part или partition (обязательный при установке, при обновлении игнорируется)

Создаёт в системе раздел.

Если Red Hat Enterprise Linux уже установлена на компьютера в нескольких разделах, программа установки спрашивает у пользователя, какую инсталляцию обновить.

Предупреждение Предупреждение

Все созданные разделы форматируются в процессе установки, если только не используются параметры --noformat и --onpart.

Подробный пример действия part вы найдёте в главе 1.4.1 Пример сложного разбиения.

<mntpoint>

Параметр <mntpoint> указывает, куда монтируется раздел, и должен иметь следующий вид:

  • /<path>

    Например, /, /usr, /home

  • swap

    Раздел используется в качестве раздела подкачки.

    Чтобы размер раздела подкачки был выбран автоматически, воспользуйтесь параметром --recommended:

    swap --recommended

    Минимальный размер автоматичечки создаваемого раздела подкачки будет не меньше объёма ОЗУ компьютера и не больше чем удвоенный объём ОЗУ.

  • raid.<id>

    Раздел используется в программном RAID-массиве (см. raid).

  • pv.<id>

    Раздел используется в LVM (см. logvol).

--size=

Минимальный размер раздела в мегабайтах. Укажите здесь целочисленное значение, например 500. Не добавляйте к числу MB.

--grow

Укажите, будет ли раздел занимать всё доступное пространство (если оно есть), или заданный максимальный объём.

--maxsize=

Максимальный размер раздела, если задан параметр grow. Укажите здесь целочисленное значение, например 500, и не добавляйте к числу MB.

--noformat

Указывает программе установки не форматировать раздел, используется вместе с параметром --onpart.

--onpart= или --usepart=

Разместить раздел на уже существующем устройстве. Например:

partition /home --onpart=hda1

размещает /home на устройстве /dev/hda1, которое уже должно существовать.

--ondisk= или --ondrive=

Определяет диск, на котором будет создан раздел. Например, --ondisk=sdb размещает раздел на втором SCSI-диске компьютере.

--asprimary

Созданный автоматически раздел должен стать основным или разбиение не должно выполниться.

--type= (заменён на fstype)

Этот параметр более не поддерживается. Используйте fstype.

--fstype=

Определяет тип файловой системы раздела. Допускаются значения ext2, ext3, swap и vfat.

--start=

Определяет первый цилиндр раздела. Этот параметр требует указания диска с помощью --ondisk= или ondrive=. Также этот параметр требует указания последнего цилиндра с помощью --end= или размера раздела в параметре --size.

--end=

Определяет последний цилиндр раздела. Необходимо, чтобы в параметре --start= был указан начальный цилиндр.

Замечание Замечание

Если разбиение диска по какой-либо причине заканчивается неудачно, диагностические сообщения выводятся на виртуальную консоль 3.

poweroff (необязательный)

После установки завершает работу системы и отключает питание компьютера. Обычно при установке вручную anaconda выводит на экран сообщение и ждёт нажатия клавиши для перезагрузки. Если при установке kickstart не указан никакой метод завершения, по умолчанию выбирается режим reboot.

Параметр poweroff примерно соответствует команде shutdown -p.

Замечание Замечание

Параметр poweroff сильно зависит от оборудования компьютера. То есть, чтобы он работал, определённые компоненты системы, в частности BIOS, система расширенного управления питанием (Advanced Power Management, APM) и расширенный интерфейс настройки и управления питанием (Advanced Configuration and Power Interface, ACPI) должны правильно взаимодействовать с ядром системы. Больше о возможностях APM/ACPI своего компьютера вы можете узнать у производителя компьютера.

Чтобы узнать о других методах завершения, обратитесь к параметрам kickstart halt, reboot и shutdown.

raid (необязательный)

Собирает программный RAID-массив. Команда имеет следующий вид:

raid <mntpoint> --level=<level> --device=<mddevice> <partitions*>

<mntpoint>

Точка, в которую монтируется файловая система RAID. Если это /, уровень RAID должен быть равен 1, если только не определён загрузочный раздел (/boot). Если загрузочный раздел определён, раздел /boot должен иметь уровень 1, а корневой (/) раздел может иметь любой допустимый тип. Параметр <partitions*> (что указывает, что здесь может быть указано несколько разделов) определяет идентификаторы RAID, добавляемые в RAID-массив.

--level=

Используемый уровень RAID (0, 1 или 5).

--device=

Имя используемого устройства RAID (например md0 или md1). Устройства RAID имеют имена от md0 до md7, и каждое может использоваться только один раз.

--spares=

Определяет число резервных дисков, отведённых для RAID-массива. Резервные диски используются для перестроения массива в случае сбоя диска.

--fstype=

Определяет тип файловой системы RAID-массива. Допустимы значения: ext2, ext3, swap и vfat.

--noformat

Определяет, что должно использоваться существующее устройство RAID и RAID-массив не должен форматироваться.

--useexisting

Определяет, что должно использоваться существующее устройство RAID и оно должно форматироваться.

В следующем примере показано, как создать раздел /, используя RAID-массив уровня 1, и раздел /usr, используя RAID-массив уровня 5; предполагается, что в компьютере установлено три SCSI-диска. Здесь также создаётся три раздела подкачки, каждый на отдельном диске.

part raid.01 --size=60 --ondisk=sda
part raid.02 --size=60 --ondisk=sdb
part raid.03 --size=60 --ondisk=sdc
part swap --size=128 --ondisk=sda
part swap --size=128 --ondisk=sdb
part swap --size=128 --ondisk=sdc
part raid.11 --size=1 --grow --ondisk=sda
part raid.12 --size=1 --grow --ondisk=sdb
part raid.13 --size=1 --grow --ondisk=sdc
raid / --level=1 --device=md0 raid.01 raid.02 raid.03
raid /usr --level=5 --device=md1 raid.11 raid.12 raid.13

Подробный пример действия raid приводится в главе 1.4.1 Пример сложного разбиения.

reboot (необязательный)

Перегружает компьютер после успешного завершения установки (без аргументов). Обычно при установке вручную anaconda выводит на экран сообщение и ждёт нажатия клавиши для перезагрузки.

Параметр reboot примерно соответствует команде shutdown -r.

Замечание Замечание

Использование параметр reboot может привести к бесконечному зацикливанию установки, в зависимости от выбранного носителя и способа установки.

Если в файле kickstart явно не указаны не указаны другие режимы завершения, используется параметр reboot.

Чтобы узнать о других методах завершения, обратитесь к параметрам kickstart halt, poweroff и shutdown.

rootpw (обязательный)

Определяет для пользователя root пароль <password>.

rootpw [--iscrypted] <password>

--iscrypted

Если этот параметр присутствует, <password> подразумевается уже зашифрованным.

selinux (необязательный)

Устанавливает режим SELinux в соответствии со следующими аргументами:

--enforcing

Включает SELinux с применением целевой политики по умолчанию.

Замечание Замечание

Если параметр selinux в файле kickstart отсутствует, SELinux включён и по умолчанию работает в режиме --enforcing.

--permissive

Только выводит сообщения согласно политике SELinux, но на самом деле не применяет её.

--disabled (отсутствует)

Полностью отключает SELinux в системе.

Полную информацию о SELinux в Red Hat Enterprise Linux можно найти в Руководстве по Red Hat SELinux.

shutdown (необязательный)

Выключает компьютер после успешного завершения установки. Если при установке kickstart не указан никакой метод завершения, по умолчанию выбирается режим reboot.

Параметр shutdown примерно соответствует команде shutdown.

Чтобы узнать о других методах завершения, обратитесь к параметрам kickstart halt, poweroff и reboot.

skipx (необязательный)

Если присутствует, система X Window в устанавливаемой системе не настраивается.

text (необязательный)

Установка kickstart выполняется в текстовом режиме. Kickstart-установка по умолчанию выполняется в графическом режиме.

timezone (обязательный)

Определяет часовой пояс <timezone>, аргумент может быть одним из приведённых в timeconfig.

timezone [--utc] <timezone>

--utc

Если присутствует, подразумевается что часы системы установлены по Гринвичу (UTC).

upgrade (необязательный)

Указывает системе, выполнить обновление, а не новую установку. В качестве размещения дерева каталогов установки вы должны указать cdrom, harddrive, nfs или url (при использовании FTP или HTTP). Подробнее об этом рассказывается в описании параметра install.

xconfig (необязательный)

Настраивает систему X Window. Если этот параметр не определен, пользователь должен во время установки настроить X вручную, если X устанавливается; этот параметр не следует использовать, если X на компьютере не устанавливается.

--noprobe

Не проверять монитор.

--card=

Использует указанную плату, название платы следует выбрать из списка плат в файле /usr/share/hwdata/Cards из пакета hwdata. Также список плат можно увидеть в диалоге Настройка X (X Configuration) программы Настройка Kickstart (Kickstart Configurator). Если аргумент не указан, выявляет платы, опрашивая шину PCI. Так как AGP является частью PCI, платы с интерфейсом AGP, если они поддерживаются, также будут обнаружены. Порядок выявления устройств определяется порядком сканирования шины PCI материнской платой.

--videoram=

Указывает объём видео-памяти, установленной на плате.

--monitor=

Использует заданный монитор, название монитора следует выбрать из списка плат в файле /usr/share/hwdata/Cards из пакета hwdata. Также список мониторов можно увидеть в диалоге Настройка X (X Configuration) программы Настройка Kickstart (Kickstart Configurator). Этот параметр игнорируется, если указан параметр --hsync или --vsync. Если информация о мониторе не предоставлена, программа установки пытается определить его автоматически.

--hsync=

Определяет частоту горизонтальной развёртки монитора.

--vsync=

Определяет частоту вертикальной развертки монитора.

--defaultdesktop=

Задаёт графическое окружение по умолчанию: GNOME или KDE (предполагается что окружение рабочего стола GNOME и/или KDE устанавливается в разделе %packages).

--startxonboot

Включает вход в установленную систему в графическом режиме.

--resolution=

Определяет разрешение по умолчанию для X Window в устанавливаемой системе. Допустимы значения: 640x480, 800x600, 1024x768, 1152x864, 1280x1024, 1400x1050, 1600x1200. Убедитесь в том, что указанное вами разрешение поддерживается видео-адаптером и монитором.

--depth=

Определяет глубину цвета по умолчанию для X Window System в устанавливаемой системе. Допустимы значения: 8, 16, 24 и 32. Убедитесь в том, что указанная вами глубина цвета поддерживается видео-адаптером и монитором.

volgroup (необязательный)

Используется для создания группы системы управления логическими томами (Logical Volume Management, LVM) следующим образом:

volgroup <name> <partition> <options>

Параметры описываются ниже:

--noformat

Использует существующую группу томов и не форматирует её.

--useexisting

Использует существующую группу томов и переформатирует её.

Создавайте сначала раздел, затем группу логических томов, и, наконец, логический том. Например:

part pv.01 --size 3000
volgroup myvg pv.01
logvol / --vgname=myvg --size=2000 --name=rootvol

Подробный пример действия volgroup вы найдёте в главе 1.4.1 Пример сложного разбиения.

zerombr (необязательный)

Если указан параметр zerombr и в качестве единственного аргумента указано yes, все неправильные таблицы разделов, обнаруженных на дисках, будут очищены. Это приведёт к потере всех данных, расположенных на дисках с неправильными таблицами разбиения разделов. Команда должна иметь следующий формат:

zerombr yes

В любой другой записи команда не будет действовать.

%include

Используйте команду %include /path/to/file, чтобы включить в файле kickstart содержимое другого файла так, как если бы содержимое было непосредственно было вставлено в файл kickstart вместо команды %include.

1.4.1. Пример сложного разбиения

Ниже показан один комплексный пример, иллюстрирующий параметры kickstart clearpart, raid, part, volgroup, and logvol в действии:

clearpart --drives=hda,hdc --initlabel

# Raid 1 IDE config
part raid.11    --size 1000     --asprimary     --ondrive=hda
part raid.12    --size 1000     --asprimary     --ondrive=hda
part raid.13    --size 2000     --asprimary     --ondrive=hda
part raid.14    --size 8000                     --ondrive=hda
part raid.15    --size 1 --grow                 --ondrive=hda

part raid.21    --size 1000     --asprimary     --ondrive=hdc
part raid.22    --size 1000     --asprimary     --ondrive=hdc
part raid.23    --size 2000     --asprimary     --ondrive=hdc
part raid.24    --size 8000                     --ondrive=hdc
part raid.25    --size 1 --grow                 --ondrive=hdc

# You can add --spares=x
raid /          --fstype ext3 --device md0 --level=RAID1 raid.11 raid.21
raid /safe      --fstype ext3 --device md1 --level=RAID1 raid.12 raid.22
raid swap       --fstype swap --device md2 --level=RAID1 raid.13 raid.23
raid /usr       --fstype ext3 --device md3 --level=RAID1 raid.14 raid.24
raid pv.01      --fstype ext3 --device md4 --level=RAID1 raid.15 raid.25

# LVM configuration so that we can resize /var and /usr/local later
volgroup sysvg pv.01
logvol /var             --vgname=sysvg  --size=8000     --name=var
logvol /var/freespace   --vgname=sysvg  --size=8000     --name=freespacetouse
logvol /usr/local       --vgname=sysvg  --size=1 --grow --name=usrlocal

В этом примере реализован LVM поверх RAID, а также показаны возможности, позволяющие увеличивать размер каталогов в будущем.

Назад | Начало | Вперёд
Создание файла Kickstart | Вверх | Выбор пакетов


Выбор пакетов

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.5. Выбор пакетов

Используйте команду %packages для обозначения начала раздела, в котором вы опишите пакеты, которые хотели бы установить (эта команда подходит только для установки, так как выбор пакетов во время обновления системы не поддерживается).

Пакеты можно выбрать, указав группу или имя отдельного пакета. Программа установки определяет несколько групп, объединяющих в себе связанные пакеты. Список групп вы можете найти в файле RedHat/base/comps.xml, расположенном на первом компакт-диске Red Hat Enterprise Linux. Каждая группа имеет свой код, признак отображения для пользователей, название, описание и список пакетов. Пакеты, помеченные в этом списке как обязательные, устанавливаются всегда, если устанавливается группа, пакеты, помеченные как устанавливаемые по умолчанию, выбираются при выборе групппы, а пакеты, помеченные как необязательные, должны выбираться явно, даже при выборе группы.

В большинстве случаев вполне достаточно устанавливать нужные группы, а не отдельные пакеты. Обратите внимание, что группы Core и Base выбраны по умолчанию, поэтому их указывать в разделе %packages не требуется.

Ниже приведён пример раздела %packages:

%packages
@ X Window System
@ GNOME Desktop Environment
@ Graphical Internet
@ Sound and Video
dhcp

Как вы можете заметить, группы указываются по одной в строке, при этом в начале строки указывается символ @, затем пробел, а за ним следует полное название группы, определённое в файле comps.xml. Группы также можно указывать с помощью идентификаторов групп, например, gnome-desktop. Отдельные пакеты указываются без дополнительных символов (в приведённом выше примере строка dhcp содержит название отдельного пакета).

Вы также может определить, какие пакеты из списка пакетов по умолчанию не устанавливать:

-autofs

Параметр %packages поддерживает следующие аргументы:

--resolvedeps

Устанавливает выбранные пакеты и автоматически разрешает зависимости пакетов. Если этот параметр не указан и пакеты имеют зависимости, автоматическая установка приостанавливается и ждём вмешательства пользователя. Например:

%packages --resolvedeps
--ignoredeps

Игнорирует неразрешённые зависимости и устанавливает выбранные пакеты без зависимостей. Например:

%packages --ignoredeps
--ignoremissing

Игнорирует пропущенные пакеты и группы, вместо того, чтобы прервать установку или спросить, следует ли её остановить или продолжить. Например:

%packages --ignoremissing
Назад | Начало | Вперёд
Параметры Kickstart | Вверх | Сценарий, выполняемый до установки


Сценарий, выполняемый после установки

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.7. Сценарий, выполняемый после установки

У вас есть возможность задать команды, которые будут выполнены сразу после завершения установки. Этот раздел должен располагаться в конце файла kickstart и начинаться с команды %post. Данный раздел полезен для таких операций, как установка дополнительного программного обеспечения и настройка дополнительного сервера имён.

Замечание | Замечание
 | Если вы используете статическую настройку IP, включая сервер имён, в разделе %post вы можете обращаться к сети и разрешать IP-адреса. Если для определения сетевых параметров используется DHCP, файл /etc/resolv.conf не будет создан к моменту, когда программа установки выполняет раздел %post. Вы можете обращаться к сети, но вы не можете разрешать IP-адреса. Таким образом, если вы используете DHCP, в разделе %post вы должны указывать IP-адреса.

Замечание | Замечание
 | Сценарий, запускаемый после установки, работает в окружении chroot; поэтому выполнить некоторые задачи, такие как копирование сценариев или пакетов RPM с установочных носитителей, не удастся.

--nochroot

Позволяет вам указать команды, которые вы бы хотели выполнить вне окружения chroot.

В следующем примере файл /etc/resolv.conf копируется в только что созданную файловую систему.

%post --nochroot
cp /etc/resolv.conf /mnt/sysimage/etc/resolv.conf
--interpreter /usr/bin/python

Позволяет вам указать другой язык сценариев, например, Python. Замените /usr/bin/python предпочитаемым вами языком сценариев.

1.7.1. Примеры

Включение и выключение служб:

/sbin/chkconfig --level 345 telnet off
/sbin/chkconfig --level 345 finger off
/sbin/chkconfig --level 345 lpd off
/sbin/chkconfig --level 345 httpd on

Запуск сценария с именем runme, находящегося в разделяемом NFS-ресурсе:

mkdir /mnt/temp
mount -o nolock 10.10.0.2:/usr/new-machines /mnt/temp
open -s -w -- /mnt/temp/runme
umount /mnt/temp

Замечание | Замечание
 | NFS-блокировка файлов в режиме kickstart неподдерживаетс, поэтому при монтировании NFS-ресурса требуется указать -o nolock.

Добавление пользователя в систему:

/usr/sbin/useradd bob
/usr/bin/chfn -f "Bob Smith" bob
/usr/sbin/usermod -p 'kjdf$04930FTH/ ' bob
Назад | Начало | Вперёд
Сценарий, выполняемый до установки | Вверх | Обеспечение доступности файла Kickstart


Сценарий, выполняемый до установки

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.6. Сценарий, выполняемый до установки

Вы можете добавить команды, которые будут выполнены в системе сразу после обработки файла ks.cfg. Этот раздел должен располагаться в конце файла kickstart (после команд) и должен начинаться с команды %pre. В разделе %pre вы можете обращаться к сети; однако, на этом этапе служба разрешения имён ещё не настроена, поэтому будут работать только IP-адреса.

Замечание | Замечание
 | Обратите внимание, пред-установочный сценарий не выполняется в окружении chroot.

--interpreter /usr/bin/python

Позволяет вам указать другой язык сценариев, например, Python. Замените /usr/bin/python предпочитаемым вами языком сценариев.

1.6.1. Пример

Ниже приведён пример раздела %pre:

%pre

#!/bin/sh

hds=""
mymedia=""

for file in /proc/ide/h*
do
  mymedia=`cat $file/media`
  if [ $mymedia == "disk" ] ; then
      hds="$hds `basename $file`"
  fi
done

set $hds
numhd=`echo $#`

drive1=`echo $hds | cut -d' ' -f1`
drive2=`echo $hds | cut -d' ' -f2`

#Write out partition scheme based on whether there are 1 or 2 hard drives

if [ $numhd == "2" ] ; then
  #2 drives
  echo "#partitioning scheme generated in %pre for 2 drives" > /tmp/part-include
  echo "clearpart --all" >> /tmp/part-include
  echo "part /boot --fstype ext3 --size 75 --ondisk hda" >> /tmp/part-include
  echo "part / --fstype ext3 --size 1 --grow --ondisk hda" >> /tmp/part-include
  echo "part swap --recommended --ondisk $drive1" >> /tmp/part-include
  echo "part /home --fstype ext3 --size 1 --grow --ondisk hdb" >> /tmp/part-include
else
  #1 drive
  echo "#partitioning scheme generated in %pre for 1 drive" > /tmp/part-include
  echo "clearpart --all" >> /tmp/part-include
  echo "part /boot --fstype ext3 --size 75" >> /tmp/part-includ
  echo "part swap --recommended" >> /tmp/part-include
  echo "part / --fstype ext3 --size 2048" >> /tmp/part-include
  echo "part /home --fstype ext3 --size 2048 --grow" >> /tmp/part-include
fi

Этот сценарий определяет количество жёстких дисков в компьютере и сохраняет текстовый файл с другой схемой разбиения, если установлены один или два диска. Вместо того, чтобы вставлять набор команд разбиения в файл kickstart, добавьте строку:

%include /tmp/part-include

При этом будут выполняться команды разбиения, указанные в этом сценарии.

Замечание | Замечание
 | В разделе сценариев kickstart, выполняемых до установки, нельзя управлять множеством деревом установочных каталогов или исходным носителем. Эту информация должна включаться в каждый создаваемый файл ks.cfg, так как эти сценарии выполняются на втором этапе процесса установки.
Назад | Начало | Вперёд
Выбор пакетов | Вверх | Сценарий, выполняемый после установки


Обеспечение доступности файла Kickstart

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.8. Обеспечение доступности файла Kickstart

Файл kickstart должен быть расположен в одном из следующих размещений:

  • На загрузочной дискете

  • На загрузочном компакт-диске

  • В сети

Обычно файл kickstart копируется на загрузочную дискету или размещается в сети. Размещение в сети используется чаще, так как установки kickstart обычно выполняются на компьютерах, подключенных к сети.

Далее варианты размещения файла kickstart будут рассмотрены подробнее.

1.8.1. Создание загрузочного носителя Kickstart

Загрузка с дискеты в Red Hat Enterprise Linux более не поддерживается. Для загрузки программы установки необходимо использовать компакт-диски или флэш-накопители. Однако файл kickstart по-прежнему должен находится в корневом каталоге дискеты и называться ks.cfg.

При установке kickstart с использованием CD-ROM файл kickstart должен называться ks.cfg и располагаться в корневом каталоге компакт-диска. Так как компакт-диск доступен только на чтение, файл нужно добавить в каталог, из которого создаётся образ для записи на компакт-диск. Инструкции по созданию загрузочного носителя вы можете найти в Руководстве по установке Red Hat Enterprise Linux; но, прежде чем создавать файл образа file.iso, скопируйте файл kickstart ks.cfg в каталог isolinux/.

Для kickstart-установки с использованием флэш-накопителя файл kickstart должен иметь имя ks.cfg и располагаться в корневом каталоге флэш-диска. Сначала создайте загрузочный образ, а затем скопируйте файл ks.cfg.

Например, ниже показано, как перенести загрузочный образ на флэш-накопитель (/dev/sda) с помощью команды dd:

dd if=diskboot.img of=/dev/sda bs=1M

Замечание | Замечание
 | USB флэш-накопители можно сделать загрузочными, но на практике это сильно зависит от параметров BIOS. Узнать, поддерживает ли ваш компьютер загрузку с альтернативных устройств, можно у производителя вашего оборудования.

1.8.2. Предоставление доступа к файлу Kickstart по сети

Сетевые установки с помощью kickstart выполняются достаточно часто, так как системные администраторы могут автоматизировать установку множества сетевых компьютеров быстро и безболезненно. Вообще говоря, чаще всего этот подход требует от администратора настройки в локальной сети серверов BOOTP/DHCP и NFS. BOOTP/DHCP сервер определяет сетевую конфигурацию для клиентской системы, тогда как файлы, используемые во время установки, находятся на NFS-сервере. Часто эти два сервера располагаются на одной физической машине, хотя это и не требуется.

Чтобы выполнить kickstart-установку с использованием сети, вы должны установить в вашей сети сервер BOOTP/DHCP; он должен содержать параметры настройки компьютеров, на которые вы будете устанавливать Red Hat Enterprise Linux. Сервер BOOTP/DHCP предоставляет клиенту информацию о его сетевой конфигурации, а также о размещении файла kickstart.

Если файл kickstart определён сервером BOOTP/DHCP, клиентская система пытается смонтировать путь к файлу с помощью NFS, а затем скопировать и использовать указанный файл kickstart. Конкретные настройки могут меняться в зависимости от используемого сервера BOOTP/DHCP.

Ниже приведён пример строки из файла dhcpd.conf с DHCP-сервера:

filename "/usr/new-machine/kickstart/";
next-server blarg.redhat.com;

Обратите внимание, вы должны заменить значение после filename именем файла kickstart (или каталога, в котором располагается файл kickstart), а значение после next-server именем сервера NFS.

Если имя файла, возвращаемое BOOTP/DHCP сервером, оканчивается косой чертой ("/"), оно воспринимается только как путь. В этом случае клиентская система подключает этот путь, используя NFS, и ищет конкретный файл. Имя файла, который ищет клиент, имеет следующий вид:

<ip-addr>-kickstart

Часть <ip-addr> имени файла должна быть заменена IP-адресом клиента в виде десятичных чисел, разделенных точками. Например, файл для компьютера с IP-адресом 10.10.0.1 будет иметь имя 10.10.0.1-kickstart.

Обратите внимание, если вы не определите имя сервера, клиентская система попытается использовать в качестве сервера NFS текущий BOOTP/DHCP-сервер. Если вы не указываете путь или имя файла, клиентская система пытается смонтировать каталог /kickstart, расположенный на BOOTP/DHCP сервере, а затем пытается найти файл kickstart используя, имя <ip-addr>-kickstart, как описано выше.

Назад | Начало | Вперёд
Сценарий, выполняемый после установки | Вверх | Обеспечение доступности дерева каталогов установки


Начало установки при помощи Kickstart

Назад Глава 1. Установка при помощи Kickstart Вперёд

1.10. Начало установки при помощи Kickstart

Чтобы начать установку kickstart, вы должны загрузить компьютер с подготовленного вами загрузочного носителя или CD-ROM Red Hat Enterprise Linux №1 и ввести специальную команду в приглашении загрузчика. Программа установки ищет файл kickstart, если ядру передаётся аргумент командной строки ks.

CD-ROM №1 и дискета

Команда linux ks=floppy также будет работать, если файл ks.cfg размещён в файловой системе vfat или ext2 на дискете и вы загружаетесь с CD-ROM Red Hat Enterprise Linux №1.

Также можно загрузиться с компакт-диска Red Hat Enterprise Linux CD-ROM №1 и записать файл kickstart на дискету с файловой системой vfat или ext2 . Для этого введите в приглашении boot: следующую команду:

linux ks=hd:fd0:/ks.cfg

С диском драйверов

Если вам нужно использовать с kickstart диск драйверов, также укажите параметр dd. Например, чтобы загрузиться с загрузочной дискеты и использовать диск с драйверами, введите в приглашении boot: следующую команду:

linux ks=floppy dd
Загрузочный CD-ROM

Если вы разместили файл kickstart на загрузочном компакт-диске, как описано в разделе 1.8.1 Создание загрузочного носителя Kickstart, вставьте в компьютер CD-ROM, загрузите его и введите в приглашении boot: следующую команду (где ks.cfg — имя файла kickstart):

linux ks=cdrom:/ks.cfg

Ниже описаны другие параметры, используемые для запуска установки kickstart:

ks=nfs:<server>:/<path>

Программа установки ищет файл kickstart на NFS-сервере <server>, согласно указанному пути <path>. Программа установки настраивает Ethernet-платы, используя DHCP. Например, если ваш NFS-сервер называется server.example.com, а файл kickstart расположен в разделяемом NFS-ресурсе /mydir/ks.cfg, правильной командой загрузчика будет ks=nfs:server.example.com:/mydir/ks.cfg.

ks=http://<server>/<path>

Программа установки ищет файл kickstart на HTTP-сервере <server>, согласно указанному пути <path>. Программа установки настраивает Ethernet-платы, используя DHCP. Например, если ваш HTTP-сервер называется server.example.com, а файл kickstart расположен в разделяемом HTTP-ресурсе /mydir/ks.cfg, правильной командой загрузчика будет ks=http://server.example.com/mydir/ks.cfg.

ks=floppy

Программа установки ищет файл ks.cfg на дискете с файловой системой vfat или ext2, в устройстве /dev/fd0.

ks=floppy:/<path>

Программа установки ищет файл kickstart на дискете в устройстве /dev/fd0, согласно пути <path>.

ks=hd:<device>:/<file>

Программа установки монитирует файловую систему устройства <device> (поддерживаются vfat и ext2) и ищет в ней файл конфигурации kickstart с именем <file> (например, ks=hd:sda3/mydir/ks.cfg).

ks=file:/<file>

Программа установки попытается прочитать в файловой системе файл <file>, не выполняя никаких операций монтирования. Обычно этот вариант используется, если файл kickstart уже находится в образе initrd.

ks=cdrom:/<path>

Программа установки ищет файл kickstart на CD-ROM, согласно пути <path>.

ks

Если параметр ks используется без аргументов, программа установки настраивает Ethernet-плату, используя DHCP. Файл kickstart загружается с сервера, определённого параметром DHCP-ответа «bootServer», в случае, когда NFS-сервер предоставляет доступ к этому файлу. По умолчанию в качестве bootServer выступает DHCP-сервер. Имя файла kickstart будет выбрано следующим образом:

  • Если используется DHCP и сообщённое DHCP имя файла начинается с /, система ищет файл загрузки на сервере NFS.

  • Если используется DHCP и сообщённое DHCP имя файла начинается не с /, система ищет файл загрузки в каталоге /kickstart на сервере NFS.

  • Если служба DHCP не сообщила имя файла, программа установки пытается прочитать файл /kickstart/1.2.3.4-kickstart, где 1.2.3.4 десятичный IP-адрес компьютера, на котором производится установка.

ksdevice=<device>

Программа установки использует это сетевое устройство для подключения к сети. Например, чтобы начать kickstart-установку с файлом kickstart, который расположен на NFS-сервере, подключенном к компьютеру через устройство eth1, выполните команду ks=nfs:<server:>/<path> ksdevice=eth1 в ответ на приглашение boot:.

Назад | Начало | Вперёд
Обеспечение доступности дерева каталогов установки | Вверх | Настройка Kickstart


Добавление файла журнала

Назад Глава 36. Файлы журналов Вперёд

36.3. Добавление файла журнала

Чтобы добавить в список файл журнала, выберите в меню Правка (Edit) => Параметры (Preferences) и нажмите кнопку Добавить (Add) на вкладке Файлы журналов (Log Files).

Рисунок 36-3. Добавление файла журнала

Укажите имя, описание и размещение добавляемого файла журнала. Если этот файл существует, сразу после нажатия OK, он немедленно добавляется в область просмотра.

Назад | Начало | Вперёд
Просмотр файлов журналов | Вверх | Анализ файлов журналов


Анализ файлов журналов

Назад Глава 36. Файлы журналов Вперёд

36.4. Анализ файлов журналов

Программу Системные Log Viewer можно настроить, чтобы рядок со строками, содержащими критические ключевые слова, показывался значок критического события, а рядом со строками, содержащими предупреждающие ключевые слова — значок предупреждения.

Чтобы добавить критические слова, выберите в выпадающем меню Правка (Edit) => Параметры (Preferences) и перейдите на вкладку Тревоги (Alerts). Нажмите кнопку Добавить (Add) для добавления критического слова. Чтобы удалить критическое слово, выберите его в списке и нажмите кнопку Удалить (Delete).

Слева от строк, содержащих критические слова, отображается значок критического события [image] .

Рисунок 36-4. Тревоги

Чтобы добавить предупреждающие слова, выберите в выпадающем меню Правка (Edit) => Параметры (Preferences) и перейдите на вкладку Предупреждения (Warnings). Нажмите кнопку Добавить (Add) для добавления предупреждающего слова. Чтобы удалить предупреждающее слово, выберите его в списке и нажмите кнопку Удалить (Delete).

Слева от строк, содержащих предупреждающие слова, отображается предупреждающий значок [image] .

Рисунок 36-5. Предупреждение

Назад | Начало | Вперёд
Добавление файла журнала | Вверх | Обновление ядра вручную


Просмотр файлов журналов

Назад Глава 36. Файлы журналов Вперёд

36.2. Просмотр файлов журналов

Большинство файлов журналов имеют простой текстовый формат. Вы можете просмотреть их в любом текстовом редакторе, например, в Vi или Emacs. Некоторые файлы могут прочитать все пользователи системы, однако для чтения большинства файлов журналов требуются привилегии root.

Чтобы просмотреть файлы журналов системы в интерактивном приложении реального времени, воспользуйтесь программой Системные журналы (Log Viewer). Чтобы её запустить, выберите в главном меню Приложения (Applications) (на панели) => Система (System Tools) => Системные журналы (System Logs) или введите команду system-logviewer в приглашении оболочки.

Эта программа показывает только существующие файлы, поэтому вы можете увидеть не совсем то, что показано на рисунке 36-1.

Чтобы отфильтровать содержимое файла журнала по ключевым словам, введите их в текстовом поле Фильтровать по (Filter for) и нажмите кнопку Отфильтровать (Filter). Нажмите Сброс (Reset), чтобы сбросить содержимое.

Рисунок 36-1. Просмотр журналов

По умолчанию просматриваемый в данный момент файл журнала обновляется каждые 30 секунд. Чтобы поменять скорость обновления, выберите в выпадающем меню Правка (Edit) => Параметры (Preferences). На экране появится окно, показанное на рисунке 36-2. Чтобы задать другую скорость обновления, воспользуйтесь стрелками вверх и вниз рядом со значением скорости на вкладке Файлы журналов (Log Files). Нажмите Закрыть (Close), чтобы вернуться к основному окну. Скорость обновления меняется немедленно. Чтобы обновить просматриваемый в данный момент файл вручную, выберите в меню Файл (File) => Обновить сейчас (Refresh Now) или нажмите [Ctrl]-[R].

На вкладке Файлы журналов (Log Files) окна Параметры (Preferences) можно изменить расположение файла журнала. Выберите в списке файл журнала и нажмите кнопку Изменить (Edit). Введите новое расположение файла журнала и нажмите кнопку Обзор (Browse) для выбора размещения файла в диалоге выбора файла. Нажмите OK, чтобы вернуться к изменению параметров, и Закрыть (Close), чтобы вернуться к главному окну.

Рисунок 36-2. Расположение файла журнала

Назад | Начало | Вперёд
Файлы журналов | Вверх | Добавление файла журнала


Что такое LVM2?

Назад Глава 7. Диспетчер логических томов (LVM) Вперёд

7.2. Что такое LVM2?

LVM версии 2, или LVM2 работает в Red Hat Enterprise Linux по умолчанию и использует драйвер сопоставителя устройств, включённый в ядро 2.6. LVM2, почти полностью совместимый с предыдущей версией LVM1, можно обновить на версиях Red Hat Enterprise Linux с ядром 2.4.

Хотя переход с LVM1 на LVM2 обычно проходит без сложностей, обратитесь к разделу 7.3 Дополнительные ресурсы, чтобы подробнее узнать о более сложных требованиях и сценариях обновления.

Назад | Начало | Вперёд
Диспетчер логических томов (LVM) | Вверх | Дополнительные ресурсы


Дополнительные ресурсы

Назад Глава 7. Диспетчер логических томов (LVM) Вперёд

7.3. Дополнительные ресурсы

Чтобы узнать о LVM больше, обратитесь к следующим источникам.

7.3.1. Установленная документация

  • rpm -qd lvm — Эта команда выведете вам всю информацию, имеющуюся в пакете lvm, включая страницы man.

  • lvm help — Эта команда показывает все доступные команды LVM.

7.3.2. Полезные сайты

  • http://sourceware.org/lvm2 — веб-страница LVM2, содержащая обзор LVM, ссылку на списки расссылки и многое другое.

  • http://tldp.org/HOWTO/LVM-HOWTO/ — LVM HOWTO из проекта документации Linux.

Назад | Начало | Вперёд
Что такое LVM2? | Вверх | Настройка LVM


Разбиение LVM вручную

Назад Глава 8. Настройка LVM Вперёд

8.2. Разбиение LVM вручную

Следующий раздел рассказывает о настройке LVM в Red Hat Enterprise Linux вручную. Так как вы можете настраивать LVM вручную множеством способов, следующий пример иллюстрирует создание стандартной конфигурации, описанной в разделе 8.1 Автоматическое разбиение.

В диалоге Настройка разбиения диска (Disk Partitioning Setup) выберите вариант Ручное разбиение программой Disk Druid (Manually partition with Disk Druid).

8.2.1. Создание раздела /boot/

В обычной ситуации вы будете иметь дело с новыми, неформатированными дисками. На приведённом ниже рисунке 8-2 оба диска показаны неформатированными и не разбитыми на разделы.

Рисунок 8-2. Два чистых диска, готовых к настройке

Предупреждение | Предупреждение
 | Раздел /boot/ не может располагаться в группе логических томов, так как в этом случае загрузчику не удастся его прочитать.

  1. Выберите Создать (New).

  2. Выберите /boot в выпадающем меню Точка монтирования (Mount Point).

  3. Выберите ext3 в выпадающем меню Тип ФС (File System Type).

  4. Отметьте один флажок sda в области Доступные устройства (Allowable Drives).

  5. Оставьте значение 100 (по умолчанию) в меню Размер (Мбайт) (Size (MB)).

  6. Оставьте выбранным вариант Фикс. размер (Fixed size) (по умолчанию) в разделе Доп. опции размера (Additional Size Options).

  7. Отметьте Сделать первичным разделом (Force to be a primary partition), чтобы сделать раздел основным. Основным разделом считается один из первых четырёх разделов на жёстком диске. Если флажок не установлен, создаваемый раздел будет логическим. Если на этом компьютере уже установлены другие операционные системы, возможно, этот флажок следует снять. За дополнительными сведениями о различиях между основными и логическими/расширенными разделами, обратитесь к приложениям Руководства по установке Red Hat Enterprise Linux.

Сверьте введённые значения с показанными на рис. 8-3:

Рисунок 8-3. Создание загрузочного раздела

Нажмите OK, чтобы вернуться к основному окну. На следущем рисунке показан правильно определённый загрузочный раздел:

Рисунок 8-4. Созданный раздел /boot/

8.2.2. Создание физических томов LVM

После того, как создан загрузочный раздел, всё остальное пространство можно отвести под разделы LVM. Первым шагом при правильной реализации LVM является создание физического тома.

  1. Выберите Создать (New).

  2. Выберите физический том (physical volume) (LVM) в выпадающем меню Тип ФС (File System Type), как показано на рисунке 8-5.

    Рисунок 8-5. Создание физического тома

  3. На данном этапе вы не можете задать точку монтирования (но сможете, когда создадите все физические тома и группы томов).

  4. Физический том должен располагаться на одном диске. В списке Доступные устройства (Allowable Drives), выберите устройство, на котором будет создан физический том. Если у вас несколько дисков, автоматически выбираются все, и сначала вы должны снять отметки со всех, кроме одного.

  5. Введите размер, который вы хотите задать для физического тома.

  6. Выберите вариант Фикс. размер (Fixed size) и явно задайте размер тома, или Заполнить всё пространство до (Мбайт) (Fill all space up to (MB)) и введите предел размера физического тома, или Заполнить всё доступное пространство (Fill to maximum allowable size), чтобы он занял всё доступное пространство на жёстком диске. Если вы хотите сделать растущим более одного тома, такие тома поделят между собой свободное пространство на диске.

  7. Отметьте Сделать первичным разделом (Force to be a primary partition), если хотите, чтобы был создан основной раздел.

  8. Нажмите OK, чтобы вернуться к основному окну.

Повторяя эти действия, вы можете создать столько физических томов, сколько требуется для вашей конфигурации LVM. Например, если вы хотите, чтобы группа томов располагалась на нескольких дисках, создайте на каждом из них физический том. Следующий рисунок показывает, как выглядят диски после завершения всего процесса:

Рисунок 8-6. Два созданных физических тома

8.2.3. Создание групп LVM-томов

Создав все физические тома, вы можете создавать группы томов:

  1. Нажмите кнопку LVM, чтобы собрать физические тома в группы томов. Группа томов в общем представляет собой набор физических томов. У вас может быть несколько групп логических томов, но физический том может относиться только к одной группе томов.

    Замечание Замечание

    При использовании групп логических томов на диске резервируется дополнительное место. Сумма размеров физических томов может не равняться размеру группы томов, тем не менее, размер группы томов показывается правильно.

    Рисунок 8-7. Создание группы LVM-томов

  2. Если хотите, измените Имя группы томов (Volume Group Name).

  3. Пространство для любых логических томов внутри группы отводится физическими блоками. По умолчанию физический блок имеет размер 32 Мбайтам, таким образом размеры физических томов должны быть кратны 32 Мбайтам. Если вы введёте размер, не кратный этому числу, программа установки автоматически выберет ближайшее подходящее значение. Изменять этот параметр не рекомендуется.

  4. Выберите, физические тома, которые будут использоваться в этой группе томов.

8.2.4. Создание физических томов LVM

Создайте физические тома с точками монтирования, например, /, /home/ и том для подкачки. Помните, что раздел /boot не может быть логическим томом. Чтобы добавить логический том, нажмите кнопку Добавить (Add) в разделе Логические тома (Logical Volumes). На экране появится диалоговое окно, показанное на Рисунке 8-8.

Рисунок 8-8. Создание логического тома

Повторяйте эти действия для каждой создания каждой группы томов, которую вы хотите создать.

Подсказка | Подсказка
 | Возможно, вам захочется оставить какое-то место в группе логических томов, чтобы позже вы смогли расширить логические тома. При автоматической настройке по умолчанию этого не происходит, но в примере ручной настройки примерно 1 Гбайт оставляется нераспределённым, для будущего расширения.

Рисунок 8-9. Подготовленные логические тома

Нажмите OK, чтобы принять конфигурацию группы томов и всех связанных с ней логических томов.

Окончательная конфигурация, полученная при настройке вручную, показана на следующем рисунке:

Рисунок 8-10. Окончательная конфигурация

Назад | Начало | Вперёд
Настройка LVM | Вверх | Массив независимых дисков с избыточностью (RAID)


Добавление PXE-узлов

Назад Глава 3. Установка по сети с применением PXE Вперёд

3.3. Добавление PXE-узлов

После настройки сетевого сервера на экране появляется окно, показанное на рисунке 3-2.

Рисунок 3-2. Добавление узлов

Теперь необходимо определить, каким узлам разрешено подключаться к серверу PXE-загрузки. Описание этих действий, ориентированное на командную строку, вы найдёте в Разделе 3.3.1 Настройка в командной строке.

Для добавления узла нажмите кнопку Создать (New).

Рисунок 3-3. Добавление узла

Введите следующую информацию:

  • Имя узла или IP-адрес/подсеть (Hostname or IP Address/Subnet) — IP-адрес, полностью определённое имя узла или подсеть, определяющая множество компьютеров, которым разрешено обращаться к PXE-серверу для проведения установки.

  • Операционная система (Operating System) — Идентификатор операционной системы, которая будет устанавливаться на этом клиенте. В этот список включаются экземпляры сетевых установок, созданные в Диалоге «Сетевая установка» (Network Installation Dialog).

  • Использовать последовательную консоль (Serial Console) — Этот параметр позволяет использовать последовательную консоль.

  • Файл Kickstart (Kickstart File) — Размещение используемого файла, например, http://server.example.com/kickstart/ks.cfg. Этот файл создать с помощью инструмента Настройка Kickstart (Kickstart Configurator). За подробностями обратитесь к главе 2 Настройка Kickstart.

Параметры Название снимка (Snapshot name) и адаптер Ethernet (Ethernet) не важны. Они используется только для бездисковых окружений. За дополнительной информацией о настройке бездискового окружения обратитесь к главе 4 Бездисковое окружение.

3.3.1. Настройка в командной строке

Если на сетевом сервере система X не работает, для определения узлов, которым разрешено подключаться к PXE-серверу, можно воспользоваться утилитой pxeboot, входящей в пакет system-config-netboot:

pxeboot -a -K <kickstart> -O <os-identifier> -r <value> <host>

Её параметры рассматриваются ниже:

  • -a — Определяет, что узел добавляется.

  • -K <kickstart> — Размещение файла kickstart, если он используется.

  • -O <os-identifier> — Определяет идентификатор операционной системы, описанный в разделе 3.2 Настройка PXE-загрузки.

  • -r <value> — Определяет размер диска в ОЗУ.

  • <host> — Определяет IP-адрес или имя добавляемого узла.

За дополнительной информацией о доступных параметрах команды pxeboot обратитесь к странице man pxeboot.

Назад | Начало | Вперёд
Настройка PXE-загрузки | Вверх | Запуск tftp-сервера


Настройка DHCP-сервера

Назад Глава 3. Установка по сети с применением PXE Вперёд

3.5. Настройка DHCP-сервера

Если в вашей сети ещё нет DHCP-сервера, настройте его. Подробнее об этом можно узнать в главе 24 Протокол динамической настройки узлов (DHCP). Чтобы компьютеры, поддерживающие PXE, смогли выполнить PXE-загрузку, файл конфигурации должен содержать следующие строки:

allow booting;
allow bootp;
class "pxeclients" {
   match if substring(option vendor-class-identifier, 0, 9) = "PXEClient";
   next-server <server-ip>;
   filename "linux-install/pxelinux.0";
}

где вместо <server-ip> следует подставить IP-адрес tftp-сервера.

Назад | Начало | Вперёд
Запуск tftp-сервера | Вверх | Добавление своего сообщения загрузки


Настройка PXE-загрузки

Назад Глава 3. Установка по сети с применением PXE Вперёд

3.2. Настройка PXE-загрузки

После этого нужно скопировать файлы, необходимые для запуска установки, на tftp-сервер, чтобы они были доступны, когда клиент их запросит. Сервер tftp обычно разворачивается на том же компьютере, где и сетевой сервер, экспортирующий дерево каталогов установки.

Чтобы скопировать эти файлы, запустите на NFS, FTP или HTTP-сервере Настройку загрузки по сети (Network Booting Tool). Использовать для PXE отдельный сервер не требуется.

Эти же инструкции, но ориентированные на командную строку, вы найдёте в Разделе 3.2.1 Настройка в командной строке.

Чтобы вы могли использовать графическую версию инструмента Настройки загрузки по сети (Network Booting Tool), у вас должна работать система X Window, должен быть установлен RPM-пакет system-config-netboot и вы должны иметь права root. Чтобы запустить Настройку загрузку по сети (Network Booting Tool) с рабочего стола, выберите в главном меню Приложения (Applications) (на панели) => Системные параметры (System Settings) => Настройка сервера (Server Settings) => Служба загрузки по сети (Network Booting Service). Или введите команду system-config-netboot в приглашении оболочки (например, в XTerm или терминале среды GNOME).

Если вы запускаете Настройку загрузки по сети впервые, выберите в Помощнике первого запуска (First Time Druid) вариант Сетевая установка (Network Install). В противном случае, выберите в выпадающем меню Настройка (Configure) => Сетевая установка (Network Installation) и нажмите Добавить (Add). На экране появляется диалог, показанный на рис 3-1.

Рисунок 3-1. Сетевая установка

  • Идентификатор операционной системы (Operating system identifier) — укажите уникальное имя из одного слова, определяющее версию и редакцию Red Hat Enterprise Linux. Он используется в качестве имени подкаталога в каталоге /tftpboot/linux-install/.

  • Описание (Description) — Введите краткое описание данной версии и редакции Red Hat Enterprise Linux.

  • Выберите протокол для установки (Selects protocol for installation) — Выберите тип сетевой установки: NFS, FTP или HTTP, в зависимости от того, какой вы настроили ранее. Если выбран FTP и используется не анонимный FTP-сервер, снимите флажок Анонимный FTP (Anonymous FTP) и укажите правильное сочетание имени и пароля.

  • Файл Kickstart — Укажите размещение файла kickstart. Это может быть URL или путь к файлу, размещённому локально (на дискете). Файл kickstart можно создать с помощью инструмента Настройка Kickstart (Kickstart Configurator). За подробностями обратитесь к главе 2 Настройка Kickstart.

  • Сервер (Server) — Укажите доменное имя или IP-адрес NFS, FTP или HTTP-сервера.

  • Расположение (Location) — Укажите общий каталог сетевого сервера. Если был выбран вариант FTP или HTTP, этот каталог должен находиться внутри каталога по умолчанию FTP-сервера или корневого каталога документов HTTP-сервера. При любой сетевой установке указанный каталог должен содержать каталог RedHat/ дерева установки.

После нажатия OK файлы initrd.img и vmlinuz, необходимые для загрузки программы установки, переносятся из каталога images/pxeboot/ указанного дерева установки в каталог /tftpboot/linux-install/<os-identifier>/ сервера tftp (на котором вы запустили Настройку загрузки по сети (Network Booting Tool)).

3.2.1. Настройка в командной строке

Если на сетевом сервере система X не работает, для выполнения настройки файлов tftp-сервера, как описано в разделе 3.4 Запуск tftp-сервера, можно воспользоваться утилитой командной строки pxeos, входящей в пакет system-config-netboot.

pxeos -a -i "<description>" -p <NFS|HTTP|FTP> -D 0 -s client.example.com \
-L <net-location> -k <kernel> -K <kickstart> <os-identifer>

Данные параметры рассматриваются ниже:

  • -a — Указывает, что в конфигурацию PXE добавляется экземпляр ОС.

  • -i "<description>" — Замените <description> описанием экземпляра ОС. Ему соответствует поле Описание (Description), показанное на рисунке 3-1.

  • -p <NFS|HTTP|FTP> — Указывает, какой из протоколов: NFS, FTP или HTTP, использовать при установке. Указать можно только один из них. Ему соответствует меню Выберите протокол для установки (Select protocol for installation), показанное на рисунке 3-1.

  • -D <0|1> — Укажите значение «0», показывающее, что это не бездисковая конфигурация, так как pxeos также может использоваться для настройки бездискового окружения.

  • -s client.example.com — Укажите после параметра -s имя NFS, FTP или HTTP-сервера. Ему соответствует поле Сервер (Server), показанное на рисунке 3-1.

  • -L <net-location> — После параметра -L укажите размещение дерева установки на этом сервере. Ему соответствует поле Размещение (Location), показанное на рисунке 3-1.

  • -k <kernel> — Укажите для загрузки конкретную версию ядра в дереве установки сервера.

  • -K <kickstart> — Укажите размещение файла kickstart, если он используется.

  • <os-identifer> — Укажите идентификатор ОС, который используется в качестве имени подкаталога в каталоге /tftpboot/linux-install/. Ему соответствует поле Идентификатор операционной системы (Operating system identifier), показанное на рисунке 3-1.

Если в качестве протокола установки выбран FTP и используется не анонимный FTP-сервер, задайте имя пользователя и пароль для подключения, указав перед <os-identifer> в предыдущей команде следующие параметры:

-A 0 -u <username> -p <password>

За дополнительной информацией о доступных параметрах команды pxeos обратитесь к странице man pxeos.

Назад | Начало | Вперёд
Установка по сети с применением PXE | Вверх | Добавление PXE-узлов


Запуск tftp-срвера

Назад Глава 3. Установка по сети с применением PXE Вперёд

3.4. Запуск tftp-сервера

Проверьте, установлен ли на DHCP-сервере пакет tftp-server, выполнив команду rpm -q tftp-server. Если он отсутствует, установите его с компакт-дисков Red Hat Enterprise Linux или из сети Red Hat Network. За дополнительными сведениями об установке RPM-пакетов обратитесь к части III Управление пакетами.

tftp — это служба, работающая на базе xinetd; чтобы запустить её, выполните следующие команды:

/sbin/chkconfig --level 345 xinetd on
/sbin/chkconfig --level 345 tftp on

Эти команды настраивают немедленный запуск служб tftp и xinetd, а также запуск во время загрузки на уровнях выполнения 3, 4 и 5.

Назад | Начало | Вперёд
Добавление PXE-узлов | Вверх | Настройка DHCP-сервера


Псевдонимы устройств

Назад Глава 18. Настройка сети Вперёд

18.11. Псевдонимы устройств

Псевдонимы устройств — это виртуальные устройства с одним физическим оборудованием и разными IP-адресами, но их можно включить одновременно. Обычно они представлены в виде названия устройства, за которым следует двоеточие и число (например, eth0:1). Они полезны в случаях, когда вы хотите назначить компьютеру несколько IP-адресов, но у вас всего одна сетевая плата.

Настроив для устройства Ethernet (например, eth0) статический IP-адрес (DHCP с псевдонимами не поддерживается), перейдите на вкладку Устройства (Devices) и нажмите кнопку Создать (New). Выберите плату Ethernet, для которой вы хотите настроить псевдоним, определите статический IP-адрес псевдонима и нажмите Применить (Apply), чтобы его создать. Так как устройство для Ethernet-платы уже существует, для псевдонима создаётся ещё одно (например, eth0:1).

Предупреждение | Предупреждение
 | Если вы определяете для Ethernet-устройства псевдоним, ни для этого устройства, ни для псевдонима, нельзя использовать DHCP. Вы должны определять IP-адреса вручную.

На рисунке 18-18 показан пример псевдонима для устройства eth0. Заметьте, что устройство eth0:1 — это первый псевдоним eth0. Вторым псевдонимом для eth0 могло бы быть устройство с именем eth0:2, и т.д. Чтобы изменить параметры псевдонима, например, определить, будет ли он активироваться при загрузке, или задать номер псевдонима, выберите его из списка и нажмите клавишу Изменить (Edit).

Рисунок 18-18. Пример псевдонима сетевого устройства

Выберите псевдоним и нажмите кнопку Активизировать (Activate), чтобы его включить. Если вы настроили несколько профилей, выбери тот, в который следуют включить псевдоним.

Чтобы убедиться в том, что псевдоним работает, выполните команду /sbin/ifconfig. В результате вы должны увидеть устройство и его псевдоним с разными IP-адресами:

eth0      Link encap:Ethernet  HWaddr 00:A0:CC:60:B7:G4
          inet addr:192.168.100.5  Bcast:192.168.100.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:161930 errors:1 dropped:0 overruns:0 frame:0
          TX packets:244570 errors:0 dropped:0 overruns:0 carrier:0
          collisions:475 txqueuelen:100
          RX bytes:55075551 (52.5 Mb)  TX bytes:178108895 (169.8 Mb)
          Interrupt:10 Base address:0x9000

eth0:1    Link encap:Ethernet  HWaddr 00:A0:CC:60:B7:G4
          inet addr:192.168.100.42  Bcast:192.168.100.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:10 Base address:0x9000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5998 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5998 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1627579 (1.5 Mb)  TX bytes:1627579 (1.5 Mb)
Назад | Начало | Вперёд
Работа с профилями | Вверх | Установка IPsec-подключения


Управление параметрами DNS

Назад Глава 18. Настройка сети Вперёд

18.8. Управление параметрами DNS

На вкладке DNS вы можете определить имя компьютера, домен, адреса серверов имён и домен поиска. Серверы имён используются при поиске других узлов сети.

Если адреса DNS-серверов получаются по протоколу DHCP или PPPoE (или выдаются Интернет-провайдером), не добавляйте адреса первичного, вторичного или третичного DNS-серверов.

Если имя узла получается автоматически по протоколу DHCP или PPPoE (или выдаётся провайдером), не меняйте его.

Рисунок 18-14. Настройка DNS

Замечание | Замечание
 | Раздел серверов имён не позволяет сделать ваш компьютер сервером имён. Он предназначен только лишь для определения серверов имён, которые будут использоваться для разрешения IP-адресов в имена и наоборот.
Назад | Начало | Вперёд
Установка беспроводного подключения | Вверх | Управление узлами


Установка Ethernet-подключения

Назад Глава 18. Настройка сети Вперёд

18.2. Установка Ethernet-подключения

Чтобы установить Ethernet-подключение, вам понадобится сетевая плата (network interface card, NIC), сетевой кабель (обычно это CAT5) и сеть, к которой вы будете подключаться. Разные сети могут быть настроены на разные скорости, убедитесь в том, что ваша сетевая плата совместима с сетью, к которой вы хотите подключиться.

Чтобы добавить Ethernet-подключение, выполните следующие действия:

  1. Перейдите на вкладку Устройства (Devices).

  2. Нажмите кнопку Создать (New) на панели инструментов.

  3. Выберите Соединение Ethernet (Ethernet connection) в списке Тип соединения (Device Type) и нажмите кнопку Вперёд (Forward).

  4. Если ваша плата уже добавлена в список оборудования, выберете её из списка Карта Ethernet (Ethernet card). В противном случае выберите Другая карта Ethernet (Other Ethernet Card), чтобы добавить своё оборудование.

    Замечание Замечание

    Программа установки сама выявляет поддерживаемые устройства Ethernet и предлагает вам настроить их. Если вы настраивали устройства Ethernet во время установки, они показываются в списке оборудования на вкладке Оборудование (Hardware).

  5. Если вы выбрали Другая карта Ethernet (Other Ethernet Card), появляется окно Выберите адаптер Ethernet (Select Ethernet Adapter). Выберите производителя и модель платы Ethernet. Выберите название устройства. Если это первая плата Ethernet в компьютере, выберите в качестве названия устройства eth0, если вторая — выберите eth1 (и т.д.). Программа Настройка сети также позволяет вам настроить ресурсы сетевой платы. Нажмите Вперёд (Forward) для продолжения.

  6. В окне Настроить параметры сети (Configure Network Settings), показанном на рисунке 18-2, выберите между DHCP и статическим IP-адресом. Если устройство получает разные IP-адреса при каждом подключении к сети, не указывайте имя узла. Нажмите Вперёд (Forward) для продолжения.

  7. Нажмите Применить (Apply) на странице Создать устройство Ethernet (Create Ethernet Device).

Рисунок 18-2. Параметры Ethernet

После того, как вы настроите устройство Ethernet, оно появится в списке устройств, показанном на рисунке 18-3.

Рисунок 18-3. Устройство Ethernet

Не забудьте сохранить изменения, выбрав в меню Файл (File) => Сохранить (Save).

Добавив устройство Ethernet, вы можете изменить его настройки, выбрав устройство из списка и нажав Изменить (Edit). Например, после добавления устройства оно по умолчанию будет запускаться при загрузке. Чтобы изменить это поведение, откройте настройки устройства, измените значение Активизировать устройство при запуске компьютера (Activate device when computer starts) и сохраните изменения.

Сразу после добавления устройство не включается, о чём говорит состояние Неактивно (Inactive). Чтобы включить устройство, выберите его из списка и нажмите клавишу Активизировать (Activate). Если в системе настроено автоматическое включение устройства при запуске компьютера (по умолчанию это так), повторять это действие не потребуется.

Если вы связываете с одной платой Ethernet несколько устройств, вы получаете так называемые псевдонимы устройств. Псевдоним устройства позволяет вам назначить одному физическому устройству множество виртуальных, и, таким образом, привязывать к одному физическому устройству больше чем один IP-адрес. Например, вы можете настроить устройство eth1 и eth1:1. За подробностями обратитесь к разделу 18.11 Псевдонимы устройств.

Назад | Начало | Вперёд
Настройка сети | Вверх | Установка ISDN-подключения


Управление узлами

Назад Глава 18. Настройка сети Вперёд

18.9. Управление узлами

На вкладке Узлы (Hosts) вы можете добавить, изменить или удалить записи из файла /etc/hosts. Этот файл содержит IP-адреса и связанные с ними имена узлов.

Когда ваша система пытается преобразовать имя в IP-адрес или определить имя по IP-адресу, она обращается к файлу /etc/hosts перед обращением к серверам имён (если вы используете стандартную конфигурацию Red Hat Enterprise Linux). Если нужный IP-адрес присутствует в файле /etc/hosts, сервера имён не используются. Если в вашей сети есть компьютеры, IP-адреса которых отстутствуют в DNS, рекомендуется добавить их в файл /etc/hosts.

Чтобы добавить запись в файл /etc/hosts, перейдите на вкладку Узлы (Hosts), нажмите кнопку Создать (New) на панели инструментов, предоставьте требуемую информацию и нажмите OK. Выберите в меню Файл (File) => Сохранить (Save) или нажмите [Ctrl]-[S], чтобы сохранить изменения в файле /etc/hosts. Перезапускать сеть или сетевые службы не требуется, так как при каждом разрешении адреса система обращается к последней версии файла.

Предупреждение | Предупреждение
 | Не удаляйте запись localhost. Даже если компьютер не подключен к сети, или подключен не постоянно, некоторые программы должны подключаться к компьютеру через локальный фиктивный интерфейс localhost.

Рисунок 18-15. Настройка узлов

Подсказка | Подсказка
 | Порядок преобразования имён можно изменить в файле /etc/host.conf. Строка order hosts, bind определяет, что файл /etc/hosts просматривается до обращения к серверам имён. Изменив строку на order bind, hosts, вы укажите системе разрешать имена узлов и IP-адреса сначала на серверах имён. Если IP-адрес не удастся разрешить с помощью серверов имён, ваша система будет искать IP-адрес в файле /etc/hosts.
Назад | Начало | Вперёд
Управление параметрами DNS | Вверх | Работа с профилями


Установка IPsec-подключения

Назад Глава 18. Настройка сети Вперёд

18.12. Установка IPsec-подключения

IPsec расшифровывается как Internet Protocol Security (Безопасность протокола Интернета). Этот протокол позволяет организовать виртуальные частные сети (Virtual Private Network, VPN), в которых между двумя компьютерами или сетями устанавливается зашифрованное соединение (компьютер-компьютер или сеть-сеть, соответственно).

Подсказка | Подсказка
 | За дополнительными сведениями об IPsec обратитесь по адресу http://www.ipsec-howto.org/.

18.12.1. Соединение компьютер-компьютер

IPsec-соединение компьютер-компьютер — это зашифрованное соединение между двумя компьютерами, на которых работает IPsec с одним ключом шифрования. При активном IPsec-соединении весь трафик между двумя компьютерам шифруется.

Чтобы настроить IPSec-подключение компьютер-компьютер, выполните на каждом компьютере следующие действия:

  1. Запустите программу Настройка сети (Network Administration Tool).

  2. На вкладке IPsec нажмите кнопку Создать (New).

  3. Нажмите Вперёд (Forward), чтобы приступить к настройке IPsec-подключения компьютер-компьютер.

  4. Назначьте название подключения из одного слова, например, ipsec0, и укажите, должно ли подключение активироваться автоматически при запуске компьютера. Нажмите Вперёд (Forward).

  5. Выберите тип подключения Шифрование узел-узел (Host to Host encryption). Нажмите Вперёд (Forward).

  6. Выберите тип используемого шифрования: ручное или автоматическое.

    Если выбрано ручное шифрование, позже должен быть представлен ключ для шифрования. Если выбрано автоматическое шифрование, ключами шифрования управляет демон racoon. Если используется racoon, должен быть установлен пакет ipsec-tools.

    Нажмите Вперёд (Forward) для продолжения.

  7. Укажите IP-адрес другого компьютера.

    Если вы не знаете IP-адрес другого компьютера, запустите на нём команду /sbin/ifconfig <device>, где <device> — Ethernet-устройство, используемое для соединения компьютеров. Если в компьютере установлена всего одна плата Ethernet, устройство будет называться eth0. IP-адрес компьютера — это число, указанное за меткой inet addr:.

    Нажмите Вперёд (Forward) для продолжения.

  8. Если на этапе 6 вы выбрали ручное шифрование, укажите ключ, который будет использоваться, или нажмите Создать (Generate) чтобы создать его.

    Укажите ключ для проверки подлинности или нажмите Создать (Generate), чтобы создать его. Это может быть любое сочетание цифр и букв.

    Нажмите Вперёд (Forward) для продолжения.

  9. Проверьте эти данные на странице IPsec — Сводка (IPsec — Summary) и нажмите Применить (Apply).

  10. Выберите в меню Файл (File) => Сохранить (Save), чтобы сохранить конфигурацию.

  11. Выберите из списка IPsec-подключение и нажмите кнопку Активизировать (Activate).

  12. Повторите это действие на другом компьютере. Очень важно, чтобы на других компьютерах использовались ключи, выбранные на этапе 8. В противном случае, IPsec работать не будет.

После того, как вы настроите IPsec-подключение, оно появится в списке IPsec, показанном на рисунке 18-19.

Рисунок 18-19. IPsec-подключение

При этом в каталоге /etc/sysconfig/network-scripts/ создаются два файла ifcfg-<nickname> и keys-<nickname>. Если выбрано автоматическое шифрование, также создаётся файл /etc/racoon/racoon.conf.

В момент активизации интерфейса в каталоге /etc/racoon/ создаются файлы <remote-ip>.conf и psk.txt, а в файл racoon.conf включается <remote-ip>.conf.

Чтобы определить, успешно ли установлено IPsec-соединение, обратитесь к разделу 18.12.3 Проверка IPsec-соединения.

18.12.2. Соединение сеть-сеть (VPN)

Для организации IPsec-соединения сеть-сеть используются два IPsec-маршрутизатора, по одному для для каждой сети,через которые трафик проходит в частные подсети.

Например, как показано на рисунке 18-20, если частная сеть 192.168.0/24 передаёт трафик в частную сеть 192.168.2.0/24, пакеты проходят через gateway0 к ipsec0, затем через Интернет к ipsec1 и gateway1, и, наконец, попадают в сеть 192.168.2.0/24.

Маршрутизаторы IPsec должны иметь адресуемые в Интернете IP-адреса, также, как и любое другое Ethernet-устройство, подключающее частную сеть к Интернету. Трафик проходит через него, только если он связался с другом маршрутизатором IPsec и установил шифрованное соединение.

Рисунок 18-20. IPsec сеть-сеть

Также можно установить брандмауэры между IP-маршрутизаторами и Интернетом, и брандмауэры интрасети между маршрутизатором IPsec и шлюзом во внутреннюю сеть. Маршрутизатор IPsec и шлюз подсети можно организовать на одном компьютере с двумя устройствами Ethernet, первое, с внешним IP-адресом, будет работать как маршрутизатор IPsec, а второе, с внутренним IP-адресом, станет шлюзом в частную сеть. IPsec-маршрутизаторы будут использовать этот шлюз для трафика частной сети, а внешний шлюз — для пересылки пакетов другому маршрутизатору IPsec.

Чтобы настроить IPsec-соединение сеть-сеть, выполните следующие действия:

  1. Запустите программу Настройка сети (Network Administration Tool).

  2. На вкладке IPsec нажмите кнопку Создать (New).

  3. Нажмите Вперёд (Forward), чтобы приступить к настройке IPsec-подключения сеть-сеть.

  4. Назначьте название подключения из одного слова, например, ipsec0, и укажите, должно ли подключение активироваться автоматически при запуске компьютера. Нажмите Вперёд (Forward).

  5. Выберите вариант Шифрование сеть-сеть (Network to Network encryption) (VPN) и нажмите Вперёд (Forward).

  6. Выберите тип используемого шифрования: ручное или автоматическое.

    Если выбрано ручное шифрование, позже должен быть представлен ключ для шифрования. Если выбрано автоматическое шифрование, ключами шифрования управляет демон racoon. Если используется racoon, должен быть установлен пакет ipsec-tools. Нажмите Вперёд (Forward) для продолжения.

  7. На странице Локальная сеть (Local Network) введите следующие сведения:

    • Адрес локальной сети (Local Network Address) — IP-адрес устройства, которое соединяет IPsec-маршрутизатор с частной сетью.

    • Маска локальной сети (Local Subnet Mask) — Маска подсети для локального IP-адреса.

    • Шлюз локальной сети (Local Network Gateway) — Шлюз, соединяющий маршрутизатор с частной сетью.

    Нажмите Вперёд (Forward) для продолжения.

    Рисунок 18-21. Информация о локальной сети

  8. На странице Удалённая сеть (Remote Network) введите следующие сведения:

    • Удалённый адрес IP (Remote IP Address) — Адресуемый из внешнего мира IP-адрес маршрутизатора IPsec другой частной сети. В нашем примере, на компьютере ipsec0 следует ввести адресуемый из Интернета IP-адрес компьютера ipsec1, и наоборот.

    • Адрес удалённой сети (Remote Network Address) — Сетевой адрес частной сети, расположенной за другим маршрутизатором IPsec. В нашем примере, настраивая ipsec1, нужно ввести 192.168.1.0, а настраивая ipsec0 — 192.168.2.0.

    • Маска удалённой сети (Remote Subnet Mask) — Маска подсети удалённого IP-адреса.

    • Шлюз удалённой сети (Remote Network Gateway) — IP-адрес шлюза, соединяющего с удалённой сетью.

    • Если на этапе 6 вы выбрали ручное шифрование, укажите ключ, который будет использоваться, или нажмите Создать (Generate) чтобы создать его.

      Укажите ключ для проверки подлинности или нажмите Создать (Generate), чтобы создать его. Это может быть любое сочетание цифр и букв.

    Нажмите Вперёд (Forward) для продолжения.

    Рисунок 18-22. Информация об удалённой сети

  9. Проверьте эти данные на странице IPsec — Сводка (IPsec — Summary) и нажмите Применить (Apply).

  10. Выберите в меню Файл (File) => Сохранить (Save), чтобы сохранить конфигурацию.

  11. Выберите IPsec-подключение из списка и нажмите кнопку Активизировать (Activate).

  12. Включите маршрутизацию IP, выполнив от имени root в приглашении оболочки следующее:

    1. Отредактируйте /etc/sysctl.conf и задайте net.ipv4.ip_forward равным 1.

    2. Чтобы изменение вступило в силу, выполните команду:

      /sbin/sysctl -p /etc/sysctl.conf

Если необходимо, сценарий запуска сети, активизирующий IPsec-соединение, автоматически настраивает маршруты для передачи пакетов через маршрутизатор IPsec.

Чтобы определить, успешно ли установлено IPsec-соединение, обратитесь к разделу 18.12.3 Проверка IPsec-соединения.

18.12.3. Проверка IPsec-соединения

Чтобы проверить, шифрует ли IPsec пакеты, передаваемые между узлами (или сетями), запустите утилиту tcpdump и, проанализируйте пересылаемые сетевые пакеты. Пакет должен содержать заголовок AH и данные ESP. ESP означает, что шифрование работает. Например, выполните от имени root следующую команду:

# tcpdump

17:13:20.617872 pinky.example.com > ijin.example.com: \
        AH(spi=0x0aaa749f,seq=0x335): ESP(spi=0x0ec0441e,seq=0x335) (DF)

Команда tcpdump показывает сетевой трафик в режиме реального времени. Когда tcpdump поработает несколько секунд, вручную снимите этот процесс, нажав [Ctrl]-[C]. Вы должны увидеть подобные пакеты с ESP, показывающие, что IPsec работает.

Для расширенной проверки IPsec потребуются четыре компьютера, которые образую полную сеть IPsec с несколькими подсетями, но здесь это не рассматривается.

18.12.4. Запуск и остановка соединения

Если вы не настроили IPsec-соединение, чтобы оно запускалось при загрузке, запускайте и останавливайте его от имени root в командной строке.

Чтобы запустить соединение, выполните от имени root на каждом компьютере в схеме IPsec компьютер-компьютер или на каждом маршрутизаторе в схеме сеть-сеть (замените <ipsec-nick> именем, определённым ранее, например, ipsec0):

/sbin/ifup <ipsec-nick>

Чтобы разорвать соединение, выполните от имени root на каждом компьютере в схеме IPsec компьютер-компьютер или на каждом маршрутизаторе в схеме сеть-сеть (замените <ipsec-nick> именем, определённым ранее, например, ipsec0):

/sbin/ifdown <ipsec-nick>
Назад | Начало | Вперёд
Псевдонимы устройств | Вверх | Сохранение и восстановление сетевых параметров


Установка ISDN-подключения

Назад Глава 18. Настройка сети Вперёд

18.3. Установка ISDN-подключения

ISDN-подключение — это тип подключения к Интернету, устанавливаемого с помощью ISDN-модема по специальной телефонной линии, проведённой телефонной компанией. ISDN-подключения популярны в Европе.

Чтобы добавить ISDN-подключение, выполните следующее:

  1. Перейдите на вкладку Устройства (Devices).

  2. Нажмите кнопку Создать (New) на панели инструментов.

  3. Выберите Соединение ISDN (ISDN connection) в списке Тип соединения (Device Type) и нажмите кнопку Вперёд (Forward).

  4. Выберите ISDN-адаптер в выпадающем меню. Затем настройте ресурсы и протокол канала D для этого адаптера. Нажмите Вперёд (Forward) для продолжения.

    Рисунок 18-4. Параметры ISDN

  5. Если вы нашли своего провайдера Интернета (Internet Service Provider, ISP) в существующем списке, выберите его. В противном случае введите данные вашей учётной записи. Если вы их не знаете, свяжитесь со своим провайдером. Нажмите Вперёд (Forward).

  6. В окне Параметры IP (IP Settings) выберите Режим инкапсуляции (Encapsulation Mode) и определите, будет ли IP-адрес выдаваться автоматически или задаваться статически. Закончив, нажмите Вперёд (Forward).

  7. На странице Создать модемное подключение (Create Dialup Connection) нажмите кнопку Применить (Apply).

После настройки устройство ISDN появляется в списке устройств с типом ISDN, как показано на рисунке 18-5.

Не забудьте сохранить изменения, выбрав в меню Файл (File) => Сохранить (Save).

Добавив устройство ISDN, вы можете изменить его настройки, выбрав устройство из списка и нажав Изменить (Edit). Например, после добавления устройства оно по умолчанию не будет запускаться при загрузке. Чтобы изменить это, отредактируйте его конфигурацию. Вы можете изменить параметры сжатия, PPP, имя и пароль пользователя, и другие.

Сразу после добавления устройство не включается, о чём говорит состояние Неактивно (Inactive). Чтобы включить устройство, выберите его из списка и нажмите клавишу Активизировать (Activate). Если в системе настроено автоматическое включение устройства при запуске компьютера (по умолчанию это так), повторять это действие не потребуется.

Рисунок 18-5. Устройство ISDN

Назад | Начало | Вперёд
Установка Ethernet-подключения | Вверх | Установка модемного подключения


Установка модемного подключения

Назад Глава 18. Настройка сети Вперёд

18.4. Установка модемного подключения

С помощью модема можно установить подключение к Интернету по обычной телефонной линии. Для этого необходимо иметь учётную запись какого-либо Интернет-провайдера.

Чтобы добавить модемное подключение, выполните следующее:

  1. Перейдите на вкладку Устройства (Devices).

  2. Нажмите кнопку Создать (New) на панели инструментов.

  3. Выберите Модемное соединение (Modem connection) в списке Тип соединения (Device Type) и нажмите кнопку Вперёд (Forward).

  4. Если ваш модем уже настроен в списке оборудования (на вкладке Оборудование (Hardware)), программа Настройка сети (Network Administration Tool) предполагает, что для установки модемного подключения вы будете использовать его. Если модем ещё не настроен, она пытается выявить модемы, установленные в вашем компьютере. Это может занять некоторое время. Если модем не найден, появляется сообщение, предупреждающее вас о том, что показанные настройке не были получены в результате обнаружения оборудования.

  5. После выявления оборудования появляется окно, показанное на рисунке 18-6.

    Рисунок 18-6. Параметры модема

  6. Настройте физическое устройство, скорость порта, параметры управления потоком и громкость модема. Если вы не знаете, какие значение нужны, примите значения по умолчанию, если ваш модем был выявлен успешно. Если ваша станция не поддерживает тоновый набор, снимите соответсвующий флажок. Нажмите Вперёд (Forward).

  7. Если вы нашли своего Интернет-провайдера в существующем списке, выберите его. В противном случае введите данные вашей учётной записи. Если вы их не знаете, свяжитесь со своим провайдером. Нажмите Вперёд (Forward).

  8. На странице Параметры IP (IP Settings) определите, будет ли IP-адрес выдаваться автоматически или задавать статически. Закончив, нажмите Вперёд (Forward).

  9. На странице Создать модемное соединение (Create Dialup Connection) нажмите кнопку Применить (Apply).

После настройки модемное устройство появляется в списке устройств с типом Modem, как показано на рисунке 18-7.

Рисунок 18-7. Модемное устройство

Не забудьте сохранить изменения, выбрав в меню Файл (File) => Сохранить (Save).

Добавив модем, вы можете изменить его настройки, выбрав это устройство из списка и нажав Изменить (Edit). Например, после добавления устройства оно по умолчанию не будет запускаться при загрузке. Чтобы изменить это, отредактируйте его конфигурацию. Вы можете изменить параметры сжатия, PPP, имя и пароль пользователя, и другие.

Сразу после добавления устройство не включается, о чём говорит состояние Неактивно (Inactive). Чтобы включить устройство, выберите его из списка и нажмите клавишу Активизировать (Activate). Если в системе настроено автоматическое включение устройства при запуске компьютера (по умолчанию это так), повторять это действие не потребуется.

Назад | Начало | Вперёд
Установка ISDN-подключения | Вверх | Установка xDSL-подключения


Установка подключения Token Ring

Назад Глава 18. Настройка сети Вперёд

18.6. Установка подключения Token Ring

Сеть Token Ring — это сеть, в которой все компьютеры соединяются по кругу. Token(маркер) — это специальный сетевой пакет, который перемещается по сети и позволяет компьютерам передавать информацию друг другу.

Подсказка | Подсказка
 | За дополнительной информацией об использовании Token Ring в Linux обратитесь к сайту проекта Linux Token Ring, расположенному по адресу http://www.linuxtr.net/.

Чтобы добавить подключение Token Ring, выполните следующее:

  1. Перейдите на вкладку Устройства (Devices).

  2. Нажмите кнопку Создать (New) на панели инструментов.

  3. Выберите Соединение Token Ring (Token Ring connection) в списке Тип соединения (Device Type) и нажмите кнопку Вперёд (Forward).

  4. Если ваша плата Token Ring уже добавлена в список оборудования, выберете её из списка Карта Token Ring (Tokenring card). В противном случае выберите Другая карта Token Ring (Other Tokenring Card), чтобы добавить своё устройство.

  5. Если вы выберете вариант Другая карта Token Ring (Other Tokenring Card), на экране появится окно Выберите адаптер Token Ring (Select Token Ring Adapter), показанное на рисунке 18-10. Выберите производителя и модель адаптера. Выберите название устройства. Для первой платы Token Ring выберите название tr0, для второй — tr1 (и т.д.). Программа Настройка сети также позволяет пользователю настроить ресурсы адаптера. Нажмите Вперёд (Forward) для продолжения.

    Рисунок 18-10. Параметры Token Ring

  6. На странице Настроить параметры сети (Configure Network Settings) выберите между DHCP и статическим IP-адресом. Вы можете указать имя узла для этого устройства. Если устройство при подключении к сети получает динамический IP-адрес, не указывайте имя узла. Нажмите Вперёд (Forward) для продолжения.

  7. Нажмите Применить (Apply) на странице Создание устройства Token Ring (Create Tokenring Device).

После того, как вы настроите устройство Token Ring, оно появится в списке устройств, показанном на рисунке 18-11.

Рисунок 18-11. Устройство Token Ring

Не забудьте сохранить изменения, выбрав в меню Файл (File) => Сохранить (Save).

Добавив устройство, вы можете изменить его настройки, выбрав это устройство из списка и нажав Изменить (Edit). Например, вы можете определить, будет ли устройство запускаться при загрузке.

Сразу после добавления устройство не включается, о чём говорит состояние Неактивно (Inactive). Чтобы включить устройство, выберите его из списка и нажмите клавишу Активизировать (Activate). Если в системе настроено автоматическое включение устройства при запуске компьютера (по умолчанию это так), повторять это действие не потребуется.

Назад | Начало | Вперёд
Установка xDSL-подключения | Вверх | Установка беспроводного подключения


Установка беспроводного подключения

Назад Глава 18. Настройка сети Вперёд

18.7. Установка беспроводного подключения

Беспроводные Ethernet-устройства становятся всё более популярными. Настройка таких похожа на настройку Ethernet, за исключением того, что в данном случае вы можете определить такие параметры, как SSID и ключ беспроводного устройства.

Чтобы добавить беспроводное Ethernet-подключение, выполните следующее:

  1. Перейдите на вкладку Устройства (Devices).

  2. Нажмите кнопку Создать (New) на панели инструментов.

  3. Выберите Беспроводное соединение (Wireless connection) в списке Тип соединения (Device Type) и нажмите кнопку Вперёд (Forward).

  4. Если ваша беспроводная плата уже добавлена в список оборудования, выберете её из списка Беспроводная карта (Wireless card). В противном случае выберите Другая беспроводная карта (Other Wireless Card), чтобы добавить своё устройство.

    Замечание Замечание

    Обычно программа установки сама выявляет поддерживаемые беспроводные Ethernet-устройства и предлагает вам настроить их. Если вы настраивали их во время установки, они показываются в списке оборудования на вкладке Оборудование (Hardware).

  5. Если вы выбрали Другая беспроводная карта (Other Wireless Card), появляется окно Выберите адаптер Ethernet (Select Ethernet Adapter). Выберите производителя и модель беспроводной Ethernet-платы. Если это первая плата Ethernet в компьютере, выберите eth0, если вторая — eth1 (и т.д.). Программа Настройка сети также позволяет пользователю настроить ресурсы беспроводной сетевой платы. Нажмите Вперёд (Forward) для продолжения.

  6. На странице Параметры беспроводного соединения (Configure Wireless Connection), показанном на рисунке 18-12, настройте параметр своего беспроводного устройства.

    Рисунок 18-12. Параметры беспроводного соединения

  7. На странице Настроить параметры сети (Configure Network Settings) выберите между DHCP и статическим IP-адресом. Вы можете указать имя узла для этого устройства. Если устройство при подключении к сети получает динамический IP-адрес, не указывайте имя узла. Нажмите Вперёд (Forward) для продолжения.

  8. Нажмите Применить (Apply) на странице Создать беспроводное устройство (Create Wireless Device).

После того, как вы настроите беспроводное устройство, оно появится в списке устройств, показанном на рисунке 18-13.

Рисунок 18-13. Беспроводное устройство

Не забудьте сохранить изменения, выбрав в меню Файл (File) => Сохранить (Save).

Добавив беспроводное устройство, вы можете изменить его настройки, выбрав это устройство из списка и нажав Изменить (Edit). Например, вы можете определить, будет ли устройство включаться при загрузке.

Сразу после добавления устройство не включается, о чём говорит состояние Неактивно (Inactive). Чтобы включить устройство, выберите его из списка и нажмите клавишу Активизировать (Activate). Если в системе настроено автоматическое включение устройства при запуске компьютера (по умолчанию это так), повторять это действие не потребуется.

Назад | Начало | Вперёд
Установка подключения Token Ring | Вверх | Управление параметрами DNS


Установка xDSL-подключения

Назад Глава 18. Настройка сети Вперёд

18.5. Установка xDSL-подключения

DSL расшифровывается как Digital Subscriber Line (Цифровая абонентская линия). DSL бывает разных типов, например, ADSL, IDSL и SDSL. В программе Настройка сети используется термин xDSL, обозначающий все типы DSL-подключений.

Некоторые провайдеры DSL требуют, чтобы ваша система получала IP-адрес по DHCP через устройство Ethernet. Другие провайдеры требуют, чтобы вы настраивали подключение по протоколу точка-точка поверх Ethernet (Point-to-Point Protocol over Ethernet, PPPoE) через устройство Ethernet. Какой способ использовать вам, узнайте у своего провайдера.

Если от вас требуется использовать DHCP, обратитесь к разделу 18.2 Установка Ethernet-подключения за информацией о настройке устройства Ethernet.

Если от вас требуется использовать PPPoE, выполните следующие действия:

  1. Перейдите на вкладку Устройства (Devices).

  2. Нажмите кнопку Создать (New).

  3. Выберите Соединение xDSL (xDSL connection) в списке Тип соединения (Device Type) и нажмите Вперёд (Forward).

  4. Если вы нашли свою плату Ethernet в списке оборудования, выберите Устройство Ethernet (Ethernet Device) в выпадающем меню на странице, показанной на рисунке 18-8. В противном случае воспользуйтесь окном Выберите адаптер Ethernet (Select Ethernet Adapter).

    Замечание Замечание

    Программа установки сама выявляет поддерживаемые устройства Ethernet и предлагает вам настроить их. Если вы настраивали устройства Ethernet во время установки, они показываются в списке оборудования на вкладке Оборудование (Hardware).

    Рисунок 18-8. Параметры xDSL

  5. В появившемся окне Выберите адаптер Ethernet (Select Ethernet Adapter) выберите производителя и модель платы Ethernet. Выберите название устройства. Если это первая плата Ethernet в компьютере, выберите в качестве названия устройства eth0, если вторая — выберите eth1 (и т.д.). Программа Настройка сети также позволяет вам настроить ресурсы сетевой платы. Нажмите Вперёд (Forward) для продолжения.

  6. Введите Имя провайдера (Provider Name), Учётное имя (Login Name) и Пароль (Password). Если вы используете учётную запись T-Online, вместо того, чтобы вводить Учётное имя и Пароль в стандартном окне, нажмите кнопку Настройка учётной записи T-Online (T-Online Account Setup) и введите все необходимые сведения. Нажмите Вперёд (Forward) для продолжения.

  7. На странице Создать соединение DSL (Create DSL Connection) нажмите Применить.

После того, как вы настроите DSL-подключение, оно появится в списке устройств, показанном на рисунке 18-7.

Рисунок 18-9. Устройство xDSL

Не забудьте сохранить изменения, выбрав в меню Файл (File) => Сохранить (Save).

Добавив xDSL-подключение, вы можете изменить его настройки, выбрав соответствующее устройство из списка и нажав Изменить (Edit). Например, после добавления устройства оно по умолчанию не будет запускаться при загрузке. Чтобы изменить это, отредактируйте его конфигурацию.

Сразу после добавления устройство не включается, о чём говорит состояние Неактивно (Inactive). Чтобы включить устройство, выберите его из списка и нажмите клавишу Активизировать (Activate). Если в системе настроено автоматическое включение устройства при запуске компьютера (по умолчанию это так), повторять это действие не потребуется.

Назад | Начало | Вперёд
Установка модемного подключения | Вверх | Установка подключения Token Ring


Работа с профилями

Назад Глава 18. Настройка сети Вперёд

18.10. Работа с профилями

Для одного физического устройства можно создать множество логических сетевых устройств. Например, если в вашем компьютере установлена одна плата Ethernet (eth0), вы можете создать логические сетевые устройства с разными названиями и параметрами, при этом они будут связаны с eth0.

Логические сетевые устройства — это не то же самое, что псевдонимы устройств. Логические сетевые устройства, связанные с одним физическим устройство, должны существовать в разных профилях и не могут работать одновременно. Псевдонимы устройств также связаны с одним физическим сетевым устройством, но они могут быть активны одновременно. За подробностями создания псевдонимов устройств обратитесь к разделу 18.11 Псевдонимы устройств.

Для создания разных наборов настроек для разных сетей можно использовать профили. Набор настроек может включать логические устройства, а также параметры DNS и файл hosts. Определив профили, вы можете переключаться между ними с помощью программы Настройка сети (Network Administration Tool).

По умолчанию есть только один профиль, Common (стандартный). Чтобы создать новый профиль, выберите в выпадающем меню Профиль (Profile) => Создать (New) и введите уникальное имя профиля.

Теперь вы редактируете новый профиль, как можно увидеть в строке состояния в нижней части основного окна.

Выберите существующее устройство в списке и нажмите кнопку Скопировать (Copy), чтобы скопировать существующее устройство в логическое сетевое устройство. Если вы воспользуйтесь кнопкой Создать (New), создастся псевдоним, что будет неправильно. Чтобы изменить свойства логического устройства, выберите его из списка и нажмите Изменить свойства (Edit). Например, чтобы устройство было легче узнать, можно изменить название на более говорящее, например, eth0_office.

В списке устройств есть столбец с флажками Профиль (Profile). Вы можете включать или исключать устройства в каждом профиле. В текущий выбранный профиль включаются только отмеченные устройства. Например, если вы создаёте логическое устройство eth0_office в профиле Office и хотите активировать логическое устройство, если профиль выбран, снимите флажок с устройства eth0 и отметьте устройство eth0_office.

Например, на рисунке 18-16 показан профиль Office с логическим устройством eth0_office. В этом профиле первая плата Ethernet активизируется через DHCP.

Рисунок 18-16. Профиль Office

Заметьте, что профиль Home, показанный на рисунке 18-17 активизирует логическое устройство eth0_home, также связанное с eth0.

Рисунок 18-17. Профиль Home

Вы также можете сделать так, чтобы устройство eth0 активировалось только в профиле Office, а PPP-устройство (модем) — только в профиле Home. Также можно, например, сделать так, чтобы профиль Common активизировал eth0, а профиль Away — PPP-устройство, для использования во время путешествий.

Чтобы задействовать профиль во время загрузки, измените файл конфигурации загрузчика, включив параметр netprofile=<profilename>. Например, если на вашем компьютере в качестве загрузчика используется GRUB и файл /boot/grub/grub.conf содержит:

title Red Hat Enterprise Linux (2.6.9-5.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-5.EL ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.9-5.EL.img

измените его следующим образом (где <profilename> — имя профиля, который вы хотите задействовать при загрузке):

title Red Hat Enterprise Linux (2.6.9-5.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-5.EL ro root=/dev/VolGroup00/LogVol00 \
      netprofile=<profilename> \
      rhgb quiet
        initrd /initrd-2.6.9-5.EL.img

Чтобы переключить профили после загрузки системы, выберите в Главном меню (Main Menu) (на панели) => Система (System Tools) => Управление устройствами сети (Network Device Control) (или введите команду system-control-network), затем выберите нужный профиль и активируйте его. Раздел активизации профилей появляется в программе Управление устройствами сети (Network Device Control), только если существуют интерфейсы помимо стандартного Common.

Вы также можете включить профиль,выполнив следующую команду (замените <profilename> названием профиля):

system-config-network-cmd --profile <profilename> --activate
Назад | Начало | Вперёд
Управление узлами | Вверх | Псевдонимы устройств


Сохранение и восстановление сетевых параметров

Назад Глава 18. Настройка сети Вперёд

18.13. Сохранение и восстановление сетевых параметров

Для сохранения сетевых параметров системы в файле можно воспользоваться версией программы Настройка сети для командной строки. Затем с помощью этого файла можно будет восстановить сетевые параметры системы Red Hat Enterprise Linux.

Эту возможность можно использовать в автоматическом сценарии резервного копирования, для копирования конфигурации перед обновлением или переустановкой или для переноса конфигурации в другую систему Red Hat Enterprise Linux.

Чтобы сохранить или экспортировать сетевые параметры системы в файл /tmp/network-config, выполните от имени root следующую команду:

system-config-network-cmd -e > /tmp/network-config

Чтобы восстановить или импортировать сетевые параметры из файла, созданного предыдущей командой, выполните от имени root команду:

system-config-network-cmd -i -c -f /tmp/network-config

Параметр -i выполняет импорт данных, -c очищает существующую конфигурацию перед импортом, а -f определяет файл, который должен импортироваться.

Назад | Начало | Вперёд
Установка IPsec-подключения | Вверх | Основная настройка брандмауэра


Дополнительные ресурсы

Назад Глава 22. Сетевая файловая система (NFS) Вперёд

22.4. Дополнительные ресурсы

В этой главе рассматривались основы использования NFS. За более подробной информацией обратитесь к следующим ресурсам.

22.4.1. Установленная документация

  • Страницы man nfsd, mountd, exports, auto.master и autofs (разделы руководства 5 и 8) — На этих страницах показан правильный синтаксис файлов конфигурации NFS и autofs.

22.4.2. Полезные сайты

  • http://nfs.sourceforge.net/ — Веб-страница NFS, содержащая адреса почтовых рассылок и ответы на часто задаваемые вопросы.

  • http://www.tldp.org/HOWTO/NFS-HOWTO/index.html — Набор инструкций Linux NFS-HOWTO из проекта документации Linux.

22.4.3. Книги по этой теме

  • Managing NFS and NIS Services (автор Хал Стерн (Hal Stern), издательство O'Reilly & Associates, Inc.).

Назад | Начало | Вперёд
Экспорт файловых систем NFS | Вверх | Samba


Экспорт файловых систем NFS

Назад Глава 22. Сетевая файловая система (NFS) Вперёд

22.3. Экспорт файловых систем NFS

Предоставление в общий доступ или разделение файлов NFS-сервером называется экспортом каталогов. Для настройки системы в качестве NFS-сервера можно воспользоваться програмой Настройка сервера NFS (NFS Server Configuration Tool).

Чтобы вы могли использовать графическую версию средства Настройка сервера NFS (NFS Server Configuration Tool), у вас должна работать система X Window, должен быть установлен RPM-пакет system-config-nfs и вы должны иметь права root. Чтобы запустить это приложение, выберите в Главном меню (Main Menu) (на панели) => Системные параметры (System Settings) => Настройка сервера (Server Settings) => NFS или введите команду system-config-nfs.

Рисунок 22-1. Настройка сервера NFS

Чтобы добавить NFS-ресурс, нажмите кнопку Добавить (Add). На экране появляется окно, показанное на Рисунке 22-2.

На вкладке Основные (Basic) вы должны задать следующие сведения:

  • Каталог (Directory) — Укажите разделяемый каталог, например /tmp.

  • Узел(узлы) (Host(s)) — Укажите названия узла (узлов), для которых вы предоставляете доступ к каталогу. Допустимые форматы имён описываются в разделе 22.3.2 Форматы имён узлов.

  • Основные права доступа (Basic permissions) — Укажите, будут ли для каталога назначены разрешения только на чтение или на чтение/запись.

Рисунок 22-2. Добавление ресурса

Вкладка Общие параметры (General Options) позволяет настроить следующие параметры:

  • Разрешить соединения с портов 1024 и выше (Allow connections from port 1024 and higher) — Службы, работающие с портами до 1024, должны быть запущены от имени root. Выберите этот вариант, что разрешить запуск NFS-службы другими пользователями. Этот параметр соответствует указанию insecure.

  • Разрешить небезопасную блокировку файлов (Allow insecure file locking) — Запрос на блокировку не требуется. Этот параметр соответствует указанию insecure_locks.

  • Запретить проверку подкаталогов (Disable subtree checking) — Если экспортируется подкаталог файловой системы, но не вся файловая система, сервер, проверяет, находится ли запрошенный файл в экспортированном подкаталоге. Эта проверка называется проверкой подкаталога. Отметьте этот пункт, чтобы запретить проверку подкаталогов. Если экспортируется вся файловая система, запрет проверки подкаталогов может увеличить скорость передачи. Этот параметр соответствует указанию no_subtree_check.

  • Синхронизировать операции записи по запросу (Sync write operations on request) — Включенный по умолчанию, этот параметр не позволяет серверу отвечать на запросы до того, как изменения, внесённые запросом будут записаны на диск. Этот параметр соответствует указанию sync. Если этот параметр не установлен, используется режим async.

    • Принудительно синхронизировать операции записи немедленно (Force sync of write operations immediately) — Не откладывает запись на диск. Этот параметр соответствует указанию no_wdelay.

Вкладка Доступ пользователей (User Access) позволяет настроить следующие параметры:

  • Рассматривать удалённого пользователя root как локального root (Treat remote root user as local root) — По умолчанию коды группы и пользователя root равны 0. Механизм смещения root сопоставляет группу и пользователя с кодом 0 с группой и пользователем anonymous, чтобы root на клиенте не получил привилегии root на NFS-сервере. Если выбран этот параметр, сопоставление root с anonymous не происходит и root на клиенте получает привилегии root в экспортированных каталогах. Выбор этого варианта может серьёзно повредить безопасности системы. Не выбирайте его, если это не абсолютно необходимо. Этот параметр соответствует указанию no_root_squash.

  • Рассматривать всех пользователей клиентов как анонимных пользователей (Treat all client users as anonymous users) — Если указан этот параметр, коды любых групп и пользователей сопоставляются с пользователем anonymous. Этот параметр соответствует указанию all_squash.

    • Укажите ID локального пользователя для анонимных пользователей (Specify local user ID for anonymous users) — Если выбран вариант Рассматривать всех пользователей клиентов как анонимных пользователей, этот параметр позволяет вам указать код анонимного пользователя. Этот параметр соответствует указанию anonuid.

    • Укажите ID локальной группы для анонимных пользователей (Specify local group ID for anonymous users) — Если выбран вариант Рассматривать всех пользователей клиентов как анонимных пользователей, этот параметр позволяет вам указать код группы анонимного пользователя. Этот параметр соответствует указанию anongid.

Чтобы отредактировать существующий NFS-раздел, выберите раздел из списка и нажмите кнопку Свойства (Properties). Чтобы удалить существующий NFS-раздел, выберите раздел из списка и нажмите кнопку Удалить (Delete).

После того, как вы добавите, измените или удалите из списка NFS-раздел и нажмёте OK, изменения вступают в силу немедленно — демон сервера перезагружается, а старый файл конфигурации сохраняется под именем /etc/exports.bak. Новая конфигурация записывается в файл /etc/exports.

Средство Настройка NFS-сервера (NFS Server Configuration Tool) читает и пишет непосредственно файл конфигурации /etc/exports. Таким образом, после работы с этой программой файл можно поменять вручную, а затем снова использовать эту программу (если синтаксис файла не был нарушен).

22.3.1. Настройка в командной строке

Если вы предпочитаете редактировать файлы конфигурации в текстовом редакторе, или у вас не установлена система X Window, вы можете изменить этот файл конфигурации непосредственно.

Каталогами, экспортируемыми NFS-сервером, управляет файл /etc/exports. Он имеет следующий формат:

directory hostname(options)

Единственный параметр, который следует указать — это sync или async (рекомендуется sync). Если вы указали sync, сервер не бедт отвечать на запросы раньше, чем запрошенные изменения будут записаны на диск.

Например,

/misc/export     speedy.example.com(sync)

позволит пользователям компьютера speedy.example.com подключить /misc/export со стандартными разрешениемя (только чтение), а

/misc/export     speedy.example.com(rw,sync)

позволит пользователям компьютера speedy.example.com подключить /misc/export с разрешениями на чтение и запись.

Допустимые форматы имён узлов описываются в разделе 22.3.2 Форматы имён узлов.

Список параметров, которые здесь можно указаться, вы найдёте в Справочном руководстве по Red Hat Enterprise Linux.

Внимание Внимание

Будьте осторожны, используя пробелы в файле /etc/exports. Если между именем компьютера и параметрами в скобках пробелы отсутствует, эти параметры будут относиться только к компьютеру. Если же между именем компьютера и параметрами присутствует пробел, эти параметры относятся ко всем остальным компьютерам. Например, рассмотрите следующие строки:

/misc/export speedy.example.com(rw,sync)
/misc/export speedy.example.com (rw,sync)

В первой строке пользователи компьютера speedy.example.com получают доступ на чтение-запись, а всем остальным доступ запрещён. Во второй строке пользователи компьютера speedy.example.com получают доступ только на чтение (по умолчанию), а все остальные получают доступ на чтение и запись.

Как только вы изменили файл /etc/exports, вы должны сообщить демону NFS об этом изменении, или перезагрузить файл конфигурации, с помощью следующей команды:

/sbin/service nfs reload

22.3.2. Форматы имён узлов

Имя узла (узлов) может задаваться в следующей форме:

  • Один компьютер — Полностью определённое доменное имя (которое сможет разрешить сервер), имя узла (которое сможет разрешить сервер) или IP-адрес.

  • Набор компьютеров, определённый знаками подстановки — Используйте символ * или ?, чтобы определить строку совпадения. Знаки подстановки не должны использоваться в IP-адресах, однако, они могут случайно заработать, если обратный поиск в DNS не удастся. При указаниии в полностью определённом доменном имени знаков подстановки, точки (.) в них не включаются. Например, строка *.example.com включает имя one.example.com, но не включает one.two.example.com.

  • IP-сети — Используйте запись вида a.b.c.d/z, где a.b.c.d — адрес сети, а z — число бит в маске сети (например, 192.168.0.0/24). Также допускается формат a.b.c.d/netmask, где a.b.c.d — сеть, а netmask — маска сети (например, 192.168.100.8/255.255.255.0).

  • Сетевые группы — В виде @group-name, где group-name — имя сетевой группы NIS.

22.3.3. Запуск и остановка сервера

На сервере, экспортирующем файловые системы NFS, должна работать служба nfs.

Просмотрите состояние демона NFS, выполнив следующую команду:

/sbin/service nfs status

Запустите демона NFS с помощью следующей команды:

/sbin/service nfs start

Остановите демона NFS с помощью следующей команды:

/sbin/service nfs stop

Чтобы служба nfs запускалась при загрузке, выполните следующую команду:

/sbin/chkconfig --level 345 nfs on

Определить службы, запускающиеся при загрузке системы вы также можете с помощью chkconfig, ntsysv или средства Настройка служб (Services Configuration Tool). За подробностями обратитесь к главе 20 Управление доступа к службам.

Назад | Начало | Вперёд
Монтирование файловых систем NFS | Вверх | Дополнительные ресурсы


Монтирование файловых систем NFS

Назад Глава 22. Сетевая файловая система (NFS) Вперёд

22.2. Монтирование файловых систем NFS

Для монтирования общего NFS-каталога другого компьютера используйте команду mount :

mount shadowman.example.com:/misc/export /misc/local

Предупреждение | Предупреждение
 | К моменту выполнения этой команду уже должен существовать каталог точки монтирования на локальном компьютере (в приведённом выше примере /mnt/local).

В этой команде shadowman.example.com — имя узла файлового сервера NFS, /misc/export — каталог, который экспортирует shadowman, а /misc/local — размещение монтируемой файловой системы на локальном компьютере. Выполнив команду mount (и имея необходимые разрешения на NFS-сервере shadowman.example.com), клиент может запустить команду ls /misc/local и получить список файлов в каталоге /misc/export на компьютере shadowman.example.com.

22.2.1. Подключение файловых систем NFS с помощью /etc/fstab

Также можно подключить NFS-ресурс другого компьютера, добавив строку в файл /etc/fstab. В этой строке указывается имя NFS-сервера, каталог, экспортируемый этим сервером, и каталог локального компьютера, в который будет смонтирован этот NFS-ресурс. Чтобы изменить файл /etc/fstab, вы должны быть пользователем root.

Типичная запись в файле /etc/fstab выглядит следующим образом:

server:/usr/local/pub    /pub   nfs    rsize=8192,wsize=8192,timeo=14,intr

К моменту выполнения этой команды, каталог /pub уже должен существовать на клиентском компьютере. Добавив эту строку в файл /etc/fstab на клиентском компьютере, введите в приглашении оболочки команду mount /pub, и каталог /pub будет смонтирован с сервера.

22.2.2. Монтирование файловых систем NFS с помощью autofs

Кроме этого, подключить NFS-ресурс можно с помощью службы autofs. Autofs использует демона automount для управления своими точками монтирования, монтируя их динамически по мере обращения.

Autofs анализирует главный файл сопоставлений /etc/auto.master для определения точек монтирования. Затем запускается процесс автоматического монтирования каждой точки с указанными параметрами. Каждая строка в главном файле сопоставлений определяет точку монтирования, а отдельный файл сопоставлений определяет, какие файловые системы должны быть смонтированы в эту точку. Например, файл /etc/auto.mnt может определять точки монтирования для каталога /mnt, и эта связь будет определяться в файле /etc/auto.master.

Каждая запись в auto.master имеет три поля. В первом поле указывается точка монтирования. Во втором поле определяется размещение файла сопоставлений, а третье поле является необязательным. Третье поле может содержать дополнительную информацию, например значение таймаута.

Например, чтобы смонтировать каталог /proj52 удалённого компьютера penguin.example.net в точку монтирования /mnt/myproject на вашем компьютере, добавьте в файл auto.master следующую строку:

/misc   /etc/auto.misc --timeout 60

Затем, добавьте в файл /etc/auto.mnt следующую строку:

myproject  -rw,soft,intr,rsize=8192,wsize=8192 penguin.example.net:/proj52

Первое поле в файле /etc/auto.mnt содержит имя подкаталога в /misc. Этот подкаталог динамически создаётся демоном automount. Он не должен существовать на клиентском компьютере. Второе поле содержит параметры подключения, например, параметр rw разрешает доступ на чтение и запись. В третьем поле определяется размещение NFS-экспорта, включая имя компьютера и каталога.

Замечание | Замечание
 | Каталог /misc должен уже существовать в локальной файловой системе. При этом в локальном каталоге /misc не должно быть подкаталогов.

Чтобы запустить службу autofs, введите в приглашении оболочки следующую команду:

/sbin/service autofs restart

Чтобы просмотреть активные точки монтирования, введите в приглашении оболочки следующую команду:

/sbin/service autofs status

Если вы измените файл конфигурации /etc/auto.master во время работы autofs, вы должны указать демону automount перегрузить его, выполнив следующую команду в приглашении оболочки:

/sbin/service autofs reload

Чтобы узнать, как настроить запуск autofs при загрузке, и получить другую информацию об управлении службами, обратитесь к разделу 20 Управление доступом к службам.

22.2.3. Использование TCP

Транспортным протоколом в NFSv4 по умолчанию является TCP; однако, ядро Red Hat Enterprise Linux 4 также поддерживает NFS поверх UDP. Чтобы использовать NFS поверх TCP, при подключении экспортированной файловой системы NFS на клиентском компьютере передайте параметр -o udp команде mount.

Подключить экспорт файловой системы NFS можно тремя способами. По требованию, в командной строке (на стороне клиента), автоматически, с помощью файла /etc/fstab (на стороне клиента) и автоматически, с помощью файлов конфигурации autofs, например, /etc/auto.master и /etc/auto.misc (на стороне сервера с использованием NIS).

Например, чтобы настроить экспорт в командной строке (на стороне клиента):

mount -o udp shadowman.example.com:/misc/export /misc/local

Когда NFS-монтирование указано в /etc/fstab (на стороне клиента):

server:/usr/local/pub    /pub   nfs    rsize=8192,wsize=8192,timeo=14,intr,udp

Когда NFS-монтирование указано в файле конфигурации NIS-сервера (для рабочих станций, поддерживающих NIS):

myproject  -rw,soft,intr,rsize=8192,wsize=8192,udp penguin.example.net:/proj52

Так как по умолчанию используется TCP, если параметр -o udp не указан, клиент обращается к экспортированной файловой системе NFS по протоколу TCP.

Использование TCP даёт в частности следующие преимущества:

  • Повышенная прочность соединения, то есть меньше сообщений NFS stale file handles.

  • Выигрыш в скорости в сильно загруженных сетях, так как TCP подтверждает каждый пакет, в отличие от UDP, который подтверждает только завершение всей операции.

  • TCP имеет лучшие средства для работы в загруженных сетях, по сравнению с UDP (у него их вообще нет). В первую очередь в сильно загруженных сетях пропадают пакеты UDP. Это значит, что если NFS пишет данные блоками по 8 Кбайт, по UDP приходится передавать повторно все 8 Кбайт. А так как TCP работает надёжно, передаются только части этих 8 Кбайт.

  • Выявление ошибок. Когда TCP-соединение разрывается (по причине недоступности сервера) клиент прекращает передачу данных и перезапускает подключение, пока сервер не будет доступен. Так как протокол UDP не контролирует подключения, сеанс продолжает забрасывать сеть данными, пока сервер не восстановит подключение.

Основным недостатком TCP является очень незначительное снижение производительности из-за накладных расходов, связанных с протоколом TCP.

22.2.4. Сохранение ACL

Ядро Red Hat Enterprise Linux 4 обеспечивает поддержку ACL для файловой системы ext3 и файловых системы ext3, смонтированных с использованием протоколов NFS или Samba. Таким образом, если в файловой системе ext3 включены ACL, она экспортируется через NFS, и NFS-клиент может читать ACL, он также будет работать с ACL.

Назад | Начало | Вперёд
Сетевая файловая система (NFS) | Вверх | Экспорт файловых систем NFS


Дополнительные ресурсы

Назад Глава 21. OpenSSH Вперёд

21.4. Дополнительные ресурсы

Проекты OpenSSH и OpenSSL находятся в постоянном развитии, поэтому за самой последней информацией о них обращайтесь к их сайтам. Хорошими источниками информации о инструментах OpenSSH и OpenSSL также являются страницы руководства man.

21.4.1. Установленная документация

  • Страницы man ssh, scp, sftp, sshd и ssh-keygen — Эти страницы руководства содержат информацию об использовании этих команды, а также обо всех их параметрах.

21.4.2. Полезные сайты

  • http://www.openssh.com/ — Страница часто-задаваемых вопросов, посвященных OpenSSH, сообщения об ошибках, списки рассылки, задачи проекта и подробное техническое описание возможностей.

  • http://www.openssl.org/ — Страница часто-задаваемых вопросов относительно OpenSSL, списки рассылки и описание задач проекта.

  • http://www.freessh.org/ — Клиентское программное обеспечение SSH для других платформ.

21.4.3. Книги по этой теме

  • Справочное руководство по Red Hat Enterprise Linux — В нём описывается последовательность событий, происходящих в процессе SSH-соединения, рассматривается список файлов конфигурации и рассказывается о том, как можно использовать SSH для перенаправления X.

Назад | Начало | Вперёд
Настройка клиента OpenSSH | Вверх | Сетевая файловая система (NFS)


Настройка клиента OpenSSH

Назад Глава 21. OpenSSH Вперёд

21.3. Настройка клиента OpenSSH

Чтобы подключиться к серверу OpenSSH с клиентского компьютера, на этом компьютере вы должны установить пакеты openssh-clients и openssh.

21.3.1. Использование команды ssh

Команда ssh является безопасной заменой команд rlogin, rsh и telnet. Она позволяет вам регистрироваться и выполнять команды на удалённом компьютере.

Регистрация на удалённом компьютере с помощью ssh похожа на использование telnet. Чтобы зарегистрироваться на удалённом компьютере с именем penguin.example.net, введите следующую команду в приглашении оболочки:

ssh penguin.example.net

При первом ssh-подключении к удалённому компьютеру вы увидите подобное сообщение:

The authenticity of host 'penguin.example.net' can't be established.
DSA key fingerprint is 94:68:3a:3a:bc:f3:9a:9b:01:5d:b3:07:38:e2:11:0c.
Are you sure you want to continue connecting (yes/no)?

Введите yes для продолжения. При этом сервер будет добавлен в ваш список известных узлов ~/.ssh/known_hosts/), о чём говорит следующее сообщение:

Warning: Permanently added 'penguin.example.net' (RSA) to the list of known hosts.

Затем вы увидите приглашение для ввода пароля удалённого компьютера. Введя правильный пароль, вы окажетесь в приглашении оболочки удалённого компьютера. Если вы не указываете имя пользователя, на удалённый компьютер передаётся имя, с которым вы зарегистрированы на локальном клиентском компьютере. Если же вы хотите указать другое имя пользователя, выполните следующую команду:

ssh username@penguin.example.net

Вы можете использовать и такую запись: ssh -l username penguin.example.net.

Команда ssh может применяться для выполнения команд на удалённом компьютере без использования приглашения оболочки. При этом используется запись: ssh hostname command. Например, если вы хотите выполнить команду ls /usr/share/doc на удалённом компьютере penguin.example.net, введите в приглашении оболочки:

ssh penguin.example.net ls /usr/share/doc

Когда вы введёте правильный пароль, на экране появится содержимое удалённого каталога /usr/share/doc и вы вернётесь к приглашению своей локальной оболочки.

21.3.2. Использование команды scp

Команда scp используется для передачи файлов между компьютерами через безопасное, шифрованное соединение. Она похожа на rcp.

Общий синтаксис передачи локального файла на удалённый компьютер выглядит так:

scp <localfile> username@tohostname:<remotefile>

Здесь <localfile> указывает исходный файл, включая путь к нему, например, /var/log/maillog. Параметр <remotefile> определяет назначение; это может быть новое имя файла, например /tmp/hostname-maillog. Если вы не укажите в начале пути удалённого каталога /, будет выбран путь относительно домашнего каталога пользователя username, обычно это /home/username/.

Чтобы переслать локальный файл shadowman в домашний каталог вашей учётной записи на компьютере penguin.example.net, введите в приглашении оболочки следующее (подставьте вместо username ваше имя пользователя):

scp shadowman username@penguin.example.net:shadowman

При этом локальный файл shadowman скопируется в /home/username/shadowman на компьютере penguin.example.net. Вы также можете опустить имя файла shadowman в конце команды scp.

Общий синтаксис передачи удалённого файла на локальный компьютер выглядит так:

scp username@tohostname:<remotefile> <newlocalfile>

Где <remotefile> обозначает исходный файл, включая путь, а <newlocalfile> — назначение, включая путь.

В качестве исходных файлов можно указать несколько файлов. Например, чтобы переслать содержимое каталога downloads/ в существующий каталог uploads/ удалённого компьютера penguin.example.net, введите в приглашении оболочки следующую команду:

scp downloads/* username@penguin.example.net:uploads/

21.3.3. Использование команды sftp

Утилита sftp используется для создания защищенного, интерактивного сеанса FTP. Она похожа на ftp, за исключением того, что используется безопасное, зашифрованное соединение. Общий синтакстис команды: sftp username@hostname.com. Пройдя проверку подлинности, вы можете использовать тот же набор команд, что и с FTP. Список этих команд можно получить на странице man sftp. Чтобы прочитать страницу man, выполните в приглашении оболочки man sftp. Утилита sftp включена в состав пакета OpenSSH версии 2.5.0p1 и выше.

21.3.4. Создание пар ключей

Если вы не хотите вводить пароль при каждом подключении к удалённому компьютеру с помощью ssh, scp или sftp, вы можете создать пару ключей для авторизации.

Ключи должны быть созданы для каждого пользователя. Чтобы создать ключи для пользователя, выполните следующие действия от имени пользователя, который будет подключаться к удалённым компьютерам. Если вы выполните эти действия под именем root, только root сможет использовать эти ключи.

Начиная с OpenSSH верии 3.0, файлы ~/.ssh/authorized_keys2, ~/.ssh/known_hosts2 и /etc/ssh_known_hosts2 являются устаревшими. В протоколах SSH 1 и 2 используются файлы ~/.ssh/authorized_keys, ~/.ssh/known_hosts и /etc/ssh/ssh_known_hosts.

Red Hat Enterprise Linux 4 по умолчанию использует протокол SSH версии 2 и ключи RSA.

Подсказка | Подсказка
 | Если вы переустанавливаете систему и хотите сохранить созданную пару ключей, сделайте копию подкаталога .ssh в вашем домашнем каталоге. Переустановив систему, верните скопированный каталог в свой домашний каталог. Этот процесс можно выполнить для всех пользователей вашей системы, включая root.

21.3.4.1. Создание пары ключей RSA для версии 2

Чтобы создать пару ключей RSA для версии 2 протокола SSH, следуйте следующим указаниям. OpenSSH, начиная с версии 2.9, по умолчанию использует этот протокол.

  1. Чтобы создать пару ключей RSA, работающих с протоколом версии 2, введите в приглашении оболочки следующую команду:

    ssh-keygen -t rsa

    Согласитесь с предложенным расположением файла ~/.ssh/id_rsa. Введите секретную фразу, отличную от пароля вашей учётной записи и подтвердите её.

    Открытый ключ сохраняется в файле ~/.ssh/id_rsa.pub. Закрытый ключ сохраняется в ~/.ssh/id_rsa.pub. Никогда не давайте свой закрытый ключ никому.

  2. Измените разрешения на каталог .ssh, выполнив следующую команду:

    chmod 755 ~/.ssh

  3. Скопируйте содержимое ~/.ssh/id_rsa.pub в файл ~/.ssh/authorized_keys на компьютер, к которому вы хотите подключиться. Если на другом компьютере уже существует файл ~/.ssh/authorized_keys, добавьте содержимое файла ~/.ssh/id_rsa.pub в файл ~/.ssh/authorized_keys.

  4. Измените разрешения файла authorized_keys, выполнив следующую команду:

    chmod 644 ~/.ssh/authorized_keys

  5. Если вы используете GNOME, перейдите к разделу 21.3.4.4 Настройка ssh-agent в GNOME. Если вы не используйте систему X Window , перейдите к разделу 21.3.4.5 Настройка ssh-agent.

21.3.4.2. Создание пары ключей DSA для версии 2

Выполните следующие действия для создания пары ключей DSA для версии 2 протокола SSH.

  1. Чтобы создать пару ключей DSA, работающих с протоколом версии 2, введите в приглашение оболочки следующую команду:

    ssh-keygen -t dsa

    Согласитесь с предложенным расположением файла ~/.ssh/id_dsa. Введите секретную фразу, отличную от пароля вашей учётной записи и подтвердите её.

    Подсказка Подсказка

    Секретная фраза — это строка слов и символов, используемая для проверки подлинности пользователя. Секретные фразы отличаются от паролей, тем, что они могут содержать пробелы и табуляции. Секретные фразы обычно длиннее паролей, так как чаще всего это не одно слово, а несколько.

    Открытый ключ сохраняется в файле ~/.ssh/id_dsa.pub. Закрытый ключ сохраняется в ~/.ssh/id_dsa. Важно никогда и никому не давать свой закрытый ключ.

  2. Измените разрешения на каталог .ssh с помощью следующей команды:

    chmod 755 ~/.ssh

  3. Скопируйте содержимое ~/.ssh/id_dsa.pub в файл ~/.ssh/authorized_keys на компьютер, к которому вы хотите подключиться. Если на другом компьютере уже существует файл ~/.ssh/authorized_keys, добавьте содержимое файла ~/.ssh/id_dsa.pub в файл ~/.ssh/authorized_keys.

  4. Измените разрешения файла authorized_keys, выполнив следующую команду:

    chmod 644 ~/.ssh/authorized_keys

  5. Если вы используете GNOME, перейдите к разделу 21.3.4.4 Настройка ssh-agent в GNOME. Если вы не используйте систему X Window , перейдите к разделу 21.3.4.5 Настройка ssh-agent.

21.3.4.3. Создание пары ключей RSA для версии 1.3 и 1.5

Выполните следующие действия для создания пары ключей RSA для версии 1 протокола SSH. Если вы системы, который вы соединяете, используют только DSA, пара ключей для RSA версий 1.3 и 1.5 вам не нужна.

  1. Чтобы создать пару ключей RSA (для версий протокола 1.3 и 1.5), введите в приглашении оболочки следующую команду:

    ssh-keygen -t rsa1

    Согласитесь с предложенным расположением файла (~/.ssh/identity). Введите секретную фразу, отличную от пароля вашей учётной записи. Подтвердите секретную фразу, введя её снова.

    Открытый ключ сохраняется в файле ~/.ssh/identity.pub. Закрытый ключ сохраняется в ~/.ssh/identity. Не давайте никому свой закрытый ключ.

  2. Измените права доступа к своему каталогу .ssh и ключу, выполнив команды chmod 755 ~/.ssh и chmod 644 ~/.ssh/identity.pub.

  3. Скопируйте содержимое ~/.ssh/identity.pub в файл ~/.ssh/authorized_keys на компьютер, к которому вы хотите подключиться. Если файл ~/.ssh/authorized_keys не существует, вы можете скопировать файл ~/.ssh/identity.pub в файл ~/.ssh/authorized_keys удалённого компьютера.

  4. Если вы используете GNOME, перейдите к разделу 21.3.4.4 Настройка ssh-agent в GNOME. Если вы не используете GNOME, перейдите к разделу 21.3.4.5 Настройка ssh-agent.

21.3.4.4. Настройка ssh-agent в GNOME

Программа ssh-agent может сохранять вашу секретную фразу, чтобы вам не понадобилось вводить её при каждом установлении соединения ssh или scp. Если вы работает в GNOME, вы можете воспользоваться программой, которое спросит у вас секретную фразу при входе в систему и сохранит её до выхода из GNOME (она включена в пакет openssh-askpass-gnome). В этом случае вам не придётся вводить пароль или секретную фразу для каждого ssh или scp-соединения, установленного в течении этого сеанса GNOME. Если вы не используете GNOME, перейдите к разделу 21.3.4.5 Настройка ssh-agent.

Чтобы сохранить вашу секретную фразу в течение сеанса GNOME, выполните следующие действия:

  1. Вам потребуется установить пакет openssh-askpass-gnome; чтобы проверить, установлен ли он, выполните команду rpm -q openssh-askpass-gnome. Если он не установлен, установите его с компакт-дисков Red Hat Enterprise Linux, FTP-сайта (или зеркала) Red Hat или воспользуйтесь сетью Red Hat Network.

  2. Выберите в Главном меню (Main Menu) (на панели) => Параметры (Preferences) => Дополнительные параметры (More Preferences) => Сеансы (Sessions) и перейдите на вкладку Программы, запускаемые при старте (Startup Programs). Нажмите кнопку Добавить (Add) и введите /usr/bin/ssh-add в текстовом поле Команда, запускаемая при старте (Startup Command). Задайте коэфициент приоритета, больший, чем у любой существующей команды, чтобы эта команда выполнялась последней. Подходящим значением приоритета для ssh-add будет 70 или выше. Чем выше коэффициент приоритета, тем ниже приоритет. Если у вас перечислены другие программы, это должна иметь наименьший приоритет. Нажмите Закрыть (Close), чтобы выйти из программы.

  3. Выйдите из системы и вернитесь в GNOME; другими словами, перезапустите X. После запуска GNOME на экране появляется диалог, предлагающий ввести вашу секретную фразу. Введите требуемую секретную фразу. Если вы создавали пары ключей DSA и RSA, вы будете вводить обе фразы. С этого момента вы не будете вводить пароль для того, чтобы использовать ssh, scp или sftp.

21.3.4.5. Настройка ssh-agent

Программа ssh-agent может сохранять вашу секретную фразу, чтобы вам не понадобилось вводить её при каждом установлении соединения ssh или scp. Если вы не используете X Window System, выполните следующие действия в приглашении оболочки. Если вы используете GNOME, но не хотите, чтобы он спрашивал вас секретную фразу при регистрации (как описано в разделе 21.3.4.4 Настройка ssh-agent в GNOME), эта процедура будет работать в окне терминала, например, XTerm. Если же вы используете X, но не GNOME, в окне терминала будет работать следующая процедура. Однако, ваша секретная фраза будет сохранена только в окне терминала; она не будет доступна глобально.

  1. В приглашении оболочки выполните следующую команду:

    exec /usr/bin/ssh-agent $SHELL

  2. Затем введите команду:

    ssh-add

    и введите вашу секретную фразу. Если вы настроили несколько пар ключей, вам будет предложено ввести пароль для каждой.

  3. Когда вы завершите сеанс, ваша секретная фраза будет забыта. Вы должны выполнять эти две команды каждый раз при регистрации на виртуальной консоли или создании нового окна терминала.

Назад | Начало | Вперёд
Настройка сервера OpenSSH | Вверх | Дополнительные ресурсы


Настройка сервера OpenSSH

Назад Глава 21. OpenSSH Вперёд

21.2. Настройка сервера OpenSSH

Прежде чем запускать сервер OpenSSH, вы должны убедиться в том, что установлены нужные RPM-пакеты . Необходимо установить пакет openssh-server, зависящий от пакета openssh.

Демон OpenSSH использует файл конфигурации /etc/ssh/sshd_config. Для большинства применений должно быть достаточно стандартного файла конфигурации. Если же вы хотите настроить поведение демона, отличное от определённого в стандартном sshd_config, на странице man sshd вы можете найти список ключевых слов, которые можно использовать в файле конфигурации.

Запустить службу OpenSSH вы можете, выполнив команду /sbin/service sshd start. Остановить службу OpenSSH можно, выполнив команду /sbin/service sshd stop. Если вы хотите, чтобы демон автоматически запускался при загрузке системы, обратитесь к главе 20 Управление доступом к службам за информацией об управлении службами.

Если вы выполните переустановку, в новой системе будет создан новый набор ключей. Клиенты, которые подключались к системе средствами OpenSSH до переустановки, увидят следующее сообщение:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.

Если вы хотите сохранить созданные для вашей системы ключи, сделайте копию файлов /etc/ssh/ssh_host*key* и восстановите её после переустановки. При этом уникальный ключ системы будет сохранен, и когда клиенты попытаются подключиться к системе после переустановки, этого предупреждения они не увидят.

Назад | Начало | Вперёд
OpenSSH | Вверх | Настройка клиента OpenSSH


Дополнительные ресурсы

Назад Глава 41. OProfile Вперёд

41.9. Дополнительные ресурсы

Эта глава освещает только основные моменты OProfile и знакомит с его настройкой и использованием. Чтобы узнать о нём больше, обратитесь к следующим источникам.

41.9.1. Установленная документация

  • /usr/share/doc/oprofile-<version>/oprofile.html — Руководство по OProfile

  • Страница man oprofile — Посвящена opcontrol, opreport, opannotate и op_help

41.9.2. Полезные сайты

  • http://oprofile.sourceforge.net/ — Содержит самую последнюю документацию, списки рассылки, каналы IRC и многое другое.

Назад | Начало | Вперёд
Графический интерфейс | Вверх | Предметный указатель


Анализ данных

Назад Глава 41. OProfile Вперёд

41.5. Анализ данных

Демон OProfile oprofiled периодически собирает выборки и сохраняет их в каталоге /var/lib/oprofile/samples/. Прежде чем анализировать эти данные, убедитесь в том, что в этом каталоге все необходимые данные сохранены, выполнив от имени root следующую команду:

opcontrol --dump

В имени каждого файла с данными отражено имя исполняемого модуля. Например, выборки события по умолчанию на процессоре Pentium III для /bin/bash будут называться:

\{root\}/bin/bash/\{dep\}/\{root\}/bin/bash/CPU_CLK_UNHALTED.100000

Для обработки уже собранных данных мониторинга предназначены следующие инструменты:

  • opreport

  • opannotate

Используйте эти инструменты и отслеживаемый двоичный код для построения отчётов, которые затем можно будет анализировать.

Предупреждение | Предупреждение
 | Чтобы проанализировать данные, помимо этих инструментов необходимо иметь отслеживаемый исполняемый код. Если этот код необходимо изменять после сбора данных, сделайте резервную копию не только файлов с показателями мониторинга, но и исполняемого модуля, мониторинг которого выполнялся.

Выборки, связанные с каждым исполняемым файлом, сохраняются в отдельном файле. Выборки, связанные с динамически загружаемыми библиотеками, также сохраняются в отдельном файле. Если в процессе работы OProfile отслеживаемый исполняемый модуль изменяется, и существует файл с данными его мониторинга, этот файл автоматически удаляется. Таким образом, если существующий файл с данными необходим, его необходимо скопировать вместе с исполняемым модулем, прежде чем исполняемый модуль будет заменён новой версией. За подробными инструкциями по копированию файла данных обратитесь к разделу 41.4 Сохранение данных.

41.5.1. Использование opreport

Программа opreport предоставляет сводку по всем отслеживаемым исполняемым модулям.

Ниже приведён фрагмент вывода этой команды:

Profiling through timer interrupt
          TIMER:0|
  samples|      %|
------------------
    25926 97.5212 no-vmlinux
      359  1.3504 pi
       65  0.2445 Xorg
       62  0.2332 libvte.so.4.4.0
       56  0.2106 libc-2.3.4.so
       34  0.1279 libglib-2.0.so.0.400.7
       19  0.0715 libXft.so.2.1.2
       17  0.0639 bash
        8  0.0301 ld-2.3.4.so
        8  0.0301 libgdk-x11-2.0.so.0.400.13
        6  0.0226 libgobject-2.0.so.0.400.7
        5  0.0188 oprofiled
        4  0.0150 libpthread-2.3.4.so
        4  0.0150 libgtk-x11-2.0.so.0.400.13
        3  0.0113 libXrender.so.1.2.2
        3  0.0113 du
        1  0.0038 libcrypto.so.0.9.7a
        1  0.0038 libpam.so.0.77
        1  0.0038 libtermcap.so.2.0.8
        1  0.0038 libX11.so.6.2
        1  0.0038 libgthread-2.0.so.0.400.7
        1  0.0038 libwnck-1.so.4.9.0

Для каждого исполняемого модуля отводится отдельная строка. В первом столбце указывается число выборок, сделанных для этого исполняемого модуля. Во втором столбце указывается процентное отношение этого числа к общему числу выборок. В третьем столбе указывается имя исполняемого модуля.

Обратитесь к странице man opreport за списком доступных параметров командной строки, в число которых входит, например, параметр -r, сортирующий выводимые строки в порядке возрастания числа выборок для исполняемого модуля.

41.5.2. Использование opreport для одного исполняемого модуля

Чтобы получить более подробную информацию о конкретном исполняемом модуле, используйте opreport:

opreport <mode> <executable>

Здесь вместо <executable> необходимо указть полный путь к анализируемому исполняемому модулю. Параметр <mode> может принимать следующее значения:

-l

Выводит список выбранных данных по символам. Например, ниже показан фрагмент результата выполнения команды opreport -l /lib/tls/libc-<version>.so:

samples  %        symbol name
12       21.4286  __gconv_transform_utf8_internal
5         8.9286  _int_malloc
4         7.1429  malloc
3         5.3571  __i686.get_pc_thunk.bx
3         5.3571  _dl_mcount_wrapper_check
3         5.3571  mbrtowc
3         5.3571  memcpy
2         3.5714  _int_realloc
2         3.5714  _nl_intern_locale_data
2         3.5714  free
2         3.5714  strcmp
1         1.7857  __ctype_get_mb_cur_max
1         1.7857  __unregister_atfork
1         1.7857  __write_nocancel
1         1.7857  _dl_addr
1         1.7857  _int_free
1         1.7857  _itoa_word
1         1.7857  calc_eclosure_iter
1         1.7857  fopen@@GLIBC_2.1
1         1.7857  getpid
1         1.7857  memmove
1         1.7857  msort_with_tmp
1         1.7857  strcpy
1         1.7857  strlen
1         1.7857  vfprintf
1         1.7857  write

В первом столбце указывается начальный адрес в виртуальной памяти (virtual memory address, vma). Во втором столбце указывается число выборок, сделанных для этого символа. Третий столбец показывает процентное отношение этого числа к общему числу выборок для исполняемого модуля, а четвёртый — имя символа.

Чтобы отсортировать результаты в обратном порядке, передайте в командной строке -r вместе с параметром -l.

-i <symbol-name>

Выводит данные выборок, связанных с заданным символом. Например, ниже показан фрагмент результата выполнения команды opreport -l -i __gconv_transform_utf8_internal /lib/tls/libc-<version>.so:

samples  %        symbol name
12       100.000  __gconv_transform_utf8_internal

В первой строке приводится сводка по указанному символу/исполняемому модулю.

В первом столбце указывается число выборок, сделанных для этого символа в памяти. Во втором столбце указывается процентное отношение числа выборок по этому адресу в памяти к общему числу выборок, сделанных для этого символа. Название символа указывается в третьем столбце.

-d

Выводит данные выборки по символам в более подробном виде, чем -l. Например, ниже показан фрагмент результата выполнения команды opreport -l -d __gconv_transform_utf8_internal /lib/tls/libc-<version>.so:

vma      samples  %        symbol name
00a98640 12       100.000  __gconv_transform_utf8_internal
00a98640 1         8.3333
00a9868c 2        16.6667
00a9869a 1         8.3333
00a986c1 1         8.3333
00a98720 1         8.3333
00a98749 1         8.3333
00a98753 1         8.3333
00a98789 1         8.3333
00a98864 1         8.3333
00a98869 1         8.3333
00a98b08 1         8.3333

В результате выводятся те же данные, что и с параметром -l, только в данном случае для каждого символа показыватся используемый адрес виртуальной памяти. По каждому адресу показывается число выборок и процентное отношение этого числа к общему числу выборок для данного символа.

-x <symbol-name>

Исключает из результатов указанные через запятую символы.

session:<name>

Определяет полный путь к сеансу или каталогу относительно каталога /var/lib/oprofile/samples/.

41.5.3. Использование opannotate

Утилита opannotate пытается сопоставить выборки, полученные при выполнении конкретных инструкций, с соответствующими строками в исходном коде. В формируемых ей файлах слева от этих строк будут представлены полученные выборки. Она также помещает комментарий в начало листинга каждой функции, и помещает в него сводку по выборкам, полученным в этой функции.

Чтобы эта утилита работала, исполняемый модуль должен быть скомпилирован компилятором GCC с ключом -g. По умолчанию пакеты Red Hat Enterprise Linux компилируются без этого ключа.

Общий синтаксис opannotate выглядит так:

opannotate --search-dirs <src-dir> --source <executable>

В параметрах необходимо указать каталоги анализируемого исходного кода и исполняемой программы. За списком дополнительных параметров командной строки обратитесь к странице man opannotate.

Назад | Начало | Вперёд
Сохранение данных | Вверх | Изучение /dev/oprofile/


Настройка OProfile

Назад Глава 41. OProfile Вперёд

41.2. Настройка OProfile

Прежде чем OProfile можно будет запустить, его необходимо настроить. Как минимум, необходимо выбрать, включить ли мониторинг ядра или нет. В следующих разделах рассказывается о том, как настроить OProfile с помощью утилиты opcontrol. При выполнении команд opcontrol параметры настройки сохраняются в файле /root/.oprofile/daemonrc.

41.2.1. Указание ядра

Прежде всего определите, будет ли OProfile осуществлять мониторинг ядра. Это единственный обязательный параметр, который необходимо настроить до запуска OProfile. Остальные параметры не являются обязательными.

Чтобы включить мониторинг ядра, выполните от имени root следующую команду:

opcontrol --setup --vmlinux=/usr/lib/debug/lib/modules/`uname -r`/vmlinux

Замечание | Замечание
 | Чтобы работал мониторинг ядра, должен быть установлен пакет debuginfo (содержащий несжатое ядро).

Чтобы отключить мониторинг ядра в OProfile, выполните от имени root следующую команду:

opcontrol --setup --no-vmlinux

Эта команда также загружает модуль ядра oprofile, если он не загружен и создаёт каталог /dev/oprofile/, если он не существует. За подробным описанием этого каталога обратитесь к разделу 41.6 Рассмотрение /dev/oprofile/.

Замечание | Замечание
 | Даже если в OProfile выключен мониторинг ядра, тем не менее должно работать SMP-ядро, чтобы из него можно было загрузить модуль oprofile.

Выбор собирать ли показатели ядра влияет только на то, какие данные собираются, но не на то, как и где хранятся собранные данные. Чтобы узнать, как использовать для показателей ядра и библиотек приложений разные файлы, обратитесь к разделу 41.2.3 Разделение профилей ядра и пространства пользователя.

41.2.2. Выбор отслеживаемых событий

Многие процессоры предоставляют счётчики, которые позволяют OProfile отслеживать определённые события. Как показывает таблица 41-2, в разных процессорах доступно разное число счётчиков.

Процессор | тип процессора | Число счётчиков
Pentium Pro | i386/ppro | 2
Pentium II | i386/pii | 2
Pentium III | i386/piii | 2
Pentium 4 (без Hyper-Threading) | i386/p4 | 8
Pentium 4 (c Hyper-Threading) | i386/p4-ht | 4
Athlon | i386/athlon | 4
AMD64 | x86-64/hammer | 4
Itanium | ia64/itanium | 4
Itanium 2 | ia64/itanium2 | 4
TIMER_INT | timer | 1
IBM eServer iSeries и pSeries | timer | 1
 | ppc64/power4 | 8
 | ppc64/power5 | 6
 | ppc64/970 | 8
IBM eServer S/390 и S/390x | timer | 1
IBM eServer zSeries | timer | 1

Таблица 41-2. Процессоры и счётчики OProfile

Воспользуйтесь таблицей 41-2, чтобы проверить, был ли правильно определён тип процессора, и узнать, сколько событий можно отслеживать одновременно. Тип timer применяется в случае, если процессор не имеет поддерживаемых аппаратных средств мониторинга прозводительности.

Если используется тип timer, назначить события для процессора нельзя, так как в нём отсутствует аппаратная поддержка счётчиков производительности. Вместо этих счётчиков для мониторинга используется прерывание по таймеру.

Если в качестве типа процессора используется не timer, отслеживаемые события можно изменить и по умолчанию нулевой счётчик связывается с событием, происходящим по времени. Если в процессоре есть несколько счётчиков, по умолчанию другие счётчики не связываются с событием. Отслеживаемые по умолчанию события показаны в таблице 41-3.

Процессор | Событие по умолчанию для счётчика | Описание
Pentium Pro, Pentium II, Pentium III, Athlon, AMD64 | CPU_CLK_UNHALTED | Тактовый генератор процессора не остановлен
Pentium 4 (HT и не HT) | GLOBAL_POWER_EVENTS | Время, в течение которого процессор не останавливался
Itanium 2 | CPU_CYCLES | Такты процессора
TIMER_INT | (отсутствует) | Выборка по каждому прерыванию от таймера
ppc64/power4 | CYCLES | Такты процессора
ppc64/power5 | CYCLES | Такты процессора
ppc64/970 | CYCLES | Такты процессора

Таблица 41-3. События по умолчанию

Число одновременно отслеживаемых событий определяется числом счётчиков процессора. Однако они не соответствуют один-к-одному; на некоторых процессорах определённые события должны быть сопоставлены с конкретными счётчиками. Чтобы определить число доступных счётчиков, выполните следующую команду:

cat /dev/oprofile/cpu_type

Набор доступных событий зависит от типа процессора. Чтобы определить, какие события можно отслеживать, выполните от имени root следующую команду (результаты команды зависят от типа процессора):

op_help

События для каждого счётчика можно настраивать в командной строке или в графическом интерфейсе. За дополнительными сведениями о графическом интерфейсе обратитесь к разделу 41.8 Графический интерфейс. Если счётчик нельзя сопоставить с заданным событием, выводится сообщение об ошибке.

Чтобы назначить событие для настраиваемого счётчика в командной строке, используйте opcontrol:

opcontrol --event=<event-name>:<sample-rate>

Замените <event-name> точным названием события, полученным от команды op_help, а <sample-rate> числом событий между выборками.

41.2.2.1. Частота выборки

По умолчанию выбирается набор событий, связанных с таймером. При этом выборка выполняется через каждые 100000 тактов процессора. Если используется прерывание таймера, таймер программируется на базовую частоту, изменить которую пользователь не может. Если тип процессора не timer, для каждого события можно задать частоту выборки. Частота выборки определяет, через сколько событий будут сниматься показания.

Назначая события для счётчика, также можно указать частоту выборки:

opcontrol --event=<event-name>:<sample-rate>

Замените <sample-rate> числом событий между выборками. Чем меньше это число, тем чаще снимаются показания. Небольшие значения могут потребоваться для событий, происходящих нечасто, чтобы не пропустить происходящие события.

Внимание | Внимание
 | Настраивайте частоту выборки очень аккуратно. Выборка с очень большой частотой может сильно загрузить систему, при этом система будет казаться «зависшей» или «повиснет» на самом деле.

41.2.2.2. Маски

Если тип процессора не timer, для дальшейшего определения события могут потребоваться маски.

Маски любого события показывает команда op_help. Значения масок даются в шестнадцатеричном виде. Чтобы указать несколько масок, их шестнадцатеричные значения нужно сложить, используя операцию «логическое или».

opcontrol --event=<event-name>:<sample-rate>:<unit-mask>

41.2.3. Разделение профилей ядра и пространства пользователя

По умолчанию при каждом событии собираются показатели режима ядра и пользовательского режима. Чтобы OProfile не учитывал события определённого счётчика в режиме ядра, выполните следующую команду:

opcontrol --event=<event-name>:<sample-rate>:<unit-mask>:0

Чтобы снова начать отслеживания этого счётчика в режиме ядра, выполните следующую команду:

opcontrol --event=<event-name>:<sample-rate>:<unit-mask>:1

Чтобы OProfile не учитывал события определённого счётчика в пользовательском режиме, выполните следующую команду:

opcontrol --event=<event-name>:<sample-rate>:<unit-mask>:<kernel>:0

Чтобы снова начать отслеживания этого счётчика в пользовательском режиме, выполните команду:

opcontrol --event=<event-name>:<sample-rate>:<unit-mask>:<kernel>:1

Когда демон OProfile записывает отслеживаемые данные в файлы с выборками, он может разделять данные отслеживания ядра и библиотек, записывая их в разные файлы. Чтобы выбрать режим записи файлов с выборками, выполните он имени root следующую команду:

opcontrol --separate=<choice>

Параметр <choice> может быть следующим:

  • none — не разделять профили (по умолчанию)

  • library — создавать профили библиотек в разрезе приложений

  • kernel — создавать профили ядра и его модулей в разрезе приложений

  • all — создавать профили библиотек и профили ядра и его модулей в разрезе приложений

Если используется вариант --separate=library, имя файла с выборками включает имя исполняемого файла, а также имя файла библиотеки.

Назад | Начало | Вперёд
OProfile | Вверх | Запуск и остановка OProfile


Рассмотрение /dev/oprofile/

Назад Глава 41. OProfile Вперёд

41.6. Изучение /dev/oprofile/

В каталоге /dev/oprofile/ находится файловая система OProfile. Используйте команду cat, чтобы просмотреть содержимое виртуальных файлов в этой файловой системе. Например, следующая команда показывает тип процессора, выявленного программой OProfile:

cat /dev/oprofile/cpu_type

Каждому счётчику соответствует свой подкаталог в /dev/oprofile/. Например, для двух счётчиков будут представлены каталоги /dev/oprofile/0/ и dev/oprofile/1/.

В каталоге каждого счётчика содержатся следующие файлы:

  • count — Интервал между выборками.

  • enabled — если содержит 0, счётчик отключён и никакие выборки не производятся; если содержит 1, счётчик включён и сбор данных производится.

  • event — Наблюдаемое событие.

  • kernel — Если содержит 0, выборки по этому счётчику не учитываются, когда процессор работает в режиме ядра; если содержит 1, выборки учитываются даже в режиме ядра.

  • unit_mask — Определяет, какие маски включены для данного счётчика.

  • user — Если содержит 0, выборки по этому счётчику не учитываются, когда процессор работает в пространстве пользователя; если содержит 1, выборки учитываются даже в пространстве пользователя.

Содержимое этих файлов можно получить с помощью команды cat. Например:

cat /dev/oprofile/0/count
Назад | Начало | Вперёд
Анализ данных | Вверх | Пример использования


Пример использования

Назад Глава 41. OProfile Вперёд

41.7. Пример использования

Хотя OProfile применяется разработчиками для анализа производительности приложений, его также могут использовать и системные администраторы для анализа системы. Например:

  • Чтобы определить, какие приложения и службы нагружают систему больше остальных — используя opreport, можно определить, сколько процессорного времени уходит на выполнение приложения или службы. Если система используется несколькими службами и работает очень медленно, службы, требующие больше процессорного времени, чем остальные, можно вынести на выделенные компьютеры.

  • Чтобы определить нагрузку процессора — Отслеживая событие CPU_CLK_UNHALTED, можно определить нагрузку процессора в течение определённого периода времени. Эти данные затем можно использовать, чтобы определить, увеличится ли быстродействие системы в результате замены процессора на более быстрый или добавления дополнительных процессоров.

Назад | Начало | Вперёд
Изучение /dev/oprofile/ | Вверх | Графический интерфейс


Графический интерфейс

Назад Глава 41. OProfile Вперёд

41.8. Графический интерфейс

Некоторые параметры OProfile можно определить в графическом интерфейсе. Чтобы его запустить, выполните в приглашении оболочки от имени root команду oprof_start.

Изменив параметры, сохраните их, нажав кнопку Сохранить и выйти (Save and quit). При этом параметры записываются в файл /root/.oprofile/daemonrc и приложение завершает работу. При завершении этого приложения OProfile не прекращает сбор данных.

На вкладке Установка (Setup) можно связать события со счётчиками процессора, как обсуждалось в разделе 41.2.2 Выбор отслеживаемых событий, для этого выберите счётчик в выпадающем меню, а затем выберите событие в списке. В текстовой области под списком появляется короткое описание события. В списке выводятся только события, доступные для выбранного счётчика и данной архитектуры. В этом окне также показывается, работает ли профилировщик и краткая статистика его работы.

Рисунок 41-1. Установки OProfile

В правой части вкладки отметьте флажок Профилировать ядро (Profile kernel), чтобы учитывать выборки текущего события в режиме ядра, что обсуждалось в разделе 41.2.3 Разделение профилей ядра и пространства пользователя. Если этот флажок снят, выборки в режиме ядра не учитываются.

В правой части вкладки отметьте флажок Профилировать двоичный код пользователя (Profile user binaries), чтобы учитывать выборки текущего события в пользовательском режиме, что обсуждалось в разделе 41.2.3 Разделение профилей ядра и пространства пользователя. Если этот флажок снят, выборки для пользовательских приложений не учитываются.

Используйте текстовое поле Счётчик (Count), чтобы определить частоту выборки текущего выбранного события, рассмотренную в разделе 41.2.2.1 Частота выборки.

Если для текущего выбранного события допускаются какие-либо маски, обсуждаемые в разделе 41.2.2.2 Маски, они отображаются в области Маски (Unit Masks) в правой части вкладки Установка (Setup). Чтобы установить маску для события, отметьте расположенный рядом с ней флажок.

Чтобы включить мониторинг ядра, на вкладке Настройка (Configuration) укажите имя и расположения файла vmlinux для отслеживаемого ядра в текстовом поле Файл образа ядра (Kernel image file). Чтобы OProfile не выполнял мониторинг ядра, отметьте флажок Без образа ядра (No kernel image).

Рисунок 41-2. Настройка OProfile

Если установлен флажок Подробно (Verbose), в журнал демона oprofiled будет выводиться дополнительная информация.

Если отмечен флажок Файлы выборок в ядре по приложениям (Per-application kernel samples files), OProfile создаёт профили ядра и его модулей в разрезе приложений, как обсуждалось в разделе 41.2.3 Разделение профилей ядра и пространства пользователя. Этот флажок соответствует команде opcontrol --separate=kernel. Если отмечен флажок Файлы выборок в общих библиотеках по приложениям (Per-application shared libs samples files), OProfile создаёт профили библиотек в разрезе приложений. Этот флажок соответствует команде opcontrol --separate=library.

Чтобы принудительно сбросить данные в файлы с выборками, как рассматривалось в разделе 41.5 Анализ данных, нажмите кнопку Сбросить данные профилировщика (Flush profiler data). Этот флажок соответствует команде opcontrol --dump.

Чтобы запустить OProfile в графическом интерфейсе, нажмите кнопку Запустить профилировщик (Start profiler). Чтобы остановить его, нажмите Остановить профилировщик (Stop profiler). При завершении этого приложения OProfile не прекращает сбор данных.

Назад | Начало | Вперёд
Пример использования | Вверх | Дополнительные ресурсы


Сохранение данных

Назад Глава 41. OProfile Вперёд

41.4. Сохранение данных

Иногда полезно сохранять выборки в определённое время. Например, во время мониторинга приложения может быть полезным сделать разные выборки в зависимости от разных наборов входных данных. Если число отслеживаемых событий превосходит число доступных счётчиков процессора, для сбора данных можно запускать OProfile несколько раз, каждый раз сохраняя полученные данные в отдельных файлах.

Чтобы сохранить текущий набор файлов с выборками, выполните следующую команду, заменив <name> неповторящимся понятным названием текущего сеанса.

opcontrol --save=<name>

При этом создаётся каталог /var/lib/oprofile/samples/name/ и в него копируются текущие файлы с выборками.

Назад | Начало | Вперёд
Запуск и остановка OProfile | Вверх | Анализ данных


Запуск и остановка OProfile

Назад Глава 41. OProfile Вперёд

41.3. Запуск и остановка OProfile

Чтобы начать мониторинг системы с помощью OProfile, выполните от имени root следующую команду:

opcontrol --start

В результате на экран выводится примерно следующее:

Using log file /var/lib/oprofile/oprofiled.log
Daemon started.
Profiler running.

При этом используются настройки из файла /root/.oprofile/daemonrc.

В результате выполнения команды запускается демон OProfile, oprofiled; он периодически записывает выборки в каталог /var/lib/oprofile/samples/. Журнал этого демона находится в файле /var/lib/oprofile/oprofiled.log.

Чтобы остановить мониторинг, выполните от имени root следующую команду:

opcontrol --shutdown
Назад | Начало | Вперёд
Настройка OProfile | Вверх | Сохранение данных


Дополнительные ресурсы

Назад Глава 34. Настройка принтера Вперёд

34.14. Дополнительные ресурсы

Чтобы узнать о печати в системе Red Hat Enterprise Linux больше, обратитесь к следующим ресурсам.

34.14.1. Установленная документация

  • map lpr — Страница руководства, посвящённая команде lpr, позволяющей вам печатать файлы с командной строки.

  • man lprm — Страница руководства с описанием утилиты командной строки, удаляющей задания из очереди печати.

  • man mpage — Страница руководства с описанием утилиты командной строки, печатающей на одном листе бумаги несколько страниц.

  • man cupsd — Страница руководства, посвящённая демону принтера CUPS.

  • man cupsd.conf — Страница руководства, посвящённая файлу конфигурации демона принтера CUPS.

  • man classes.conf — Страница руководства, посвящённая файлу конфигурации классов CUPS.

34.14.2. Полезные сайты

  • http://www.linuxprinting.org — Сайт GNU/Linux Printing (Печать в GNU/Linux) содержит большой объём информации о печати в системе Linux.

  • http://www.cups.org/ — Документация, ответы на вопросы, и группы новостей, посвящённые CUPS.

Назад | Начало | Вперёд
Предоставление общего доступа к принтеру | Вверх | Автоматизация задач


Использование командной строки

Назад Глава 34. Настройка принтера Вперёд

34.11. Использование командной строки

Если у вас не установлена система X и вы не хотите использовать текстовую версию программы, вы можете добавить принтер в командной строке. Этот вариант также полезен, если вы хотите добавить принтер в сценарии или в разделе %post установки kickstart.

34.11.1. Добавление локального принтера

Чтобы добавить принтер, выполните:

system-config-printer-tui --Xadd-local options

Параметры:

--device=node

(Обязательный) Узел используемого устройства. Например, /dev/lp0.

--make=make

(Обязательный) Строка «IEEE 1284 MANUFACTURER» или название производителя принтера в том виде, в каком оно фигурирует в базе данных foomatic.

--model=model

(Обязательный) Строка «IEEE 1284 MODEL» или название модели принтера, включённое в базу данных foomatic.

--name=name

(Необязательный) Имя, назначаемое новой очереди. Если оно не указано, используется имя, полученное из названия узла устройства (например, "lp0").

--as-default

(Необязательный) Назначает очередь очередью по умолчанию.

Добавив принтер, запустите или перезапустите демон принтера, воспользовавшись следующей командой:

service cups restart

34.11.2. Удаление локального принтера

В командной строке также можно удалить очередь печати.

Для этого выполните от имени root:

system-config-printer-tui --Xremove-local options

Параметры:

--device=node

(Обязательный) Используемый узел устройства, например, /dev/lp0.

--make=make

(Обязательный) Строка «IEEE 1284 MANUFACTURER» или название производителя принтера в том виде, в каком оно фигурирует в базе данных foomatic.

--model=model

(Обязательный) Строка «IEEE 1284 MODEL» или название модели принтера, включённое в базу данных foomatic.

После удаления принтера из конфигурации программы Настройка принтера (Printer Configuration Tool), перезапустите демон принтера, чтобы изменения вступили в силу (от имени root):

service cups restart

Если удалены все принтеры и вы не хотите, чтобы демон принтера продолжал работу, выполните следующую команду (от имени root):

service cups stop

34.11.3. Назначение принтера по умолчанию

Чтобы назначить принтер по умолчанию, выполните следующую команду, указав queuename (имя очереди):

system-config-printer-tui --Xdefault --queue=queuename
Назад | Начало | Вперёд
Сохранение файла конфигурации | Вверх | Управление заданиями печати


Изменение параметров установленных принтеров

Назад Глава 34. Настройка принтера Вперёд

34.9. Изменение параметров установленных принтеров

Чтобы удалить существующий принтер, выберите принтер и нажмите на панели кнопку Удалить (Delete). При этом принтер удаляется из списка. Нажмите кнопку Применить (Apply), чтобы сохранить изменения и перезапустить демон принтера.

Чтобы выбрать принтер по умолчанию, выберите принтер из списка и нажмите на панели инструментов кнопку По умолчанию (Default). При этом в списке принтеров, в столбце По умолчанию (Default) появится значок принтера по умолчанию [image] . Программа Настройка принтера (Printer Configuration Tool) не позволяет сделать принтером по умолчанию принтер найденной очереди IPP. Чтобы принтер IPP стал принтером по умолчанию, добавьте его, как описано в разделе 34.2 Добавление принтера IPP и назначьте его принтером по умолчанию.

Замечание Замечание

Диспетчер печати GNOME (GNOME Print Manager) более не назначает принтеры по умолчанию на уровне пользователей.

Чтобы установить принтер по умолчанию на уровне системы, используйте команду system-config-printer или средство Настройка принтера (Printer Configuration Tool).

Чтобы пользователи могли настроить принтер по умолчанию для себя, каждый пользователь должен использовать средство Выбор принтера по умолчанию для GNOME (GNOME Default Printer Tool), которое можно запустить, выбрав в меню Приложения (Applications) (на панели) => Параметры (Preferences) => Дополнительные параметры (More Preferences) => Принтер по умолчанию (Default Printer).

Параметры добавленного принтера можно изменить, выбрав его из списка и нажав кнопку Изменить (Edit). При этом на экране появляется окно с закладками, показанное на рисунке 34-12. В этом окне показаны текущие значения параметров выбранного принтера. Внесите необходимые изменения и нажмите OK. Нажмите кнопку Применить (Apply) в основном окне программы Настройка принтера (Printer Configuration Tool), чтобы сохранить изменения и перезапустить демон печати.

Рисунок 34-12. Редактирование свойств принтера

34.9.1. Имя очереди

Чтобы переименовать принтер или изменить его краткое описание, отредактируйте соответствующие поля на вкладке Имя очереди (Queue name). Нажмите OK, чтобы вернуться к основному окну. После этого имя принтера в списке должно измениться. Нажмите кнопку Изменить (Apply), чтобы сохранить изменение и перезапустить демон принтера.

34.9.2. Тип очереди

На вкладке Тип очереди (Queue Type) показывается тип очереди, выбранный при добавлении принтера. Вы можете изменить тип очереди принтера или только её параметры. Произведя необходимые изменения, нажмите кнопку OK, чтобы вернуться к главному окну. Нажмите кнопку Применить (Apply), чтобы сохранить изменения и перезапустить демон принтера.

В зависимости от выбранного типа очереди, её параметры могут различаться. За описанием этих параметров обратитесь к соответствующему разделу, посвященному добавлению принтера.

34.9.3. Драйвер принтера

На вкладке Драйвер принтера (Printer driver) показывается текущий драйвер принтера. Если вы сменили его, нажмите OK, чтобы вернуться к главному окну. Нажмите кнопку Изменить (Apply), чтобы сохранить изменение и перезапустить демон принтера.

34.9.4. Параметры драйвера

На вкладке Параметры драйвера (Driver Options) задаются расширенные параметры принтера. Эти параметры различаться в зависимости от драйвера принтера. В число общих параметров входят:

  • Параметр Рендерер Postscript (Prerender Postscript), который следует устанавливать, если вы печатаете символы, не входящие в основную таблицу ASCII, но они распечатываются неверно (например, японские иероглифы). Когда этот параметр установлен, формируются нестандартные шрифты PostScript, благодаря чему они печатаются правильно.

    Если принтер не поддерживает шрифты, которые вы пытаетесь напечатать, попробуйте установить этот параметр. Например, попробуйте установить его, чтобы напечатать японские шрифты на не японском принтере.

    Для выполнения этой операции требуется дополнительное время. Не устанавливаёте этот параметр, если вы не испытываете проблем с печатью правильных шрифтов.

    Кроме этого, данный параметр следует выбирать, если принтер не поддерживает 3 уровень PostScript. При этом задание будет преобразовано в PostScript уровня 1.

  • Параметр Предфильтрация GhostScript (GhostScript pre-filtering), позволяющий вам выбрать режим Без предфильтрации (No pre-filtering), Преобразовать в PS уровня 1 (Convert to PS level 1) или Преобразовать в PS уровня 2 (Convert to PS level 2, в случаях, когда принтер не способен обработать PostScript определённых уровней. Этот параметр доступен, только если используется драйвер PostScript.

  • Параметр Размер страницы (Page Size), позволяющий выбрать размер страницы. В число параметров входят US Letter, US Legal, A3 и A4.

  • Параметр Действующий региональный фильтр (Effective Filter Locale), по умолчанию имеющий значение C. Если вы распечатываете японские символы, выберите ja_JP. В противном случае, оставьте значение по умолчанию C.

  • Параметр Источник бумаги (Media Source), по умолчанию имеющий значение По умолчанию (Printer default). Измените этот параметр, чтобы использовать бумагу из другого лотка.

Чтобы поменять параметры драйвера, нажмите кнопку OK для возврата к основному окну. Нажмите кнопку Изменить (Apply), чтобы сохранить изменение и перезапустить демон принтера.

Назад | Начало | Вперёд
Печать пробной страницы | Вверх | Сохранение файла конфигурации


Добавление принтера IPP

Назад Глава 34. Настройка принтера Вперёд

34.2. Добавление принтера IPP

Принтер IPP — это принтер, подключенный к другому, расположенному в той же сети компьютеру с Linux или к компьютеру с другой операционной системой, поддерживающей IPP. По умолчанию средство Настройка принтера (Printer Configuration Tool) выполняет поиск всех общих IPP-принтеров в сети. (Это поведение может изменить, выбрав Действие (Action) => Доступ (Sharing) в выпадающем меню.) Все сетевые принтеры IPP, обнаруженные при поиске, показываются в основном окне, в разделе Найденные очереди (Browsed queues).

Если на вашем сервере печати настроен брандмауэр, он должен принимать трафик в UDP-порт 631 и пропускать ответный. Если брандмауэр настроен на клиенте (компьютере, отправляющем запрос на печать), он должен пропускать трафик в порт 631 и принимать ответный.

Если вы отключите возможность автоматического поиска, вы, тем не менее, можете добавить сетевой принтер IPP, нажав кнопку Создать в основном окне программы Настройка принтера, чтобы вызвать окно, показанное на рисунке 34-2. Нажмите Вперёд для продолжения.

В показанном на рисунке 34-3 окне введите уникальное имя принтера в текстовом поле Имя (Name). Имя принтера не может содержать пробелы и должно начинаться с буквы. Имя принтера может содержать буквы, цифры, символы минус (-) и подчёркивания (_). По своему усмотрению введите короткое описание принтера, которое может содержать пробелы.

После нажатия кнопки Вперёд появляется рисунок 34-5. Выберите вариант Сетевой принтер CUPS (Networked CUPS) (IPP) в меню Выберите тип очереди (Select a queue type).

Рисунок 34-5. Добавление принтера IPP

На экране появляются текстовые поля для определения следующих параметров:

  • Сервер (Server) — Имя узла или IP-адрес удалённого компьютера, к которому подключен принтер.

  • Путь (Path) — Путь к очереди печати на удалённом компьютере.

Нажмите Вперёд для продолжения.

Затем определите тип принтера. За подробными инструкциями обратитесь к разделу 34.7 Выбор модели принтера и завершение настройки.

Важно | Важно
 | Сетевой сервер печати IPP должен допускать подключения с локального компьютера. Дополнительные сведения приведены в разделе 34.13 Предоставление доступа к принтеру.
Назад | Начало | Вперёд
Настройка принтера | Вверх | Добавление удалённого принтера UNIX (LPD)


Добавление принтера JetDirect

Назад Глава 34. Настройка принтера Вперёд

34.6. Добавление принтера JetDirect

Чтобы добавить принтер JetDirect, нажмите кнопку Создать (New) в основном окне программы Настройка принтера (Printer Configuration Tool). На экране появится окно, показанное на рисунке 34-1. Нажмите Вперёд для продолжения.

В показанном на рисунке 34-3 окне введите уникальное имя принтера в текстовом поле Имя (Name). Имя принтера не может содержать пробелы и должно начинаться с буквы. Имя принтера может содержать буквы, цифры, символы минус (-) и подчёркивания (_). По своему усмотрению введите короткое описание принтера, которое может содержать пробелы.

Выберите вариант Сетевой принтер JetDirect (Networked JetDirect) в меню Выберите тип очереди (Select a queue type) и нажмите кнопку Вперёд (Forward).

Рисунок 34-9. Добавление принтера JetDirect

На экране появляются текстовые поля для определения следующих параметров:

  • Принтер (Printer) — Имя узла или IP-адрес принтера JetDirect.

  • Порт (Port) — Порт, в котором принтер JetDirect ждёт задания на печать. По умолчанию используется порт 9100.

Затем определите тип принтера. За подробными инструкциями обратитесь к разделу 34.7 Выбор модели принтера и завершение настройки.

Назад | Начало | Вперёд
Добавление принтера Novell NetWare (NCP) | Вверх | Выбор модели принтера и завершение настройки


Добавление удалённого принтера UNIX (LPD)

Назад Глава 34. Настройка принтера Вперёд

34.3. Добавление удалённого принтера UNIX (LPD)

Чтобы подключить удалённый принтер UNIX, например, установленный на другом компьютере Linux в той же сети, нажмите кнопку Создать (New) в основном окне программы Настройка принтера (Printer Configuration Tool). На экране появится окно, показанное на рисунке 34-2. Нажмите Вперёд для продолжения.

В показанном на рисунке 34-3 окне введите уникальное имя принтера в текстовом поле Имя (Name). Имя принтера не может содержать пробелы и должно начинаться с буквы. Имя принтера может содержать буквы, цифры, символы минус (-) и подчёркивания (_). По своему усмотрению введите короткое описание принтера, которое может содержать пробелы.

Выберите вариант Сетевой принтер UNIX (Networked UNIX) (LPD) в меню Выберите тип очереди (Select a queue type) и нажмите Вперёд (Forward).

Рисунок 34-6. Подключение удалённого принтера LPD

На экране появляются текстовые поля для определения следующих параметров:

  • Сервер (Server) — Имя узла или IP-адрес удалённого компьютера, к которому подключен принтер.

  • Queue (Очередь) — Удалённая очередь печати. Очередь печати по умолчанию обычно называется lp.

Нажмите Вперёд для продолжения.

Затем определите тип принтера. За подробными инструкциями обратитесь к разделу 34.7 Выбор модели принтера и завершение настройки.

Важно | Важно
 | Удалённый сервер печати должен принимать задания печати с локального компьютера.
Назад | Начало | Вперёд
Добавление принтера IPP | Вверх | Добавление принтера Samba (SMB)


Добавление принтера Novell NetWare (NCP)

Назад Глава 34. Настройка принтера Вперёд

34.5. Добавление принтера Novell NetWare (NCP)

Чтобы добавить принтер Novell NetWare (NCP), нажмите кнопку Создать (New) в основном окне программы Настройка принтера (Printer Configuration Tool). На экране появится окно, показанное на рисунке 34-1. Нажмите Вперёд для продолжения.

В показанном на рисунке 34-3 окне введите уникальное имя принтера в текстовом поле Имя (Name). Имя принтера не может содержать пробелы и должно начинаться с буквы. Имя принтера может содержать буквы, цифры, символы минус (-) и подчёркивания (_). По своему усмотрению введите короткое описание принтера, которое может содержать пробелы.

Выберите вариант Сетевой принтер Novell (Networked Novell) (NCP) в меню Выберите тип очереди (Select a queue type).

Рисунок 34-8. Добавление принтера NCP

На экране появляются текстовые поля для определения следующих параметров:

  • Сервер (Server) — Имя или IP-адрес компьютера, поддерживающего NCP, к которому подключен принтер.

  • Очередь (Queue) — Удалённая очередь принтера на компьютере, поддерживающем NCP.

  • Пользователь (User) — Имя пользователя, с которым вы должны подключиться, чтобы иметь доступ к принтеру.

  • Пароль (Password) — Пароль пользователя, указанного в поле Пользователь (User).

Затем определите тип принтера. За подробными инструкциями обратитесь к разделу 34.7 Выбор модели принтера и завершение настройки.

Предупреждение | Предупреждение
 | Если для подключения требуется имя и пароль пользователя, они хранятся в открытом виде, в файлах, доступных на чтение только root и lpd. Таким образом, это имя и пароль могут узнать посторонние, если они смогут получить права root. Чтобы избежать этого, имя и пароль пользователя, используемые при обращении к принтеру, должны отличаться от имени и пароля пользователя в локальной системе Red Enterprise Hat Linux. Если они будут различаться, единственной возможностью нанести ущерб будет несанкционированное использование принтера. Если на этом сервере также есть общие папки, рекомендуется не использовать для доступа к ним имя и пароль пользователя принтера.
Назад | Начало | Вперёд
Добавление принтера Samba (SMB) | Вверх | Добавление принтера JetDirect


Сохранение файла конфигурации

Назад Глава 34. Настройка принтера Вперёд

34.10. Сохранение файла конфигурации

Когда конфигурация принтера сохраняется с помощью программы Настройка принтера (Printer Configuration Tool), эта программа создаёт собственный файл конфигурации, который используется для создания файлов в каталоге /etc/cups/. Вы можете сохранить или восстановить файл программы Настройка принтера, используя параметры командной строки. Если сохранить каталог /etc/cups/ и восстановить его в то же место, конфигурация принтера не будет восстановлена, так как при каждом перезапуске демона печати он создаёт новый файл /etc/printcap из файла конфигурации программы Настройка принтера (Printer Configuration Tool). Создавая резервную копию файлов конфигурации системы, сохраните файлы конфигурации принтера следующим образом.

Чтобы сохранить вашу конфигурацию принтера, выполните от имени root эту команду:

/usr/sbin/system-config-printer-tui --Xexport > settings.xml

Ваша конфигурация будет сохранена в файле settings.xml.

Если этот файл сохранён, его можно использовать впоследствии для восстановления параметров принтера. Это полезно, когда конфигурация принтера удалена или переустановлена система Red Hat Enterprise Linux или одну конфигурацию принтера требуется использовать на нескольких компьютерах. Этот файл следует сохранить на другом компьютере до переустановки. Чтобы восстановить конфигурацию, выполните от имени root эту команду:

/usr/sbin/system-config-printer-tui --Ximport < settings.xml

Если у вас уже есть файл конфигурации (вы уже настроили один или несколько принтеров) и вы попытаетесь загрузить другой файл конфигурации, существующий файл будет перезаписан. Если вы хотите сохранить свою существующую конфигурацию и добавить конфигурацию сохранённого файла, вы можете объединить файлы, выполнив следующую команду (от имени root):

/usr/sbin/system-config-printer-tui --Ximport --merge < settings.xml

После этого список ваших принтеров будет включать принтеры, установленные ранее, а также принтеры, загруженные из сохранённого файла конфигурации. Если в загруженном файле была определена очередь печати с именем существующей очереди печати, очередь печати из загружаемого файла перезапишет существовавшую ранее.

После восстановления файла конфигурации (с командой merge или без неё) вы должны перезапустить демон принтера. Выполните от имени root следующую команду:

/sbin/service cups restart
Назад | Начало | Вперёд
Изменение параметров установленных принтеров | Вверх | Использование командной строки


Выбор модели принтера и завершение настройки

Назад Глава 34. Настройка принтера Вперёд

34.7. Выбор модели принтера и завершение настройки

Следующее действие после выбора типа очереди печати — выбор модели принтера.

На экране появляется окно, показанное на рисунке 34-10. Если принтер не был выявлен автоматически, выберите модель из списка. Принтеры разделены на группы по производителям. Выберите производителя принтера в выпадающем меню. При выборе другого производителя обновляется список моделей принтеров. Выберите модель принтера из этого списка.

Рисунок 34-10. Выбор модели принтера

В зависимости от выбранной модели принтера выбирается рекомендуемый драйвер. Драйвер печати преобразует данные, которые вы хотите напечатать, в формат, понятный принтеру. Так как локальный принтер подключен непосредственно к вашему компьютеру, вы должны выбрать драйвер печати, который будет обрабатывать данные, отправляемые на принтер.

Если вы настраиваете удалённый принтер (LPD, SMB или NCP), удалённый сервер печати обычно использует свой собственный драйвер печати. Если вы выбрали на своём локальном компьютере дополнительный драйвер печати, данные фильтруются неоднократно и приводятся к формату, не воспринимаемому принтером.

Чтобы данные не фильтровались несколько раз, попробуйте сначала выбрать в качестве производителя Стандартный (Generic), а в качестве модели принтера Прямая очередь печати (Raw Print Queue) или Принтер Postscript (Postscript Printer). Применив изменения, напечатайте пробную страницу, чтобы проверить новую конфигурацию. Если проверка не удалась, возможно, на удалённом сервере печати неверно настроен драйвер принтера. Попробуйте выбрать драйвер печати, указав производителя и модель удалённого принтера, примените изменения и распечатайте пробную страницу.

Подсказка | Подсказка
 | Вы можете выбрать другой драйвер печати после добавления принтера. Для этого запустите программу Настройка принтера, выберите принтер из списка, нажмите кнопку Изменить (Edit), перейдите на вкладку Драйвер принтера (Driver), выберите другой драйвер печати, а затем примените изменения.

34.7.1. Подтверждение параметров принтера

И, наконец, подтвердите выбранные параметры вашего принтера. Нажмите кнопку Завершить (Finish), чтобы добавить очередь печати, если параметры принтера заданы правильно, или кнопку Назад (Back), чтобы изменить эти параметры.

Нажмите кнопку Применить (Apply) в главном окне, чтобы сохранить изменения и перезапустить демон принтера. Применив изменения, напечатайте пробную страницу, чтобы убедиться в правильности конфигурации. За подробными инструкциями обратитесь к разделу 34.8 Печать пробной страницы.

Если вам нужно распечатывать символы, не входящие в основную таблицу ASCII, (включая используемые, например, в японском языке), вы должны перейти к настройкам драйвера и выбрать вариант Рендерер Postscript (Rerender Postscript). За подробными инструкциями обратитесь к разделу 34.9 Изменение параметров существующих принтеров. Изменяя свойства добавленной очереди печати, вы также можете настроить другие параметры, например, размер бумаги.

Назад | Начало | Вперёд
Добавление принтера JetDirect | Вверх | Печать пробной страницы


Предоставление общего доступа к принтеру

Назад Глава 34. Настройка принтера Вперёд

34.13. Предоставление общего доступа к принтеру

Способность программы Настройка принтера (Printer Configuration Tool) разделять параметры конфигурации принтера можно использовать, только если вы используете систему печати CUPS.

Предоставление пользователям других компьютеров в сети возможности печатать на принтере, подключенном к вашему компьютеру, называется разделением принтера. По умолчанию принтеры, настраиваемые в программе Настройка принтера (Printer Configuration Tool) не разделяются.

Чтобы сделать настроенный принтер общим, запустите средство Настройка принтера (Printer Configuration Tool) и выберите принтер из списка. Затем выберите в выпадающем меню Действия (Action) => Настройки доступа (Sharing).

Замечание | Замечание
 | Если принтер не выбран, в диалоге, вызванном из меню Действия (Action) => Настройки доступа (Sharing), показываются только глобальные параметры доступа, обычно расположенные на вкладке Общие (General).

Установите на вкладке Очередь (Queue) флажок, открывающий доступ к очереди другим пользователям.

Рисунок 34-17. Параметры очереди

Когда вы открываете доступ к очереди, печатать на данном общем принтере по умолчанию могут все компьютеры. Предоставление доступа к очереди печати всем компьютерам в сети может быть опасным, особенно, если ваш компьютер напрямую подключен к Интернету. Это рекомендуется изменить, выбрав запись Все узлы (All hosts) и нажав кнопку Изиенить (Edit), чтобы вызвать окно, показанное на рисунке 34-18.

Если на вашем сервере печати настроен брандмауэр, он должен принимать трафик в UDP-порт 631 и пропускать ответный. Если брандмауэр настроен на клиенте (компьютере, отправляющем запрос на печать), он должен пропускать трафик в порт 631 и принимать ответный.

Рисунок 34-18. Разрешённые узлы

На вкладке Общие (General) настраиваются параметры всех принтеров, включая те, что не показывает средство Настройка принтера (Printer Configuration Tool). Здесь представлены два параметра:

  • Автоматически находить общие очереди (Automatically find remote shared queues) — Этот параметр разрешает обнаружение очередей IPP и по умолчанию установлен. Когда другие компьютеры в сети передают широковещательные объявления об имеющихся очередях, каждый компьютер автоматически добавляет эти очереди в список доступных принтеров; никакая дополнительная настройки принтера, обнаруженного таким образом, не требуется. Этот параметр не означает, что все принтеры, подключенные к локальному компьютеру, автоматически становятся общими.

  • Включить протокол LPD (Enable LPD protocol) — Этот параметр позволяет принтеру принимать задания печати от клиентов, работающих по протоколу LPD, используя службу cups-lpd — одну из служб xinetd.

    Предупреждение Предупреждение

    Если этот параметр включён, компьютер принимает любые задания печати от любых компьютеров, если это клиенты LPD.

Рисунок 34-19. Глобальные параметры общего доступа

Назад | Начало | Вперёд
Управление заданиями печати | Вверх | Дополнительные ресурсы


Добавление принтера Samba (SMB)

Назад Глава 34. Настройка принтера Вперёд

34.4. Добавление принтера Samba (SMB)

Чтобы добавить принтер, достуный по протоколу SMB (например, принтер, подключенный к компьютеру с Microsoft Windows), нажмите кнопку Создать (New) в основном окне программы Настройка принтера (Printer Configuration Tool). На экране появится окно, показанное на рисунке 34-2. Нажмите Вперёд для продолжения.

В показанном на рисунке 34-3 окне введите уникальное имя принтера в текстовом поле Имя (Name). Имя принтера не может содержать пробелы и должно начинаться с буквы. Имя принтера может содержать буквы, цифры, символы минус (-) и подчёркивания (_). По своему усмотрению введите короткое описание принтера, которое может содержать пробелы.

Выберите вариант Сетевой принтер Windows (Networked Windows) (SMB) в меню Выберите тип очереди (Select a queue type) и нажмите Вперёд (Forward). Выбирайте этот тип очереди, если принтер установлен на компьютере с системой Microsoft Windows.

Рисунок 34-7. Добавление принтера SMB

Как показано на рисунке 34-7, общие ресурсы SMB обнаруживаются и показываются автоматически. Нажмите стрелку рядом с названием ресурса, чтобы развернуть список. Выберите принтер в развёрнутом списке.

Если нужный вам принтер отсутствует в списке, нажмите расположенную справа кнопку Указать (Specify). На экране появляются текстовые поля для определения следующих параметров:

  • Рабочая группа (Workgroup) — Имя рабочей группы Samba, в которой находится общий принтер.

  • Сервер (Server) — Имя сервера, предоставляющего принтер в общее пользование.

  • Общий ресурс (Share) — Имя общего принтера, на котором вы хотите печатать. Это имя должно совпадать с именем общего ресурса для принтера на удалённом компьютере Windows.

  • Имя пользователя (User name) — Имя пользователя, с которым вы должны подключиться, чтобы иметь доступ к принтеру. Этот пользователь должен существовать в системе Windows и иметь права для обращения к принтеру. Обычно для серверов Windows это имя guest, или nobody — для серверов Samba.

  • Пароль (Password) — Пароль пользователя (если требуется), имя которого указано в поле Имя пользователя (User name).

Нажмите Вперёд для продолжения. Затем программа Настройка принтера (Printer Configuration Tool) пытается подключиться к общему принтеру. Если общий принтер требует указать имя и пароль пользователя, на экране появляется диалоговое окно, предлагающее вам ввести правильное имя и пароль для доступа к общему принтеру. Если указано неверное имя ресурса, здесь вы также можете изменить. Если для подключения к ресурсу требуется указать имя рабочей группы, его можно указать в этом диалоговом окне. Это то же диалоговое окно, что вызывается при нажатии кнопки Указать (Specify).

Затем определите тип принтера. За подробными инструкциями обратитесь к разделу 34.7 Выбор модели принтера и завершение настройки.

Предупреждение | Предупреждение
 | Если для подключения требуется имя и пароль пользователя, они хранятся в открытом виде, в файлах, доступных на чтение только root и lpd. Таким образом, это имя и пароль могут узнать посторонние, если они смогут получить права root. Чтобы избежать этого, имя и пароль пользователя, используемые при обращении к принтеру, должны отличаться от имени и пароля пользователя в локальной системе Red Enterprise Hat Linux. Если они будут различаться, единственной возможностью нанести ущерб будет несанкционированное использование принтера. Если на этом сервере также есть общие папки, рекомендуется не использовать для доступа к ним имя и пароль пользователя принтера.
Назад | Начало | Вперёд
Добавление удалённого принтера UNIX (LPD) | Вверх | Добавление принтера Novell NetWare (NCP)


Печать пробной страницы

Назад Глава 34. Настройка принтера Вперёд

34.8. Печать пробной страницы

Настроив принтер, следует напечатать пробную страницу, чтобы убедиться в том, что принтер работает правильно. Чтобы распечатать пробную страницу, выберите из списка принтер, который вы хотите опробовать, а затем выберите в выпадающем меню Проверка (Test) подходящую пробную страницу.

Если вы меняете драйвер принтера или его настройки, распечатайте пробную страницу, чтобы проверить новую конфигурацию.

Рисунок 34-11. Параметры пробной страницы

Назад | Начало | Вперёд
Выбор модели принтера и завершение настройки | Вверх | Изменение параметров установленных принтеров


Сравнение аппаратных и программных RAID-массивов

Назад Глава 9. Массив независимых дисков с избыточностью (RAID) Вперёд

9.3. Сравнение аппаратных и программных RAID-массивов

Существуют две реализации RAID: Аппаратный и программный RAID-массив.

9.3.1. Аппаратный RAID

Аппаратный массив управляет подсистемой RAID независимо от процессора и представляет весь RAID-массив в виде одного диска.

Например, аппаратный RAID-массив может подключаться к контроллеру SCSI, при этом он будет выглядеть как один SCSI-диск. Внешний RAID-массив переносит обработку логики RAID в контроллер, размещённый во внешней дисковой подсистеме. Вся подсистема подключается к компьютеру через обычный SCSI-контроллер и выглядит для него как один диск.

RAID-контроллеры также часто выпускаются в виде плат, выглядящих для операционной системы как контроллер SCSI, но кроме этого они сами работают с дисками. В таких случаях вы можете подключить диски к RAID-контроллеру как к обычному контроллеру SCSI, а затем добавить их в конфигурации RAID-контроллера, при этом операционная система никогда не узнает о реальной конфигурации.

9.3.2. Программный RAID

Программная поддержка различных уровней RAID реализована в коде ядра для диска (блочного устройства). Её можно использовать как самое недорогое решение, так как дорогие платы контроллеров дисков и шасси для горячей замены [1] не требуются. Программный RAID работает также хорошо с более дешёвыми IDE-дисками, как и с дисками SCSI. Учитывая скорость современных процессоров, производительность программных RAID-массивов может превосходить производительность аппаратных RAID.

Драйвер MD в ядре Linux представляет собой пример реализации RAID, полностью независимой от оборудования. Производительность программного массива зависит от производительности процессора и его нагрузки.

Информацию о настройке программного RAID во время установки вы получите в главе 10 Настройка программного RAID.

Для тех, кому интересно узнать, что ещё может предложить программный RAID, ниже перечислены самые важные возможности:

  • Процесс перестроения поддерживает потоки

  • Конфигурация, привязанная к ядру

  • Массив может быть перенесён в другие Linux системы без перестроения

  • Перестроение массива выполняется в фоновом режиме, используя свободные ресурсы системы

  • Поддержка дисков с «горячей» заменой

  • Автоматическое определение CPU позволяет получить выигрыш, используя оптимизацию

Замечания

[1]

Шасси для горячей замены позволяет вам удалить жёсткий диск без отключения компьютера.

Назад | Начало | Вперёд
Кто должен использовать RAID? | Вверх | Уровни RAID-массивов и линейный RAID


Создание устройств RAID и точек монтирования

Назад Глава 10. Настройка программного RAID-массива Вперёд

10.2. Создание устройств RAID и точек монтирования

После того, как вы сделали все необходимые разделы программного RAID, создайте устройство RAID и точку монтирования, проделав следующие действия:

  1. Нажмите кнопку RAID в основном диалоге разбиения дисков утилиты Disk Druid (см. рисунок 10-5).

  2. Появляется диалог, показанный на рисунке 10-5. Выберите Создать устройство RAID (Create a RAID device).

    Рисунок 10-5. Параметры RAID

  3. Затем появляется, диалог, показанный на рисунке 10-6, в котором вы можете создать устройство RAID и назначить точку монтирования.

    Рисунок 10-6. Создание устройства RAID и назначение точки монтирования

  4. Укажите точку монтирования.

  5. Выберите тип файловой системы раздела. Здесь вы можете либо настроить динамическую файловую систему LVM или традиционную ext2/ext3. Если вы хотите настроить LVM, выберите физ. том (physical volume) (LVM), а затем обратитесь к разделу 8 Настройка LVM. Если LVM не требуется, продолжайте выполнение следующих инструкций.

  6. Выберите для устройства RAID имя, например md0.

  7. Выберите уровень RAID. Вы можете выбрать RAID 0, RAID 1 или RAID 5. Если вам нужно помощь в определении требуемого уровня RAID, обратитесь к разделу 9 Массив независимых дисков с избыточностью (RAID).

    Замечание Замечание

    Если вы создаёте массив RAID для раздела /boot, вы должны выбрать RAID уровня 1 и при этом использовать один из первых двух дисков (IDE первый, SCSI второй). Если вы не создавали отдельный RAID для /boot, и создаёте раздел RAID его для корневой файловой системы (/), это должен быть RAID уровня 1 и при этом он должен использовать один из первых двух дисков (IDE первый, SCSI второй).

    Рисунок 10-7. Ошибка монтирования /boot/

  8. Созданные разделы RAID отображаются в списке Члены RAID (RAID Members). Выберите разделы, которые следует использовать для создания RAID-массива.

  9. Если вы создаёте RAID 1 или RAID 5, укажите число резервных разделов. Если в разделе программного RAID происходит сбой, в качестве замены автоматически используется резервный раздел. Для каждого резервного раздела, который вы хотите здесь указать, вы должны создать дополнительный раздел программного RAID (помимо рабочих разделов RAID-массива). Выберите разделы длы RAID-массива и для резерва.

  10. После нажатия клавиши OK, созданное устройство RAID появляется в списке Сведения о дисках (Drive Summary).

  11. Повторите весь процесс, описанный в этой главе, для каждого дополнительного раздела, устройства, или точки подключения, например, для корневого раздела (/), /home/ или раздела подкачки.

После завершения всего процесса вы увидите окно, показанное на рисунке 10-8, в котором, в данном случае показана стандартная конфигурация, за исключением использования RAID.

Рисунок 10-8. Окончательная пробная конфигурация RAID

На рисунке 10-9 показан пример конфигурации RAID и LVM.

Рисунок 10-9. Окончательная пробная конфигурация RAID и LVM

После этого вы можете продолжить процесс установки. За дополнительными указаниями обратитесь к Руководству по установке Red Hat Linux.

Назад | Начало | Вперёд
Настройка программного RAID-массива | Вверх | Пространство подкачки


Уровни RAID-массивов и линейный RAID

Назад Глава 9. Массив независимых дисков с избыточностью (RAID) Вперёд

9.4. Уровни RAID-массивов и линейный RAID

RAID поддерживает различные конфигурации, включая уровни 0, 1, 4, 5 и линейный. Типы RAID описаны ниже:

  • Уровень 0 — RAID уровня 0, часто называется «чередование» (striping), приём записи на диски данных с чередованием, увеличивающий производительность. Это означает, что записываемые на диск данные, делятся на полосы, а затем записываются на все диски, входящие в массив, при этом увеличивается производительность ввода/вывода при небольших накладных расходах, но не обеспечивается отказоустойчивость. Ёмкость массива уровня 0 равна суммарной ёмкости дисков, составляющих аппаратный RAID или суммарной ёмкости разделов, включенных в программный RAID.

  • Уровень 1 — RAID уровня 1, или «зеркалирование» (mirroring) используется дольше всех остальных уровней RAID. Уровень 1 обеспечивает избыточность, записывая одинаковые данные на каждый диск, включенный в массив, сохраняя «зеркальную» копию данных на каждом диске. Зеркалирование остаётся популярным и сегодня по причине простоты и высокой степени доступности данных. На уровне 1 работа с двумя или более дисками может выполняться параллельно, что увеличивает скорость чтения данных, но всё же чаще они работают независимо, что увеличивает скорость выполнения транзакций ввода/вывода. Уровень 1 обеспечивает очень хорошую защиту данных и увеличивает производительность в приложениях, читающих много данных, но цена этого довольно высока. [1] Ёмкость массива уровня 1 равна ёмкости одного из зеркальных дисков в аппаратном RAID или ёмкости одного из зеркальных разделов, включенных в программный RAID.

  • Уровень 4 — На уровне 4 для защиты данных используется чётность [2], сосредоточенная на одном диске. Этот вариант больше подходит для транзакций ввода/вывода, чем для передачи больших файлов. Так как выделенный для чётности диск представляет собой узкое место, уровень 4 редко используется без сопутствующих технологий, таких как кэширование записи. Хотя RAID уровень 4 может применяться в каких-то схемах разбиения RAID, реализацией RAID в Red Hat Enterprise Linux он не поддерживается. [3] Ёмкость аппаратного RAID массива уровня 4 равняется ёмкости дисков, включенных в массив, минус ёмкость одного. Ёмкость программного RAID массива уровня 4 равняется ёмкости включённых в массив разделов минус размер одного из разделов, если все они одного размера.

  • Уровень 5 — Это самый распространённый уровень RAID. Распределяя чётность по всем дискам, включенным в массив, RAID уровня 5 ликвидирует узкое место при записи, существующее на уровне 4. Единственное, что влияет на производительность — процесс расчёта чётности. Для программного RAID, использующего современный процессор, обычно это не является большой проблемой. Также как и на уровне 4, производительность ассиметрична, то есть скорость чтения значительно превосходит скорость записи. Уровень 5 часто используется с кэшированием записи, что уменьшает ассиметрию. Ёмкость аппаратного RAID массива уровня 5 равняется ёмкости дисков, включённых в массив, минус ёмкость одного. Ёмкость программного RAID массива уровня 5 равняется ёмкости включённых в массив разделов минус размер одного из разделов, если все они одного размера.

  • Линейный RAID — Линейный RAID представляет собой простое объединение дисков, создающее большой виртуальный диск. В линейном RAID, блоки выделяются сначала на одном диске, включенном в массив, затем, если этот заполнен, на другом и т.д. Такое объединение не даёт выигрыша в производительности, так как скорее всего операции ввода/вывода не будут распределены между дисками. Линейный RAID также не содержит избыточности и, в действительности, увеличивает вероятность сбоя — если откажет всего один диск, из строя выйдет весь массив. Ёмкость массива равняется суммарной ёмкости всех дисков.

Замечания

[1] | RAID уровня 1 имеет высокую стоимость, так как вы записываете одну и ту же информацию на все диски в массиве, расходуя дисковое место. Например, если вы создали RAID-массив уровня 1, таким образом, что ваш корневой (/) раздел расположен на двух дисках объёмом 40 ГБайт, в сумме у вас будет 80 ГБайт, но доступно только 40 из этих 80. Другие 40 ГБайт являются отражением первых 40.
[2] | Информация о чётности рассчитывается на основании содержимого остальных дисков, включенных в массив. Эта информация затем может быть использована для восстановления данных, если откажет один диск массива. Восстановленные данные затем могут быть использованы при ответе на запросы ввода/вывода к отказавшему диску, пока он не будет заменён, а также для восстановления содержимого отказавшего диска после замены.
[3] | RAID уровня 4 занимает тот же объём, что и RAID уровня 5, но уровень 5 даёт больше преимуществ. Именно поэтому уровень 4 не поддерживается.
Назад | Начало | Вперёд
Сравнение аппаратных и программных RAID-массивов | Вверх | Настройка программного RAID-массива


Кто должен использовать RAID?

Назад Глава 9. Массив независимых дисков с избыточностью (RAID) Вперёд

9.2. Кто должен использовать RAID?

Те, кто нуждается в больших объемах дискового хранилища (например, системные администраторы) выиграют от использования технологии RAID. Основные причины использования RAID:

  • Увеличение скорости

  • Увеличение объёма одного виртуального диска

  • Уменьшение последствий отказа диска

Назад | Начало | Вперёд
Массив независимых дисков с избыточностью (RAID) | Вверх | Сравнение аппаратных и программных RAID-массивов


Проверка подлинности

Назад Глава 2. Настройка Kickstart Вперёд

2.6. Проверка подлинности

Рисунок 2-9. Проверка подлинности

В разделе Аутентификация (Authentication) определяется, будут ли использоваться скрытые пароли и MD5 для шифрования пользовательских паролей. Настоятельно рекомендуются устанавливать эти параметры, и по умолчанию они установлены.

На странице Настройка аутентификации (Authentication Configuration) вы можете настроить следующие методы проверки подлинности:

  • NIS

  • LDAP

  • Kerberos 5

  • Hesiod

  • SMB

  • Name Switch Cache

По умолчанию они не включены. Чтобы включить один или несколько этих методов, перейдите к соответствующей закладке, установите флажок Включить (Enable) и определите подходящие параметры метода проверки подлинности. За дополнительной информацией об этом обратитесь к главе 27 Настройка проверки подлинности.

Назад | Начало | Вперёд
Настройка сети | Вверх | Настройка брандмауэра


Параметры загрузчика

Назад Глава 2. Настройка Kickstart Вперёд

2.3. Параметры загрузчика

Рисунок 2-3. Параметры загрузчика

Загрузчиком по умолчанию в Red Hat Enterprise Linux является GRUB. Если вы не хотите устанавливать загрузчик, выберите вариант Не устанавливать загрузчик (Do not install a boot loader). Если вы решили не устанавливать загрузчик, убедитесь в том, что вы создали загрузочную дискету или у вас есть другая возможность загрузить вашу систему (например, какой-то другой загрузчик).

Вы должны решить, куда устанавливать загрузчик (в главную загрузочную запись или в первый сектор раздела /boot). Установите загрузчик в MBR, если вы планируете использовать его в качестве основного загрузчика системы.

Чтобы при загрузке системы передать ядру какие-то особые параметры, введите их в текстовом поле Параметры ядра (Kernel parameters). Например, если у вас есть записывающий привод IDE CD-ROM, вы можете включить в ядре драйвер эмуляции SCSI, который должен быть загружен перед использованием программыcdrecord, передав ядру параметр hdd=ide-scsi (где hdd — привод CD-ROM).

Вы можете настроить пароль GRUB и тем самым защитить загрузчик. Выберите Использовать пароль GRUB (Use GRUB password) и введите пароль в поле Пароль (Password). Введите тот же пароль в текстовое поле Повторите пароль (Confirm Password). Чтобы сохранить пароль в зашифрованном виде, установите флажок Зашифровать пароль GRUB (Encrypt GRUB password). Если вы выберете этот вариант, при сохранении файла введённый вами пароль в открытом виде будет зашифрован и записан в файл kickstart. Если вы вводите уже зашифрованный пароль, снимите этот флажок.

Если вы выбрали вариант Обновить существующую систему (Upgrade an existing installation) на странице Метод установки (Installation Method), отметьте вариант Обновить установленный начальный загрузчик (Upgrade existing boot loader), чтобы обновить параметры существующего загрузчика, но сохранить при этом старые записи.

Назад | Начало | Вперёд
Метод установки | Вверх | Информация о разделах


Настройка брандмауэра

Назад Глава 2. Настройка Kickstart Вперёд

2.7. Настройка брандмауэра

Окно Настройка брандмауэра (Firewall Configuration) похоже на аналогичный диалог в программе установки и в средстве Настройки уровня безопасности (Security Level Configuration Tool).

Рисунок 2-10. Настройка брандмауэра

Если выбран вариант Отключить брандмауэр (Disable firewall), система открывает полный доступ к любым активным службам и портам. Никакие подключения к системе не отклоняются и не запрещаются.

Если выбрана настройка Включить брандмауэр (Enable firewall), система отклоняет входящие подключения, кроме тех, что отвечают на исходящие запросы, как, например, ответы DNS или DHCP. Если доступ к службам, запущенным на этом компьютере, необходим, вы можете разрешить требуемые службы в брандмауэре.

В списке Доверенные устройства (Trusted devices) показываются только устройства, настроенные в разделе Настройка сети (Network Configuration). Система будет принимать соединения с любых устройств, выбранных в этом списке. Например, если eth1 получает данные только от внутренних компьютеров, возможно, вы захотите разрешить подключения с этого устройства.

Если служба выбрана в списке Доверенные службы (Trusted services), система принимает и обрабатывает подключения к этой службе.

В текстовом поле Другие порты (Other ports) можно перечислить дополнительные порты, которые следует открыть для удалённого доступа. Используйте следующий формат: port:protocol. Например, чтобы разрешить IMAP-доступ через брандмауэр, укажите imap:tcp. Также можно явно указать числовой номер порта; чтобы пропустить через брандмауэр UDP-пакеты в порт 1234, введите 1234:udp. Чтобы указать несколько портов, разделите их запятыми.

2.7.1. Настройка SELinux

Хотя конфигурация SELinux не задаётся в программе Настройка Kickstart (Kickstart Configurator), kickstart включает SELinux в режиме enforcing, если в файле kickstart опущен параметр selinux.

Назад | Начало | Вперёд
Проверка подлинности | Вверх | Настройка дисплея


Метод установки

Назад Глава 2. Настройка Kickstart Вперёд

2.2. Метод установки

Рисунок 2-2. Метод установки

Диалог Метод установки (Installation Method) позволяет вам определить, будете ли вы выполнить полную установку или обновление. Если вы выберете обновление, параметры Информация о разделах (Partition Information) и Выбор пакетов (Package Selection) будут недоступны. Эти параметры не поддерживаются при kickstart-обновлениях.

Выберите тип kickstart-установки или обновления из следующих вариантов:

  • CD-ROM — Выберите этот вариант, чтобы установить или обновить систему с компакт-дисков Red Hat Enterprise Linux.

  • NFS — Выберите этот вариант, чтобы установить или обновить систему из общего каталога NFS. В текстовом поле для указания NFS-сервера введите полностью определённое доменное имя или IP-адрес. В поле, где задаётся NFS-каталог, введите имя NFS-каталога, содержащего каталог RedHat дерева установки. Например, если на вашем NFS-сервере есть каталог /mirrors/redhat/i386/RedHat, в поле Каталог NFS (NFS directory) введите /mirrors/redhat/i386.

  • FTP — Выберите этот вариант, чтобы установить или обновить систему с FTP-сервера. В текстовом поле для указания FTP-сервера введите полностью определённое доменное имя или IP-адрес. В поле, где указывается каталог FTP, введите имя каталога, в котором находится подкаталог RedHat. Например, если на вашем FTP-сервере есть каталог /mirrors/redhat/i386/RedHat, в поле Каталог FTP (FTP directory) введите /mirrors/redhat/i386. Если FTP-серверу требует ввода имени пользователя и пароля, укажите их также.

  • HTTP — Выберите этот вариант, чтобы установить или обновить систему с HTTP-сервера. В текстовом поле для указания HTTP-сервера введите полностью определённое доменное имя или IP-адрес. В поле Каталог HTTP введите имя каталога, содержащего подкаталог RedHat. Например, если HTTP-сервер содержит каталог /mirrors/redhat/i386/RedHat, в поле Каталог HTTP (HTTP directory) введите /mirrors/redhat/i386.

  • Жёсткий диск (Hard Drive) — Выберите этот вариант, чтобы установить или обновить систему с жёсткого диска. Этот способ установки требует использования ISO (или CD-ROM) образов. До того как начнёте установку, убедитесь в том, что ISO-образы не повреждены. Чтобы проверить их, воспользуйтесь программой md5sum, а также параметром загрузки linux mediacheck, описанным в Руководстве по установке Red Hat Enterprise Linux. Укажите раздел жёсткого диска, содержащего ISO-образы (например, /dev/hda1) в текстовом поле Раздел жёсткого диска (Hard Drive Partition). Укажите каталог, содержащий ISO-образы в текстовом поле Каталог на жёстком диске (Hard Drive Directory).

Назад | Начало | Вперёд
Настройка Kickstart | Вверх | Параметры загрузчика


Настройка сети

Назад Глава 2. Настройка Kickstart Вперёд

2.5. Настройка сети

Рисунок 2-8. Настройка сети

Если в компьютере, устанавливаемом с помощью kickstart, нет платы Ethernet, не настраивайте её на странице Настройка сети (Network Configuration).

Поддержка сети необходима, только если выполняется сетевая установка (NFS, FTP или FTP). Сеть всегда можно настроить и после установки с помощью программы Настройка сети (Network Administration Tool) (system-config-network). За подробностями обратитесь к главе 18 Настройка сети.

Для каждой Ethernet-платы в вашем компьютере нажмите Добавить сетевое устройство (Add Network Device) и выберите для этой платы название устройства и тип сети. Выберите eth0 для первой платы Ethernet, eth1 — для второй, и т. д.

Назад | Начало | Вперёд
Информация о разделах | Вверх | Проверка подлинности


Информация о разделах

Назад Глава 2. Настройка Kickstart Вперёд

2.4. Информация о разделах

Рисунок 2-4. Информация о разделах

Определите, следует ли очищать главную загрузочную запись (Master Boot Record, MBR). Выберите, удалять ли существующие разделы, или удалять только разделы Linux, или сохранить имеющиеся разделы.

Чтобы присвоить метку диска, по умолчанию принятую в вашей архитектуре (например, msdos в x86 и gpt в Itanium), выберите пункт Инициализировать метку диска (Initialize the disk label), если вы проводите установку на совершенно новый жёсткий диск.

2.4.1. Создание разделов

Чтобы создать раздел нажмите кнопку Добавить (Add). На экране появится окно Параметры раздела (Partition Options), показанно на рисунке 2-5. Определите точку подключения, тип файловой системы и размер создаваемого раздела. По своему усмотрению вы также можете установить следующие параметры:

  • В разделе Дополнительные параметры размера (Additional Size Options) определите, будет ли размер раздела фиксированным, ограничен определенным максимумом или размером всего диска. Если создаваемый раздел имеет тип swap, вы можете выбрать вариант, когда программа установки сама выбирает размер для этого раздела, вместо того, чтобы указывать явно.

  • Создаваемый раздел должен стать основным (первичным) (Force the partition to be created as a primary partition.

  • Создать раздел на указанном жёстком диске (Make the partition on a specific hard drive). Напримиер, чтобы создать раздел на первом жёстком диске IDE (/dev/hda), укажите в качестве диска hda. Включать в имя диска /dev не нужно.

  • Использовать существующий раздел (Use an existing partition). Например, чтобы создать раздел в первом разделе первого жёсткого диска IDE (/dev/hda1), указжите в качестве раздела hda1. Включать в имя раздела /dev не нужно.

  • Форматировать раздел (Format the partition).

Рисунок 2-5. Создание разделов

Чтобы отредактировать существующий раздел, выберите раздел из списка и нажмите кнопку Правка (Edit). На экране появится то же окно Параметры раздела (Partition Options), что и при добавлении раздела (см. рисунок 2-5), только в данном случае оно отражает параметры выбранного раздела. Измените эти параметры и нажмите OK.

Чтобы удалить существующий раздел, выберите раздел в списке и нажмите кнопку Удалить (Delete).

2.4.1.1. Создание разделов программных RAID-массивов

Чтобы создать раздел программного RAID-массива, выполните следующие действия:

  1. Нажмите кнопку RAID.

  2. Выберите Создать программный раздел RAID (Create a software RAID partition).

  3. Настройте раздел, как описано ранее, только в этом случае выберите в качестве типа файловой системы Программный RAID (Software RAID). Кроме этого вы должны указать жёсткий диск, на котором будет создан раздел, или выбрать уже существующий раздел.

Рисунок 2-6. Создание программного раздела RAID

Повторяйте эти действия, создавая столько разделов, сколько необходимо для построения вашего RAID-массива. Вовсе не обязательно, чтобы все ваши разделы были RAID-разделами.

Создав все разделы, необходимые для организации RAID-массива, следуйте следующим указаниям:

  1. Нажмите кнопку RAID.

  2. Выберите Создать устройство RAID (Create a RAID device).

  3. Выберите точку подключения, тип файловой системы, имя RAID-устройства, уровень RAID, членов RAID-массива, число резервных разделов программного RAID-устройства, и определите, форматировать ли его.

    Рисунок 2-7. Создание программного устройства RAID

  4. Нажмите OK, чтобы добавить устройство в список.

Назад | Начало | Вперёд
Параметры загрузчика | Вверх | Настройка сети


Выбор пакетов

Назад Глава 2. Настройка Kickstart Вперёд

2.9. Выбор пакетов

Рисунок 2-14. Выбор пакетов

В окне Выбор пакетов (Package Selection) вы можете выбрать устанавливаемые группы пакетов.

Также здесь вы определить, будут ли зависимости разрешаться автоматически или игнорироваться.

В данной реализации программа Настройка Kickstart (Kickstart Configurator) не позволяет вам выбирать отдельные пакеты. Чтобы установить отдельные пакеты, отредактируйте раздел %packages файла kickstart после его создания. За подробностями обратитесь к разделу 1.5 Выбор пакетов.

Назад | Начало | Вперёд
Настройка дисплея | Вверх | Сценарий, выполняемый до установки


Сценарий, выполняемый после установки

Назад Глава 2. Настройка Kickstart Вперёд

2.11. Сценарий, выполняемый после установки

Рисунок 2-16. Сценарий после установки

Вы можете определить команды, которые будут выполнены в системе сразу после окончания установки. Если поддержка сети правильно настроена в фале kickstart, она включается и сценарий может выполнять команды, обращающиеся к сетевым ресурсам. Чтобы задать сценарий, выполняемый после установки, введите его в представленной текстовой области.

Внимание | Внимание
 | Не добавляйте команду %post. Она добавится сама.

Например, чтобы изменить сообщение дня установленной системы, добавьте следующую команду в раздел %post:

echo "Система установлена!" > /etc/motd

Подсказка | Подсказка
 | Дополнительные примеры можно найти в разделе 1.7.1 Примеры.

2.11.1. Окружение Chroot

Чтобы ваш сценарий выполнялся вне окружения chroot, установите флажок в верхней части страницы После установки (Post-Installation). Ему соответствует ключ --nochroot в разделе %post.

Чтобы внести изменения в только что установленную файловую систему, в пределах данного раздела, но вне окружения chroot, вы должны указать перед именем каталога /mnt/sysimage/.

Например, если вы установите флажок Выполнять вне окружения chroot (Run outside of the Сhroot environment), предыдущий пример потребуется изменить следующим образом:

echo "Система установлена!" > /mnt/sysimage/etc/motd

2.11.2. Использование интерпретатора

Чтобы определить язык для выполнения вашего сценария, установите флажок Использовать интерпретатор (Use an interpreter) и введите название интерпретатора в соседнем текстовом поле. Например, вы можете указать /usr/bin/python2.2 для выполнения сценария Python. Этот параметр соответствует ключу %post --interpreter /usr/bin/python2.2 в файле kickstart.

Назад | Начало | Вперёд
Сценарий, выполняемый до установки | Вверх | Сохранение файла


Сценарий, выполняемый до установки

Назад Глава 2. Настройка Kickstart Вперёд

2.10. Сценарий, выполняемый до установки

Рисунок 2-15. Сценарий до установки

Вы можете определить команды, которые будут выполняться в системе до начала установки, сразу после загрузки файла kickstart. Если вы определили в файле kickstart параметры сети, сеть будет настроена до обработки этого раздела. Чтобы задать сценарий, выполняемый перед установкой, введите его в представленной текстовой области.

Чтобы определить язык для выполнения вашего сценария, установите флажок Использовать интерпретатор (Use an interpreter) и введите название интерпретатора в соседнем текстовом поле. Например, вы можете указать /usr/bin/python2.2 для выполнения сценария Python. Этот параметр соответствует ключу %pre --interpreter /usr/bin/python2.2 в вашем файле kickstart.

Внимание | Внимание
 | Не добавляйте команду %pre. Она добавится сама.
Назад | Начало | Вперёд
Выбор пакетов | Вверх | Сценарий, выполняемый после установки


Сохранение файла

Назад Глава 2. Настройка Kickstart Вперёд

2.12. Сохранение файла

Чтобы просмотреть содержимое файла kickstart после окончания настройки параметров, выберите в меню Файл (File) => Предварительный просмотр (Preview).

Рисунок 2-17. Предварительный просмотр

Чтобы сохранить файл kickstart, нажмите в окне предпросмотра кнопку Сохранить в файл (Save to File). Чтобы сохранить файл без предпросмотра, выберите в меню Файл (File) => Сохранить файл (Save File) или нажмите [Ctrl]-[S]. На экране появляется диалоговое окно. Выберите, куда сохранить файл.

Сохранив файл, обратитесь к разделу 1.10 Начало установки Kickstart за инструкциями по запуску kickstart-установки.

Назад | Начало | Вперёд
Сценарий, выполняемый после установки | Вверх | Установка по сети с применением PXE


Настройка дисплея

Назад Глава 2. Настройка Kickstart Вперёд

2.8. Настройка дисплея

Если вы устанавливаете X Window System, вы можете настроить её во время kickstart-установки, отметив флажок Настройка системы X Window (Configure the X Window System) в окне Настройка дисплея (Display Configuration), показанном на рисунке 2-11. Если этот флажок не отмечен, параметры настройки X отключаются, а в файл kickstart записывается параметр skipx.

2.8.1. Общие

На первом этапе настройки X определяется глубина цвета и разрешение, используемые по умолчанию. Выберите значения параметров в соответствующих выпадающих меню. Убедитесь в том, что выбранные вами глубина цвета и разрешение поддерживаются вашим видеоадаптером и монитором.

Рисунок 2-11. Настройка X — Общие

Если вы устанавливаете два окружения рабочего стола GNOME и KDE, вы должны выбрать окружение по умолчанию. Если устанавливается только одно окружение, выберите его. Как только система будет установлена, пользователи смогут изменить окружение по умолчанию.

Затем определите, будет ли запускаться X Window System при загрузке системы. Если параметр установлен, система запускается на уровне выполнения 5 с графическим экраном входа. После установки системы это поведение можно изменить в файле конфигурации /etc/inittab.

Также выберите, должен ли запускаться Помощник по настройке (Setup Agent) после первой перезагрузки. По умолчанию он отключен, но, изменив этот параметр, вы можете включить его в обычном режиме или в режиме перенастройки. Режим перенастройки помимо стандартных параметров конфигурации позволяет также изменить настройки мыши, клавиатуры, языковые параметры, пароль root, уровень безопасности, часовой пояс и настройки сети.

2.8.2. Видеокарта

Флажок Определить видеокарту автоматически (Probe for video card) по умолчанию включён. При такой настройке программа установки выполняет автоматическое определение видеокарты в процессе установки. Автоопределение работает для большинства современных видеокарт. Если выбран этот параметр и программе установки не удаётся успешно обнаружить видеокарту, программа установки останавливается на диалоге настройки видеокарты. Для продолжения процесса установки вы должны будете выбрать видеокарту из списка и нажать Далее (Next).

Также вы можете выбрать видеокарту из списка на вкладке Видеокарта (Video Card), как показано на рисунке 2-12. Также выберите в выпадающем меню ОЗУ видекарты (Video Card RAM) объём видеопамяти, установленной на видеокарте. Эти значения используются программой установки для настройки системы X Window.

Рисунок 2-12. Настройка X — Видеокарта

2.8.3. Монитор

Настроив видеокарту перейдите на вкладку Монитор (Monitor), показанную на рисунке 2-13.

Рисунок 2-13. Настройка X — Монитор

По умолчанию флажок Определить монитор автоматически (Probe for monitor) включён. При такой настройке программа установки выполняет автоматическое определение монитора в процессе установки. Автоопределение работает для большинства современных мониторов. Если выбран этот параметр и программе установки не удаётся успешно обнаружить монитор, она останавливается на диалоге настройки монитора. Для продолжения процесса установки вы должны будете выбрать монитор из списка и нажать Далее (Next).

Здесь вы также можете выбрать свой монитор из списка. Вместо модели монитора вы можете указать частоты вертикальной и горизонтальной развёрток, установив флажок Использовать другие частоты развёртки монитора (Specify hsync and vsync instead of monitor). Этот параметр полезен, если монитор отсутствует в списке. Обратите внимание, когда этот флажок установлен, список мониторов недоступен.

Назад | Начало | Вперёд
Настройка брандмауэра | Вверх | Выбор пакетов


Создание новой группы

Назад Глава 33. Управление пользователями и группами Вперёд

33.3. Создание новой группы

Чтобы создать новую группу пользователей, нажмите кнопку Создать группу (New Group). На экране появится окно, показанное на рисунке 33-4. Введите имя создаваемой группы. Чтобы задать код новой группы явно, отметьте флажок Указать ID группы вручную (Specify group ID manually) и введите код группы (GID). В Red Hat Enterprise Linux коды групп, меньшие 500, зарезервированы для системных групп.

Нажмите OK, чтобы создать группу. Новая группа появляется в списке групп.

Рисунок 33-4. Новая группа

О том, как добавить пользователей в группу, рассказывает раздел 33.4 Изменение свойств группы.

Назад | Начало | Вперёд
Изменение свойств пользователя | Вверх | Изменение свойств группы


Изменение свойств группы

Назад Глава 33. Управление пользователями и группами Вперёд

33.4. Изменение свойств группы

Чтобы просмотреть свойства созданной группы, выберите её в списке групп и нажмите кнопку Свойства (Properties) (или выберите в выпадающем меню Файл (File) => Свойства (Properties)). На экране появится окно, показанное на рисунке 33-5.

Рисунок 33-5. Свойства группы

На вкладке Пользователи группы (Group Users) показано, какие пользователи входят в эту группу. Отметьте пользователей, которых нужно добавить в эту группу, и снимите отметку с пользователей, которых нужно исключить. Нажмите OK, чтобы изменить список членов группы.

Назад | Начало | Вперёд
Создание новой группы | Вверх | Использование командной строки


Объяснение процесса

Назад Глава 33. Управление пользователями и группами Вперёд

33.6. Объяснение процесса

Ниже иллюстрируется, что происходит, когда в системе, в которой включены скрытые пароли, выполняется команда useradd juan:

  1. В /etc/passwd добавляется новая строка для пользователя juan. Эта строка обладает следующими свойствами:

    • Она начинается с имени пользователя juan.

    • В поле пароля стоит x, что указывает на то, что в системе используются скрытые пароли.

    • Создаётся код пользователя (UID), больший или равный 500. (В Red Hat Enterprise Linux коды пользователей и групп (UID и GID), меньшие 500, зарезервированы для системы.)

    • Создаётся код группы (GID), больший или равный 500.

    • Необязательная информация GECOS остаётся незаполненной.

    • Пользователю juan назначается домашний каталог /home/juan/.

    • В качестве оболочки по умолчании назначается /bin/bash.

  2. В /etc/shadow также добавляется новая строка для пользователя juan. Эта строка обладает следующими свойствами:

    • Она начинается с имени пользователя juan.

    • В поле пароля в файле /etc/shadow стоят два восклицательных знака (!!), это означает, что учётная запись заблокирована.

      Замечание Замечание

      Если зашифрованный пароль был передан с помощью флага -p, он помещается в файл /etc/shadow в отдельной строке этого пользователя.

    • Срок действия заданного пароля не ограничен.

  3. В /etc/group добавляется новая строка для группы juan. Группа с тем же именем, что и пользователь, назыается личной группой пользователя. За дополнительной информацией о личных группах пользователей обратитесь к разделу 33.1 Создание нового пользователя.

    Созданная в /etc/group строка, обладает следующими свойствами:

    • Она начинается с имени группы juan.

    • В поле пароля стоит x, что указывает на то, что в системе используются скрытые пароли групп.

    • Код группы (GID) соответствует указанному для пользователя juan в файле /etc/passwd.

  4. В /etc/gshadow добавляется новая строка для группы juan. Эта строка обладает следующими свойствами:

    • Она начинается с имени группы juan.

    • В поле пароля в файле /etc/shadow стоит восклицательный знак (!!), это означает, что группа заблокирована.

    • Все остальные поля не заполнены.

  5. Для пользователя juan в каталоге /home/ создаётся домашний каталог. Владельцем этого каталога является пользователь juan и группа juan. Однако, доступ на чтение, запись и исполнение разрешён только пользователю juan. Любой другой доступ запрещён.

  6. Файлы, находящиеся в каталоге /etc/skel/ (который содержит параметры пользователей по умолчанию), копируются в созданный каталог /home/juan/.

На данном этапе в системе появляется заблокированная учётная запись с именем juan. Чтобы теперь активизировать её, администратор должен назначить ей пароль, используя команду passwd и, если требуется, определить политику устаревания пароля.

Назад | Начало | Вперёд
Использование командной строки | Вверх | Дополнительная информация


Изменение свойств пользователя

Назад Глава 33. Управление пользователями и группами Вперёд

33.2. Изменение свойств пользователя

Чтобы просмотреть свойства созданного пользователя, перейдите на вкладку Пользователи (Users), выберите пользователя из списка и нажмите кнопку Свойства (Properties) или выберите в выпадающем меню Файл (File) => Свойства (Properties). На экране появится окно, показанное на Рисунке 33-3.

Рисунок 33-3. Свойства пользователя

Окно Свойства пользователя (User Properties) разделено на на несколько вкладок:

  • Данные пользователя (User Data) — Содержит основные свойства пользователя, настраиваемые при создании пользователя. На этой вкладке вы можете изменить полное имя пользователя, пароль, домашний каталог или оболочку.

  • Свойства о учётной записи (Account Info) — Установите флажок Ограничить срок действия учётной записи (Enable account expiration), чтобы учётная запись перестала действовать в определённый день. Введите в предоставленные поля требуемую дату. Заблокировать учётную запись, чтобы пользователь не смог войти в систему, можно, установив флажок Локальный пароль заблокирован (User account is locked).

  • Сведения о пароле (Password Info) — На этой вкладке показаны дата и время последнего изменения пароля. Чтобы вынудить пользователя менять пароль по истечении определённого количества дней, выберите Ограничить срок действия учётной записи (Enable password expiration). Вы можете определить, за сколько дней истекает срок действия пароля, за сколько дней пользователь предупреждается о необходимости сменить пароль, а также через сколько дней учётная запись становится неактивной.

  • Группы (Groups) — Выберите группы, членом которых вы хотите сделать пользователя, а также основную группу пользователя.

Назад | Начало | Вперёд
Управление пользователями и группами | Вверх | Создание новой группы


Загрузка в режиме восстановления

Назад Глава 5. Основы восстановления системы Вперёд

5.2. Загрузка в режиме восстановления

Режим восстановления предоставляет возможность вместо загрузки с жёсткого диска загрузить минимальное окружение Red Hat Enterprise Linux целиком с CD-ROM или иным способом.

Как и следует из названия, режим восстановления предусмотрен для восстановления в случае сбоя. В штатном режиме ваша система Red Hat Enterprise Linux использует файлы, размещённые на жёстком диске компьютера для всего — запуска программ, хранения файлов и т.д.

Однако бывают ситуации, когда вы не можете полностью запустить Red Hat Enterprise Linux, и, таким образом, не получаете доступ к файлам на жёстком диске компьютера. В режиме восстановления вы можете обращаться к файлам на жёстком диске, даже если вы не смогли запустить Red Hat Enterprise Linux с этого диска.

Чтобы загрузиться в режиме восстановления вы должны иметь возможность загрузить систему одним из следующих способов [1]:

  • С загрузочного компакт-диска для установки.

  • С другого загрузочного носителя, например, с USB-устройства.

  • С компакт-диска Red Hat Enterprise Linux №1.

Загрузив систему одним из перечисленных способов, передайте ядру в качестве параметра слово rescue. Например, на платформе x86, введите в приглашении загрузчика установки следующую команду:

linux rescue

Вам предлагается ответить на некоторые базовые вопросы, в частности, выбрать используемый язык. Также вам предлагается выбрать, где расположен корректный образ восстановления. Выберите Локальный CD-ROM (Local CD-ROM), Жёсткий диск (Hard Drive), Образ NFS (NFS image), FTP или HTTP. В выбранном вами местоположении должно находиться подходящее дерево установки, и это должны быть установочные файлы той же версии Red Hat Enterprise Linux, что и на компакт-диске Red Hat Enterprise Linux CD-ROM #1, с которого вы загрузились. Если вы используете для запуска режима восстановления загрузочный компакт-диск или другой носитель, это должно быть то же дерево установочных каталогов, из которого создавался носитель. За дополнительными сведениями о настройке дерева установочных каталогов на жёстком диске, NFS, FTP или HTTP-сервере, обратитесь к Руководству по установке Red Hat Enterprise Linux.

Если вы выбрали образ восстановления, который не требует подключения к сети, вам предлагается определить, хотите ли вы установить сетевое подключение. Подключение к сети полезно, если, например, вам нужно скопировать файлы на другой компьютер или установить какие-то RPM-пакеты с общего сетевого ресурса.

На экране появляется следующее сообщение:

The rescue environment will now attempt to find
your Linux installation and mount it under the
directory /mnt/sysimage.  You can then make any
changes required to your system.  If you want
to proceed with this step choose 'Continue'.
You can also choose to mount your file systems
read-only instead of read-write by choosing
'Read-only'.

If for some reason this process fails you can
choose 'Skip' and this step will be skipped and
you will go directly to a command shell.

Если вы выберете Continue(Продолжить), система попытается смонтировать вашу файловую систему в точку /mnt/sysimage. Если смонтировать раздел не удастся, она сообщит вам об этом. Если вы выберете Read-Only(только чтение), она попытается смонтировать вашу файловую систему в точку /mnt/sysimage/, но в режиме только чтения. Если вы выберете Skip(Пропустить), ваша файловая система не будет смонтирована. Выбирайте Skip(Пропустить), если считаете, что файловая система повреждена.

Как только система загрузится в режиме восстановления, на VC (виртуальной консоли) 1 и VC 2 появляется приглашение (используйте сочетание клавиш [Ctrl]-[Alt]-[F1] для перехода к VC 1 и сочетание [Ctrl]-[Alt]-[F2] для доступа к VC 2):

sh-3.00b#

Если вы выбрали Continue (Продолжить), чтобы разделы смонтировались автоматически, и они были успешно смонтированы, вы оказываетесь в режиме одного пользователя.

Даже если ваша файловая система смонтирована, в режиме восстановления корневым разделом по умолчанию становится временный раздел, а не тот, что используется при работе в обычном режиме (на уровнях выполнения 3 или 5). Если решили смонтировать свою файловую систему и она была смонтирована успешно, вы можете сменить корневой раздел окружения режима восстановления на корневой раздел вашей файловой системы, выполнив следующую команду:

chroot /mnt/sysimage

Это полезно, если вы хотите выполнять команды, такие как rpm, требующие, чтобы корневой раздел системы был подключен как /. Чтобы выйти из окружения chroot, введите в приглашении exit.

Если вы выбрали Skip(Пропустить), вы, тем не менее, можете попробовать смонтировать раздел или логический том LVM2 вручную в режиме восстановления, создав каталог, например, с именем /foo, и выполнив следующую команду:

mount -t ext3 /dev/mapper/VolGroup00-LogVol02 /foo

В приведённой выше команде, /foo — созданный вами каталог, а /dev/mapper/VolGroup00-LogVol02 — логический том LVM2, который вы хотите смонтировать. Если раздел имеет тип ext2, замените ext3 на ext2.

Если вы не знаете названий всех ваших физических разделов, их можно узнать, выполнив следующую команду:

fdisk -l

Если вы не знаете названий всех ваших физических томов LVM2, их можно узнать, выполнив следующие команды:

pvdisplay
vgdisplay
lvdisplay

Вы можете выполнять в приглашении множество полезных команд, включая следующие:

  • ssh, scp и ping, если сеть запущена

  • dump и restore, если вы используете ленточные накопители

  • parted и fdisk для управления разделами

  • rpm для установки или обновления программного обеспечения

  • joe для редактирования файлов конфигурации

    Замечание Замечание

    Если вы попытаетесь запустить другие популярные редакторы, например, emacs, pico или vi, всё равно запустится редактор joe.

5.2.1. Переустановка загрузчика

Часто случается, что загрузчик GRUB по ошибке заменяется загрузчиком другой операционной системы, удаляется или портится.

Ниже подробно описан процесс переустановки GRUB в главной загрузочной записи:

  • Загрузите компьютер с загрузочного носителя для установки.

  • Введите в приглашении загрузчика установки linux rescue, чтобы попасть в среду восстановления.

  • Введите chroot /mnt/sysimage, чтобы смонтировать корневой раздел.

  • Введите /sbin/grub-install /dev/hda, чтобы переустановить загрузчик GRUB, где /dev/hda — загрузочный раздел.

  • Просмотрите файл /boot/grub/grub.conf, возможно, для загрузки с помощью GRUB других операционных систем потребуется добавить дополнительные записи.

  • Перегрузите компьютер.

Замечания

[1]

Подробнее об этом рассказывается в Руководстве по установке Red Hat Enterprise Linux.

Назад | Начало | Вперёд
Основы восстановления системы | Вверх | Загрузка в монопольном режиме


Загрузка в аварийном режиме

Назад Глава 5. Основы восстановления системы Вперёд

5.4. Загрузка в аварийном режиме

В аварийном (emergency) режиме, система будет загружена с минимальным окружением. Корневая файловая система монтируется в режиме только чтения и почти ничего настраивать не надо. Основным преимуществом аварийного режима по сравнению с монопольным, является то, что файлы init не загружаются. Если окружение init повреждено и не работает, вы всё же можете смонтировать файловые системы, чтобы восстановить данные, которые могут быть потеряны при переустановке.

Чтобы загрузиться в аварийном режиме, выполните действия для входа в монопольный режим, описанные в разделе 5.3 Загрузка в монопольном режиме с одним исключением: вместо слова single вы должны указать emergency.

Назад | Начало | Вперёд
Загрузка в монопольном режиме | Вверх | Файловые системы


Загрузка в монопольном режиме

Назад Глава 5. Основы восстановления системы Вперёд

5.3. Загрузка в монопольном режиме

Одним из преимуществ монопольного режима является то, что вам не нужен загрузочный CD-ROM; однако в этом режиме вы не имеете возможности монтировать файловые системы только для чтения, и вообще монтировать их.

Если ваша система загружается, но вы не можете зарегистрироваться после завершения загрузки, попробуйте монопольный режим.

В монопольном режиме ваш компьютер загружается до уровня выполнения 1. Локальные файловые монтируются, но сеть не запускается. Тем не менее вы получаете полезную оболочку для обслуживания системы. В отличие от режима восстановления, монопольный режим пытается автоматически смонтировать вашу файловую систему. Не используйте монопольный режим, если смонтировать вашу файловую систему нельзя.Вы не сможете использовать монопольный режим, если у вас испорчена конфигурация уровня выполнения 1.

Чобы загрузить в монопольном режиме компьютер x86 с загрузчиком GRUB, выполните следующие действия, :

  1. Увидев окно приветствия GRUB при загрузке, нажмите любую клавишу, чтобы войти в интерактивное меню GRUB.

  2. Выберите Red Hat Enterprise Linux с версией ядра, которую вы хотите загрузить, и нажмите a для добавления новой строки.

  3. Перейдите к концу строки и введите single в виде отдельного параметра (нажмите [пробел], а затем введите single). Нажмите [Enter], чтобы выйти из режима редактирования.

Назад | Начало | Вперёд
Загрузка в режиме восстановления | Вверх | Загрузка в аварийном режиме


Дополнительные ресурсы

Назад Глава 15. Управление пакетами с помощью RPM Вперёд

15.5. Дополнительные ресурсы

RPM — очень сложная программа со множеством параметров и способов анализа, установки, обновления и удаления пакетов. Чтобы узнать о RPM больше, обратитесь к следующим ресурсам.

15.5.1. Установленная документация

  • rpm --help — Эта команда показывает краткий список параметров RPM.

  • man rpm — На этой странице руководства man вы найдёте более подробное описание параметров RPM, по сравнению с командой rpm --help.

15.5.2. Полезные сайты

  • http://www.rpm.org/ — Сайт RPM.

  • http://www.redhat.com/mailman/listinfo/rpm-list/ — Здесь находится архив списка рассылки RPM. Чтобы подписаться на рассылку, пошлите письмо по адресу <rpm-list-request@redhat.com>, указав в поле Тема слово subscribe.

15.5.3. Книги по этой теме

  • Red Hat RPM Guide (автор Ерик Фостер-Джонсон (Eric Foster-Johnson), издательство Wiley, John & Sons, Incorporated) — Эта книга является исчерпывающим руководством по RPM, в ней рассматривается самые разные вопросы, от установки пакетов до создания собственных RPM-пакетов.

Назад | Начало | Вперёд
Удивите друзей возможностями RPM | Вверх | Средство «Управление пакетами»


Удивите друзей возможностями RPM

Назад Глава 15. Управление пакетами с помощью RPM Вперёд

15.4. Удивите друзей возможностями RPM

RPM представляет собой полезный инструмент для управления системой, а также для выявления и исправления проблем. Лучше всего понять его возможности можно, взглянув на несколько примеров.

  • Возможно, вы случайно удалили несколько файлов, но не знаете, какие именно. Чтобы проверить всю систему и найти утраченное, выполните следующую команду:

    rpm -Va

    Если некоторые файлы потеряны или кажутся испорченными, вы, вероятно, должны переустановить пакет или удалить его, а затем установить снова.

  • Вы также можете случайно наткнуться на неизвестный вам файл. Чтобы выяснить, к какому пакету он относится, выполните:

    rpm -qf /usr/bin/ggv

    На экране появится примерно следующее:

    ggv-2.6.0-2

  • Можно объединить оба примера в следующем сценарии. Скажем, у вас возникли проблемы с программой /usr/bin/paste. Вы хотели бы проверить пакет, в который она включена, но не знаете, в какой пакет включена программа paste. Введите следующую информацию,

    rpm -Vf /usr/bin/paste

    и соответствующий пакет будет проверен.

  • Вы хотите получить дополнительную информацию о конкретной программе? Вы можете выполнить следующую команду, чтобы найти документацию, поставляемую с пакетом, включающим эту программу:

    rpm -qdf /usr/bin/free

    При этом на экране появится примерно следующее:

    /usr/share/doc/procps-3.2.3/BUGS
/usr/share/doc/procps-3.2.3/FAQ
/usr/share/doc/procps-3.2.3/NEWS
/usr/share/doc/procps-3.2.3/TODO
/usr/share/man/man1/free.1.gz
/usr/share/man/man1/pgrep.1.gz
/usr/share/man/man1/pkill.1.gz
/usr/share/man/man1/pmap.1.gz
/usr/share/man/man1/ps.1.gz
/usr/share/man/man1/skill.1.gz
/usr/share/man/man1/slabtop.1.gz
/usr/share/man/man1/snice.1.gz
/usr/share/man/man1/tload.1.gz
/usr/share/man/man1/top.1.gz
/usr/share/man/man1/uptime.1.gz
/usr/share/man/man1/w.1.gz
/usr/share/man/man1/watch.1.gz
/usr/share/man/man5/sysctl.conf.5.gz
/usr/share/man/man8/sysctl.8.gz
/usr/share/man/man8/vmstat.8.gz

  • Возможно, вы нашли новый RPM-пакет, но не знаете, что он делает. Чтобы найти информацию о нём, выполните следующую команду:

    rpm -qip crontabs-1.10-7.noarch.rpm

    При этом на экране появится примерно следующее:

    Name        : crontabs                     Relocations: (not relocatable)
Version     : 1.10                              Vendor: Red Hat, Inc.
Release     : 7                             Build Date: Mon 20 Sep 2004 05:58:10 PM EDT
Install Date: (not installed)               Build Host: tweety.build.redhat.com
Group       : System Environment/Base       Source RPM: crontabs-1.10-7.src.rpm
Size        : 1004                             License: Public Domain
Signature   : DSA/SHA1, Wed 05 Jan 2005 06:05:25 PM EST, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Root crontab files used to schedule the execution of programs.
Description :
The crontabs package contains root crontab files. Crontab is the
program used to install, uninstall, or list the tables used to drive the
cron daemon. The cron daemon checks the crontab files to see when
particular commands are scheduled to be executed. If commands are
scheduled, then it executes them.

  • Возможно, вы захотите узнать, какие файлы устанавливает RPM-пакет crontabs. Выполните следующую команду:

    rpm -qlp crontabs-1.10-5.noarch.rpm

    При этом на экране появится примерно следующее:

    /etc/cron.daily
/etc/cron.hourly
/etc/cron.monthly
/etc/cron.weekly
/etc/crontab
/usr/bin/run-parts

Здесь приведены всего несколько примеров. По мере использования RPM вы найдете множество новых вариантов его применения.

Назад | Начало | Вперёд
Проверка подписи пакета | Вверх | Дополнительные ресурсы


Использование RPM

Назад Глава 15. Управление пакетами с помощью RPM Вперёд

15.2. Использование RPM

RPM имеет пять основных режимов работы (не считая создания пакета): установка, удаление, обновление, анализ и проверка. Этот раздел содержит описание каждого режима. Чтобы получить полное описание всех подробностей и параметров, попробуйте выполнить rpm --help или обратиться к разделу 15.5 Дополнительные ресурсы.

15.2.1. Поиск RPM-пакетов

Прежде чем воспользоваться пакетами RPM, вы должны знать, где их найти. Поисковые машины в Интернете знают о множество хранилищ RPM, но если вы ищете пакеты RPM, созданные компанией Red Hat, обратитесь к следующим источникам:

  • Компакт-диски Red Hat Enterprise Linux

  • Страница обновлений Red Hat, расположенная по адресу http://www.redhat.com/apps/support/errata/.

  • Список зеркал FTP-сервера Red Hat, опубликованный по адресу http://www.redhat.com/download/mirror.html

  • Сеть Red Hat Network — Подробнее о ней вы узнаете в главе 17 Red Hat Network

15.2.2. Установка

Обычно файлы, содержащие пакеты RPM, имеют имена вроде foo-1.0-1.i386.rpm. Имя файла включает название пакета (foo), версию (1.0), выпуск (1) и архитектуру (i386). Чтобы установить пакет, войдите в систему под именем root и введите в приглашении оболочки следующую команду:

rpm -Uvh foo-1.0-1.i386.rpm

Если установка пройдёт успешно, на экране появится следующее:

Preparing...                ########################################### [100%]
   1:foo                    ########################################### [100%]

Как вы видите, RPM выводит имя пакета, а затем, по мере установки пакета, последовательность символов «решётка», отражающую процесс установки.

При установке или обновлении пакета автоматически проверяется подпись пакета. Эта подпись подтверждает то, что пакет был подписан разработчиком и не был изменён. Например, если при проверке подписи происходит ошибка, вы получите примерно следующее сообщение:

error: V3 DSA signature: BAD, key ID 0352860f

Если это новая подпись только для заголовка появляется такое сообщение:

error: Header V3 DSA signature: BAD, key ID 0352860f

Если у вас не установлен ключ, подходящий для проверки подписи, сообщение об ошибке содержит слово NOKEY, например:

warning: V3 DSA signature: NOKEY, key ID 0352860f

За дополнительными сведениями о проверке подписи пакета обратитесь к разделу 15.3 Проверка подписи пакета.

Предупреждение | Предупреждение
 | Если вы устанавливаете пакет ядра, вместо этой команды следует использовать rpm -ivh. За подробностями обратитесь к главе 37 Обновление ядра вручную.

Установка пакетов должна выполняться просто, но иногда вы можете встретить ошибки:

15.2.2.1. Пакет уже установлен

Если пакет той же версии уже установлен, вы увидите:

Preparing...                ########################################### [100%]
package foo-1.0-1 is already installed

Если версия пакета, который вы пытаетесь установить, совпадает с версией уже установленного, но вы, тем не менее, хотите установить пакет, вы можете указать параметр --replacepkgs и RPM проигнорирует эту ошибку:

rpm -ivh --replacepkgs foo-1.0-1.i386.rpm

Этот параметр полезен, если файлы, установленные из пакета RPM, были удалены или вы не хотите, чтобы были установлены оригинальные файлы конфигурации RPM.

15.2.2.2. Конфликтующие файлы

Если вы пытаетесь установить пакет, который содержит файл, установленный другим пакетом или более ранней версий того же пакета, на экране появляется сообщение:

Preparing...                ########################################### [100%]
file /usr/bin/foo from install of foo-1.0-1 conflicts with file from package bar-2.0.20

Чтобы RPM игнорировал эту ошибку, укажите параметр --replacefiles:

rpm -ivh --replacefiles foo-1.0-1.i386.rpm

15.2.2.3. Нарушенная зависимость

Пакеты RPM могут по сути зависеть от других пакетов, что означает, что для их нормальной работы необходимо установить другие пакеты. Если вы попытаетесь установить пакет с неразрешёнными зависимостями, вы увидите примерно следующее:

error: Failed dependencies:
        bar.so.2 is needed by foo-1.0-1
    Suggested resolutions:
        bar-2.0.20-3.i386.rpm

Если вы устанавливаете пакет с набора компакт-дисков Red Hat Enterprise Linux CD-ROM, обычно вам предлагается название пакета, необходимого для разрешения зависимости. Найдите предлагаемый пакет(ы) на компакт-дисках Red Hat Enterprise Linux или на FTP-сайте Red Hat (или зеркале) и добавьте его в команду:

rpm -ivh foo-1.0-1.i386.rpm bar-2.0.20-3.i386.rpm

Если установка обоих пакетов прходит успешно, на экран выводится примерно следующее:

Preparing...                ########################################### [100%]
   1:foo                    ########################################### [ 50%]
   2:bar                    ########################################### [100%]

Если система не предлагает пакет для разрешения зависимости, вы можете попробовать параметр --redhatprovides, чтобы определить, какой пакет содержит требуемый файл. Для использования этого параметра вам потребуется установить пакет rpmdb-redhat.

rpm -q --redhatprovides bar.so.2

Если пакет, содержащий bar.so.2, есть в установленной базе данных из пакета rpmdb-redhat, вы увидите название этого пакета:

bar-2.0.20-3.i386.rpm

Чтобы выполнить установку, нарушив зависимости (что не рекомендуется делать, так как пакет может работать некорректно), воспользуйтесь параметром --nodeps.

15.2.3. Удаление

Удаление пакета выполняется также просто, как и его установка. Введите в приглашении оболочки следующую команду:

rpm -e foo

Замечание | Замечание
 | Обратите внимание, здесь используется имя пакета foo, а не имя файла оригинального пакета foo-1.0-1.i386.rpm. Чтобы удалить пакет, замените foo действительным именем первоначального пакета.

Вы можете столкнуться с нарушением зависимости при удалении пакета, если другой установленный пакет зависит от пакета, который вы пытаетесь удалить. Например:

error: Failed dependencies:
        foo is needed by (installed) bar-2.0.20-3.i386.rpm

Чтобы заставить RPM игнорировать эту ошибку и удалить пакет, что может привести к поломке пакета, зависящего от него, используйте параметр --nodeps.

15.2.4. Обновление

Обновление пакета похоже на его установку. Введите в приглашении оболочки следующую команду:

rpm -Uvh foo-2.0-1.i386.rpm

В процессе обновления пакета RPM автоматически удаляет все старые версии пакета foo. В действительности, вы можете всегда использовать параметр -U для установки пакетов, так как он работает, даже если предыдущая версия пакета не установлена.

Подсказка Подсказка

Не стоит использовать параметр -U для установки пакетов ядра, так как при этом RPM заменит предыдущий пакет ядра. Это не влияет на работающую систему, но если после следующей перезагрузки запустить новое ядро не удастся, никакого другого ядра для загрузки вместо него не будет.

Параметр -i добавляет ядро в меню загрузчика GRUB (/etc/grub.conf). Подобным образом, при удалении старого, ненужного ядра, запись этого ядра удаляется из GRUB.

Так как RPM выполняет умное обновление пакетов с файлами конфигурации, вам может встретиться подобное сообщение:

saving /etc/foo.conf as /etc/foo.conf.rpmsave

Это сообщение означает, что изменения файла конфигурации могут оказаться не совместимыми снизу вверх с новым файлом конфигурации, входящим в пакет, поэтому RPM сохранил ваш первоначальный файл и установил новый. Вы должны проанализировать различия между двумя файлами конфигурации и разобраться с ними как можно скорее, чтобы ваша система смогла продолжить нормальную работу.

Обновление в самом деле представляет собой комбинацию удаления и установки, поэтому во время обновления RPM вы можете встретить ошибки и удаления, и установки, плюс ещё одну. Если RPM считает, что вы пытаетесь обновить пакет с более старой версией, он сообщает примерно следующее:

package foo-2.0-1 (which is newer than foo-1.0-1) is already installed

Чтобы, несмотря на это, принудительно обновить пакет, укажите параметр --oldpackage:

rpm -Uvh --oldpackage foo-1.0-1.i386.rpm

15.2.5. Освежение

Освежение пакета похоже на его обновление. Введите в приглашении оболочки следующую команду:

rpm -Fvh foo-1.2-1.i386.rpm

Получив указание освежить пакет, RPM сравнивает версию пакетов, заданных в командной строке с версией пакетов, установленных в системе. Если в параметрах RPM указан пакет с версией новее установленного пакета, он обновляется до более новой версии. Однако, указание RPM освежить версию не будет работать, если пакет с таким именем не был установлен ранее. Этим данным параметр и отличается от параметра обновления, так как при обновлении пакеты устанавливаются вне зависимости от того, была ли установлена старая верия пакета.

RPM может выполнить эту операцию как для одного пакета, так и для групп пакетов. Если вы только что загрузили много разнообразных пакетов и хотите обновить только установленные в системе, «освежение» пакетов — именно то, что вам нужно. Если вы освежаете пакеты, перед использованием RPM вы можете не удалять ненужные пакеты из загруженной группы пакетов.

В этом случае выполните следующую команду:

rpm -Fvh *.rpm

RPM автоматически обновит только уже установленные пакеты.

15.2.6. Анализ

Чтобы обратиться к базе данных установленных пакетов, используйте команду rpm -q. Команда rpm -q foo выводит название пакета, версию и номер выпуска установленного пакета foo:

foo-2.0-1

Замечание | Замечание
 | Чтобы запросить информацию о пакете, замените foo действительным именем пакета.

Вместо указания имени пакета используйте следующие параметры команды -q для указания запрашиваемого пакета (ов). Эти параметры называются Параметрами выбора пакета.

  • -a запрашивает все установленные пакеты.

  • -f <file> запрашивает пакет, к которому относится файл <file>. Указывая файл, вы должны определить полный путь к файлу (например, /bin/ls).

  • -p <packagefile> запрашивает пакет <packagefile>.

Указать параметры запроса можно разными способами. Следующие параметры определяют тип искомой информации. Они называются Параметрами запроса информации.

  • -i отображает информацию о пакете, включая имя, описание, выпуск, размер, дату сборки, дату установки, производителя и другую разнообразную информацию.

  • -l выводит список файлов, содержащихся в пакете.

  • -s выводит состояние всех файлов в пакете.

  • -d выводит список файлов, помеченных как документация (страницы man, info, файлы README, и т.д.).

  • -c выводит список файлов, помеченных как файлы конфигурации. Таковыми считаются файлы, изменяемые вами после установки при настройке пакета в вашей системе (например, sendmail.cf, passwd, inittab и т.д.).

Добавьте для параметров, выводящих списки файлов, команду -v и вы получите списки в знакомом формате ls -l.

15.2.7. Проверка

При проверке пакета информация о файлах, установленных из пакета, сравнивается с информацией из оригинального пакета. Помимо прочего, при такой проверке проверяется размер, сумма MD5, разрешения, тип, владелец и группа владельца каждого файла.

Проверку пакета выполняет команда rpm -V. Вы можете указать пакет, который хотите проверить, используя любой из перечисленных параметров выбора пакета. Простым примером проверки является команда rpm -V foo, которая проверяет, что все файлы пакета foo находятся там, куда они были изначально установлены. Например:

  • Чтобы проверить пакет, содержащий конкретный файл, выполните:

    rpm -Vf /usr/bin/vim

  • Чтобы проверить ВСЕ установленные пакеты:

    rpm -Va

  • Чтобы сравнить установленный пакет с файлом RPM-пакета:

    rpm -Vp foo-1.0-1.i386.rpm

    Эта команда может быть полезна, если вы сомневаетесь в целостности баз данных RPM.

Если проверка проходит успешно, никакие сообщения на экран не выводятся. В случае обнаружения каких-либо нарушений, вы увидите сообщения об этом. Для каждого несоответствия на экран будет выведена строка из восьми символов ( c обозначает файл конфигурации), а затем имя файла. Каждый из восьми символов обозначает результат сравнения одного атрибута файла со значением атрибута, записанного в базе данных RPM. Единственная точка (.) означает, что тест пройден. Следующие символы обозначают ошибки при выполнении определённых проверок:

  • 5 — контрольная сумма MD5

  • S — размер

  • L — символическая ссылка

  • T — дата изменения файла

  • D — устройство

  • U — пользователь

  • G — группа

  • M — режим (включая разрешения и тип файла)

  • ? — файл не удалось прочитать

Если вы увидели такие сообщения, вы должны решить, будете ли вы удалять или переустанавливать пакет, или исправлять проблему другим способом.

Назад | Начало | Вперёд
Управление пакетами с помощью RPM | Вверх | Проверка подписи пакета


Дополнительные ресурсы

Назад Глава 23. Samba Вперёд

23.4. Дополнительные ресурсы

Информацию о параметрах настройки, не освященных здесь, можно найти в следующих источниках.

23.4.1. Установленная документация

  • Страница man smb.conf — объясняет, как настроить файл конфигурации Samba

  • Страница man smbd — описывает принцип работы демона Samba

  • Страницы msn smbclient и findsmb рассказывают об этих клиентсках утилитах больше

  • /usr/share/doc/samba-<version-number>/docs/ — файлы справки, включенные в пакет samba.

23.4.2. Полезные сайты

  • http://www.samba.org — Сайт, посвященный Samba, содержит полезную документацию, информацию о списках рассылки и список графических интерфейсов.

  • http://www.samba.org/samba/docs/using_samba/toc.html — Интернет-версия книги Using Samba, 2nd Edition (авторы Джей Ц (Jay Ts), Роберт Екстейн (Robert Eckstein) и Дэвид Колье-Браун (David Collier-Brown), издательство O'Reilly & Associates).

Назад | Начало | Вперёд
Подключение к общему ресурсу Samba | Вверх | Протокол динамической конфигурации узлов (DHCP)


Настройка сервера Samba

Назад Глава 23. Samba Вперёд

23.2. Настройка сервера Samba

Файл конфигурации Samba по умолчанию (/etc/samba/smb.conf) позволяет пользователям просматривать свои домашние каталоги как ресурсы Samba. Служба Samba также позволяет разделять все настроенные в системе принтеры в виде общих принтеров Samba. Другими словами, вы можете подключить к своему компьютеру принтер и печатать на нём, работая в сети на компьютерах с Windows.

23.2.1. Настройка в графическом режиме

Чтобы настроить Samba в графическом интерфейсе, воспользуйтесь средством Настройка сервера Samba (Samba Server Configuration Tool). Если вас интересует настройка в командной строке, перейдите к разделу 23.2.2 Настройка в командной строке.

Средство Настройка сервера Samba (Samba Server Configuration Tool) — это графическое приложение для управления общими ресурсами, пользователями и основными настройками сервера Samba. Оно изменяет файлы конфигурации в каталоге /etc/samba/. При этом сохраняются изменения внесённые за рамками этого приложения.

Чтобы вы могли использовать это приложение, у вас должна работать система X Window, должен быть установлен RPM-пакет system-config-samba и вы должны иметь привилегии root. Чтобы запустить средство Настройка сервера Samba (Samba Server Configuration Tool) с рабочего стола, выберите в Главном меню (Main Menu) (на панели) => Системные параметры (System Settings) => Настройка сервера (Server Settings) => Samba или введите команду system-config-samba в приглашении оболочки (например, в XTerm или терминале GNOME).

Рисунок 23-1. Настройка сервера Samba

Замечание | Замечание
 | Средство Настройка сервера Samba не показывает общих принтеров и стандартной строфы конфигурации, позволяющей пользователям обращаться к своим домашним каталогам на сервере Samba.

23.2.1.1. Настройка параметров сервера

Первым шагом настройки сервера Samba является настройка основных параметров сервера и нескольких параметров безопасности. Запустив приложение, выберите в выпадающем меню Настройка (Preferences) => Параметры сервера (Server Settings). На экране появится вкладка Основные (Basic), показанная на рисунке 23-2.

Рисунок 23-2. Настройка основных параметров сервера

На вкладке Основные (Basic) определите, к какой рабочей группе должен относиться компьютер, а также его краткое описание. Этим полям соответствуют параметры workgroup и server string в файле smb.conf.

Рисунок 23-3. Настройка параметров безопасности сервера

Вкладка Доступ содержит следующие параметры:

  • Режим аутентификации (Authentication Mode) — Этой настройке соответствует параметр security. Выберите один из следующих типов проверки подлинности.

    • ADS — Сервер Samba работает как участник домена в сфере домена Active Directory (Active Directory Domain, ADS). Для этого на сервере должен быть установлени и настроен Kerberos, а Samba должна стать участником сферы ADS с помощью команды net, включённой в пакет samba-client. За дополнительной информацией обратитесь к странице man net. При выборе этого варианта Samba не становится контроллером ADS. Укажите сферу сервера Kerberos в поле Домен Kerberos (Kerberos Realm).

      Замечание Замечание

      Значение поля Домен Kerberos (Kerberos Realm) должно указываться большими буквами, например EXAMPLE.COM.

      Использование сервера Samba в качестве участника домена в сфере ADS подразумевает правильную настройку Kerberos, включая файл /etc/krb5.conf.

    • Домен (Domain) — Сервер Samba проверяет пользователя, полагаясь на первичный и резервный контроллер домена Windows NT. Сервер контроллеру передаёт имя и пароль пользователя, и ждёт от него ответа. Укажите в поле Сервер аутентификации (Authentication Server) NETBIOS-имя первичного или резервного контроллера домена.

      Если выбран этот вариант, параметр Шифровать пароли (Encrypted Passwords) должен иметь значение Да (Yes).

    • Сервер (Server) — Сервер Samba пытается проверить комбинацию имени пользователя и пароля с помощью другого сервера Samba. Если это не удаётся, сервер пытается проверить её, используя режим проверки подлинности пользователя. Укажите в поле Сервер аутентификации (Authentication Server) NETBIOS-имя другого сервера Samba.

    • Ресурс (Share) — Пользователи Samba не должны вводить своё имя и пароль при подключении к серверу Samba. Сервер Samba не спрашивает имя и пароль, пока они не попытаются подключиться к определённому общему каталогу этого сервера.

    • Пользователь (User) — (По умолчанию) Пользователи Samba должны представить правильное имя пользователя и пароль для сервера Samba. Выберите этот вариант, если вы хотите чтобы работал параметр Имя пользователя Windows (Windows Username). За подробностями обратитесь к разделу 23.2.1.2 Управление пользователями Samba.

  • Шифровать пароли (Encrypt Passwords) — Этот параметр должен быть включён, если к серверы подключаются клиенты с системой Windows 98, Windows NT 4.0 с пакетом исправления 3 или более новой системой Microsoft Windows. В этом случае пароли между клиентом и сервером передаются не открытым текстом (при этом их можно перехватить), а в зашифрованном виде. Этой настройке соответствует параметр encrypted passwords. За дополнительными сведениями о шифрование паролей Samba обратитесь к разделу 23.2.3 Зашифрованные пароли.

  • Гостевая учётная запись (Guest Account) — Когда обычные или гостевые пользователи подключаются к серверу Samba, им должен сопоставляться подходящий пользователь сервера. Выберите одного из существующих пользователей системы, который станет гостевой учётной записью Samba. Когда к серверу Samba подключаются гости, они получают те же привилегии, что и данный пользователь. Этой настройке соответствует параметр guest account.

После нажатия OK изменения сохраняются в файл конфигурации и демон перезапускается, таким образом, изменения вступают в силу немедленно.

23.2.1.2. Управление пользователями Samba

Средство Настройка сервера Samba требуется, чтобы перед добавлением пользователя Samba в системе, играющей роль сервера Samba, уже существовала учётная пользователя. Пользователь Samba сопоставляется с существующей учётной записью пользователя.

Рисунок 23-4. Управление пользователями Samba

Чтобы добавить пользователя Samba, выберите в выпадающем меню Настройка (Preferences) => Пользователи Samba (Samba Users) и нажмите кнопку Добавить пользователя (Add User). В окне Добавить пользователя (Create New Samba User) выберите Имя пользователя Unix (Unix Username) из списка существующих в локальной системе пользователей.

Если в системе Windows пользователь имеет другое имя и ему нужно подключаться из своей системы к серверу Samba, укажите имя пользователя Windows в поле Имя пользователя Windows. Чтобы этот вариант работал, параметр Режим аутентификации (Authentication Mode) на вкладке Доступ (Security) окна Параметры сервера (Server Settings) должен иметь значение Пользователь (User).

Также настройте Пароль Samba (Samba Password) этого пользователя Samba и подтвердите его, набрав его ещё раз. Даже если вы решили использовать для Samba зашифрованные пароли, рекомендуется назначать для всех пользователей Samba пароли, отличающиеся от их паролей в системе.

Чтобы поменять свойства существующего пользователя, выберите его из списка и нажмите кнопку Изменить пользователя (Edit User). Чтобы удалить существующего пользователя Samba, выберите его и нажмите кнопку Удалить пользователя (Delete User). При удалении пользователя Samba соответствующая учётная запись пользователя в системе не удаляется.

Внесённые изменения вступают в силу сразу после нажатия кнопки OK.

23.2.1.3. Добавление ресурса

Чтобы создать ресурс Samba, нажмите кнопку Добавить (Add) в основном окне программы настройки Samba.

Рисунок 23-5. Добавление ресурса

На вкладке Основные (Basic) настраиваются следующие параметры:

  • Каталог (Directory) — Каталог, который станет общим ресурсом Samba. Здесь указывается имя уже существующего каталога.

  • Имя ресурса (Share name) — Действительное имя ресурса, с которым его будет видно с удалённых компьютеров. По умолчанию, это значение совпадает со значением поля Каталог (Directory), но его можно изменить.

  • Описание (Descriptions) — Краткое описание ресурса.

  • Права (Basic Permissions) — Параметр, определяет будут ли пользователи иметь право только на чтение файлов в общем каталоге или смогут и читать, и писать файлы.

На вкладке Доступ (Access) определите, будет ли доступ к ресурсу разрешён только выбранным или всем пользователям Samba. Если вы хотите разрешить доступ только определённым пользователям, выберите их из списка доступных пользователей Samba.

Ресурс добавляется сразу после нажатия OK.

23.2.2. Настройка в командной строке

Конфигурация Samba находится в файле /etc/samba/smb.conf. Если вы вносите изменения в этот файл, они не вступают в силу до перезапуска демона Samba с помощью команды: service smb restart.

Чтобы указать рабочую группу Windows и краткое описание сервера Samba, измените следующие строки в файле smb.conf:

workgroup = WORKGROUPNAME
server string = BRIEF COMMENT ABOUT SERVER

Замените WORKGROUPNAME именем рабочей группы Windows, к которой должен относиться этот компьютер. Параметр BRIEF COMMENT ABOUT SERVER необязателен и используется в качестве комментария Windows для данной системы Samba.

Чтобы создать в системе Linux разделяемый ресурс Samba, добавьте следующий раздел в файл smb.conf (изменив его в соответствии со своими и системными требованиями):

[sharename]
comment = Insert a comment here (Добавьте здесь примечание)
path = /home/share/
valid users = tfox carole
public = no
writable = yes
printable = no
create mask = 0765

В показанном выше примере пользователи tfox и carole смогут читать и писать в каталог /home/share сервера Samba, используя клиента Samba.

23.2.3. Зашифрованные пароли

По умолчанию используются зашифрованные пароли, так как это более безопасно. Если вместо них используются пароли в открытом виде, их могут перехватить с помощью программы, прослушивающей сетевой трафик. Рекомендуется использовать зашифрованные пароли.

В протоколе Microsoft SMB изначально пароли передавались открытым текстом. Однако, Windows NT 4.0, начиная с Service Pack 3, Windows 98, Windows 2000, Windows ME и Windows XP требуют шифрования паролей Samba. Чтобы использовать протокол Samba между системой Linux и одной из этих операционных систем Windows, вы можете либо отредактировать реестр Windows и разрешить использование паролей в открытом виде, либо настроить в своей системе Linux шифрование паролей в Samba. Если вы решите изменить реестр, вы должны проделать это на всех компьютерах с Windows — это рискованно и может привести к другим конфликтам. Для лучшей безопасности рекомендуется использовать зашифрованные пароли.

Чтобы настроить в Samba зашифрованные пароли, выполните следующие действия:

  1. Создайте отдельный файл с паролями Samba. Чтобы создать его на основе существующего файла /etc/passwd, выполните в приглашении оболочки следующую команду:

    cat /etc/passwd | mksmbpasswd.sh > /etc/samba/smbpasswd

    Если в вашей системе используется NIS, введите следующую команду:

    ypcat passwd | mksmbpasswd.sh > /etc/samba/smbpasswd

    Сценарий mksmbpasswd.sh устанавливается в каталог /usr/bin в составе пакета samba.

  2. Измените разрешения файла паролей Samba, чтобы разрешение на чтение и запись имел только root:

    chmod 600 /etc/samba/smbpasswd

  3. Этот сценарий не копирует пароли пользователей в новый файл, и учётная запись пользователя остаётся неактивной, пока для неё не будет определён пароль. Для большей безопасности рекомендуется назначать для пользователя Samba пароль, отличный от пароля пользователя в системе. Чтобы задать пароль пользователя Samba, выполните следующую команду (заменяйте username именем пользователя):

    smbpasswd username

  4. По умолчаниию должны быть включены зашифрованные пароли. Таким образом, специально включать их в файле конфигурации не требуется. Однако они также не могут быть отключены в файле конфигурации. Убедитесь в том, что в файле /etc/samba/smb.conf отсутствует следующая строка:

    encrypt passwords = no

    Если она присутствует, но закомментирована точкой с запятой (;) в начале строке, эта строка игнорируется и шифрование паролей включается. Если эта строка присутствует и не закомментирована, уберите её или закомментируйте.

    Чтобы явно включить шифрование паролей в файле конфигурации, добавьте в файл etc/samba/smb.conf следующие строки:

    encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd

  5. Убедитесь в том, что служба smb запущена, введя в приглашении оболочки команду service smb restart.

  6. Если вы хотите, чтобы служба smb запускалась автоматически, её можно включить с помощью ntsysv, chkconfig или средства Настройка служб. За подробностями обратитесь к главе 20 Управление доступа к службам.

Для синхронизации паролей пользователей Samba с их паролями в системе можно применить PAM-модуль pam_smbpass, используя команду passwd. Когда пользователь вызывает команду passwd, одновременно изменяется и пароль, с которым он входит в систему Red Hat Enterprise Linux, и пароль, с которым он подключается к ресурсу Samba.

Чтобы включить эту возможность, добавьте в файл /etc/pam.d/system-auth ниже вызова pam_cracklib.so следующую строку:

password required /lib/security/pam_smbpass.so nullok use_authtok try_first_pass

23.2.4. Запуск и остановка сервера

На сервере, предоставляющем доступ к каталогам через Samba, должна работать служба smb.

Определите состояние демона Samba, выполнив следующую команду:

/sbin/service smb status

Запустите демона с помощью следующей команды:

/sbin/service smb start

Остановите демона с помощью следующей команды:

/sbin/service smb stop

Чтобы служба smb запускалась при загрузке, выполните команду:

/sbin/chkconfig --level 345 smb on

Определить службы, запускающиеся при загрузке системы, вы также можете с помощью chkconfig, ntsysv или средства Настройка служб (Services Configuration Tool). За подробностями обратитесь к главе 20 Управление доступа к службам.

Подсказка | Подсказка
 | Чтобы просмотреть активные подключения к системе, выполните команду smbstatus.
Назад | Начало | Вперёд
Samba | Вверх | Подключение к общему ресурсу Samba


Подключение к общему ресурсу Samba

Назад Глава 23. Samba Вперёд

23.3. Подключение к общему ресурсу Samba

Для просмотра доступных общих ресурсов Samba в сети вы можете воспользоваться программой Наутилус (Nautilus). Выберите в Главном меню (Main Menu) (на панели) => Сетевые серверы (Network Servers), чтобы просмотреть список рабочих групп Samba в вашей сети. Чтобы просмотреть рабочие группы, вы также можете ввести smb: в строке Наутилуса Адрес: (Location:).

Как показано на рисунке 23-6, на экране появляются значки для всех доступных в сети групп SMB.

Рисунок 23-6. Рабочие группы SMB в Наутилусе

Дважды щёлкните значок одной из рабочих групп, и вы получите список компьютеров в этой группе.

Рисунок 23-7. Компьютеры SMB в Наутилусе

Как показывает рисунок 23-7, каждый компьютер в рабочей группе показан в виде значка. Дважды щёлкните значок компьютера, чтобы просмотреть список общих ресурсов компьютера. Если для подключения требуется имя и пароль пользователя, вам будет предложено ввести их.

Вы также можете указать имя сервера и ресурса Samba в строке Адрес: (Location:) программы Nautilus, используя следующий синтаксис (замените <servername> и <sharename> подходящими значениями):

smb://<servername>/<sharename>/

23.3.1. Командная строка

Чтобы найти в сети серверы Samba, воспользуйтесь командой findsmb. Она выводит IP-адрес, имя NetBIOS, имя рабочей группы, название операционной системы и версию SMB каждого найденного сервера.

Чтобы подключиться к общему ресурсу Samba из приглашения оболочки, выполните следующую команду:

smbclient //<hostname>/<sharename> -U <username>

Замените <hostname> именем узла или IP-адресом сервера Samba, к которому вы хотите подключиться, <sharename> — названием каталога, который вы хотите просмотреть, а <username> — именем пользователя Samba в удалённой системе. Введите правильный пароль или нажмите [Enter], если для этого пользователя пароль не требуется.

Появившееся приглашение smb:\> означает, что вы успешно подключились. Подключившись, выполните команду help для получения списка команд. Если вы хотите просмотреть содержимое своего домашнего каталога, замените sharename своим именем пользователя. Если параметр -U не указан, серверу Samba передаётся имя текущего пользователя.

Чтобы выйти из smbclient, наберите exit в ответ на приглашение smb:\>.

23.3.2. Подключение общего ресурса

Иногда полезно монтировать ресурс Samba в каталог, чтобы можно было работать с файлами в этом каталоге, как будто они являются частью локальной файловой системы.

Чтобы смонтировать ресурс Samba в каталог, создайте каталог, если он ещё не существует, и выполните от имени root следующую команду:

mount -t  smbfs -o username=<username> //<servername>/<sharename> /mnt/point/

Эта команда монтирует ресурс <sharename> с сервера <servername> в локальный каталог /mnt/point/.

Назад | Начало | Вперёд
Настройка сервера Samba | Вверх | Дополнительные ресурсы


Обащение к серверу

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.10. Обащение к серверу

Подключиться к вашему безопасному адресу можно, используя примерно следующий адрес:

https://server.example.com

Обратиться к не безопасному серверу можно, используя подобный адрес:

http://server.example.com

Стандартным портом для безопасных веб-соединений принят порт 443. Стандартным портом для не безопасных веб-соединений принят порт 80. Безопасный сервер, настроенный по умолчанию, принимает подключения к этим стандартным портам. Поэтому указывать номер порта в адресе ресурса не обязательно (при этом подразумевается стандартный порт).

Однако, если вы настроили сервер на использование нестандартного порта (т.е. отличного от 80 и 443), при подключении к этому серверу вы должны указывать номер порта в каждом адресе.

Например, вы можете настроить сервер так, что виртуальный узел будет использовать не безопасный порт 12331. При обращении к этому виртуальному узлу вы должны будете указать в адресе номер этого порта. Ниже показан пример адреса, используемого при подключении к порту 12331 не безопасного сервера:

http://server.example.com:12331
Назад | Начало | Вперёд
Проверка сертификата | Вверх | Дополнительные ресурсы


Дополнительные ресурсы

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.11. Дополнительные ресурсы

За дополнительными сведениями о HTTP-сервере Apache обратитесь к разделу 25.7 Дополнительные ресурсы.

26.11.1. Полезные сайты

  • http://www.redhat.com/mailman/listinfo/redhat-secure-server — Список рассылки redhat-secure-server.

    Вы также можете подписаться на список рассылки redhat-secure-server, послав письмо по адресу <redhat-secure-server-request@redhat.com> и включив слово subscribe в поле «Тема».

  • http://www.modssl.org/ — Сайт mod_ssl содержит исчерпывающую информацию о mod_ssl. Сайт содержит большой объём документации, включая User Manual (Руководство пользователя) по адресу http://www.modssl.org/docs/.

26.11.2. Книги по этой теме

  • Apache: The Definitive Guide, вторая редакция (авторы Бен Лаури (Ben Laurie) и Питер Лаури (Peter Laurie), издательство O'Reilly & Associates, Inc.).

Назад | Начало | Вперёд
Обащение к серверу | Вверх | Настройка проверки подлинности


Виды сертификатов

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.5. Виды сертификатов

Если вы устанавливали безопасный веб-сервер из RPM-пакета, предоставленного Red Hat, случайный ключ и сертификат для проверки автоматически генерируются и помещаются в соответствующие каталоги. Однако до начала эксплуатации вашего безопасного сервера, вы должны сгенерировать свои собственные ключи и получить сертификат, подтверждающий подлинность вашего сервера.

Для работы вашего безопасного сервера вам потребуется ключ и сертификат — это означает, что вы можете либо выдать себе сертификат самостоятельно, либо приобрести сертификат, подписанный центром сертификации. Чем же они будут отличаться?

Сертификат, подписанный центром сертификации, даёт вашему серверу два важных преимущества:

  • Браузеры автоматически принимают сертификат (обычно) и устанавливают безопасное соединение, не спрашивая пользователя.

  • Когда центр сертификации выдаёт подписанный сертификат, он гарантирует подлинность организации, публикующей в Интернете веб-страницы.

Если к безопасному серверу обращаются множество пользователей, вашему безопасному серверу потребуется сертификат, подписанный центром сертификации, чтобы посетители сайта, знали, что сайт действительно принадлежит данной организации. Перед тем как сертификат будет подписан, центр сертификации проверяет, является ли организация, запрашивающая сертификат, той, за кого себя выдаёт.

Большинство браузеров, поддерживающих SSL, содержат список центров сертификации, сертификатам которых они доверяют автоматически. Если обозреватель встречает сертификат, и центр сертификации, выдавший его, ему неизвестен, обозреватель предлагают пользователю либо принять, либо отклонить соединение.

Вы можете сгенерировать для своего безопасного сервера сертификат, выданный себе, но не забывайте о том, что такой сертификат не имеет всей функциональности сертификата, подписанного в центре сертификации. Выданный себе сертификат не будет автоматически приниматься браузерами пользователей, кроме того, подписанный самостоятельно сертификат не предоставляет гарантий подлинности организации, публикующей сайт. Сертификат, подписанный в центре сертификации, даёт безопасному серверу две этих важных возможности. Если вы используете безопасный сервер в безопасном окружении, рекомендуется применять сертификат, подписанный центром сертификации.

Процесс получения сертификата в центре сертификации достаточно прост. Ниже приведено его краткое описание:

  1. Создать пару ключей (открытый и закрытый) для шифрования.

  2. Сформировать запрос на получение сертификата для открытого ключа. Сертификат будет содержать информацию о вашем сервере и компании, владеющей им.

  3. Послать запрос на получение сертификата вместе с документами, подтверждающими вашу подлинность, в центр сертификации. Red Hat не даёт никаких рекомендаций относительно того, какой центр сертификации выбирать. Ваше решение может основываться на предыдущем опыте или мнении ваших друзей и коллег, а может только на стоимости этой услуги.

    Выбрав для себя центр сертификации, вы должны следовать указаниям этого центра, чтобы получить от него сертификат.

  4. Когда центр сертификации проверит вашу подлинность, он предоставит вам цифровой сертификат.

  5. Установите этот сертификат на вашем безопасном сервере, после этого он сможет осуществлять безопасные транзакции.

Как бы вы не получали сертификат — из центра сертификации, или сгенерировали самостоятельно, начинать следует с создания ключей. За инструкциями обратитесь к разделу 26.6 Генерация ключа.

Назад | Начало | Вперёд
Использование существующих ключей и сертификатов | Вверх | Генерация ключа


Формирование запроса к центру сертификации на получение сертификата

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.7. Формирование запроса к центру сертификации на получение сертификата

Как только вы создали ключ, вы можете сформировать запрос на получение сертификата, который затем нужно отправить в выбранный вами центр сертификации. Убедитесь в том, что вы находитесь в каталоге /usr/share/ssl/certs/, и введите следующую команду:

make certreq

На экране появится следующее сообщение и предложение ввести вашу секретную фразу (если только вы не отказались от её использования):

umask 77 ; \
/usr/bin/openssl req -new -key /etc/httpd/conf/ssl.key/server.key
-out /etc/httpd/conf/ssl.csr/server.csr
Using configuration from /usr/share/ssl/openssl.cnf
Enter pass phrase:

Введите секретную фразу, выбранную при создании ключа, если она требуется. Затем на экране появятся дополнительные указания и вы должны будете ответить на несколько вопросов. Введённые вами данные включаются в запрос на получение сертификата. Эти вопросы и примеры ответов на них приведены ниже:

You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a
DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [GB]:US
State or Province Name (full name) [Berkshire]:North Carolina
Locality Name (eg, city) [Newbury]:Raleigh
Organization Name (eg, company) [My Company Ltd]:Test Company
Organizational Unit Name (eg, section) []:Testing
Common Name (your name or server's hostname) []:test.example.com
Email Address []:admin@example.com
Please enter the following 'extra' attributes
to be sent with your certificate request
A challenge password []:
An optional company name []:

Ответы по умолчанию приводятся в квадратных скобках ([]) сразу после вопроса. Например, в первой строке задаётся код страны, в которой будет использоваться сертификат, как показано ниже:

Country Name (2 letter code) [GB]:

Ответ по умолчанию размещён в скобках: GB. Примите предложенный вариант, нажав [Enter], или введите двухбуквенный код страны.

Вы должны определить остальные значения. Все они достаточно понятны, но вы должны принять учитывать следующее:

  • Не следует сокращать название местности или штата. Вводите их полностью (например, St. Louis должно быть введено как Saint Louis).

  • Если вы отправляете этот запрос (CSR) в центр сертификации (CA), будьте очень внимательны, заполняя все эти поля, но особенно важны Organization Name (Название организации) и Common Name (Имя сервера). Центр сертификации проверяет информацию, представленную в запросе (CSR), чтобы убедиться в том, что сервер с именем Common Name, закреплён именно за вашей организацией. Центр сертификации не принимает запросы CSR, в которых содержится неверная информация.

  • Убедитесь в том, что в качестве значения Common Name введено реальное имя вашего безопасного сервера (правильное имя DNS), а не какой-либо из его псевдонимов.

  • В качестве Email Address используйте почтовый адрес веб-мастера или системного администратора.

  • Избегайте использования специальных символов, например @, #, &, ! и т.д. Некоторые центры сертификации не примут запрос сертификата, содержащий специальные символы. Поэтому, если название компании включает амперсанд (&), запишите его в виде «and» вместо «&».

  • Не заполняйте дополнительные атрибуты (A challenge password(Пароль вызова) и An optional company name (Необязательное имя компании)). Если вы решили не заполнять эти поля, просто нажмите [Enter], чтобы согласиться с предложенным ответом, в каждом из этих запросов.

Когда вы заканаиваете ввод этих сведений, создаётся файл /etc/httpd/conf/ssl.csr/server.csr. Этот файл и есть ваш запрос сертификата, готовый к отправке в центр сертификации.

После того как вы определились с выбором CA, следуйте инструкциям, приведённым на сайте этого центра. Из них вы узнаете, как отправить запрос сертификата, произвести оплату и какие дополнительные документы требуются.

После того, как вы выполните все требования центра сертификации, они вышлют вам сертификат (обычно по электронной почте). Сохраните или скопируйте через буфер обмена полученный сертификат в файл /etc/httpd/conf/ssl.crt/server.crt. Обязательно сохраните копию этого файла.

Назад | Начало | Вперёд
Генерация ключа | Вверх | Самостоятельное формирование сертификата


Генерация ключа

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.6. Генерация ключа

Чтобы сгенерировать ключ, вы должны быть пользователем root.

Сначала, с помощью команды cd перейдите в каталог /etc/httpd/conf/. Удалите фиктивный ключ и сертификат, созданные во время установки, выполнив следующие команды:

rm ssl.key/server.key
rm ssl.crt/server.crt

Затем создайте свой собственный случайный ключ. Перейдите в каталог /usr/share/ssl/certs/ и введите следующую команду:

make genkey

На экране компьютера появляется примерно следующее:

umask 77 ; \
/usr/bin/openssl genrsa -des3 1024 > /etc/httpd/conf/ssl.key/server.key
Generating RSA private key, 1024 bit long modulus
.......++++++
................................................................++++++
e is 65537 (0x10001)
Enter pass phrase:

Теперь вы должны ввести секретную фразу. В целях безопасности ваш пароль должен содержать как минимум восемь символов, включать в себя цифры и/или специальные знаки, и не являться словом из словаря. Помните, в секретной фразе имеет значение регистр символов.

Замечание | Замечание
 | Вы должны запомнить эту секретную фразу и вводить её при каждом запуске своего безопасного сервера. Если вы забудете её, ключ потребуется сгенерировать заново.

Введите секретную фразу ещё раз, чтобы подтвердить её правильность. Если вы не допустите ошибок, будет создан файл /etc/httpd/conf/ssl.key/server.key, содержащий ваш ключ.

Обратите внимание, если вы не хотите вводить секретную фразу при каждом запуске вашего безопасного сервера, вместо команды make genkey можно выполнить следующие две команды.

Создать свой ключ с помощью следующей команды:

/usr/bin/openssl genrsa 1024 > /etc/httpd/conf/ssl.key/server.key

Затем назначить правильные права доступа к этому файлу, выполнив следующую команду:

chmod go-rwx /etc/httpd/conf/ssl.key/server.key

Если вы создадите ключ с помощью этих команд, вводить секретную фразу для запуска безопасного сервера не потребуется.

Внимание | Внимание
 | Отключение запроса секретной фразы для сервера представляет собой угрозу безопасности. Отключать запрос секретной фразы для безопасного сервера не рекомендуется.

В зависимости от защищённости вашего компьютера, у вас могут возникнуть проблемы, связанные с отключением секретной фразы. Например, если злоумышленник взломает систему безопасности UNIX на этом компьютере, он сможет получить ваш закрытый ключ (содержимое файла server.key). Затем этот ключ может использоваться для фальсификации веб-страниц и компрометации вашего безопасного сервера.

Если безопасность UNIX на сервере поддерживается должным образом (все обновления и исправления операционной системы устанавливаются по мере их появления, ненужные или опасные службы отключены, и т. д.), может показаться, что секретная фраза для безопасного веб-сервера не нужна. Однако, так как ваш безопасный сервер не должен перегружаться слишком часто, дополнительный уровень защиты, обеспечиваемый паролем, в большинстве случаев оправдывает неудобство ввода секретной фразы.

Файл server.key должен принадлежать пользователю root и не должен быть доступен другим пользователям. Сделайте резервную копию этого файла и сохраните её в безопасном, защищённом месте. Эта копию необходимо сохранить, так как если вы утеряете файл server.key, сформировав до этого с его помощью запрос на получение сертификата, ваш сертификат больше не будет работать и центр сертификации ничем не сможет вам помочь. В таком случае вы сможете только запросить (и ещё раз оплатить) новый сертификат.

Если вы собираетесь приобрести сертификат в центре сертификации, перейдите к разделу 26.7 Формирование запроса к центру сертификации на получение сертификата. Если вы выдаёте себе сертификат самостоятельно, перейдите к разделу 26.8 Самостоятельное формирование сертификата.

Назад | Начало | Вперёд
Виды сертификатов | Вверх | Формирование запроса к центру сертификации на получение сертификата


Проверка сертификата

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.9. Проверка сертификата

Чтобы проверить тестовый сертификат, установленный по умолчанию, сертификат, выданный центром сертификации, или подписанный самостоятельно, обратитесь в своём браузере к следующей странице (замените server.example.com своим доменным именем):

https://server.example.com

Замечание | Замечание
 | Обратите внимание на s после http. Префикс https: используется для безопасных HTTP-транзакций.

Если вы используете сертификат, подписанный известным центром сертификации, ваш браузер автоматически принимает сертификат (без подтверждения с вашей стороны) и устанавливает безопасное соединение. Ваш браузер не будет автоматически принимать тестовый или самостоятельно подписанный сертификат, так как этот сертификат не подписан центром сертификации. Если ваш сертификат не был подписан центром сертификации, примите его, следуя инструкциям для вашего браузера.

Как только браузер примет сертификат, ваш безопасный сервер выдаст домашнюю страницу по умолчанию.

Назад | Начало | Вперёд
Самостоятельное формирование сертификата | Вверх | Обащение к серверу


Использование существующих ключей и сертификатов

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.4. Использование существующих ключей и сертификатов

Если у вас уже есть ключ и сертификат (например, если вы устанавливаете безопасный сервер вместо другого безопасного сервера компании), вы вероятно будете использовать существующий ключ и сертификат на этом безопасном сервере. Ниже описаны две ситуации, в которых вы не сможете использовать существующий ключ и сертификат:

  • Если вы изменили IP-адрес или имя домена — Сертификаты выдаются для определённого сочетания IP-адреса и доменного имени. Если вы меняете IP-адрес или доменное имя, вы должны получить новый сертификат.

  • Если вы получили сертификат VeriSign и заменили программное обеспечение сервера — VeriSign — это широко известный центр сертификации. Если у вас есть сертификат VeriSign, имеющий другое предназначение, вы можете попытаться использовать его на вашем новом безопасном сервере. Однако это не допускается, так как VeriSign выдаёт сертификаты для конкретного программного обеспечения сервера и совокупности IP-адреса и имени домена.

    Если вы меняете один из этих параметров (например, если вы ранее использовали другой безопасный сервер), сертификат VeriSign, полученный вами для предыдущей конфигурации, с новой конфигурацией работать не будет. Вы должны получить новый сертификат.

Если у вас есть подходящий ключ и сертификат, формировать новые ключи и получать новый сертификат не нужно. Однако, вам может потребоваться переместить и переименовать файлы, содержащие ключ и сертификат.

Переместите существующий ключ в:

/etc/httpd/conf/ssl.key/server.key

Переместите существующий сертификат в:

/etc/httpd/conf/ssl.crt/server.crt

Переместив ключ и сертификат, перейдите к разделу 26.9 Проверка сертификата.

Если вы производили обновление с Red Hat Secure Web Server, ваш старый ключ (httpsd.key) и сертификат (httpsd.crt) располагаются в каталоге /etc/httpd/conf/. Переместите свой ключ и сертификат, чтобы их мог использовать безопасный сервер. Выполните следующие команды для перемещения и переименования ваших файлов ключа и сертификата:

mv /etc/httpd/conf/httpsd.key /etc/httpd/conf/ssl.key/server.key
mv /etc/httpd/conf/httpsd.crt /etc/httpd/conf/ssl.crt/server.crt

Затем запустите свой безопасный сервер, выполнив команду:

/sbin/service httpd start

Вам предлагается ввести свою секретную фразу. После того как вы введёте её и нажмёте [Enter], сервер запустится.

Назад | Начало | Вперёд
Обзор сертификатов и безопасности | Вверх | Виды сертификатов


Обзор пакетов, связанных с безопасностью

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.2. Обзор пакетов, связанных с безопасностью

Чтобы запустить безопасный сервер, вы должны установить как минимум следующие пакеты:

httpd

Пакет httpd содержит демона httpd и сопутствующие утилиты, файлы конфигурации, значки, модули HTTP-сервера Apache, страницы руководства man, а также другие файлы, используемые HTTP-сервером Apache.

mod_ssl

Пакет mod_ssl включает в себя модуль mod_ssl, обеспечивающий сильное шифрование для HTTP-сервера посредством протоколов «безопасность на уровне сокетов» (Secure Sockets Layer, SSL) и «безопасность на транспортном уровне» (Transport Layer Security, TLS).

openssl

Пакет openssl содержит набор инструментов OpenSSL. В пакете OpenSSL реализованы протоколы SSL и TLS, а также включена криптографическая библиотека общего назначения.

Кроме этого другие программные пакеты могут обеспечить дополнительные (но не обязательные для работы безопасного сервера) возможности безопасности:

httpd-devel

Пакет httpd-devel содержит включаемые файлы HTTP-сервера Apache (include), файлы заголовков и утилиту APXS. Все они вам понадобятся, если помимо модулей, поставляемых с продуктом, вы намерены загружать дополнительные модули. Обратитесь к Справочному руководству по Red Hat Enterprise Linux за дополнительной информацией о загрузке модулей на безопасном сервере, используя функциональность динамических разделяемых объектов (Dynamic Shared Object, DSO) сервера Apache.

Если вы не намерены загружать на своём HTTP-сервере Apache другие модули, устанавливать этот пакет не требуется.

Пакеты OpenSSH

Пакет OpenSSH содержат набор сетевых инструментов OpenSSH для регистрации на удалённом компьютере и выполнения команд. Инструменты OpenSSH шифруют все передаваемые данные (включая пароли), что предотвращает перехват информации, похищение соединений и другие атаки на соединения между вашим компьютером и удалённым.

Пакет openssh содержит ключевые файлы, необходимые и клиентским, и серверным программам OpenSSH. Пакет openssh также содержит утилиту scp, безопасную замену rcp (для безопасного копирования файлов между компьютерами).

Пакет openssh-askpass обеспечивает отображение диалогового окна, в котором пользователь вводит пароль во время использования агента OpenSSH.

Пакет openssh-askpass-gnome может использоваться в среде рабочего стола GNOME для отображения графического диалогового окна, когда программы OpenSSH запрашивают пароль. Если вы используете GNOME и утилиты OpenSSH, вы должны установить этот пакет.

Пакет openssh-server содержит демона безопасной оболочки sshd и связанные с ним файлы. Демон безопасной оболочки находится на серверной стороне набора OpenSSH и должен быть установлен на вашем компьютере, чтобы клиенты SSH смогли к нему подключаться.

Пакет openssh-clients содержит клиентские программы, необходимые для установления защищённого подключения к серверам SSH, включая следующие: ssh — безопасная замена rsh; sftp — безопасная замена ftp (утилите передачи файлов между компьютерами); slogin — безопасная замена rlogin (утилите удалённой регистрации в системе) и telnet (утилите связи с удалённым узлом по протоколу Telnet).

За дополнительными сведениями об OpenSSH обратитесь к главе 21 OpenSSH, Справочному руководству по Red Hat Enterprise Linux и сайту OpenSSH, по адресу http://www.openssh.com/.

openssl-devel

Пакет openssl-devel содержит статические библиотеки и включаемые файлы (include), необходимые для компиляции приложений, использующих различные криптографические алгоритмы и протоколы. Вы должны устанавливать этот пакет, только если вы разрабатываете приложения с поддержкой SSL — вам не нужно устанавливать его, если вы только используете SSL.

stunnel

В пакете stunnel реализовано туннелирование Stunnel SSL. Stunnel поддерживает SSL-шифрование TCP-соединений. Он обеспечивает шифрование для демонов и протоколов, не рассчитанных на SSL (например, POP, IMAP и LDAP), без внесения изменений в код демона.

Замечание Замечание

Более новые реализации различных демонов могут предлагать встроенную поддержку SSL, как, например, dovecot или сервер OpenLDAP slapd, и может быть предпочтительнее использовать её, а не stunnel.

Например, использование stunnel обеспечивает только туннелирование протоколов, тогда как в демоне slapd службы OpenLDAP встроенная поддержка позволяет также обрабатывать запросы на использование шифрования в ответ на запрос клиента StartTLS.

В таблице 26-1 приведён краткий список пакетов безопасного сервера и отмечено, является ли пакет необязательным на безопасном сервере.

Имя пакета | Необязательный?
httpd | нет
mod_ssl | нет
openssl | нет
httpd-devel | да
openssh | да
openssh-askpass | да
openssh-askpass-gnome | да
openssh-clients | да
openssh-server | да
openssl-devel | да
stunnel | да

Table 26-1. Пакеты безопасности

Назад | Начало | Вперёд
Настройка безопасного HTTP-сервера Apache | Вверх | Обзор сертификатов и безопасности


Обзор сертификатов и безопасности

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.3. Обзор сертификатов и безопасности

Ваш безопасный сервер обеспечивает безопасность, используя сочетание протокола SSL и (в большинстве случаев) цифровой сертификат, выданный Центром Сертификации (Certificate Authority, CA). SSL выполняет шифрование соединений, а также взаимную проверку подлинности между браузерами и вашим безопасным сервером. Цифровой сертификат, выданный центром сертификации (CA), обеспечивает проверку подлинности вашего безопасного сервера (CA потверждает подлинность вашей организации, пользуясь своей репутацией). Когда ваш браузер использует шифрование SSL, адрес ресурса (URL), в строке адреса, будет начинаться с префикса https://.

При шифровании используются ключи (представьте себе открывающий и закрывающий ключ). При обычном или симметричном шифровании, на обоих концах соединения используется один ключ, кодирующий и декодирующий передаваемые данные. При шифровании с открытым ключом или асимметричном шифровании, существуют два ключа: открытый ключ и закрытый ключ. Человек или организация сохраняет свой закрытый ключ в секрете и публикует свой открытый ключ. Данные, зашифрованные открытым ключом, могут быть расшифрованы закрытым ключом; данные, закодированные закрытым ключом, могут быть декодированы только открытым ключом.

Ваш безопасный сервер использует шифрование с открытым ключом, поэтому вы будете создаёте пару из закрытого и открытого ключей. В большинстве случаев для этого вы должны отправить в центр сертификации запрос на получение сертификата (включая ваш открытый ключ), доказательство подлинности компании и оплату услуги. Центр сертификации обрабатывает запрос сертификата, проверяет вашу подлинность и возвращает сертификат для вашего безопасного сервера.

Безопасный сервер будет использовать сертификат, чтобы доказать браузерам свою подлинность. Вы можете сформировать свой собственный сертификат (называемый «выданным себе» (self-signed) сертификатом) или получить сертификат от центра сертификации. Сертификат от доверенного центра сертификации гарантирует, что сайт связан с конкретной компанией или организацией.

Также вы можете выдать себе сертификат самостоятельно. Заметьте, однако, что выданные себе сертификаты не должны использоваться в рабочем окружении. Выданные себе сертификаты не принимаются браузером пользователем автоматически — браузер предлагает пользователям принять сертификат и установить безопасное соединение. За дополнительной информацией об отличиях между сертификатами, выданными себе, и сертификатами, подписанными в центре сертификации обратитесь к разделу 26.5 Виды сертификатов.

Получив выданный себе сертификат или сертификат, подписанный в центре сертификации, вы должны установить его на вашем безопасном сервере.

Назад | Начало | Вперёд
Обзор пакетов, связанных с безопасностью | Вверх | Использование существующих ключей и сертификатов


Самостоятельное формирование сертификата

Назад Глава 26. Настройка безопасного HTTP-сервера Apache Вперёд

26.8. Самостоятельное формирование сертификата

Вы также можете выдать себе сертификат самостоятельно. Заметьте, что сертификаты, выданные себе, не дают таких гарантий безопасности, как сертификаты, подписанные центром сертификации. Обратитесь к разделу 26.5 Виды сертификатов за дополнительными сведениями о сертификатах.

Чтобы создать сертификат, подписанный самостоятельно, сначала вы должны создать случайный ключ, следуя указаниям, приведённым в разделе 26.6 Генерация ключа. Получив ключ, перейдите в каталог /usr/share/ssl/certs/ и введите следующую команду:

make testcert

На экране появляются примерно следующие сообщения и вам предлагается ввести секретную фразу (если только вы не сгенерировали ключ без секретной фразы):

umask 77 ; \
/usr/bin/openssl req -new -key /etc/httpd/conf/ssl.key/server.key
-x509 -days 365 -out /etc/httpd/conf/ssl.crt/server.crt
Using configuration from /usr/share/ssl/openssl.cnf
Enter pass phrase:

Затем у вас запрашиваются дополнительные сведения. Примерные сообщения компьютера и ответы пользователя приведены ниже (вы должны ввести верные данные организации и узла):

You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a
DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [GB]:US
State or Province Name (full name) [Berkshire]:North Carolina
Locality Name (eg, city) [Newbury]:Raleigh
Organization Name (eg, company) [My Company Ltd]:My Company, Inc.
Organizational Unit Name (eg, section) []:Documentation
Common Name (your name or server's hostname) []:myhost.example.com
Email Address []:myemail@example.com

После того, как вы введёте правильную информацию, самостоятельно подписанный сертификат создаётся в файле /etc/httpd/conf/ssl.crt/server.crt. Сгенерировав сертификат, перезапустите безопасный сервер, выполнив следующую команду:

/sbin/service httpd restart
Назад | Начало | Вперёд
Формирование запроса к центру сертификации на получение сертификата | Вверх | Проверка сертификата


Дополнительные ресурсы

Назад Глава 20. Управление доступом к службам Вперёд

20.6. Дополнительные ресурсы

За дополнительной информацией обратитесь к следующим ресурсам.

20.6.1. Установленная документация

  • Страницы man ntsysv, chkconfig, xinetd и xinetd.conf.

  • man 5 hosts_access — Страница описания формата файлов, определяющих доступ узлов (5 раздел страниц руководства man).

20.6.2. Полезные сайты

  • http://www.xinetd.org — Сайт демона xinetd. Он содержит более подробный список возможностей и примеры файлов конфигурации.

20.6.3. Книги по этой теме

  • Справочное руководство по Red Hat Enterprise Linux (выпущенное компанией Red Hat, Inc.) — Это вспомогательное руководство содержит подробную информацию о том, как TCP-оболочки и xinetd разрешают или запрещают доступ, а также о том, как настроить сетевой доступ с их помощью. Кроме этого оно содержит инструкции по созданию правил брандмауэра iptables.

  • Руководство по безопасности Red Hat Enterprise Linux (выпущенное компанией Red Hat, Inc.) — Это руководство рассказывает о защите служб с помощью TCP-оболочек и xinetd, а также о регистрации попыток запрещённых подключений.

Назад | Начало | Вперёд
chkconfig | Вверх | OpenSSH


chkconfig

Назад Глава 20. Управление доступом к службам Вперёд

20.5. chkconfig

Также для запуска и остановки служб можно использовать команду chkconfig. Команда chkconfig --list выводит список системных служб и показывает, запущены ли они (on) или остановлены (off), на уровнях выполнения 0-6. В конце этого списка добавлен раздел, включающий службы, управляемые xinetd.

При выполнении chkconfig --list для запроса службы, управляемой xinetd, она показывает, включена ли служба xinetd (on) или отключена (off). Например, команда chkconfig --list finger выводит следующее:

finger          on

Как видно, служба finger работает как служба xinetd. Если xinetd запущен, finger включена.

Если вы выполните chkconfig --list, чтобы запросить состояние службы в /etc/rc.d, вы увидите установки службы для каждого уровня выполнения. Например, команда chkconfig --list httpd выводит следующее:

httpd         0:off   1:off   2:on    3:on    4:on    5:on    6:off

С помощью утилиты chkconfig также можно настроить службу, чтобы она запускалась (или не запускалась) на заданном уровне выполнения. Например, чтобы выключить nscd на уровнях выполнения 3, 4 и 5, выполните следующую команду:

chkconfig --level 345 nscd off

Предупреждение | Предупреждение
 | Службы, управляемые xinetd, при настройке с помощью chkconfig меняют своё состояние немедленно. Например, если xinetd работает, служба finger отключена, и выполняется команда chkconfig finger on, служба finger включается сразу, так что перезапускать xinetd вручную не требуется. Изменения состояния других служб не вступают в силу сразу после использования chkconfig. Вы должны остановить или запустить требуемые службы, выполнив команду service daemon stop. В предыдущем примере замените daemon именем службы, которую вы хотите остановить; например, httpd. Замените параметр stop на start или restart, чтобы запустить или перезапустить службу.
Назад | Начало | Вперёд
ntsysv | Вверх | Дополнительные ресурсы


ntsysv

Назад Глава 20. Управление доступом к службам Вперёд

20.4. ntsysv

Программа ntsysv предоставляет простой интерфейс для включения и отключения служб. Вы можете воспользоваться ntsysv для включения и выключения служб, управляемых xinetd. Вы также можете использовать ntsysv для настройки уровней выполнения. По умолчанию настраивается только текущий уровень выполнения. Чтобы настроить другой уровень выполнения, передайте один или несколько уровней выполнения с параметром --level. Например, команда ntsysv --level 345 настраивает уровни выполнения 3, 4 и 5.

Интерфейс ntsysv похож на интерфейс программы установки в текстовом режиме. С помощью кнопок вверх и вниз вы можете передвигаться по списку. Пробелом можно отмечать/снимать отметку службы, а также нажимать кнопки Ok и Отмена (Cancel). Перемещаться по спискам и кнопкам Ok и Отмена (Cancel) можно, используя клавишу [Tab]. Символ * означает, что служба включена. Клавиша [F1] вызывает краткое описание выбранной службы.

Предупреждение | Предупреждение
 | Службы, управляемые xinetd, при настройке в ntsysv меняют своё состояние немедленно. Изменения остальных служб не вступают в силу сразу. Вы должны остановить или запустить требуемые службы, выполнив команду service daemon stop. В предыдущем примере замените daemon именем службы, которую вы хотите остановить; например, httpd. Замените параметр stop на start или restart, чтобы запустить или перезапустить службу.
Назад | Начало | Вперёд
Средство «Настройка служб» | Вверх | chkconfig


Средство настройки служб

Назад Глава 20. Управление доступом к службам Вперёд

20.3. Средство «Настройка служб»

Средство Настройка служб (Services Configuration Tool) — это графическое приложение, разработанное компанией Red Hat, позволяющее определить, какие службы SysV в каталоге /etc/rc.d/init.d запускаются при загрузке системы (на уровнях выполнения 3, 4 и 5), и какие службы xinetd включены. С его помощью вы можете запускать, останавливать и перезапускать службы SysV, а также перезапускать xinetd.

Чтобы запустить Средство настройки служб с рабочего стола, выберите в Главном меню (Main Menu) (на панели) => Системные параметры (System Settings) => Настройки сервера (Server Settings) => Службы (Services) или введите команду system-config-services в приглашении оболочки (например, в XTerm или терминале среды GNOME).

Рисунок 20-1. Настройка служб

Средство Настройка служб показывает текущий уровень выполнения, а также уровень, который вы редактируете. Чтобы отредактировать другой уровень выполнения, выберите в выпадающем меню Изменить уровень (Edit Runlevel) уровень 3, 4 или 5. Описание уровней выполнение вы можете найти в разделе 20.1 Уровни выполнения .

Средство Настройка служб показывает службы из каталога /etc/rc.d/init.d, а также службы, управляемые xinetd. Щёлкните название службы в списке, расположенном слева, чтобы просмотреть краткое описанное этой службы, а также её состояние. Если эта служба не является службой xinetd, окно состояния показывает, работает ли служба в данный момент. Если служба работает под управлением xinetd, в окне состояния выводится сообщение xinetd service (служба xinetd выполняется).

Чтобы запустить, остановить или перезапустить службу немедленно, выберите службу из списка и нажмите соответствующую кнопку на панели инструментов (или выберите действие в выпадающем меню Действия (Actions)). Если служба работает под управлением xinetd, кнопки действий выключены, так как такую службу нельзя запускать или останавливать.

Если вы включаете/отключаете службу xinetd, устанавливая или снимая флажок рядом с названием службы, вы должны выбрать в выпадающем меню Файл (File) => Сохранить изменения (Save Changes), чтобы перезапустить xinetd и немедленно включить/отключить эту службу xinetd. Кроме этого, xinetd запоминает изменённое состояние. Вы можете включить/отключить несколько служб xinetd сразу и сохранить изменения в конце.

Например, предположим, вы отметили службу rsync, чтобы она запускалась на уровне выполнения 3, а затем сохранили изменения. Служба rsync включается немедленно. После следующего запуска xinetd, rsync также будет включена.

Предупреждение | Предупреждение
 | Когда вы сохраняете изменения служб xinetd, демон xinetd перезапускается и изменения вступают в силу немедленно. Когда же вы сохраняете изменения настроек других служб, уровень выполнения изменяется, но изменения не вступают в силу немедленно.

Чтобы разрешить не-xinetd службе запуск во время выполнения на выбранном в данный момент уровне выполнения, поставьте в списке флажок рядом с названием службы. Настроив уровень выполнения, примените изменения, выбрав в выпадающем меню Файл (File) => Сохранить изменения (Save Changes). При этом настройки уровня выполнения меняются, но уровень выполнения не перезапускается, таким образом, эти изменения не вступают в силу сразу.

Например, предположим, что вы настраиваете уровень выполнения 3. Если вы измените состояние службы httpd с включенного на выключенное, а затем выполните операцию Сохранить изменения (Save Changes), настройки уровня выполнения 3 меняются так, что httpd не запускается при загрузке системы. Однако уровень 3 не инициализировался заново, поэтому httpd работает по-прежнему. На этом этапе вы можете предпринять следующие действия:

  1. Остановить службу httpd — Остановить службу, выбрав её в списке, и нажав кнопку Остановить выбранную службу (Stop the selected service). На экране появляется сообщение, говорящее о том, что служба была успешно остановлена.

  2. Инициализировать уровень выполнения — Инициализировать уровень выполнения, перейдя в приглашение оболочки и набрав команду telinit 3 (где 3 — номер уровня выполнения). Этот вариант рекомендуется использовать, если вы изменяли значение параметра Запускать при загрузке (Start at Boot) для нескольких служб сразу и хотите, чтобы эти изменения вступили в силу.

  3. Не делать вообще ничего — Останавливать службу httpd не обязательно. Вы можете дождаться перезапуска системы для остановки службы. Уровень выполнения будет проинициализирован при следующей загрузке системы и служба httpd не запустится.

Чтобы добавить службу к уровню выполнения, выберите уровень выполнения в выпадающем меню Изменить уровень (Edit Runlevel), а затем выберите Действия (Actions) => Добавить службу (Add Service). Чтобы удалить службу с уровня выполнения, выберите уровень выполнения в выпадающем меню Изменить уровень (Edit Runlevel), выберите в списке слева службу, которую хотите удалить, и выполните Действия (Actions) => Удалить службу (Delete Service).

Назад | Начало | Вперёд
TCP-оболочки | Вверх | ntsysv


TCP-оболочки

Назад Глава 20. Управление доступом к службам Вперёд

20.2. TCP-оболочки

Многие системные администраторы UNIX знакомы с использованием библиотеки TCP-оболочек для управления доступа к определённым сетевым службам. Все сетевые службы, управляемые демоном xinetd (так же, как и любые другие программы со встроенной поддержкой libwrap) позволяют использовать TCP-оболочки для управления доступом. Демон xinetd может использовать файлы /etc/hosts.allow и /etc/hosts.deny для настройки доступа к системным службам. Как и следует из имени файла, hosts.allow (разрешить узлам) содержит список правил, разрещающим клиентам подключаться к сетевым службам, управляемым xinetd, а hosts.deny (запретить узлам) содержит правила, запрещающие доступ. Файл hosts.allow имеет преимущество перед файлом hosts.deny. Правила разрешения или запрета доступа могут определяться для отдельного IP-адреса (или имени узла) или для нескольких клиентов сразу. За подробностями обратитесь к Справочному руководству по Red Hat Enterprise Linux и 5 разделу страницы man, посвящённой hosts_access (man 5 hosts_access).

20.2.1. xinetd

Для управления доступом к службам Интернета используется демон xinetd, который является безопасной заменой для inetd. Демон xinetd экономит системные ресурсы, обеспечивает управление доступом и протоколирование, а также может использоваться для запуска серверов специального назначения. Демон xinetd можно использовать для предоставления или запрета доступа только определённым узлам, для предоставления доступа к службе в определённое время, для ограничения количества входящих подключений и/или нагрузки, создаваемой подключениями и т.д.

xinetd работает постоянно и прослушивает все порты служб, которыми он управляет. Когда приходит запрос к одной из управляемых им служб, xinetd запускает соответствующий сервер этой службы.

Файлом настройки демона xinetd является /etc/xinetd.conf, но этот файл содержит только несколько значений по умолчанию и указание включить каталог /etc/xinetd.d. Чтобы включить или отключить службу xinetd, отредактируйте её файл конфигурации в каталоге /etc/xinetd.d. Если параметр disable имеет значение yes, это означает, что служба отключена. Если параметр disable имеет значение no, служба включена. Вы можете отредактировать любой файл конфигурации xinetd или включить/выключить демон, используя средство Настройка служб (Services Configuration Tool), ntsysv или chkconfig. Список сетевых служб, управляемых демоном xinetd можно увидеть, просмотрев содержимое каталога /etc/xinetd.d с помощью команды ls /etc/xinetd.d.

Назад | Начало | Вперёд
Управление доступом к службам | Вверх | Средство «Настройка служб»


Активизация подписки

Назад Введение Вперёд

4. Активизация подписки

Прежде чем вы получите доступ к информации и службам сопровождения вашего программного обеспечения, а также входящей в вашу подписку документации, вы должны активизировать свою подписку, зарегистрировавшись в Red Hat. Регистрация включает следующие простые действия:

  • Предоставление учётной записи Red Hat

  • Предоставление номера подписки

  • Подключение системы.

При первой загрузке своей инсталляции Red Hat Enterprise Linux, вам предлагается зарегистрироваться в Red Hat, используя Помощника по настройке (Setup Agent). Следуя приглашениям Помощника по настройке, вы сможете выполнить регистрацию и активизировать свою подписку.

Если вы не сможете выполнить регистрацию в Помощнике по настройке (для этого нужен доступ к Интернету), вы можете пройти процесс регистрации на сайте Red Hat по адресу http://www.redhat.com/register/.

4.1. Ввод данных учётной записи Red Hat

Если у вас ещё нет учётной записи Red Hat, вы можете создать её, когда предложит Помощник по настройке, или через Интернет, по адресу:

https://www.redhat.com/apps/activate/newlogin.html

Эта учётная запись открывает вам доступ к:

  • Обновлениям приложениям, исправлениям и службе поддержки через Red Hat Network

  • Ресурсам технической поддержки Red Hat, документации и базе знаний.

Если вы забыли свою учётную запись Red Hat, вы можете восстановить её на сайте Red Hat:

https://rhn.redhat.com/help/forgot_password.pxt

4.2. Ввод номера подписки

Ваш номер подписки можно найти на пакете, пришедшем с вашим заказом. Если на вашем пакете нет номера подписки, это значит, что подписка была активизирована за вас и вы можете пропустить этот шаг.

Вы можете ввести свой номер подписки, когда его спросит Помощник по настройке, или посетив http://www.redhat.com/register/.

4.3. Подключение системы

Клиент регистрации в сети Red Hat Network помогает вам подключить вашу систему, чтобы вы могли получать обновления и осуществлять управление системами. Подключить систему можно тремя способами:

  1. В Помощнике по настройке — Отметьте пункты Передать информацию об оборудовании (Send hardware information) и Передать список пакетов системы (Send system package list), когда они появятся.

  2. После завершения Помощника по настройка — В главном меню Приложения (Applications) (на панели) откройте меню Система (System Tools) и выберите Red Hat Network.

  3. После завершения Помощника по настройке — Введите в командной строке от имени пользователя root следующую команду:

    • /usr/bin/up2date --register

Назад | Начало | Вперёд
Соглашения, принятые в документе | Вверх | Использование мыши


Добавление пространства подкачки

Назад Глава 11. Пространство подкачки Вперёд

11.2. Добавление пространства подкачки

Иногда возникает необходимость расширить пространство подкачки после установки. Например, вы могли увеличить объём памяти в вашем компьютере со 128 Мбайт до 256, но для подкачки у вас отведено только 256 Мбайт. Возможно, предпочтительнее увеличито объём файла подкачки до 512 Мбайт, если вы выполняете операции или запускаете приложения, требующие большой объём памяти.

У вас есть три варианта: создать новый раздел подкачки, создать новый файл подкачки или расширить пространство подкачки на существующем логическом томе LVM2. Рекомендуется расширить существующий логический том.

11.2.1. Расширение пространства подкачки на логическом томе LVM2

Чтобы расширить логический том LVM2, отведённый для подкачки (предположим, что этот том называется /dev/VolGroup00/LogVol01):

  1. Запретите подкачку на соответствующем логическом томе:

    # swapoff -v /dev/VolGroup00/LogVol01

  2. Увеличьте размер логического тома LVM2 на 256 Мбайт:

    # lvm lvresize /dev/VolGroup00/LogVol01 -L +256M

  3. Отформатируйте новое пространство подкачки:

    # mkswap /dev/VolGroup00/LogVol01

  4. Включите дополнительный логический том:

    # swapon -va

  5. Проверьте, был ли логический том расширен правильно:

    # cat /proc/swaps
# free

11.2.2. Создание логического тома LVM2 для подкачки

Чтобы добавить группу томов для подкачки (предположим, что том называется /dev/VolGroup00/LogVol02):

  1. Создайте логический том LVM2 размером 256 Мбайт:

    # lvm lvcreate VolGroup00 -n LogVol02 -L 256M

  2. Отформатируйте новое пространство подкачки:

    # mkswap /dev/VolGroup00/LogVol02

  3. Добавьте следующую запись в файл /etc/fstab:

    /dev/VolGroup00/LogVol02   swap     swap    defaults     0 0

  4. Включите дополнительный логический том:

    # swapon -va

  5. Проверьте, был ли логический том расширен правильно:

    # cat /proc/swaps
# free

11.2.3. Создание файла подкачки

Чтобы добавить файл подкачки:

  1. Определите размер нового файла подкачки в мегабайтах и умножьте это число на 1024, чтобы определить количество блоков. Например, файл подкачки размером в 64 Мбайта будет занимать 65536 блоков.

  2. Выполните в приглашении оболочки от имени root следующую команду, а в аргументе count укажите требуемый размер в блоках:

    dd if=/dev/zero of=/swapfile bs=1024 count=65536

  3. Создайте файл подкачки с помощью следующей команды:

    mkswap /swapfile

  4. Чтобы активизировать его немедленно, но не автоматически при загрузке, выполните:

    swapon /swapfile

  5. Чтобы включить его при загрузке, отредактируйте файл /etc/fstab и включите в него следующую запись:

    /swapfile          swap            swap    defaults        0 0

    Когда система перезагрузится в следующий раз, она подключит созданный файл подкачки.

  6. После того, как вы создали новый файл подкачки и подключили его, проверьте, работает ли, просмотрев результаты выполнения команды cat /proc/swaps или free.

Назад | Начало | Вперёд
Пространство подкачки | Вверх | Удаление пространства подкачки


Перемещение пространства подкачки

Назад Глава 11. Пространство подкачки Вперёд

11.4. Перемещение пространства подкачки

Чтобы переместить пространство подкачки из одного места в другое, сначала удалите пространство подкачки, а затем добавьте новое, следуя приведённым ранее инструкциям.

Назад | Начало | Вперёд
Удаление пространства подкачки | Вверх | Управление дисковым хранилищем


Удаление пространства подкачки

Назад Глава 11. Пространство подкачки Вперёд

11.3. Удаление пространства подкачки

Иногда имеет смысл уменьшить пространство подкачки после установки. Например, вы могли сократить объём памяти в вашем компьютере с 1 Гбайта до 512 Мбайт, но на подкачку у вас по-прежнему выделено 2 Гбайта. Возможно, предпочтительнее будет сократить объём пространства подкачки до 1 Гбайта, так как выделять 2 Гбайт может быть слишком расточительно.

У вас есть три варианта: удалить существующий логический том LVM2, отведённый для подкачки, удалить файл подкачки или уменьшить пространство подкачки на существующем логическом томе LVM2.

11.3.1. Уменьшение пространства подкачки на логическом томе LVM2

Чтобы уменьшить логический том LVM2, отведённый для подкачки (предположим, что этот том называется /dev/VolGroup00/LogVol01):

  1. Запретите подкачку на соответствующем логическом томе:

    # swapoff -v /dev/VolGroup00/LogVol01

  2. Сократите размер логического тома LVM2 на 512 Мбайт:

    # lvm lvreduce /dev/VolGroup00/LogVol01 -L -512M

  3. Отформатируйте новое пространство подкачки:

    # mkswap /dev/VolGroup00/LogVol01

  4. Включите дополнительный логический том:

    # swapon -va

  5. Проверьте, был ли логический том уменьшен правильно:

    # cat /proc/swaps
# free

11.3.2. Удаление логического тома LVM2 для подкачки

Логический том подкачки не должен использоваться (не должно быть никаких системных блокировок или работающих процессов). Легче всего выполнить это условие, загрузив систему в режиме восстановления. Инструкции по загрузке в режиме восстановления описаны в главе 5 Основы восстановления системы. Получив предложение смонтировать файловые системы, ответьте Пропустить (Skip).

Чтобы удалить группу томов для подкачки (предположим, что том называется /dev/VolGroup00/LogVol02):

  1. Запретите подкачку на соответствующем логическом томе:

    # swapoff -v /dev/VolGroup00/LogVol02

  2. Удалите логический том LVM2 размером 512 Мбайт:

    # lvm lvremove /dev/VolGroup00/LogVol02

  3. Удалите следующую запись из файла /etc/fstab:

    /dev/VolGroup00/LogVol02   swap     swap    defaults     0 0

  4. Проверьте, был ли логический том удалён правильно:

    # cat /proc/swaps
# free

11.3.3. Удаление файла подкачки

Чтобы удалить файл подкачки:

  1. Чтобы отключить файл подкачки, выполните в приглашении оболочки от имени root следующую команду (где /swapfile — файл подкачки):

    # swapoff -v /swapfile

  2. Удалите запись о нём из файла /etc/fstab.

  3. Удалите сам файл:

    # rm /swapfile
Назад | Начало | Вперёд
Добавление пространства подкачки | Вверх | Перемещение пространства подкачки


Дополнительные ресурсы

Назад Глава 40. Сбор информации о системе Вперёд

40.5. Дополнительные ресурсы

Чтобы узнать о сборе системной информации больше, обратитесь к следующим источникам.

40.5.1. Установленная документация

  • ps --help — Выводит список параметров команды ps.

  • Страница руководства top — Введите man top, чтобы больше узнать о программе top и её параметрах.

  • Страница руководства free — Введите man free, чтобы больше узнать о программе free и множестве её параметров.

  • Страница руководства df — Введите man df, чтобы больше узнать о программе df и её параметрах.

  • Страница руководства du — Введите man du, чтобы больше узнать о программе du и её параметрах.

  • Страница руководства lspci manual page — Введите man lspci, чтобы больше узнать о команде lspci и множестве её параметров.

  • Каталог /proc/ — Содержимое каталога /proc/ также может помочь собрать более подробную информацию о системе. Обратитесь к Официальному справочному руководству по Red Hat Enterprise Linux за дополнительными сведениями о каталоге /proc.

40.5.2. Книги по этой теме

  • Введение в системное администрирование Red Hat Enterprise Linux (издательство Red Hat, Inc.) — Включает главу, посвящённую мониторингу ресурсов.

Назад | Начало | Вперёд
Оборудование | Вверх | OProfile


Файловые системы

Назад Глава 40. Сбор информации о системе Вперёд

40.3. Файловые системы

Команда df выводит отчёт об использовании дискового пространства. Если вы выполните в приглашении оболочки команду df, на экране появится похожий отчёт:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      11675568   6272120   4810348  57% /
/dev/sda1               100691      9281     86211  10% /boot
none                    322856         0    322856   0% /dev/shm

По умолчанию эта программа показывает размер раздела в килобайтных блоках, а также объём используемого и свободного места на диске в килобайтах. Чтобы получить эту информацию в мегабайтах и гигабайтах, выполните команду df -h. Параметр -h включает формат, воспринимаемый человеком (Human-readable format). При этом на экране появится примерно следующее:

Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                       12G  6.0G  4.6G  57% /
/dev/sda1              99M  9.1M   85M  10% /boot
none                  316M     0  316M   0% /dev/shm

В списке смонтированных разделов присутствует запись /dev/shm. Эта запись представляет файловую систему виртуальной памяти.

Команда du выводит на экран приблизительный объём, занимаемый файлами каталога на диске. Если вы введёте в приглашении оболочки команду du, в списке будет показан объём дискового пространства, занимаемого каждым из подкаталогов. В последней строке этого списка также будет показан суммарный размер текущего каталога и его подкаталогов. Если вы не хотите видеть размеры всех подкаталогов, введите команду du -hs, чтобы увидеть только общий размер каталога в легко воспринимаемом формате. Выполните команду du --help, чтобы узнать о дополнительных параметрах.

Чтобы просмотреть использования диска и системные разделы в графическом виде, воспользуйтесь разделом Системного монитора (GNOME System Monitor), показанным на рисунке 40-2 в нижней части окна, под заголовком Устройства (Devices).

Назад | Начало | Вперёд
Использование памяти | Вверх | Оборудование


Оборудование

Назад Глава 40. Сбор информации о системе Вперёд

40.4. Оборудование

Если вы столкнулись с проблемами при настройке вашего оборудования, или просто хотите узнать, какое оборудование установлено в вашем компьютере, воспользуйтесь приложением Обзор оборудования (Hardware Browser) чтобы просмотреть оборудование, определённое вашей системой. Чтобы запустить его с рабочего стола, выберите в главном меню Приложения (Applications) (на панели) => Система (System Tools) => Обзор оборудования (Hardware Browser) или введите hwbrowser в приглашении оболочки. Как иллюстрирует рисунок 40-3, она показывает ваши приводы CD-ROM, дисководы, жёсткие диски и их разделы, сетевые платы, указывающие устройства, системные устройства и видеоадаптеры. Щёлкните имя категории в левом меню, и на экране появится информация о ней.

Рисунок 40-3. Обзор оборудования

Вы также можете выполнить команду lspci, чтобы просмотреть список всех PCI-устройств. Выполните команду lspci -v для вывода более полной информации, или lspci -vv — для самой подробной.

Например, с помощью lspci можно определить производителя, модель и объём памяти видеоплаты:

00:00.0 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
00:00.1 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
00:01.0 VGA compatible controller: S3 Inc. Savage 4 (rev 04)
00:02.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
00:0f.0 ISA bridge: ServerWorks OSB4 South Bridge (rev 50)
00:0f.1 IDE interface: ServerWorks OSB4 IDE Controller
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 04)
01:03.0 SCSI storage controller: Adaptec AIC-7892P U160/m (rev 02)
01:05.0 RAID bus controller: IBM ServeRAID Controller

Команда lspci также полезна для определения установленной в компьютере сетевой платы, если у вас нет сведений о её производителе или модели.

Назад | Начало | Вперёд
Файловые системы | Вверх | Дополнительные ресурсы


Использование памяти

Назад Глава 40. Сбор информации о системе Вперёд

40.2. Использование памяти

Команда free показывает полный объём физической памяти и раздела подкачки в системе, а также объём используемой, свободной, разделяемой памяти, размер буферов ядра и кэша.

             total       used       free     shared    buffers     cached
Mem:        645712     549720      95992          0     176248     224452
-/+ buffers/cache:     149020     496692
Swap:      1310712          0    1310712

Команда free -m выводит ту же информацию в мегабайтах, что облегчает её восприятие.

             total       used       free     shared    buffers     cached
Mem:           630        536         93          0        172        219
-/+ buffers/cache:        145        485
Swap:         1279          0       1279

Если вы предпочитаете использовать графический интерфейс free, вы можете использовать Системный монитор (GNOME System Monitor). Чтобы запустить его с рабочего стола, выберите в главном меню Приложения (Applications) (на панели) => Система (System Tools) => Системный монитор (System Monitor) или введите gnome-system-monitor в приглашении оболочки (например, в XTerm). Перейдите на вкладку Системный монитор (System Monitor).

Рисунок 40-2. Системный монитор

Назад | Начало | Вперёд
Сбор информации о системе | Вверх | Файловые системы


Дополнительная информация

Назад Глава 33. Управление пользователями и группами Вперёд

33.7. Дополнительная информация

За дополнительной информацией об управлении пользователями и группами обратитесь к следующим ресурсам.

33.7.1. Установленная документация

  • Страницы man useradd, passwd, groupadd и chage.

33.7.2. Книги по этой теме

  • Справочное руководство по Red Hat Enterprise Linux — В этом руководстве приводится список стандартных пользователей и групп, обсуждаются личные группы пользователей и предлагается обзор скрытых паролей.

  • Введение в системное администрирование Red Hat Enterprise Linux — Это вспомогательное руководство содержит дополнительные сведения об управлении пользователями и группами, а также об управлении ресурсами пользователей.

Назад | Начало | Вперёд
Объяснение процесса | Вверх | Настройка принтера


Использование командной строки

Назад Глава 33. Управление пользователями и группами Вперёд

33.5. Использование командной строки

Если вы предпочитаете средства командной строки, или у вас не установлена система X Window, этот раздел расскажет, как управлять пользователями и группами в командной строке.

33.5.1. Добавление пользователя

Чтобы добавить в систему пользователя:

  1. Выполните команду useradd, чтобы создать заблокированную учётную запись пользователя:

    useradd <username>

  2. Разблокируйте эту учётную запись, выполнив команду passwd, чтобы назначить пароль и задать политику устаревания пароля:

    passwd <username>

Параметры командной строки для утилиты useradd описаны в таблице 33-1.

Параметр | Описание
-c comment | Комментарий пользователя
-d home-dir | Домашний каталог, который следует использовать вместо стандартного /home/username/
-e date | Дата, когда учётная запись должна быть отключена, в формате ГГГГ-ММ-ДД
-f days | Число дней после истечения срока действия пароля до отключения учётной записи. (Если указано число 0, учётная запись отключается сразу, как только истекает срок действия пароля. (Если указано число -1, учётная запись не отключается после истечения срока действия пароля.
-g group-name | Имя или номер группы, которая должна стать основной группой пользователя (здесь должна указываться уже существующая группа.)
-G group-list | Список разделённых запятыми имён или номеров дополнительных групп (помимо основной), членом которых является пользователь. (Здесь должны указываться существующие группы.)
-m | Создаёт домашний каталог, если он не существует
-M | Не создаёт домашний каталог
-n | Не создаёт личную группу для пользователя
-r | Создаёт системную учётную запись с кодом, меньшим 500, и без домашнего каталога
-p password | Пароль, зашифрованный с помощью crypt
-s | Оболочка входа в систему, по умолчанию /bin/bash
-u uid | Код пользователя (UID), это должно быть уникальное число больше 499

Таблица 33-1. Параметры командной строки useradd

33.5.2. Добавление группы

Чтобы добавить группу, воспользуйтесь командой groupadd:

groupadd <group-name>

Параметры командной строки для утилиты groupadd описаны в таблице 33-2.

Параметр | Описание
-g gid | Код группы (GID), это должно быть уникальное число больше 499
-r | Создаёт системную группу с кодом меньше 500
-f | Прерывает работу программы, если группа уже существует (При этом группа не изменяется). Если указаны параметры -g и -f, но группа уже существует, параметр -g игнорируется

Таблица 33-2. Параметры командной строки groupadd

33.5.3. Срок действия пароля

В целях безопасности рекомендуется требовать, чтобы пользователи периодически меняли свои пароли. Это можно сделать при добавлении или редактировании пользователя на вкладке Сведения о пароле (Password Info) программы Менеджер пользователей (User Manager).

Чтобы настроить устаревание пароля пользователя в приглашении оболочки, воспользуйтесь командой chage, передав ей параметр из таблицы 33-3 и имя пользователя.

Важно | Важно
 | Чтобы можно было использовать команду chage, необходимо включить скрытые пароли.
Параметр | Описание
-m days | Определяет минимальный срок (в днях), по истечении которого пользователь должен менять пароль. Если это значение равно 0, срок действия пароля не будет истекать.
-M days | Определяет максимальный срок (в днях), в течение которого будет действовать пароль. Если количество дней, заданное этим параметром, и количество дней, заданное параметром -d, в сумме определяют день в прошлом, пользователь должен сменить пароль, чтобы использовать эту учётную запись.
-d days | Определяет дату смены пароля (число дней, прошедших после 1 января 1970 г.).
-I days | Определяет, через сколько дней после истечения срока действия пароля учётная запись будет заблокирована. Если значение равно 0, учётная запись не будет блокироваться.
-E date | Определяет дату блокирования учётной записи, в формате ГГГГ-ММ-ДД. Вместо такого формата даты можно также указать число дней, прошедших после 1 января 1970 г.
-W days | Определяет, за сколько дней до истечения срока действия пароля будет предупреждаться пользователь.

Таблица 33-3. Параметры командной строки chage

Подсказка | Подсказка
 | Если команде chage передаётся только имя пользователя (без параметров), она выводит текущие настройки устаревания пароля и позволяет вам изменить их.

Если системный администратор хочет, чтобы пользователь задал пароль при первом входе в систему, он может назначить пустой или какой-то исходный пароль, который истечёт немедленно, и, таким образом, пользователь должен будет сменить его при первом входе.

Чтобы настроить принудительную смену пароля при первом входе пользователя на консоли, выполните следующие действия. Заметьте, что это не будет работать, если пользователь подключается, используя протокол SSH.

  1. Заблокируйте пароль пользователя — Если пользователь не существует, воспользуйтесь командой useradd для создания учётной записи пользователя, но не назначайте пароль, чтобы она осталась заблокированной.

    Если пароль уже назначен, заблокируйте её, выполнив команду:

    usermod -L username

  2. Сделайте так, чтобы потребовалась немедленная смена пароля — Введите следующую команду:

    chage -d 0 username

    Эта команда задаёт в качестве даты последней смены пароля точку отсчёта эпохи (1 января 1970 г.). При этом значении пароль требуется сменить немедленно, вне зависимости от политики устаревания паролей, если она действует.

  3. Разблокируйте учётную запись — Выполнить это действия можно двумя распространёнными способами. Администратор может назначить пустой или какой-то начальный пароль.

    Предупреждение Предупреждение

    Не используйте для назначения пароля команду passwd, так как как она отменит только что настроенное требование смены пароля.

    Чтобы назначить начальный пароль, выполните следующие действия:

    • Запустите интерпретатор командной строки Python с помощью команды python. Он выводит следующие сообщения:

      Python 2.2.2 (#1, Dec 10 2002, 09:57:09)
[GCC 3.2.1 20021207 (Red Hat Enterprise Linux 4 3.2.1-2)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

    • В приглашении оболочки введите следующее (замените password паролем шифрования, а salt комбинацией ровно 2 больших или маленьких букв, цифр, символов точка (.) или косая черта slash (/), например, ab или 12):

      import crypt; print crypt.crypt("password","salt")

      На выходе вы полусите зашифрованный пароль, вроде 12CsGd8FRcMSM.

    • Нажмите [Ctrl]-[D], чтобы выйти из интерпретатора Python.

    • Скопируйте и вставьте показанный зашифрованный пароль, без начальных или конечных пробельных символов, в следующую команду:

      usermod -p "encrypted-password" username

    Вместо назначения начального пароля, с помощью следующей команды можно назначить пустой пароль:

    usermod -p "" username

    Внимание Внимание

    Хотя назначение пустого пароля удобно и для пользователя, и для администратора, существует небольшая угроза того, что кто-то третий сможет зарегистрироваться первым и получить доступ к системе. Чтобы сократить эту угрозу, администратору рекомендуется убедиться в том, что пользователь готов войти в систему, в момент разблокирования учётной записи.

    В любом случае при первом входе пользователю предлагается ввести новый пароль.

Назад | Начало | Вперёд
Изменение свойств группы | Вверх | Объяснение процесса


Настройки оборудования дисплея

Назад Глава 32. Настройка системы X Window Вперёд

32.2. Настройки оборудования дисплея

Когда это приложение запускается, оно определяет монитор и видеоплату. Если оборудование успешно определено, информация о нём выводится на вкладке Оборудование (Hardware), как показано на рисунке 32-2.

Рисунок 32-2. Настройки оборудования дисплея

Чтобы сменить тип монитора или какие-либо его параметры, нажмите соответствующую кнопку Настроить (Configure). Чтобы сменить тип видеоплаты или какие-либо ей параметры, нажмите кнопку Настроить (Configure) рядом с её названием.

Назад | Начало | Вперёд
Настройка системы X Window | Вверх | Настройки дисплея с двумя мониторами


Настройки дисплея с двумя мониторами

Назад Глава 32. Настройка системы X Window Вперёд

32.3. Настройки дисплея с двумя мониторами

Если в компьютере установлено несколько видеоплат, вы можете использовать поддержку двух мониторов, настраиваемую на вкладке Два монитора (Dual head), как показано на рисунке 32-3.

Рисунок 32-3. Настройки дисплея с двумя мониторами

Чтобы включить поддержку двух мониторов, отметьте флажок Два монитора (Use dual head).

Чтобы настроить тип второго монитора или какие-либо его параметры, нажмите соответствующую кнопку Настроить (Configure).

В списке Рабочий стол (Desktop layout) вариант Объединённый рабочий стол (Spanning Desktops) позволяет использовать оба монитора для создания большего полезного рабочего пространства. Вариант Отдельные рабочие столы (Individual Desktops) создаёт эффект зеркального рабочего пространства, напоминающий ноутбуки.

Назад | Начало | Вперёд
Настройки оборудования дисплея | Вверх | Управление пользователями и группами


Добавление своего сообщения загрузки

Назад Глава 3. Установка по сети с применением PXE Вперёд

3.6. Добавление своего сообщения загрузки

Вы можете по своему усмотрению изменить файл /tftpboot/linux-install/msgs/boot.msg и написать в нём собственное сообщение, которое будет выводится при загрузке.

Назад | Начало | Вперёд
Настройка DHCP-сервера | Вверх | Выполнение PXE-установки


Управление заданиями печати

Назад Глава 34. Настройка принтера Вперёд

34.12. Управление заданиями печати

Когда вы отправляете задание печати демону принтера, например, печатаете текстовый файл в Emacs или изображение в GIMP, это задание печати добавляется в очередь печати. Очередь печати представляет собой список заданий печати, отправленных на принтер, и содержит информацию о выполнении каждого задания, имя пользователя и компьютера, пославшего это задание, номер задания и т.д.

Если вы используете графическое окружение рабочего стола, щёлкните значок Диспетчер принтеров (Printer Manager) на панели, чтобы запустить Диспетчер печати GNOME (GNOME Print Manager), показанный на рисунке 34-13.

Рисунок 34-13. Диспетчер печати GNOME

Чтобы изменить параметры принтера, щёлкните правой кнопкой его значок и выберите Свойства (Properties). При этом запускается программа Настройка принтера (Printer Configuration Tool).

Дважды щёлкните настроенный принтер, чтобы просмотреть очередь печати, как показано на рисунке 34-14.

Рисунок 34-14. Список заданий печати

Чтобы отменить определённое задание печати, показанное в Диспетчере печати GNOME (GNOME Print Manager), выделите его в списке и выберите в выпадающем меню Изменить (Edit) => Отменить документы (Cancel Documents).

Если в очереди печати находятся активные задания, в области уведомлений на панели рабочего стола может появиться значок уведомлений принтера, показанный на рисунке 34-15. Так как он проверяет наличие активных заданий печати каждые пять секунд, он может не появляться, если задания имеют небольшой размер.

Рисунок 34-15. Значок уведомления принтера

Если вы щёлкните значок уведомления принтера, запустится Диспетчер печати GNOME (GNOME Print Manager) и покажет список текущих заданий печати.

Также на панели размещён значок Диспетчер печати (Print Manager). Чтобы напечатать файл в Наутилусе, перейдите к размещению этого файла в файловой системе, потяните и отпустите его на значке Диспетчер печати (Print Manager), расположенном на панели. При этом на экране появится окно, показанное на рисунке 34-16. Нажмите OK, чтобы начать печать файла.

Рисунок 34-16. Окно проверки параметров печати

Чтобы просмотреть список заданий в очереди печати, используя приглашение оболочки, введите команду lpq. Последние несколько строк будут выглядеть примерно так:

Rank   Owner/ID            Class  Job Files       Size Time
active user@localhost+902    A    902 sample.txt  2050 01:20:46

Пример 34-1. Пример сообщений команды lpq

Если вы хотите отменить задание печати, определите номер этого задания, выполнив lpq, а затем выполните команду lprm номер задания. Например, команда lprm 902 отменит печать задания, показанного в примере 34-1. Чтобы отменить задание печати, вы должны иметь достаточные разрешения. Вы не можете отменять задания печати, запущенные другими пользователями, если вы не зарегистрированы на компьютере, к которому подключен принтер, под именем root.

Кроме этого вы можете напечатать файл прямо в приглашении оболочки. Например, команда lpr sample.txt распечатывает текстовый файл sample.txt. Фильтр печати определяет тип файла, и преобразует его содержимое в формат, понятный принтеру.

Назад | Начало | Вперёд
Использование командной строки | Вверх | Предоставление общего доступа к принтеру