МАТЕМАТИЧЕСКОЕ МОДЕЛИРОВАНИЕ ДИНАМИКИ НЕЛИНЕЙНОЙ САР ЯДЕРНОГО РЕАКТОРА

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 5

МАТЕМАТИЧЕСКОЕ МОДЕЛИРОВАНИЕ ДИНАМИКИ
НЕЛИНЕЙНОЙ САР ЯДЕРНОГО РЕАКТОРА

Москва, 2003 г.

Цель работы:

  • ознакомление с описанием математических моделей нейтронно-кинетических процессов в специализированной библиотеке Кинетика нейтронов, включая:
    • сравнительный анализ частотных и переходных характеристик кинетики ядерного реактора с использованием одногруппового и “классического” (6-группового) описания ядер-предшественников запаздывающих нейтронов;
    • сравнение переходных характеристик кинетики ядерного реактора без учета и с учетом остаточного энерговыделения;
  • самостоятельное исследование нестационарных процессов в нелинейной САР ядерного реактора (САР ЯР) с релейным регулятором, включая:
    • формирование математической модели САР ЯР с релейным регулятором;
    • моделирование переходных процессов при варьировании параметров САР ЯР.

ВВЕДЕНИЕ

Типовая система автоматического регулирования ядерного реактора - управляемая система очень большой размерности. Детальное исследование динамических свойств такой САР с применением методов численного моделирования - сложная научно-техническая задача, так как в реакторной установке (РУ) присутствуют технические устройства, для описания динамических процессов в которых используется информация из большинства фундаментальных и прикладных наук.
До начала 90-х годов прошлого столетия для исследования нестационарных процессов в сложных управляемых технических системах разрабатывались специализированные динамические программы (применительно к конкретной установке). Использование таких программ для исследования нестационарных процессов в случае, например, значительной модернизации этой же установки требовало серьезной переработки расчетной программы на уровне исходных кодов (математические модели, алгоритмы и т.п.), что реально способны были выполнить только программисты, создавшие эту программу.
Значительный прогресс, достигнутый в последнее десятилетие в аппаратных и программных возможностях современной вычислительной техники, создал необходимую базу для разработки принципиально новых средств интеллектуального САПР, например, объектно-ориентированных программных сред для исследования нестационарных процессов в сложных динамических системах.
В настоящее время в РФ создан ряд современных программных комплексов (ПК) для исследования нестационарных процессов в реакторных установках.
Так, например, программно-инструментальные комплексы АИС95 и “ЭНИКОКАД” предназначены для моделирования процессов нейтронной кинетики, теплогидравлики и автоматического управления применительно к задачам разработки полномасштабных тренажеров энергоблоков АЭС с реакторами типа РБМК. Программный комплекс ТЕРМИТ-Д предназначен для проектного обоснования безопасности ядерных паропроизводящих установок (ЯППУ) транспортных ЯЭУ.
Несмотря на высокий научный уровень вышеуказанных программных средств, необходимо отметить их два серьезных недостатка:
- во-первых, каждый из них может быть рекомендован для использования в проектных разработках новых реакторных установок только аналогичного типа;
- во-вторых, ни один из этих ПКне пригоден для использования в учебном процессе высшей школы по причине отсутствия соответствующего методического наполнения.
К программным средствам интеллектуального САПР относится и программный комплекс “МВТУ”, одним из главных достоинств которого является инвариантность к предметной области исследуемого объекта или физического явления. Это позволяет выполнить в среде ПК “МВТУ” численное исследование рабочих процессов практически в любых сложных технических системах: в электромеханических, в тепловых, в пневмо- и гидродинамических, в робототехнических, в ряде других комбинированных динамические систем, в том числе и в реакторных системах.
Для описания динамики нейтронно-физических и теплогидравлических процессов в ядерных реакторах в ПК “МВТУ” используются более простые, но более “быстрые” математические модели, чем в вышеупомянутых отраслевых программных средствах.
Программно-технические возможности ПК “МВТУ” качественно превосходят возможности отечественных отраслевых программных средств в задачах разработки математических моделей систем автоматического и логического управления, систем защит и блокировок применительно к проектному обоснованию АСУ ТП для энергоблоков АЭС с реактором типа ВВЭР и РБМК.
Не менее важным достоинством ПК “МВТУ” является широта области применимости: от простейших динамических задач учебного назначения до реальных отраслевых разработок, в том числе и в экспортном исполнении.
Наличие в ПК “МВТУ” подробного учебно-методическое сопровождения позволяет использовать его в учебном процессе высшей школы по многим инженерным специальностям, включая и выбранную Вами…
В предыдущих лабораторных работах Вы освоили большинство методов работы в среде ПК “МВТУ”. В настоящей лабораторной работе Вы освоите еще ряд новых методов работы в среде ПК “МВТУ”, а также выполните самостоятельное численное исследование динамических характеристик упрощенной математической модели нелинейной САР ядерного реактора с регулятором релейного типа.
Перейдем к выполнению заданий настоящей лабораторной работы…

(к содержанию)

1. МАТЕМАТИЧЕСКИЕ МОДЕЛИ НЕЙТРОННОЙ КИНЕТИКИ

1.1. Описание блоков специализированной библиотеки Кинетика нейтронов

Специализированная библиотека Кинетика нейтронов ПК “МВТУ” содержит три типовых блока, два из которых описывают нейтронно-кинетические процессы в ядерном реакторе в точечном односкоростном приближении, а третий – описывает динамику остаточного энерговыделения с учетом предыстории реактора (кампании).
Первые два блока позволяют описывать кинетику ядер-предшественников запаздывающих нейтронов от одно- до n- группового приближений. Математические модели этих блоков получены на основании известных уравнений кинетики “точечного” ядерного реактора в односкоростном приближении (т.е. процесс деления ядер осуществляется нейтронами одной энергетической группы - либо только тепловыми, либо только быстрыми):

(1.1)

где:
- мощность реактора;
- реактивность;
- эффективная доля запаздывающих нейтронов;
- время жизни мгновенных нейтронов;
- концентрация ядер-предшественников запаздывающих нейтронов i-той группы;
- постоянная распада ядер-предшественников i-той группы;
- доля запаздывающих нейтронов i-той группы;
- интенсивность внешнего источника нейтронов.
Первый типовой блок (Классическая модель) соответствует постоянной (во времени) интенсивности внешнего источника нейтронов. Входом является изменение реактивности
Dr (t) = r (t) - r (0),
а выходом – либо безразмерное отклонение мощности
= [image], либо нормированная мощность [image].
После преобразований исходная система уравнений принимает вид:

(1.2)

где:
- нормированное отклонение концентрации ядер-предшественников запаздывающих нейтронов i-той группы;
- абсолютная (по модулю) подкритичность ядерного реактора;
- относительное изменение реактивности в долях b эфф;
- относительная доля запаздывающих нейтронов i-той группы.
При t = 0 реактор находится в стационаре, поэтому
.

На рис. 1.1 представлена копия диалогового окна этого блока. По умолчанию b i* и l i соответствуют данным для “чистого” топлива 235 U, хотя Пользователь может их скорректировать, например, если в процессе работы реактора нуклидный состав топлива изменился. Структура диалогового окна этого блока позволяет задать и другое число групп ядер-предшественников запаздывающих нейтронов и, соответственно, b i* и l i . Например, если необходимо учесть вклад фотонейтронов, то, число групп может быть увеличено, например, до 8, и наоборот, можно задать и одногрупповую модель…

Рис. 1.1

Значение времени жизни мгновенных нейтронов (по умолчанию) соответствует приблизительно времени жизни в ядерном реакторе типа РБМК.
Значения в последней диалоговой строке (Нормировка) соответствуют следующим видам выходного сигнала блока: 1 - нормированная мощность [image] , а 0 - безразмерное отклонение мощности [image].

Второй типовой блок соответствует Модели мгновенного скачка. Входом является изменение реактивности D r (t) = r (t) - r (0), а выходом – либо нормированная мощность
, либо безразмерное отклонение мощности
.
Уравнения кинетики нейтронов после преобразований исходной системы уравнений принимает вид:

(1.3)

где
,
а остальные обозначения совпадают с системой для блока с “классической” моделью кинетики нейтронов. Очевидно, что если при t [image] 0 нейтронная мощность постоянна, то начальные условия для [image] равны 1.0.
На рис. 1.2 представлена экранная копия диалогового окна этого блока, где умолчанию b i* и l i соответствуют данным для “чистого” топлива 235 U, а значения параметра Нормировка имеют тот же смысл, что и в диалоговом окне блока с “классической” моделью кинетики нейтронов.
Примечание: Переход к абсолютной нейтронной мощности ядерного реактора необходимо проводить по соотношению:

(1.4)

где [image] - стационарное значение мощности при t = 0.

Рис. 1.2

Третий типовой блок (Остаточное энерговыделение) в библиотеке Кинетика нейтронов позволяет учесть дополнительный вклад остаточного тепловыделения продуктов деления в тепловую мощность ядерного реактора, что особо актуально при резких снижениях нейтронной мощности. Входной сигнал в блок - относительная нейтронная мощность (нормированная на номинальную нейтронную мощность), а выходной сигнал из блока – относительная тепловая мощность реактора (нормированная на номинальную нейтронную мощность), определяемая выражением:

(1.5)

где [image] и [image] - нормированные на номинальную нейтронную мощность тепловая мощность реактора и мощность остаточного тепловыделения, соответственно.
Предыстория работы реактора задается в виде суперпозиции “ступенек” нормированной нейтронной мощности. На рис. 1.3 представлена экранная копия диалогового окна этого блока.

Рис. 1.3

Данные в диалоговом окне на рис. 1.3 описывают следующую предысторию работы ядерного реактора: на момент моделирования реактор имеет кампанию 9 ×10 6 с, причем: при 0 =< t =< 1× 10 5 c относительная нейтронная мощность реактора (нормированная на номинальную нейтронную мощность) равнялась 0.5;
при 1×105 < t =< 5 ×10 5 c [image];
при 5 ×10 5 < t =< 1 ×10 6 c [image];
при 1×10 6 < t =< 9×10 6 c [image].

(к содержанию)

1.2. Сравнение “классической” и одногрупповой моделей кинетики нейтронов

В прошлом семестре при выполнении лабораторных работ и домашнего задания по курсу “УТС” Вы использовали простейшую математическую модель нейтронно-кинетических процессов в ядерном реакторе, а именно: “точечную” модель с одной эффективной группой запаздывающих нейтронов.
Если рассматриваются “длительные” переходные процессы, то значение эффективной постоянной распада l ядер-предшественников запаздывающих нейтронов в одногрупповой модели рекомендуется получать осреднением “времен жизни” групп запаздывающих нейтронов по соотношению:
,

(1.6)

которое дает значение l = 0.0767 с –1 (необходимо заметить, что в некоторых учебных пособиях приводится значение l = 0.072 с–1…).
Если рассматриваются “короткие” переходные процессы (например, начальный этап развития переходного процесса при значительном скачке реактивности), то значение эффективной постоянной распада l ядер-предшественников запаздывающих нейтронов в одногрупповой модели можно получить из соотношения:
,

(1.7)

которое дает значение l = 0.405 с –1 .
Выполним сравнение частотных и переходных характеристик для одногрупповой (для обоих вариантов расчета l ) и для “классической” моделей кинетики нейтронов. Сформируйте структурную схему, внешний вид которой должен быть близок рис. 1.4.

Рис. 1.4

Внимание: Набранные структурные схемы, математические выкладки и результаты расчетов необходимо представлять преподавателю для “согласования”.

Типовые блоки В память на рис. 1.4 предназначены для выполнения анализа частотных характеристик. Переменная Вход “указывает” точку входа гармонического воздействия, а переменные Выход_6, Выход_1а и Выход_1б – точки выхода.
Откройте окно Редактора глобальных параметров… и заполните его таким же образом, как это выполнено на рис. 1.5.
Величина скачка реактивности d_po задается параметром k (в долях [image]).
Глобальные параметры Lam и Lam_1 – эффективные постоянные распада, вычисленные по соотношениям (1.6) и (1.7), соответственно.

Рис. 1.5

Переместите в окне Редактора… курсор на кнопку Вычислить константы и выполните щелчок левой клавишей мыши: появится таблица с расчетными данными. Используя “прокрутку” таблицы, убедитесь, что рассчитанные значения эффективных постоянных распада ядер-предшественников для “коротких” и “длительных” переходных процессов совпадают с приведенными выше значениями...
Закройте окно Редактора… и задайте параметры блоков структурной схемы. В блоке, описывающем 6-ти групповую модель кинетики нейтронов, оставьте параметры диалоговых строк по умолчанию. В блоках, описывающих одногрупповую модель кинетики нейтронов, в диалоговой строке Постоянные распада групп… введите Lam или Lam_1, соответственно. Что вводить в других диалоговых строках этих блоков – необходимо определить самостоятельно…
Выполним сначала моделирование “длительного” переходного процесса при скачке реактивности 0.01×b эфф. Установите в диалоговом окне Параметры расчета следующие параметры интегрирования: Время интегрирования – 1000; Минимальный шаг интегрирования – 1е-10; Максимальный шаг интегрирования – 0.1; Шаг вывода результатов – 0.1. Параметры других диалоговых строк - по умолчанию.

Выполните расчет переходного процесса. Приведите вид линий и параметры осей координат в графическом окне к виду, близкому рис. 1.6.

Рис. 1.6

На рис. 1.6 линией двойной толщины показан график переходного процесса для “классической” модели кинетики нейтронов, сплошной одинарной линией – для одногрупповой модели с эффективной постоянной распада Lam, рассчитанной по соотношению (1.6), а пунктирной линией - для одногрупповой модели с эффективной постоянной распада Lam_1, рассчитанной по соотношению (1.7).
Результаты рис. 1.6 показывают, что с эффективной постоянной распада Lam одногрупповая модель кинетики лишь приблизительно соответствует “классической” модели кинетики, а с эффективной постоянной распада Lam_1 – различие огромно (при t = 1000 c приблизительно в 40 раз).
Выполним моделирование “короткого” переходного процесса при скачке реактивности 0.1× b эфф . Установите в диалоговом окне Параметры расчета следующие параметры интегрирования: Время интегрирования – 3; Минимальный шаг интегрирования – 1е-10; Максимальный шаг интегрирования – 0.001; Шаг вывода результатов – 0.001. Параметры других диалоговых строк - по умолчанию.
Выполните расчет переходного процесса. Приведите вид линий и параметры осей координат в графическом окне к виду, близкому рис. 1.7.

Результаты рис. 1.7 показывают, что с эффективной постоянной распада Lam_1 одногрупповая модель кинетики дольше (до ~ 0.7 с) соответствует “классической” модели кинетики, а с эффективной постоянной распада Lam – примерно до 0.3 с.

Рис. 1.7

Продолжая сравнение, выполним расчет частотных характеристик для “классической” и одногрупповой моделей кинетики нейтронов (для обоих вариантов вычисления l).
Выполните щелчок “мышью” по командной кнопке Старт и затем по кнопке Стоп: расчет будет прерван, так и не начавшись; произойдет инициализация структурной схемы при нулевом сигнале на входе блоков, описывающих кинетику нейтронов...

Откройте диалоговое окно Параметры частотного анализа и заполните диалоговые поля так же, как показано на рис. 1.8.

Рис. 1.8

Переместите курсор на кнопку Годографов, выполните щелчок “мышью” и затем заполните появившуюся таблицу…
Далее выполните расчет годографов Найквиста для “классической” и обоих вариантов одногрупповой модели кинетики нейтронов. Скорректируйте параметры линий годографов и осей координат, придав графическому окну вид, близкий рис. 1.9.

Рис. 1.9

На рис. 1.9 линией двойной толщины показан годограф для “классической” модели кинетики нейтронов, сплошной одинарной линией – для одногрупповой модели с эффективной постоянной распада Lam, рассчитанной по соотношению (1.6), а пунктирной линией - для одногрупповой модели с эффективной постоянной распада Lam_1, рассчитанной по соотношению (1.7).
Анализ данных рис. 1.9 показывает, что в области высоких частот все 3 годографа почти совпадают, а в области низких частот - заметно количественное расхождение…
Дополним вышеотмеченные совпадения/расхождения сравнением ЛАХ и ФЧХ для рассматриваемых математических моделей кинетики нейтронов.
Переместите курсор на кнопку Характеристик, выполните щелчок “мышью” и далее заполните появившуюся таблицу для расчета ЛАХ.
Выполните расчет ЛАХ для “классической” и обоих вариантов одногрупповой модели кинетики нейтронов. Скорректируйте параметры линий и осей координат, придав графическому окну вид, близкий рис. 1.10.

Рис. 1.10

Рис. 1.11
Замените в таблице (столбец Характеристика) имена рассчитываемых характеристик на ФЧХ. Выполните расчет ФЧХ. Скорректируйте параметры линий и осей координат, придав графическому окну вид, близкий рис. 1.11.
Данные рис. 1.10 - 1.11 подтверждают ранее отмеченное совпадение частотных свойств для всех 3-х вариантов математической модели кинетики нейтронов при высоких частотах и, наоборот, заметное количественное расхождение в ЛАХ и ФЧХ при низких частотах.

Примечание. Типы линий на рис. 1.10 - 1.11 соответствует типу линий на рис. 1.9.
По результатам проведенного исследования необходимо сделать выводы:
Вывод № 1. Одногрупповая модель кинетики нейтронов “голого” ядерного реактора (без регулятора или отрицательных эффектов реактивности) при любом способе вычисления эффективной постоянной распада не может обеспечить корректное количественное описание переходных процессов.
Вывод № 2. По частотным свойствам из двух вариантов одногрупповой модели к “классической” модели кинетики нейтронов существенно ближе вариант с эффективной постоянной распада, рассчитанной по соотношению (1.6).
Резюме. Если моделируется динамика САР ЯР при управляющем воздействии, то предпочтительнее использовать вариант с эффективной постоянной распада, полученной по соотношению (1.6), а если моделируется динамика САР ЯР при значительном возмущающем воздействии по реактивности, то предпочтительнее использовать вариант с эффективной постоянной распада, рассчитанной по соотношению (1.7).

(к содержанию)

1.3. Роль остаточного энерговыделения в динамике ядерного реактора

Если ядерный реактор работает в окрестности номинального режима, то для расчета его мощности (нейтронной и тепловой) можно использовать только уравнения кинетики нейтронов (1.2), так как в этом случае значения относительной нейтронной мощности (нормированной на номинальную нейтронную мощность) и относительной тепловой мощности (нормированной на номинальную тепловую мощность) приблизительно равны:

(1.8)

Если нейтронная мощность реактора резко изменилась, то при расчете тепловой мощности обязательно нужно учитывать вклад остаточного энерговыделения.
Выполним количественную оценку справедливости вышеуказанного прямым моделированием следующей возможной аварийной ситуации: свободное падение одного из стержней аварийной защиты, имеющего физический вес, равный [image].
На момент аварийной ситуации ядерный реактор имел кампанию 3000 часов, причем первые 1000 часов реактор работал на 10-ти процентном уровне мощности, затем 1000 часов – на 50-ти процентном уровне мощности и, наконец, последние 1000 часов – на номинальном уровне мощности.
Сформируйте структурную схему, вид которой должен быть близок рис. 1.12.

Рис. 1.12

Закон падения стержня аварийной защиты: 10 с стержень находится в над активной зоной, затем за 1 с стержень падает в активную зону, при этом в реактор по линейному закону от времени вносится отрицательная реактивность (- [image]). Типовой блок Усилитель на рис. 1.12 выполняет нормировку тепловой мощности реактора, а подпись 1/1.0658 под блоком “сообщает”, что на момент аварийной ситуации дополнительный вклад в тепловую мощность остаточного энерговыделения составляет 6.58 %. После установки параметров всех блоков в структурной схеме, проверьте величину вклада. Для этого нужно инициализировать структурную схему и затем использовать “горячую линию”…
Для описания нейтронной кинетики используется блок с “классической” моделью, причем в диалоговой строке Нормировка необходимо установить 1, а параметры остальных диалоговых строк – по умолчанию. На рис. 1.13 представлена копия диалогового окна блока Остаточное энерговыделение, которая не требует комментариев…

Рис. 1.13

Установите в диалоговом окне Параметры расчета следующие параметры: Время интегрирования – 200; Минимальный шаг интегрирования– 1е-12; Максимальный шаг интегрирования – 0.1; Шаг вывода результатов – 0.1. Другие параметры - по умолчанию.
Выполните расчет, скорректируйте параметры линий и осей координат, придав графическому окну вид, близкий рис. 1.14.
На рис. 1.14 сплошной линией двойной толщины представлено поведение относительной тепловой мощности, а пунктирной – поведение относительной нейтронной мощности. Данные рис. 1.14 показывают, что примерно к 170 секунде относительная нейтронная мощность достигла уровня 1-го процента от номинала, в то время как относительная тепловая мощность – более 3 %.
Рис. 1.14 Рис. 1.15
Возвратите линейный масштаб по оси ординат и установите параметры осей координат такими, как это выполнено на рис. 1.15. Данные рис. 1.15 показывают, что при снижении нейтронной мощности до уровня примерно в 70 % от номинала графики относительной нейтронной и относительной тепловой мощностей практически совпадают, а при дальнейшем снижении мощности – расхождение заметно…
Резюме: При резком снижении нейтронной мощности ядерного реактора вклад остаточного энерговыделения в тепловую мощность необходимо учитывать.

(к содержанию)

2. СТРУКТУРНАЯ СХЕМА И МАТЕМАТИЧЕСКИЕ МОДЕЛИ ДИНАМИКИ ЭЛЕМЕНТОВ САР ЯДЕРНОГО РЕАКТОРА

2.1. Описание структурной схемы САР ядерного реактора

 Лабораторная работа № 5 - первая часть Вашего задания, остальные части задания Вам предстоит выполнить в последующих лабораторных работах...
В рамках настоящей лабораторной работы рассмотрим упрощенную САР ядерного реактора (ЯР), структурная схема которой (экранная копия Главного Схемного Окна) представлена на рис. 2.1 и соответствует нелинейной САР релейного типа.

Структурная схема САР ядерного реактора
Рис. 2.1

Большинство звеньев в структурной схеме, представленной на рис. 2.1, - типовые блоки из Общетехнической библиотеки. Блок Кинетика нейтронов - из Специализированной библиотеки Кинетика нейтронов, блоки Привод СУЗ и Логика аварийной защиты - субмодели 1-го уровня вложенности.
В отличие от лабораторных работ прошлого семестра и домашнего задания по курсу “Управление в технических системах”, где сигнал рассогласования подавался непосредственно на Электродвигатель Привода СУЗ, в данной САР ЯР сигнал рассогласования подается на Управляющее реле (типа релейное неоднозначное с зоной нечувствительности), которое при превышении уставок выдает сигнал управления на перемещение регулирующего стержня с постоянной скоростью вверх или вниз. Такое релейное управление существенно снижает износ исполнительного механизма СУЗ по сравнению со схемой непрерывного слежения за мощностью ЯР.
Блок Температурная обратная связь – оригинальный типовой динамический блок из библиотеки Динамические звенья (“Новый” блок), позволяющий записать динамические уравнения и другие выражения с использованием встроенного в ПК “МВТУ” Интерпретатора математических функций.
Реактивности регулирующего стержня, температурного эффекта и непосредственно ЯР, “сжимаются” посредством мультиплексора в векторный (3-х жильный) сигнал, затем векторно нормируются на эффективную долю запаздывающих нейтронов и отображаются на соответствующем Временном графике.
В цепь Главной обратной связи включен блок Запаздывание (типовой блок Идеальное запаздывающее звено), который моделирует временную задержку, связанную с обработкой показаний детекторов нейтронного потока.
В рамках проведения лабораторных работ и домашнего задания в прошлом семестре внешнее возмущающее воздействие по реактивности было только ступенчатым (т.е. мгновенный скачок реактивности). В данной лабораторной работе ввод возмущений по реактивности - линейный (с разной скоростью) с ограничением, что реализуют соответствующие блок и Ключ выкл./вкл. в верхней части схемы на рис. 2.1.
Главное сравнивающее устройство работает в режиме вычитания. Назначение остальных блоков на рис. 2.1 - очевидно и дополнительно “расшифровывается” пиктограммами и соответствующими подписями.
На рис. 2.2 представлено “содержание” субмодели Привод СУЗ, где блок Перемещение регулирующего стержня моделирует перемещение регулирующего стержня, блок Концевики (типовой блок Ключ интегратора из библиотеки Ключи) моделирует достижение верхнего или нижнего концевых выключателей, а блок Характеристика регулирующего стержня “переводит” координату нижнего конца стержня в реактивность, которую стержень внес в реактор. Входной порт и Выходной порт обеспечивают обмен данными с другими блоками в системе (см. рис. 2.1).

Структурная схема Субмодели Привод СУЗ
Рис. 2.2

В настоящей лабораторной работе субструктура Логика аварийной защиты имеет только Входной и Выходной порты (соединенные между собой). Данная Субмодель “отключена” посредством задания в Главном Схемном Окне в блоке Сумматор нулевого весового коэффициента по соответствующему входу (см. рис. 2.1). Набор структурной схемы Логики аварийной защиты будет выполнен в последней (№ 7) лабораторной работе, где данная Субмодель будет “отслеживать” нейтронную мощность, период разгона ядерного реактора и температуру теплоносителя на выходе из активной зоны с выдачей логического сигнала на сброс всех стержней аварийной защиты (режим АЗ-5) при превышении заданных уставок.

(к содержанию)

2.2. Описание математических моделей блоков САР ядерного реактора

 В структурной схеме САР на рис. 2.1 математические модели всех типовых блоков соответствуют их описанию в справочной системе ПК “МВТУ” (при инициализированном блоке вызов справки осуществляется одновременным нажатием клавиш Ctrl и F1).
Поскольку динамика САР будет анализироваться, в основном, в нормированных отклонениях, для описания нейтронной кинетики целесообразнее использовать “классическую” модель точечной кинетики с 6-ю группами запаздывающих нейтронов. Принято допущение, что при t [image] 0 реактор находится в стационарном состоянии, поэтому при t = 0 на выходе блока Кинетика нейтронов [image] (0) = 0.
Блок Главное сравнивающее устройство реализует обычное вычитание, а 2-й блок Сумматор – алгебраическое сложение 4 входных сигнала.
Высота “ступеньки” в блоке Управляющее реле (релейное неоднозначное с зоной нечувствительности) равна 1.0, а остальные параметры будут заданы преподавателем.
Динамика Температурной обратной связи описывается следующими уравнениями:

(2.1)

где N(t) - мощность реактора (абсолютная);
T(t) - температура топлива; Tw - температура теплоносителя (в данной работе считается постоянной);
To - температура топлива в стационаре;
К - коэффициент, пропорциональный теплообмену между ядерным топливом и теплоносителем;
c, g, V - удельная теплоемкость, плотность и объем топлива, соответственно;
a, roc (t) - коэффициент реактивности и температурный эффект реактивности.

Описание моделей других блоков в Главном Схемном Окне наглядно иллюстрируется пиктограммами и не требует дополнительных пояснений.

Блок Перемещение регулирующего стержня (см. рис. 2.2) описывается следующим динамическим уравнением:

t пр × x’’(t) + x’(t) = kпр × u(t) ,

(2.2)

где x(t) = z(t) / HАЗ - относительное положение нижнего конца регулирующего стержня
( x = 0 - стержень полностью погружен в активную зону,
x = 1 - стержень полностью выведен из активной зоны);
kпр , t пр - относительная скорость перемещения регулирующего стержня и постоянная времени, соответственно.
При t = 0 регулирующий стержень неподвижен и погружен в активную зону наполовину, т.е. x (0) = 0,5.

Блок Характеристика регулирующего стержня (см. рис. 2.2) описывается следующей безинерционной нелинейной зависимостью:
r ст (х) = 0.5× r ст* × sin(a× x + b)

(2.3)

(к содержанию)

2.3. Задание параметров САР через механизм глобальных параметров

Некоторые параметры математических моделей динамики блоков на рис. 2.1 - 2.2 (включая и ряд параметров блока Температурная обратная связь) необходимо задать в окне Редактора глобальных параметров Проекта (Субмодели).
Наибольший эффект от использования механизма глобальных параметров будет в тех случаях, когда один и тот же параметр (константа) используются в качестве параметра (вводимого в диалоговом окне) во многих блоках структурной схемы. В этом случае при изменении величины этого параметра можно скорректировать его значение только в окне Редактор глобальных параметров…, а не корректировать его значение во всех блоках, где он используется.
На рис. 2.3 представлена копия окна Редактор глобальных параметров… с введенными значениями и комментариями к ним. По аналогии с рис. 2.3 введите в окно Редактор… свои исходные данные (см. табл. 1 в разделе 3)…

Рис. 2.3

Откройте диалоговое окно блока Кинетика нейтронов и в 1-й диалоговой строке вместо числа 6.5е-3 введите beff. Закройте это диалоговое окно (кнопка Да). Откройте диалоговое окно блока с подписью 1/beff (см. рис. 2.1) и введите в диалоговой строке вместо числа 1 выражение 1/beff. Параметр pmax Вам необходимо будет использовать при задании параметров блока Характеристика регулирующего стержня.

(к содержанию)

2.4. Формирование динамической модели блока Температурная обратная связь с использованием “Нового” блока

Учитывая, что невозможно сформировать абсолютно полную библиотеку типовых блоков, в ПК “МВТУ” разработаны средства, которые позволяют Пользователю расширить состав личной библиотеки за счет создания новых типов блоков, например, посредством встроенного Интерпретатора математических функций, на базе которого функционирует и “Новый” блок, позволяющий прямо в процессе работы создавать экземпляры блоков со своими оригинальными математическими моделями.
Использование “Нового” блока в качестве функционального весьма эффективно в случае наличия в модели сложных функциональных преобразований, когда использование для этих целей элементарных функциональных типовых блоков приведет к неоправданному усложнению структурной схемы.
На рис. 2.4 представлена экранная копия окна Редактор интерпретатора математических функций, где в текстовом виде задана математическая модель динамики блока Температурная обратная связь.

Рис. 2.4

Если “Новый” блок имеет входы (входные порты), то первая исполняемая строка (не считая строку комментария) обязательно должна содержать оператор input, описывающий входные сигналы в данный блок, включая имя входа и его размерность.
В данном примере 1-я исполняемая строка (input u;) присваивает 1-му (и единственному) входу уникальное имя – u. Если бы, например, этот блок имел бы 2 входа, причем 1-ый вход – 3-х жильный (векторный), а 2-ой – 5-ти жильный, то 1-я исполняемая строка имела бы вид: input u[3],g[5]; Для описания размерности входов используются прямоугольные скобки.
Если “Новый” блок описывает динамику объекта моделирования в виде системы дифференциальных уравнений в форме Коши, то вторая исполняемая строка (не считая строку комментария) обязательно должна содержать оператор init, описывающий начальные условия для динамических переменных, ниже по тексту для которых будут записаны обыкновенные дифференциальные уравнения в форме Коши.
 В данном примере 2-я исполняемая строка (init T=700;) задает начальное значение для единственной динамической переменной (температура топлива в стационаре).
В том случае, когда математическая модель динамики блока описывается несколькими дифференциальными уравнениями, например, 3-мя, то 2-я исполняемая строка будет иметь вид: init x1=0,x2=1,x3=2, где х1, х2, х3 – динамические переменные, для которых ниже по тексту будут записаны соответствующие дифференциальные уравнения (точнее система уравнений) в форме Коши.
Дифференциальное уравнение для температуры топлива (Т) записано в 6-й исполняемой строке, где символ апострофа обозначает производную по времени, а теплофизические свойства топлива и температура теплоносителя в стационаре передаются в “Новый” блок посредством механизма глобальных параметров.
Предпоследняя исполняемая строка описывает эффект реактивности по температуре топлива (2-е соотношение в системе (2.1)).
Если “Новый” блок имеет выходы (выходные порты), то последняя исполняемая строка обязательно должна содержать оператор output, описывающий выходные сигналы из “Нового” блока, включая имена выходов и их размерности.
В этом примере последняя строка (output po_oc,T;) описывает 2 выходных сигнала (po_oc и T) без указания в прямоугольных скобках размерностей выходных сигналов.
Введя весь текст, закройте Редактор интерпретатора…: “Новый” блок в Главном Схемном окне будет иметь 1 вход и 2 выхода. Используя процедуры изменения ориентации блока, сделайте его ориентацию “справа-налево”. Первый выходной порт (ро_ос) будет нижним слева, а второй выходной порт (Т) – верхним слева.
Завершите оформление структурной схемы в Главном Схемном Окне, соединив все блоки линиями связи. Структурная схема САР должна принять вид, подобный рис. 2.1.

(к содержанию)

3. САМОСТОЯТЕЛЬНОЕ ИССЛЕДОВАНИЕ НЕЛИНЕЙНОЙ САР ЯДЕРНОГО РЕАКТОРА С РЕЛЕЙНЫМ РЕГУЛЯТОРОМ

3.1. Исходные данные по параметрам элементов САР

В табл. 1 приведены исходные данные по параметрам элементов САР ЯР, которую Вам предстоит исследовать. Как видно из табл. 1, параметры САР Вашего варианта не совпадают с данными, которые приведены выше в разделе 2 настоящих указаний…

Таблица 1
№ | Элемент САР | Параметры элементов САР | Номер варианта
 |  |  | 1 | 2 | 3
1 | Задатчик мощности | Время, с | 10 | 10 | 10
 |  | Y0 | 0 | 0 | 0
 |  | Y1 | 0,1 | 0,1 | 0,1
2 | Привод СУЗ | rст*/b эфф | 0,6 | 0,6 | 0,6
 |  | t пр , с | 0,2 | 0,25 | 0,25
 |  | Тхода , с | 5…50 | 5…50 | 5…50
3 | Управляющее реле | b | 0,02…0,005 | 0,02…0,005 | 0,02…0,005
 |  | m | 0,4 | 0,6 | 0,8
4 | Ядерный реактор | Vтопл , м 3 | 0,1 | 0,2 | 0,4
 |  | g топл , кг/м 3 | 10000 | 9000 | 8000
 |  | Стопл , Дж/кг× К | 300 | 350 | 400
 |  | × 10 3 , с | 1 | 0.1 | 0.05
 |  | b эфф × 10 3 | 6 | 6,5 | 7
 |  | N0 , МВт | 10 | 20 | 50
5 | Температурная обратная связь | Т0 , К | 700 | 750 | 800
 |  | Tw , K | 500 | 550 | 550
 |  | a × 10 4 , 1/K | 0,7…1,5 | 0,7…1,5 | 0,7…1,5
6 | Возмущающее воздействие | D t возм , с | 2…20 | 2…20 | 2…20
 |  | D r возм /b эфф | 0,1…0,3 | 0,1…0,3 | 0,1…0,3
7 | Запаздывание по каналу измерения | t зап , с | 0,2…1 | 0,2…1 | 0,2…1

Большая часть параметров блоков в структурной схеме САР не требует особых пояснений и комментариев. Ряд параметров в табл. 1 необходимо прокомментировать.
В субмодели Привод СУЗ параметром Тхода обозначено время перемещения регулирующим стержнем СУЗ всей активной зоны (сверху-вниз или наоборот). С помощью этого параметра Вы определите коэффициент скоростной эффективности привода. На рис. 2.2 передаточная функция блока Перемещение регулирующего стержня неизвестна: ее требуется определить на основании уравнений динамики…
В блоке Возмущающее воздействие параметр D t возм задает время, за которое величина возмущающего воздействия линейно изменяется от нуля до D r возм .
Данные в табл. 1 типа 5…50 подразумевают, что Вы должны выполнить какое-то исследование при варьировании соответствующего параметра в указанном диапазоне (обычно еще 2…3 дополнительные точки внутри указанного диапазона).

(к содержанию)

3.2. Порядок выполнения лабораторной работы
  1. Используя Линейку типовых блоков, процедуры редактирования и сервисные процедуры, заполните Главное и субмодельное схемные окна необходимыми блоками и придайте структурным схемам вид, близкий рис. 2.1 и рис. 2.2.
  2. Используя окно Редактора глобальных параметров… и диалоговые окна блоков введите параметры блоков в Главном и в субмодельном схемных окнах.
  3. Используя "Новый" блок, сформируйте (введите) математическую модель блока Температурная обратная связь.
  4. "Предъявите" набранную модель САР преподавателю для проверки правильности выполненного Вами…
  5. При исходных значениях параметров структурной схемы (a = 7× 10 – 5 1/К, t зап = 0.2 с, Тхода = 20 с, b = 0.02) выполните моделирование (время моделирования до 100 с) процесса перевода реактора на повышенный (+ 10 %) и пониженный (- 10 %) уровни мощности при варьировании скоростной эффективности привода (т.е. при варьировании Тхода). Зарисуйте качественный вид графиков переходного процесса. "Предъявите" их преподавателю с Вашими поясняющими выводами…
  6. Восстановите параметры структурной схемы в исходное состояние (a = 7× 10 – 5 1/К, t зап = 0.2 с, Тхода = 20 с, b = 0.02) и выполните моделирование (время моделирования до 100 с) процесса перевода реактора на повышенный (+ 10 %) и пониженный (- 10 %) уровни мощности при варьировании инерционности канала измерения (т.е. при варьировании t зап). Зарисуйте качественный вид графиков переходного процесса. "Предъявите" их преподавателю с Вашими поясняющими выводами…
  7. Восстановите параметры структурной схемы в исходное состояние ((a = 7× 10 – 5 1/К, t зап = 0.2 с, Тхода = 20 с, b = 0.02) и выполните моделирование (время моделирования до 100 с) процесса перевода реактора на повышенный (+ 10 %) уровень мощности при варьировании коэффициента температурной обратной связи (т.е. при варьировании a ). Зарисуйте качественный вид графиков переходного процесса. "Предъявите" их преподавателю с Вашими поясняющими выводами…
  8. Восстановите параметры структурной схемы в исходное состояние ((a = 7× 10 – 5 1/К, t зап = 0.2 с, Тхода = 20 с, b = 0.02) и выполните моделирование (время моделирования до 100 с) процесса перевода реактора на повышенный (+ 10 %) уровень мощности при варьировании ширины зоны нечувствительности в управляющем реле (т.е. при варьировании b). Зарисуйте качественный вид графиков переходного процесса. "Предъявите" их преподавателю с Вашими поясняющими выводами…
  9. Восстановите параметры структурной схемы в исходное состояние ((a = 7× 10 – 5 1/К, t зап = 0.2 с, Тхода = 20 с, b = 0.02) и выполните моделирование (время моделирования до 20 с) переходного процесса при подаче возмущающего воздействия D r возм = 0.1∙b эфф и варьировании скорости ввода возмущения по реактивности (т.е. при варьировании D tвозм). Зарисуйте качественный вид графиков переходного процесса. "Предъявите" их преподавателю с Вашими поясняющими выводами…
  10. Восстановите параметры структурной схемы в исходное состояние ((a = 7× 10 – 5 1/К, t зап = 0.2 с, Тхода = 20 с, b = 0.02) и выполните моделирование (время моделирования до 20 с) переходного процесса при подаче возмущающего воздействия за D tвозм = 5 с и варьировании величины возмущения по реактивности (т.е. при варьировании D r возм). Зарисуйте качественный вид графиков переходного процесса. "Предъявите" их преподавателю с Вашими поясняющими выводами…


МАТЕМАТИЧЕСКОЕ МОДЕЛИРОВАНИЕ ДИНАМИКИ НЕЛИНЕЙНОЙ САР ЯДЕРНОГО РЕАКТОРА.

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 5
МАТЕМАТИЧЕСКОЕ МОДЕЛИРОВАНИЕ ДИНАМИКИ
НЕЛИНЕЙНОЙ САР ЯДЕРНОГО РЕАКТОРА.

Москва, 2003 г.

Цель работы:
  • ознакомление с описанием математических моделей нейтронно-кинетических процессов в специализированной библиотеке Кинетика нейтронов, включая:
    • сравнительный анализ частотных и переходных характеристик кинетики ядерного реактора с использованием одногруппового и “классического” (6-группового) описания ядер-предшественников запаздывающих нейтронов;
    • сравнение переходных характеристик кинетики ядерного реактора без учета и с учетом остаточного энерговыделения;
  • самостоятельное исследование нестационарных процессов в нелинейной САР ядерного реактора (САР ЯР) с релейным регулятором, включая:
    • формирование математической модели САР ЯР с релейным регулятором;
    • моделирование переходных процессов при варьировании параметров САР ЯР.

Содержание:

  • Введение
  • 1. МАТЕМАТИЧЕСКИЕ МОДЕЛИ НЕЙТРОННОЙ КИНЕТИКИ
    • 1.1. Описание блоков специализированной библиотеки Кинетика нейтронов
    • 1.2. Сравнение “классической” и одногрупповой моделей кинетики нейтронов
    • 1.3. Роль остаточного энерговыделения в динамике ядерного реактора
  • 2. СТРУКТУРНАЯ СХЕМА И МАТЕМАТИЧЕСКИЕ МОДЕЛИ ДИНАМИКИ ЭЛЕМЕНТОВ САР ЯДЕРНОГО РЕАКТОРА
    • 2.1. Описание структурной схемы САР ядерного реактора
    • 2.2. Описание математических моделей блоков САР ядерного реактора
    • 2.3. Задание параметров САР через механизм глобальных параметров
    • 2.4. Формирование динамической модели блока Температурная обратная связь с использованием “Нового” блока
  • 3. САМОСТОЯТЕЛЬНОЕ ИССЛЕДОВАНИЕ НЕЛИНЕЙНОЙ САР ЯДЕРНОГО РЕАКТОРА С РЕЛЕЙНЫМ РЕГУЛЯТОРОМ
    • 3.1. Исходные данные по параметрам элементов САР
    • 3.2. Порядок выполнения лабораторной работы

Загрузить бесплатную версию "МВТУ"(3.5 Мб)