РЕАЛИЗАЦИЯ ТОЧНЫХ МЕТОДОВ АНАЛИЗА УСТОЙЧИВОСТИ НЕЛИНЕЙНЫХ ДИНАМИЧЕСКИХ СИСТЕМ В СРЕДЕ ПК “МВТУ”

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 6
 РЕАЛИЗАЦИЯ ТОЧНЫХ МЕТОДОВ АНАЛИЗА УСТОЙЧИВОСТИ НЕЛИНЕЙНЫХ ДИНАМИЧЕСКИХ СИСТЕМ В СРЕДЕ ПК “МВТУ”

Москва, 2003 г.

Цель работы:

  • освоение способов реализации векторизованного метода фазовых траекторий
  • изучение критерия В.М. Попова для анализа абсолютной устойчивости нелинейных динамических систем;

Содержание:

  • Введение
  • АНАЛИЗ УСТОЙЧИВОСТИ НЕЛИНЕЙНЫХ САР С ИСПОЛЬЗОВАНИЕМ ВЕКТОРИЗОВАННОГО МЕТОДА ФАЗОВЫХ ТРАЕКТОРИЙ
    • 1.1 Исходные уравнения, особые точки, анализ устойчивости “в малом”
    • 1.2. Анализ движения автономной системы на фазовой плоскости
  • 2. КРИТЕРИЙ В.М. ПОПОВА ДЛЯ АНАЛИЗА УСТОЙЧИВОСТИ САР
    • 2.1. О критерии абсолютной устойчивости В.М. Попова
    • 2.2. Преобразование линейной САР в нелинейную
    • 2.3. Формулировка заданий к анализу устойчивости нелинейной САР
    • 2.4. А можно ли использовать критерий В.М. Попова?
    • 2.5. Анализ устойчивости с использованием критерия В.М. Попова
    • 2.6. Новая коррекция САР и определение типа устойчивости
    • 2.7. Анализ устойчивости скорректированной нелинейной САР
    • 2.8. Расчет переходных процессов при подаче управляющего воздействия

Загрузить бесплатную версию "МВТУ"(3.5 Мб)


РЕАЛИЗАЦИЯ ТОЧНЫХ МЕТОДОВ АНАЛИЗА УСТОЙЧИВОСТИ НЕЛИНЕЙНЫХ ДИНАМИЧЕСКИХ СИСТЕМ В СРЕДЕ ПК “МВТУ”

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 6

РЕАЛИЗАЦИЯ ТОЧНЫХ МЕТОДОВ АНАЛИЗА УСТОЙЧИВОСТИ НЕЛИНЕЙНЫХ ДИНАМИЧЕСКИХ СИСТЕМ В СРЕДЕ ПК “МВТУ”

Москва, 2003 г.

Цель работы:

  • освоение способов реализации векторизованного метода фазовых траекторий
  • изучение критерия В.М. Попова для анализа абсолютной устойчивости нелинейных динамических систем;

ВВЕДЕНИЕ

Математические модели динамики реальных технических систем являются, в основном, нелинейными, и во многих случаях не могут быть линеаризованы из-за возможности потерять характерные динамические свойства, обусловленные принципиальной нелинейностью уравнений динамики…
Кроме того, при моделировании и анализе динамических систем в среде ПК “МВТУ” используется ряд процедур и приемов, которые пока Вам не известны…
Поэтому лабораторный практикум настоящего семестра направлен, во-первых, на изучение методов моделирования и анализа нелинейных динамических систем и, во-вторых, на освоение Вами новых процедур работы в среде ПК “МВТУ”…
Основной целью настоящей лабораторной работы является исследование нелинейных САР с использованием известных точных методов анализа устойчивости.
В предыдущей лабораторной работе Вы ознакомились с упрощенной реализацией метода фазовых траекторий в среде ПК “МВТУ”, заключающейся в том, что закономерности с обственного движения автономной нелинейной динамической системы на фазовой плоскости исследуется на основании последовательных расчетов переходных процессов при варьировании начальных условий…
Программно-технические возможности ПК “МВТУ” позволяют реализовать одновременный расчет переходных процессов при различных начальных условиях. Будем называть такой вариант реализации этого метода анализа устойчивости нелинейных динамических систем векторизованным методом фазовых траекторий.
Критерий абсолютной устойчивости В.М. Попова является наиболее эффективным методом (из точных) анализа устойчивости нелинейных САР и применим не только для простейших САР (например, учебного типа), но и для более “серьезных” САР. Поэтому в настоящей лабораторной работе Вы “по инструкции” и самостоятельно реализуете данный критерий в среде ПК “МВТУ” для анализа нелинейных САР…
Для самостоятельного исследования в последней части лабораторной работы Вам будет предложена математическая модель динамики САР ядерного реактора с релейным регулятором и с более точной моделью кинетики нейтронов...
Перейдем к выполнению заданий настоящей лабораторной работы…

(к содержанию)

1. АНАЛИЗ УСТОЙЧИВОСТИ НЕЛИНЕЙНЫХ САР С ИСПОЛЬЗОВАНИЕМ ВЕКТОРИЗОВАННОГО МЕТОДА ФАЗОВЫХ ТРАЕКТОРИЙ

1.1 Исходные уравнения, особые точки, анализ устойчивости “в малом”

В качестве объекта исследования рассмотрим некоторую “абстрактную” САР, математическая модель динамики которой описывается следующей системой нелинейных дифференциальных уравнений в форме Коши:
(1.1)
Особые точки находятся из системы (1.1) при равных нулю левых частях уравнений динамики (условия стационара). Данная динамическая система имеет 3 (три) особых точки:
1-я точка ==> (0, 0) ==> тривиальное решение;
2-я точка ==> (1, 0.5);
1-я точка ==> (1, - 0.5).
;Для анализа типа особых точек (устойчивое или неустойчивое равновесие) обычно используют линеаризацию уравнений динамики в особой точке и рассматривают поведение линеаризованной системы в малой окрестности особой точки:
(1.2)
где :
- малые отклонения от особой точки;
- координаты особой точки,
а коэффициенты [image] вычисляются по соотношениям:
(1.3)
Оценку типа особых точек выполним на основании корней характеристического уравнения, которое для системы (1.2) записывается в матричном виде:

Преобразуя определитель, получаем характеристическое уравнение в виде:
(1.4)
Вычислим корни уравнения (1.4) для каждой особой точки…
Для 1-ой особой точки коэффициенты равны: а 11 = 0; а 12 = 0; а 21 = 0; а 22 = 1. Тогда характеристическое уравнения принимает вид [image] По структуре это уравнение соответствует неустойчивому инерционно-интегрирующему звену. Корни уравнения равны 0 и 1 (1-ый - в начале координат; 2-ой корень - в правой полуплоскости,). Такое расположение корней не обсуждалось в лекциях при анализе типов особых точек…??!
С резюме пока не совсем ясно: с одной стороны положительный корень вроде бы “намекает”, что1-я точка является неустойчивой особой точкой “в малом”, а с другой стороны есть сомнения… Оставим выяснение истины “на потом”…, точнее на этап анализа результатов прямого расчета фазовых траекторий.
Для 2-ой особой точки коэффициенты равны: а 11 = -2; а 12 = 4; а 21 = -0.5; а 22 = 0. Характеристическое уравнения принимает вид [image] Корни этого уравнения равны (-1 ± i), т.е. корни комплексно-сопряженные и лежат в левой полуплоскости.
Резюме: 2-я точка является устойчивой “в малом” ==> устойчивый фокус.
Для 3-ой особой точки коэффициенты равны: : а 11 = -2; а 12 = - 4; а 21 = 0.5; а 22 = 0. Характеристическое уравнения принимает такой же вид, что и для 2-ой точки ( [image]), поэтому корни уравнения равны (-1 ± i)…
Резюме: 3-я точка является устойчивой “в малом” ==> устойчивый фокус.

(к содержанию)

1.2 Анализ движения автономной системы на фазовой плоскости

Используя освоенные Вами в предыдущей лабораторной работе методы структурного моделирования для решения обыкновенных дифференциальных уравнений, Вы можете выполнить в среде ПК “МВТУ” решение системы уравнений (1.1). Поскольку система уравнений (1.1) описывает динамическуюсистему 2-го порядка, то для формирования структурной схемы необходимо 2 блока Интегратор. “Легко” видеть (см. систему (1.)), что в структурной схеме должны быть 2 блока Сумматор, 1 блок Умножение и 2 блока Квадратичная функция…
Сформируйте структурную схему для решения системы уравнений (1.1). Вид структурной схемы должен быть аналогичным рис. 1.1.

Рис. 1.1

Установите в диалоговых окнах блоков Интегратор начальные условия: для переменной х 1 , равное –1, а для переменной х 2 , равное 1 ==> Эти начальные условия соответствуют “стартовой” точке (-1, 1) на фазовой плоскости при t = 0.
Выполните моделирование переходного процесса при конечном времени расчета 10 с. Фазовая траектория (см. рис. 1.2 ниже по тексту) “стартовав” из точки (-1, 1) асимптотически “накрутится” на 2-ю особую точку (1, 0.5), подтвердив ранее сделанный вывод о типе этой особой точки (устойчивый фокус).
Измените начальное условие для переменной для переменной х 2 на равное -1 ==> Эти начальные условия соответствуют новой “стартовой” точке (-1, -1) на фазовой плоскости при t = 0.
Выполните моделирование переходного процесса при конечном времени расчета 10 с. Фазовая траектория (см. рис. 1.3 ниже по тексту) “стартовав” из точки (-1, -1) асимптотически “накрутится” на 3-ю особую точку (1, -0.5), подтвердив ранее сделанный вывод о типе этой особой точки (устойчивый фокус).
Варьируя начальные условия, можно построить и другие фазовые траектории. Однако, если Вы желаете построить большое число фазовых траекторий для разных начальных условий, то процесс варьирования может значительно затянуться, а кроме того “свести” все траектории на один график будет далеко не просто… Поэтому преобразуем структурную схему на рис. 1.1 (проще сформировать новую) и реализуем расчет фазовых траекторийв векторизованном варианте…

Рис .1.2

Рис .1.3

Поскольку практически все типовые блоки в ПК “МВТУ” векторизованы, т.е. могут реализовывать преобразование векторных входных сигналов, придайте скорректированной структурной схеме вид, аналогичный рис. 1.4.

Рис. 1.4

Коррекция фактически свелась к замене типовых блоков Сумматор на блоки Векторный сумматор и типового блока Умножение на блок Векторное умножение. Типовые блоки Интегратор и Квадратичная функция не требуют замены, так как они являются векторизованными…
Для одновременного построения большого числа фазовых траекторий необходимо выбрать рассматриваемую часть фазовой плоскости. Пусть [image] а
В рассматриваемой области зададим 20 “стартовых” точек, координаты которых приведены в табл. 1.

Таблица 1
№ | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20
х1 | -1 | 0 | 1 | 2 | -1 | 0 | 1 | 2 | -1 | 0 | 1 | 2 | -1 | 0 | 1 | 2 | -1 | 0 | 1 | 2
х2 | 2 | 2 | 2 | 2 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | -1 | -1 | -1 | -1 | -2 | -2 | -2 | -2

Вектора начальных условий для переменных х1 и х2 сформируем как глобальные параметры в окне Редактора Глобальных параметров Проекта…
На рис. 1.5 приведена экранная копия окна Редактора… с введенными данными…

Рис. 1.5

Переместите курсор на командную кнопку Параметры макроблока в Дополнительной панели инструментов (крайняя слева), выполните щелчок левой клавишей “мыши” и в открывшемся окне Редактора… введите вектора х1 и х2. Сформировав вектора х1 и х2, вернитесь в Главное схемное окно.
Откройте диалоговое окно блока Интегратор для переменной х1 и заполните его так же, как это показано на рис. 1.6.

Рис. 1.6

По аналогии заполните диалоговое окна блока Интегратор для переменной х2 .
Переместите курсор на командную кнопку Продолжить и запустите задачу на счет. Примерно через 1 с модельного времени появится специальное информационное окно, экранная копия которого приведена на рис. 1.7.

Рис. 1.7

Если сделать активным графическое окно, то вид всех (20-ти) фазовых траекторий будет подобным рис. 1.8.
Очевидно, что сообщение об ошибке обусловлено поведением фазовой траектории, “стартующей” из 9-ой точки (см. табл. 1) с координатами (-1, 0), так как для данной фазовой траектории значение переменной х1 резко стремится к минус бесконечности…
Откройте окно Редактора… и измените 9-й элемент в векторе х1 с -1 на - 0.099.
Снова запустите задачу на счет и убедитесь, что теперь сообщения об ошибке нет.
Семейство фазовых траекторий образовало фазовый портрет, вид которого должен быть близким рис. 1.9 и свидетельствовать, что фазовые траектории, “стартующие” строго в верхней полуплоскости “притягиваются” к 2-ой особой точке (1, 0.5), а “стартующие” строго из нижней полуплоскости – к 3-ей особой точке (1, - 0.5).

Рис. 1.8

Рис. 1.9

Фазовые траектории, “стартующие” из точек (1, 0) и (2, 0) с нарастающим замедлением притягиваются (??!) к 1-ой особой точке (0, 0), а фазовая траектория, “стартующая” из точки (-0.099, 0) сначала почти неподвижна, а в конце моделирования с нарастающим ускорением устремляется в минус бесконечность.
Внимание: чтобы успеть увидеть вышеописанное “своими глазами”, рекомендуются установить в диалоговом окне Параметры расчета Режим реального времени…
Расширим рассматриваемую часть фазовой плоскости. Для этого откройте окно Редактора … и добавьте к каждому числу в векторных переменных х1 и х2 по одному “лишнему” нулю, т.е. умножьте каждое число на 10 (кроме 9-го элемента в векторе х1).
Снова запустите задачу на счет. По окончании расчета придайте графическому окну вид, подобный рис. 1.10.

Рис. 1.10

Подведем итоги выполненного исследования.
Практически вся фазовая плоскость (кроме отрицательной оси абсцисс) является областью “устойчивых” фазовых траекторий, т.е. траектории “накручиваются” на 2-ю или 3-ю особые точки.
Поэтому, вернемся к оставленному “на потом” вопросу о типе 1-ой особой точки. Можно сделать следующее заключение: только при отклонении системы в 1-ой особой строго в отрицательную сторону по оси абсцисс нелинейная никогда не вернется в какое-то равновесное состояние.

(к содержанию)

2. КРИТЕРИЙ В.М. ПОПОВА ДЛЯ АНАЛИЗА УСТОЙЧИВОСТИ САР

2.1. О критерии абсолютной устойчивости В.М. Попова

Одним из точных методов (критериев) анализа устойчивости нелинейных САР, не утративших свою актуальность и в настоящее время, является критерий абсолютной устойчивости В.М. Попова.
Напомним основные положения критерия абсолютной устойчивости В.М. Попова.
В этом критерии нелинейная САР условно разделена на чисто линейную часть, обычно расположенную в прямой цепи, и чисто нелинейную часть, обычно расположенную в цепи обратной связи (см. рис. 2.1 ниже по тексту).

Рис. 2.1

В “классическом” варианте доказательства данного критерия принят ряд допущений:

  1. Нелинейная часть – безинерционна.
  2. Статическая характеристика нелинейной части является однозначной (без гистерезиса) и вписывается в Гурвицев угол К(0 < K < оо).
  3. Линейная часть должна быть устойчивой, или в особых случаях иметь не более 2-х полюсов, расположенных на мнимой оси, при всех остальных полюсах передаточной функции, расположенных в левой полуплоскости.
  4. В особых случаях должна иметь место предельная устойчивость.
  5. В.М. Попов ввел понятие видоизмененной АФЧХ, обозначаемой обычно [image] и определяемой соотношениями:
    ,
    где [image] [image] - действительная и мнимая части АФЧХ линейной части, соответственно.
Существуют аналитическая и геометрическая формулировки абсолютной устойчивости по В.М. Попову.
Более наглядной является геометрическая формулировка.
Для того, чтобы имела место абсолютная устойчивость в угле [0; К] в основном и в угле [eps; К] (где eps – бесконечно малое положительное число) в особых случаях, достаточно, чтобы в плоскости [image] можно было выбрать прямую, проходящую через точку действительной оси с абсциссой –1/K так, чтобы годограф [image] весь лежал строго справа от этой прямой и чтобы, кроме того, в особых случаях имела место предельная устойчивость.
На рис. 2.2 ниже по тексту представлена графическая иллюстрация критерия Попова при анализе устойчивости нелинейной САР, где пунктирной линией представлен традиционный годограф Найквиста (годограф АФЧХ) для линейной части САР (W_лин), сплошной линией представлен видоизмененный годограф Попова, а точка на оси абсцисс с координатой -1/K (K – Гурвицев угол) расположена левее точки пересечения годографа Попова с осью абсцисс.
Очевидно, что через точку -1/К можно провести множество прямых…
На рис. 2.2 одна из множества прямых проведена так, что видоизмененный годограф Попова лежит строго справа от этой прямой.
Резюме: нелинейная САР абсолютно устойчива.

Рис. 2.2

На этом завершим краткое изложение основных положений критерия В.М. Попова и перейдем непосредственно к выполнению лабораторной работы…

(к содержанию)

2.2. Преобразование линейной САР в нелинейную

Нелинейную САР, анализ которой будет выполнен с использованием критерия абсолютной устойчивости В.М. Попова, получим редактированием структурной схемы, созданной Вами при выполнении анализа устойчивости САР с запаздыванием в начале предыдущей лабораторной работы (см. рис. 2.3)

СТРУКТУРНАЯ СХЕМА САР

Рис. 2.3

Объект управления с передаточной функцией W_2 (s), соответствует типовому звену (колебательному) с параметрами:
k2 = 1.0; T2 = 1 c; параметр демпфирования b = 0.5; начальные условия - нулевые.
Местная обратная связь с передаточной функцией W_3 (s), соответствует типовому звену - апериодическому 1-го порядка с параметрами: k3 = 0.6; T3 = 5 c.
Локальное сравнивающее устройство обеспечивает отрицательную обратную связь, т.е. “работает” в режиме обычного вычитания.
Удалите линию связи между Главным сравнивающим устройством и блоком с подписью W_1(s), а также подписи под обоими Сравнивающими устройствами (удаление подписи – процедура, обратная вводу подписи…).
Используя процедуры “перетаскивания” блоков, освободите место для вставки в структурную схему САР нового нелинейного блока (см. рис. 2.4 ниже по тексту).
Инициализируйте библиотеку Нелинейные звенья и перенесите в Схемное окно типовой блок Релейное неоднозначное с зоной нечувствительности. Сделайте под этим блоком поясняющую подпись (Управляющее реле), соедините его линиями связи с соседними блоками.
Откройте диалоговое окно блока Управляющее реле и введите в 1-ой диалоговой строке следующие шесть параметров (через пробел): -0.02 -0.02 0.02 0.02 -1 1. Фактически нелинейный блок, добавленный в структурную, реализует однозначную нелинейность типа Релейная с зоной нечувствительности. Закройте диалоговое окно щелчком по кнопке Да.
Откройте диалоговое окно блока Интегратор (блок с подписью W_1(s)) и установите “оптимальное” значение коэффициента k1 = 0.35.
Инициализируйте библиотеку Субструктуры и перенесите в Схемное окно еще один типовой блок В память. Измените имя переменной на новое: Вход_2. Подсоедините этот блок к линии связи (см. рис. 2.4).

Рис. 2.4

(к содержанию)

2.3. Формулировка заданий к анализу устойчивости нелинейной САР

  1. Используя критерий абсолютной устойчивости В.М. Попова, определить скоростную эффективность интегрирующего регулятора (блок с подписью W_1(s)), при которой созданная нелинейная САР (см. рис. 2.4) будет абсолютно устойчивой.
  2. Определить тип устойчивости нелинейной САР, используя прямое моделирование переходного процесса в автономной системе при ненулевых начальных условиях.
  3. Выполнить расчет переходного процесса в САР (нулевые начальные условия) при подаче управляющего воздействия, равного 0.8*1(t).

(к содержанию)

2.4. А можно ли использовать критерий В.М. Попова?

Проверим, удовлетворяет ли нелинейная часть нелинейной САР (созданной Вами) приведенным выше допущениям (см. пункты 1…4 в подразделе 2.1).
Для нелинейной части системы:
Типовое нелинейное звено, внесенное Вами в структурную схему “исполняет роль” нелинейной части САР и, несомненно, является безинерционным (см. справку по данному блоку).
Статическая характеристика нелинейной части (нелинейного звена с введенными Вами его параметрами) не имеет гистерезиса, т.е. является однозначной и ее статическая характеристика вписывается в Гурвицев угол [0; 50] (т.к. 1/ 0.02 = 50 = К).
Для линейной части системы:
Линейная часть САР, расположенная между точками подключения переменных Вход_2 и Выход, соответствует варианту особого случая, так как она имеет один нулевой полюс (за счет блока Интегратор) при всех остальных полюсах, расположенных в левой полуплоскости (информация из лабораторной работы № 2 в прошлом семестре).
Для линейной части с введенным Вами значением скоростной эффективности привода (k1 = 0.35) существует предельная устойчивость, т.е. при замыкании линейной части отрицательной жесткой обратной связью с бесконечно малым коэффициентом усиления САР несомненно будет устойчивой.
Последнее уверенное резюме основано на результатах лабораторной работы № 2 из прошлого семестра, в которой Вы показали, что при замыкании скорректированной линейной части даже единичной обратной связью САР является устойчивой. Поэтому при меньшем коэффициенте усиления в цепи Главной обратной связи скорректированная линейная САР в замкнутом состоянии тем более будет устойчивой.

(к содержанию)

2.5. Анализ устойчивости с использованием критерия В.М. Попова

Приведите созданную Вами нелинейную САР к автономной. Для этого установите нулевую высоту “ступеньки” в диалоговом окне блока Управляющее воздействие.
Разомкните цепь Главной обратной связи, установив в диалоговом окне Главного сравнивающего устройства нулевое значение 2-го весового коэффициента.
Выполните щелчок “мышью” по кнопке Старт (структурная схема разомкнутой нелинейной САР инициализировалась) и затем по кнопке Стоп (расчет прерван).
Посредством опции Частотный анализ в командном меню Анализ откройте диалоговое окно Параметры частотного анализа и заполните его. Для этого переместите курсор на кнопку Годографов и выполните щелчок левой клавишей “мыши”: откроется графическое окно с заголовком Годографы и изменится форма диалогового окна. Переместите курсор на крайнюю левую кнопку с символом “+” и выполните два щелчка левой клавишей “мыши”: в таблице появятся две новые строки с номерами 1 и 2. Переместите курсор на ячейку Входы 1-ой строки, выполните щелчок левой клавишей “мыши”, нажмите на появившуюся в этой ячейке таблицы специальную кнопку и из списка переменных выберите Вход_2. Повторите аналогичные действия для ячейки Входы во 2-й строке таблицы.
По аналогии с предыдущим заполните 2-й и 3-й столбцы таблицы (см. рис. 2.5).

Рис. 2.5

Переместите курсор на кнопку Расчет и выполните щелчок левой клавишей “мыши”: в поле Графического окна начнется отображение результатов расчета и заголовок окна изменится на новый – Годограф Попова, Годограф Найквиста. Вид линий годографов в поле Графического окна будет подобным графикам на рис. 2.6 ниже по тексту.

Рис. 2.6

Используя опцию Свойства меню Графического окна измените в диалоговом окне Настройка параметры осей координат, имя и тип линии годографа Найквиста (синяя сплошная на рис. 2.6) на пунктирный.
Для изменения имени и типа линии годографа Найквиста переместите курсор в диалоговом окне Настройка (см. рис. 2.7 ниже по тексту) на специальную кнопку (в поле которой текст График 1), выполните щелчок “мышью” и из списка выберите График 2. Удалите текст График 2 и введите новый текст Годограф Найквиста. Переместите курсор на специальную кнопку, расположенную чуть ниже, выполните щелчок “мышью” и далее выберите новый тип линии – пунктирный.

Рис. 2.7

Аналогичным образом можно присвоить уникальное имя и линии с именем График 1 на новое – Годограф Попова. Измените параметры осей координат, как это выполнено в диалоговом окне Настройка ниже по тексту на рис. 2.8.

Рис. 2.8

Переместите в диалоговом окне Настройка курсор на кнопку Да и выполните щелчок левой клавишей “мыши”: преобразованное графическое окно с линиями годографа Попова (черная сплошная) и годографа Найквиста (синяя пунктирная) будут иметь вид, аналогичный рис. 2.9.

Рис. 2.9

Одновременное отображение графиков годографа Найквиста и видоизмененного годографа Попова (см. рис. 2.6 и рис. 2.9) показывает, что при одном и том же значении частоты вещественные части у обоих годографов одинаковые. Поэтому точки пересечения линий этих годографов с осью абсцисс совпадают. Это позволяет во многих случаях использовать для анализа устойчивости нелинейных САР не видоизмененный годограф, а годограф Найквиста…
При частоте стремящейся к нулю годограф Попова стремится в точку с координатами(b1 – a1 × b0 , - b0), где коэффициенты a1 , b0 и b1 - коэффициенты передаточной функции линейной части САР, определяемой выражением

.

Выясним, можно ли провести через точку с координатами (-1/K, 0), где К = 50 – верхняя граница Гурвицева угла, прямую так, чтобы годограф Попова лежал строго справа от этой прямой.
Из рис. 2.9 видно, что точка с абсциссой –0.02 лежит внутри годографа Попова и любая прямая, проведенная через эту точку, пересечет линию годографа Попова.
Этот результат свидетельствует о том, что рассматриваемая замкнутая автономная нелинейная САР (структурная схема которой получена вставкой дополнительного нелинейного звена в структурную схему устойчивой линейной САР) не будет абсолютно устойчивой…
Проверим это утверждение прямым моделированием…
Закройте диалоговое окно Параметры частотного анализа. Замкните Главную обратную связь и измените начальные условия в блоке с подписью W_2(s) на новые: 0.1 0 (через пробел).
Выполните щелчок по командной кнопке Продолжить: в поле Графического окна (блок с подписью График y(t)) будут отображены результаты расчета. Внешний вид переходного процесса будет подобным кривой на рис. 2.10.

Рис. 2.10

Вид переходного процесса показывает, что в автономной замкнутой нелинейной САР при ненулевых начальных условиях устанавливается режим приблизительно гармонических автоколебаний, амплитуда которых примерно в 25 раз превышает зону нечувствительности в блоке Управляющее реле(± 0.02).
Резюме:в данной нелинейной САР устанавливается режим относительно больших автоколебаний, поэтому САР не выполняет своих “обязанностей” (не удерживает стационарное состояние с погрешностью плюс/минус 2 %) и, следовательно такая система должна считаться практически неустойчивой. ==> Необходима новая коррекция САР…

(к содержанию)

2.6. Новая коррекция САР и определение типа устойчивости

Выполним новую коррекцию параметров рассматриваемой нелинейной САР.
Из графика годографа Попова следует (см. рис. 2.9 в подразделе 2.5): чтобы замкнутая нелинейная САР стала устойчивой, необходимо либо уменьшить приблизительно в 20 раз коэффициент скоростной эффективности (k1) в интегрирующем регуляторе, либо в такое же количество раз уменьшить высоту “ступеньки” в Управляющем реле.
Реализуем первый вариант.
Откройте диалоговое окно блока Интегратор и введите в 1-ой диалоговой строке 0.35/20 (0.35 делить на 20).
Такой тип ввода параметра звена основан на том, что диалоговые строки всех типовых блоков “распознают” около 30 простейших математических операций (и операцию Деление в том числе…).
Закройте диалоговое окно и щелкните “мышью” по кнопке Продолжить…
По завершении расчета 2-х кратным щелчком левой клавиши “мыши” в поле графика выполните автомасштабирование: вид графика (см. рис. 2.11 ниже по тексту) показывает, что с новым значением k1 автономная нелинейная САР асимптотически устойчива.
Начальное отклонение (0.1) относительно быстро устраняется и САР асимптотически возвращается в свое равновесное состояние (y_стационарное = 0).

Рис. 2.11

Резюме: скорректированная автономная нелинейная САР асимптотически устойчива.

(к содержанию)

2.7. Анализ устойчивости скорректированной нелинейной САР

Проверим вышеприведенный вывод об асимптотической устойчивости нелинейной САР, полученный на основании прямого моделирования переходного процесса в автономной системе при ненулевых начальных условиях…
Возвратите нулевые начальные условия в блоке W_2(s). Разомкните Главную обратную связь.
Выполните щелчок “мышью” по кнопке Старт (структурная схема разомкнутой нелинейной САР инициализировалась) и затем по кнопке Стоп (расчет прерван).
Используя опцию Частотный анализ из меню Анализ, откройте диалоговое окно Параметры частотного анализа и затем выполните в нем щелчок “мышью” по кнопке Расчет: произойдет расчет годографов при скорректированном значении k1 = 0.35/20.
Используя опцию Свойства графического окна (щелчок правой клавишей “мыши”), измените параметры осей координат так, как это выполнено на рис. 2.12.

Рис. 2.12

Точка пересечения годографа Попова с осью абсцисс расположена правее точки с абсциссой -1/К= - 0.02 (см. рис. 2.11).
Уточним, на сколько правее расположена точка пересечения годографа Попова с осью абсцисс.

Переместите курсор “мыши” в поле графика, выполните щелчок правой клавишей “мыши” и в появившемся меню выберите опцию Список: графическое окно сменится на таблицу результатов расчета.
Используя вертикальную “прокрутку”, найдите строку, наиболее близко соответствующую координатам пересечения годографа Попова с осью абсцисс, т.е. необходимо найти в таблице место, где мнимая часть (График 1) меняет знак с минуса на плюс. После выполнения Вами поиска окно с таблицей будет иметь вид, подобный рис. 2.13 ниже по тексту.

Рис. 2.13

Из таблицы следует, что при смене знака мнимой части вещественная часть (Re) равна приблизительно - 0.0198, т.е. больше, чем – 0.02.
Поэтому через точку пересечения несомненно можно провести прямую, относительно которой годограф Попова будет расположен строго справа.
Резюме: скорректированная нелинейная замкнутая САР абсолютно устойчива.
Переместите курсор в поле таблицы, выполните щелчок правой клавишей “мыши”, в появившемся меню выберите опцию Список: таблица сменится на график годографов.
Закройте диалоговое окно Параметры частотного анализа (щелчок по кнопке Да): на экране монитора снова Схемное окно.

(к содержанию)

2.8. Расчет переходных процессов при подаче управляющего воздействия

Выполним завершающий этап заданий, а именно: расчет переходных процессов в скорректированной нелинейной САР при подаче управляющего воздействия u(t) = 0.8*1(t).
Замкните Главную обратную связь (в диалоговом окне Главного сравнивающего устройства 2-ой весовой коэффициент должен быть равен -1).
Измените конечное время расчета на 200 с (щелчок “мышью” по командной кнопке Параметры расчета).
Выполните расчет переходного процесса (щелчок “мышью” по командной кнопке Продолжить).
График переходного процесса (см. рис. 2.14 ниже по тексту) свидетельствует, что скорректированная нелинейная САР отработала управляющее воздействие, однако время переходного процесса значительно больше (около 80 с), чем в лабораторной работе № 4 в прошлом семестре при k1 = 0.35 (там было менее 20 с).

Рис. 2.14

Выполните увеличение коэффициента скоростной эффективности регулятора k1 в 2 раза (в 1-ой диалоговой строке блока Интегратор введите 0.35/10).
Выполните щелчок “мышью” по командной кнопке Продолжить…
График переходного процесса в этом случае (см. рис. 2.15) свидетельствует, что в нелинейной САР установились высокочастотные(приблизительно гармонические) автоколебания с амплитудой примерно 0.05, что в 2.5 раза превышает ширину зону нечувствительности в Управляющем реле.

Рис. 2.15

Резюме: нелинейная САР “плохо” отработала управляющее воздействие потому, что при таком значении k1 (0.35/10) не выполняются условия критерия абсолютной устойчивости В.М. Попова (точка –1/K расположена внутри годографа Попова).
Сохраните данную задачу (нелинейную САР) под новым оригинальным именем, например, Нел_САР.mrj (посредством опции Сохранить как… из меню Файл).

На этом знакомство с критерием абсолютной устойчивости В.М. Попова и его программной реализацией в ПК “МВТУ” применительно к анализу устойчивости нелинейных САР, завершено.

(к содержанию)