ОПТИМИЗАЦИЯ ПАРАМЕТРОВ САР И МОДЕЛИРОВАНИЕ ЛОГИКИ АЛГОРИТМОВ АВАРИЙНОЙ ЗАЩИТЫ В САР ЯДЕРНОГО РЕАКТОРА

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 7
 ОПТИМИЗАЦИЯ ПАРАМЕТРОВ САР И МОДЕЛИРОВАНИЕ ЛОГИКИ АЛГОРИТМОВ АВАРИЙНОЙ ЗАЩИТЫ В САР ЯДЕРНОГО РЕАКТОРА

Москва, 2003 г.

Цель работы:

  • освоение процедур работы ПК «МВТУ» в режиме ОПТИМИЗАЦИЯ на примере синтеза оптимального интегрирующего регулятора;
  • изучение методов логического управления применительно к формированию алгоритмов аварийной защиты в системе управления и защиты (СУЗ) ядерного реактора;
  • самостоятельное исследование переходных процессов в нелинейной САР ядерного реактора (САР ЯР), включая:
    • корректировку математической модели рабочих процессов в активной зоне с учетом переменности параметров теплоносителя;
    • моделирование переходных процессов в САР ЯР с учетом алгоритмов аварийной защиты СУЗ.

Содержание:

  • Введение
  • 1. ПРОЦЕДУРЫ РАБОТЫ В РЕЖИМЕ ОПТИМИЗАЦИЯ
    • 1.1. Формулировка заданий на параметрическую оптимизацию САР
    • 1.2. Последовательность действий в режиме ОПТИМИЗАЦИЯ
    • 1.3. Задание варьируемого параметра как глобального
    • 1.4. Формирование локальных критериев оптимизации
    • 1.5. Заполнение диалоговых окон в режиме ОПТИМИЗАЦИЯ
    • 1.6. Проведение оптимизационного расчета
  • 2. МАТЕМАТИЧЕСКИЕ МОДЕЛИ ЛОГИЧЕСКИХ АЛГОРИТМОВ ЗАЩИТ И БЛОКИРОВОК В САР ЯДЕРНОГО РЕАКТОРА
    • 2.1. Общие сведения о системе управления и защиты ядерного реактора
  • 3. СТРУКТУРНАЯ СХЕМА И МАТЕМАТИЧЕСКИЕ МОДЕЛИ ДИНАМИКИ ЭЛЕМЕНТОВ САР ЯДЕРНОГО РЕАКТОРА
    • 3.1. Описание структурной схемы САР ядерного реактора
    • 3.2. Описание математических моделей блоков САР ядерного реактора

Загрузить бесплатную версию "МВТУ"(3.5 Мб)


ОПТИМИЗАЦИЯ ПАРАМЕТРОВ САР И МОДЕЛИРОВАНИЕ ЛОГИКИ АЛГОРИТМОВ АВАРИЙНОЙ ЗАЩИТЫ В САР ЯДЕРНОГО РЕАКТОРА

Министерство образования Российской Федерации
Московский государственный технический университет имени Н.Э. Баумана

Козлов О.С.

ДИСЦИПЛИНА: УПРАВЛЕНИЕ В ТЕХНИЧЕСКИХ СИСТЕМАХ

ЛАБОРАТОРНАЯ РАБОТА № 7

ОПТИМИЗАЦИЯ ПАРАМЕТРОВ САР И МОДЕЛИРОВАНИЕ ЛОГИКИ АЛГОРИТМОВ АВАРИЙНОЙ ЗАЩИТЫ В САР ЯДЕРНОГО РЕАКТОРА

Москва, 2003 г.

Цель работы:

  • освоение процедур работы ПК «МВТУ» в режиме ОПТИМИЗАЦИЯ на примере синтеза оптимального интегрирующего регулятора;
  • изучение методов логического управления применительно к формированию алгоритмов аварийной защиты в системе управления и защиты (СУЗ) ядерного реактора;
  • самостоятельное исследование переходных процессов в нелинейной САР ядерного реактора (САР ЯР), включая:
    • корректировку математической модели рабочих процессов в активной зоне с учетом переменности параметров теплоносителя;
    • моделирование переходных процессов в САР ЯР с учетом алгоритмов аварийной защиты СУЗ.

ВВЕДЕНИЕ

Здесь что-то будет написано…

(к содержанию)

1. ПРОЦЕДУРЫ РАБОТЫ В РЕЖИМЕ ОПТИМИЗАЦИЯ

1.1. Формулировка заданий на параметрическую оптимизацию САР

Во всех лабораторных работах по курсу «УТС» имеется обучающая часть, в которой Вы «по инструкции» знакомились с методами и процедурами исследования САР в среде ПК «МВТУ». В качестве объекта исследования в обучающей части лабораторных работ используется «базовая» САР, математическая модель динамики которой в виде структурной схемы имела вид, близкий рис. 1.1.

СТРУКТУРНАЯ СХЕМА САР

Pис. 1.1.

Объект управления с передаточной функцией W_2 (s), соответствовал типовому звену (колебательному) с параметрами: k2 = 1.0; T2 = 1 c; параметр демпфирования b = 0.5; начальные условия - нулевые.
Местная обратная связь с передаточной функцией W_3 (s), соответствовала типовому звену - апериодическому 1-го порядка с параметрами: k3 = 0.6; T3 = 5 c.
Локальное сравнивающее устройство обеспечивало отрицательную обратную связь, т.е. «работало» в режиме обычного вычитания.

Напомним заключительное задание в Вашей 1-ой учебной задаче.
Определить значение скоростной эффективности интегрирующего регулятора (коэффициента усиления k1 в блоке Интегратор), обеспечивающей перевод замкнутой линейной САР из состояния y = 0 при t = 0 в состояние y = 0.8 ± 0.04 (5-ти процентный допуск) при следующих ограничениях:
- время переходного процесса Т_пп, определяемое по факту входа регулируемой переменной в 5-ти процентную “трубку”, должно быть не более 20 секунд;
- переходной процесс должен проходить без перерегулирования (y_max <= 0.8).
Формулировка задания стилистически несколько отличается от “оригинала” (см. методические указания к лабораторной работе № 4), однако цели совпадают…
Формулировка задания стилистически несколько отличается от “оригинала” (см. методические указания к лабораторной работе № 4), однако цели совпадают…
Используя при выполнении 1-ой учебной задачи метод прямого моделирования, Вы всего за три “попытки ” (!? ) определили “оптимальное” значение скоростной эффективности регулятора ( k1 = 0.35 ), при котором переходной процесс в САР одновременно удовлетворял обоим вышеприведенным ограничениям…
Очевидно, что при отсутствии “рекомендаций” по варьированию значений параметра k1 , поиск “оптимального” значения мог бы существенно затянуться…
Если бы число варьируемых параметров в 1-ой учебной задаче было бы два (например, k1 и k3 ), то стратегия “ручного” поиска была бы далеко не очевидной…
В ПК “МВТУ” реализован режим работы ОПТИМИЗАЦИЯ, который позволяет выполнить автоматизированный поиск таких значений варьируемых параметров САР, при которых динамические характеристики САР (и переходной процесс, в частности) удовлетворяют одному или нескольким условиям (критериям) “оптимальности” .
Использование возможностей ПК “МВТУ” для решения задач оптимального управления и параметрической оптимизации рассмотрим в процессе выполнения очередной обучающей задачи, которую Вам предлагается выполнить опять же в режиме пошаговых инструкций…
Рассмотрим основные процедуры работы в режиме ОПТИМИЗАЦИЯ на примере “базовой” САР из 1-го учебного задания при тех же условиях оптимальности (по времени входа в 5-ти процентную “трубку” и по отсутствию перерегулирования)…

(к содержанию)

1.2. Последовательность действий в режиме ОПТИМИЗАЦИЯ

Приведем перечень основных этапов, которые необходимо выполнить в среде ПК “МВТУ” для реализации режима работы ОПТИМИЗАЦИЯ:

  • задать варьируемый(е) параметр(ы) как глобальный(е) параметр(ы), используя соответствующие интерфейсные процедуры;
  • сформировать локальные критерии качества (оптимизации), которые необходимы для решения основной задачи оптимизации;
  • ввести в диалоговые окна режима ОПТИМИЗАЦИЯ требуемые данные, включая:
    • имена варьируемых параметров, пределы их изменения и погрешность расчета;
    • имена локальных критериев и допустимые пределы их значений;
    • расчетный метод оптимизации и его параметры;
  • запустить задачу на счет и ждать….
Откройте проект, соответствующий 1-ой учебной задаче, и восстановите исходное состояние САР в замкнутом состоянии. Если проекта нет в числе сохраненных, Вы способны за несколько минут сформировать новый проект, близкий рис. 1.1.

(к содержанию)

1.3. Задание варьируемого параметра как глобального

Процедура задания глобального параметра выполняется в специальном окне с заголовком Редактор Глобальных параметров Проекта (Субмодели), открытие которого может быть выполнено 3-мя способами:

  • перемещением курсора на крайнюю слева командную кнопку (с подписью Параметры макроблока) Схемного окна и щелчком левой клавишей “мыши”;
  • нажатием клавиши F8 при активном Главном Схемном окне;
  • щелчком левой клавиши “мыши” по опции Параметры макроблока в дополнительном командном меню (вызываемого щелчком правой клавиши “мыши” в свободном месте Главного Схемного окна).
Открыв окно Редактор Глобальных параметров… любым из вышеописанных способов, введите с клавиатуры в поле окна текст: К=1 ;
На рис. 1.2 представлена копия окна Редактор Глобальных параметров… (уменьшенного по высоте), где текст в фигурных скобках – комментарий к введенному оптимизируемому параметру К .

Pис. 1.2.

Закройте окно Редактор Глобальных параметров…, щелкнув “мышью” по кнопке Применить (2-я справа).
Откройте диалоговое окно Интегратора (блок с подписью W_1(s) ) и измените значение коэффициента усиления, введя вместо 1 (числа) параметр К (символ).

(к содержанию)

1.4. Формирование локальных критериев оптимизации

Перенесите в Схемное Окно блоки Максимум (библиотека Нелинейные звенья) и В память (библиотека Субструктуры). Переместите их в левый нижний угол Схемного Окна (см. рис. 1.3 ниже по тексту), проведите необходимые линии связи и сделайте поясняющие подписи …
В диалоговом окне блока В память в строке Имя переменной введите ymax.
Закройте диалоговое окно блока В память .
Переместите курсор в свободное место Схемного окна, выполните щелчок правой клавишей “мыши” и в падающем командном меню Схемного окна выберите опцию Вставить субмодель: откроется специальное диалоговое окно Открытие субмодели .
Найдите в каталоге …\Demo\Lab_work файл time_p_p.sub и перенесите его имя в строку Имя файла. Закройте это окно, щелкнув по кнопке Открыть .
Переместите курсор в ту часть Схемного Окна, где должна быть расположена вставляемая субмодель (см. рис. 1.3), и сделайте щелчок левой клавишей “мыши”: в данном месте Схемного Окна появится субмодель “Измеритель” времени ПП (аббревиатура ПП – переходной процесс).

Pис. 1.3.

Переместите курсор на субмодель и выполните 2-х кратный щелчок левой клавиши “мыши”: откроется субмодельное Схемное Окно, экранная копия содержимого которого представлена на рис. 1.4 ниже по тексту.
Процедуру открытия субмодельного Схемного Окна можно выполнить и другим способом: при активном блоке Субмодель нажать клавишу Pg Dn.
Переместите курсор на блок с подписью Величина” трубки” и измените:
- в 1-ой диалоговой строке 0.05 на 0.04 , что соответствует 5 %-ной “трубке” от будущего установившегося значения регулируемой переменной, равного 0.8;
- во 2-ой диалоговой строке из двух вариантов Скаляр или Вектор выберите первый.
Закройте диалоговое окно блока с подписью Величина” трубки ”.
Переместите курсор на блок В память и, выполнив 2-х кратный щелчок левой клавиши “мыши”, откройте его диалоговое окно.
Введите в строке Имя переменной tpp . Закройте диалоговое окно этого блока.
Субмодель “Измеритель” времени ПП реализует измерение времени переходного процесса и автоматическое присвоение этого значения переменной tpp.
Схема работает следующим образом.

Pис. 1.4.

На средний (логический) входной порт Ключа-4А ( Величина “трубки”) подается модуль сигнала рассогласования.
Если этот сигнал больше уставки (5 % от 0.8), то на выход Ключа-4А передается сигнал с 3-го (нижнего) входного порта, т.е. текущее модельное время.
Если управляющий сигнал (на среднем входном порту) меньше уставки, то на выход Ключа-4А передается сигнал с 1-го (верхнего) входного порта, т.е. тот же сигнал, но задержанный на один шаг интегрирования.
 Задержку на 1 шаг интегрирования осуществляет типовой блок с подписью Время переходного процесса (типовой блок Задержка на шаг интегрирования из библиотеки Дискретные звенья ).
Закройте субмодель “Измеритель” времени ПП, выполнив 2-х кратный щелчок “мышью” в свободном месте субмодельного Схемного окна (только не под каким-либо блоком) или нажав на клавишу Pg Up.

(к содержанию)

1.5. Заполнение диалоговых окон в режиме ОПТИМИЗАЦИЯ

Переместите курсор на надпись Оптимизация в командном меню, выполните однократный щелчок левой клавишей “мыши” и в падающем меню выберите опцию Параметры. Откроется диалоговое окно Параметры оптимизации с активной (по умолчанию) закладкой Параметры (см. рис. 1.5).

Pис. 1.5.

Примечание. Вызов диалогового окна Параметры оптимизации можно было выполнить и другим способом: щелчком левой клавишей “мыши” по командной кнопке Параметры оптимизации в Панели инструментов Главного Окна (6-я справа).

Переместите курсор на специальную кнопку в правой части диалогового окна с изображением символа “ < ” и сделайте однократный щелчок левой клавишей “мыши”: откроется дополнительное диалоговое окно Глобальные константы проекта (см. рис. 1.6).

Pис. 1.6.

Поскольку в Вашем проекте (задаче) только одна глобальная константа (параметр К = 1), можно сразу щелкнуть по кнопке Да: это диалоговое окно закроется и появится снова предыдущее диалоговое окно, соответствующее закладке Параметры с заполненной строкой по параметру К .
Скорректируйте значение Максимума для К: введите вместо 1 число 2 . Значение точности определения параметра К (колонка Точность) оставьте без изменений ( 0.01 по умолчанию).
Если бы количество глобальных констант было бы, например, 4, а для решения оптимизационной задачи нужно только 3, то в дополнительном окне глобальных констант (параметров) необходимо сначала выбрать из списка требуемые параметры и только затем щелкнуть по кнопке Да. Процедура выделения будет описана ниже при выборе критериев оптимизации…
Переместите курсор на закладку Критерии и сделайте однократный щелчок левой клавишей “мыши”: откроется незаполненное диалоговое окно для задания локальных критериев оптимизации (аналогичное рис. 1.5).
Переместите курсор на специальную кнопку в правой части диалогового окна с изображением символа “ < ” и сделайте однократный щелчок левой клавишей “мыши”: откроется специальное диалоговое окно Глобальные переменные проекта (см. рис. 1.7).

Pис. 1.7.

Выделите в окне Список переменных те переменные, которые соответствуют локальным критериям оптимизации.
Процедура выделения выполняется в следующей последовательности: переместите курсор на строку с именем переменной, нажмите клавишу Shift и затем сделайте однократный щелчок левой клавишей “мыши”.
Повторите эту процедуру и для 2-го критерия оптимизации.
Переместите курсор на кнопку Да и сделайте щелчок левой клавишей “мыши”: это диалоговое окно закроется и появится диалоговое окно, соответствующее закладке Критерии с заполненными (по умолчанию) значениями Минимум и Максимум для каждого критерия оптимизации.
Скорректируйте значения в столбце Максимум, как это показано на рис. 1.8.

Pис. 1.8.

Значение Максимум для переменной tpp формирует требование по времени переходного процесса: не более 20 секунд.
 Значение Максимум для переменной ymax формирует требование по перерегулированию: его не должно быть, поэтому в столбце Максимум для переменной ymax введено значение 0.8.
Переместите курсор на закладку Метод и сделайте однократный щелчок левой клавишей “мыши”: откроется диалоговое окно, соответствующее данной закладке.
Выберите метод, максимальное число моделирований, вид свертки локальных критериев в Глобальный критерий и т.п., как это показано на рис. 1.9.

Pис. 1.9.

Выбранный Метод оптимизации ( Поиск-2), хотя и является одним из простейших алгоритмов прямого поиска минимума функционала (целевой функции), но обладает высоким быстродействием и эффективностью, особенно, в учебных задачах.
Заданное Максимальное число моделирований (200) вполне достаточно для поиска оптимума в задачах такого типа.
Выбранный Вид общего критерия ( Квадратичный) определяет, что локальные критерии ( tpp и ymax ) будут свернуты в Глобальный критерий с использованием квадратичной формы, причем значения весовых коэффициентов будут рассчитаны автоматически по ограничениям и точности для параметра К и локальных критериев.
Диалоговые строки Число серий случайных испытаний и Количество испытаний в одной серии заполняются только при использовании Стохастического метода.
Переместите курсор на кнопку Да и выполните щелчок левой клавишей “мыши”: диалоговое окно, соответствующее опции Параметры в меню Оптимизация закроется и на экране монитора снова появится Главное Схемное Окно.

(к содержанию)

1.6. Проведение оптимизационного расчета

Переместите курсор на командную кнопку Параметры счета, выполните щелчок левой клавишей “мыши” и в открывшемся диалоговом окне Параметры расчета измените метод интегрирования, например, на метод Рунге-Кутта. Запустите задачу на счет и убедитесь, что переходной процесс расходящийся.
Переместите курсор на командное меню Оптимизация, откройте его и выберите опцию Расчет : появится окно Результаты оптимизации, а в Графическом окне будут “мелькать” графики переходных процессов при варьировании параметра К.

Примечание. Запуск оптимизационного расчета можно выполнить и другим способом: щелчком левой клавиши “мыши” по командной кнопке Начать расчет оптимальных параметров в Панели инструментов Главного Окна .

Примерно через 2…5 секунд поиск завершится и информационное окно Результаты оптимизации примет вид, аналогичный рис. 1.10.

Pис. 1.10.

Изображение “оптимального” переходного процесса в Графическом окне после автомасштабирования (2-х кратный щелчок левой клавиши “мыши”…), редактирования заголовка графика и параметров оси ординат (посредством опции Свойства меню Графического окна…) будет иметь вид, близкий рис. 1.11.

Pис. 1.11.

Выполните щелчок левой клавиши “мыши” по кнопке Применить в окне Результаты оптимизации: это информационное окно закроется, а в окне Редактор Глобальных параметров Проекта (Субмодели) произойдет автоматическая замена исходного значения параметра К ( К=1;) на оптимальное ( К=0.4; ).
Откройте окно Редактор Глобальных параметров Проекта… щелчком левой клавиши “мыши” по кнопке Параметры макроблока в Панели инструментов Схемного окна и убедитесь, что произошла автоматическая замена исходного значения К на оптимальное…
Запустите задачу на расчет переходного процесса с новым значением К (щелчок по командной кнопке Продолжить) и убедитесь, что получившийся переходной процесс полностью соответствует поставленным условиям и ограничениям…
В проведенном оптимизационном расчете значение коэффициента скоростной эффективности К было найдено при его “стартовом” значении, равном 1.
Посмотрим, а изменится ли результат, при другом “стартовом” значении коэффициента скоростной эффективности К, например, К = 0.1.
Откройте окно Редактора… и измените “стартовое” значение К (введите К=0.1 ;).
Выполните оптимизационный расчет с новый “стартовым” значением К …
Результаты расчета (см. таблицу на рис. 1.12 и график переходного процесса на рис. 1.13) показывают, что требуемым критериям оптимизации (по ymax и tpp ) удовлетворяет и значение К, равное 0.3 . По-видимому, значение К = 0.3 соответствует (приблизительно) нижней границе диапазона “оптимальности”, а значение К = 0.4 – верхней границе диапазона. Результат 1-ой учебной задачи (К = 0.35) свидетельствует, что и между значениями 0.3 и 0.4 условие “оптимальности” также выполняется…

Pис. 1.12.

Pис. 1.13.
Сохраните задачу (проект) на диск под новым именем, например, dem_opt . mrj.
На этом обучающая часть лабораторной работы, посвященная освоению процедур работы в режиме ОПТИМИЗАЦИЯ, завершена…
Рекомендуем Вам рассмотреть ряд демонстрационных примеров по оптимизации параметров САР. Демонстрационные примеры расположены в подкаталоге …\Demo\Optim (проекты Opt_nl.mrj, Opt_pid.mrj, Opt_pidd.mrj).

(к содержанию)

2. МАТЕМАТИЧЕСКИЕ МОДЕЛИ ЛОГИЧЕСКИХ АЛГОРИТМОВ ЗАЩИТ И БЛОКИРОВОК В САР ЯДЕРНОГО РЕАКТОРА

2.1. Общие сведения о системе управления и защиты ядерного реактора

Функции оперативного управления ядерной энергетической установкой (в режимах нормальной эксплуатации и в аварийных ситуациях) выполняет Автоматизированная Система Управления Технологическими Процессами (АСУ ТП), включающая в себя значительное число отдельных систем автоматического управления и допускающая также участие в управлении и эксплутационного персонала (операторов).
Система Управления и Защиты (СУЗ), включающая в себя ряд отдельных систем, – важнейшая часть АСУ ТП ядерных энергетических установок. Основное назначение СУЗ – управление нейтронно-физическими процессами в ядерном реакторе с целью обеспечения заданных режимов эксплуатации при безусловном выполнении требований ядерной безопасности.
СУЗ контролирует поведение нейтронно-физических и теплотехнических параметров реактора и, при отклонении параметров (одного или нескольких) от условий нормальной эксплуатации, реализует срабатывание соответствующих подсистем защит и блокировок.
Формирование управляющих сигналов, по которым происходит включение соответствующих исполнительных механизмов СУЗ, выполняется с использованием алгоритмов логического управления. Реализация любого из этих алгоритмов основано на использовании операций сравнения (>, >=, <, <= и др.), типовых логических операций (AND, OR, NOT, XOR, NXOR ) и других логических преобразований.
Принципы реализации алгоритмов логического управления рассмотрим на примере формирования сигнала аварийной защиты (сигнала АЗ), при появлении которого должен произойти сброс стержней АЗ ==> быстрый ввод отрицательной реактивности ==> перевод реактора в подкритическое состояние ==> останов ядерного реактора.
Предположим, что появление сигнала аварийной защиты (равного 1 ) должно произойти, если:
- давление теплоносителя в 1-ом контуре больше 16.0 МПа
или
- температура теплоносителя на выходе из активной зоны больше 320 оС
или
нормированная нейтронная мощность больше 1.2
или период разгона (точнее период удвоения) меньше 10 секунд

(к содержанию)

3. СТРУКТУРНАЯ СХЕМА И МАТЕМАТИЧЕСКИЕ МОДЕЛИ ДИНАМИКИ ЭЛЕМЕНТОВ САР ЯДЕРНОГО РЕАКТОРА

3.1. Описание структурной схемы САР ядерного реактора

В рамках настоящей лабораторной работы рассмотрим упрощенную САР ядерного реактора (ЯР), структурная схема которой (экранная копия Главного Схемного Окна) представлена на рис. 3.1 и соответствует нелинейной САР релейного типа.

Структурная схема САР ядерного реактора

Рис. 3.1

Большинство звеньев в структурной схеме, представленной на рис. 3.1, - типовые блоки из Общетехнической библиотеки. Блок Кинетика нейтронов - из Специализированной библиотеки Кинетика нейтронов, блоки Привод СУЗ и Логика аварийной защиты - субмодели 1-го уровня вложенности.
В отличие от пердыдущих лабораторных работ и домашнего задания по курсу “Управление в технических системах”, где сигнал рассогласования подавался непосредственно на Электродвигатель Привода СУЗ, в данной САР сигнал рассогласования подается на Управляющее реле (типа релейное неоднозначное с зоной нечувствительности), которое при превышении уставок выдает сигнал управления на перемещение регулирующего стержня с постоянной скоростью вверх или вниз. Такое релейное управление существенно снижает износ исполнительного механизма СУЗ по сравнению со схемой непрерывного слежения за мощностью ЯР.
Блок Температурная обратная связь – оригинальный типовой динамический блок из библиотеки Динамические звенья ( “Новый” блок), позволяющий записать динамические уравнения и другие выражения с использованием встроенного в ПК “МВТУ” Интерпретатора математических функций.
Реактивности непосредственно ЯР, регулирующего стержня и температурного эффекта “сжимаются” посредством мультиплексора в векторный (3-х жильный) сигнал, затем векторно нормируются на эффективную долю запаздывающих нейтронов и отображаются на соответствующем Временном графике .
В цепь Главной обратной связи включен блок Запаздывание (типовой блок Идеальное запаздывающее звено), который моделирует временную задержку, связанную с обработкой показаний детекторов нейтронного потока.
В рамках проведения лабораторных работ № 4...6 и при выполнении Вами в 7-ом семестре домашнего задания внешнее возмущающее воздействие по реактивности было только ступенчатым (т.е. мгновенный скачок реактивности). В данной работе ввод возмущений по реактивности - линейный (с разной скоростью) с ограничением, что реализуют соответствующие блок и Ключ выкл./вкл. в верхней части схемы на рис. 3.1.
Главное сравнивающее устройство работает в режиме вычитания. Назначение остальных блоков на рис. 3.1 - очевидно и дополнительно “расшифровывается” пиктограммами и соответствующими подписями.
На рис. 3.2 представлено “содержание” субмодели Привод СУЗ, где блок Перемещение регулирующего стержня моделирует перемещение регулирующего стержня, блок Концевики (типовой блок Ключ интегратора из библиотеки Ключи) моделирует достижение верхнего или нижнего концевых выключателей, а блок Характеристика регулирующего стержня “переводит” координату нижнего конца стержня в реактивность, которую стержень внес в реактор. Входной порт и Выходной порт обеспечивают обмен данными с другими блоками в системе (см. рис. 3 .1).

Структурная схема Субмодели Привод СУЗ
Рис. 3.2

В настоящей лабораторной работе субструктура Логика аварийной защиты имеет только Входной и Выходной порты (соединенные между собой). Данная Субмодель “отключена” посредством задания в Главном Схемном Окне в блоке Сумматор (см. рис. 3.1) нулевого весового коэффициента по соответствующему входу. Набор структурной схемы Логики аварийной защиты будет выполнен в последней лабораторной работе, где данная Субмодель будет “отслеживать” нейтронную мощность, период разгона ядерного реактора и температуру теплоносителя на выходе из активной зоны с выдачей логического сигнала на сброс всех стержней аварийной защиты (режим АЗ-5) при превышении заданных уставок.

(к содержанию)

3.2. Описание математических моделей блоков САР ядерного реактора

В представленной на рис. 3.1 структурной схеме САР математические модели почти всех блоков соответствуют их описанию в справочной системе ПК “МВТУ” (при инициализированном блоке вызов справки осуществляется одновременным нажатием клавиш Ctrl и F1).
Поскольку динамика САР будет анализироваться, в основном, в нормированных отклонениях, для описания нейтронной кинетики целесообразнее использовать “классическую” модель точечной кинетики с 6-ю группами запаздывающих нейтронов. Принято допущение, что при t [image] 0 реактор находится в стационарном состоянии, поэтому при t = 0 на выходе блока Кинетика нейтронов [image] (0) = 0.
Блок Главное сравнивающее устройство реализует обычное вычитание, а 2-й блок Сумматор – алгебраическое сложение 4 входных сигнала.
Высота “ступеньки” в блоке Управляющее реле (релейное неоднозначное с зоной нечувствительности) равна 1.0 , а остальные параметры будут заданы преподавателем.
Динамика Температурной обратной связи описывается следующими уравнениями:
(3.1)
где:
N(t) - мощность реактора (абсолютная);
T(t) - температура топлива;
Tw - температура теплоносителя (в данной работе считается постоянной);
To - температура топлива в стационаре;
К - коэффициент, пропорциональный теплообмену между ядерным топливом и теплоносителем;
c, g, V - удельная теплоемкость, плотность и объем топлива, соответственно;
a, roc (t) - коэффициент реактивности и температурный эффект реактивности.
Описание моделей других блоков в Главном Схемном Окне наглядно иллюстрируется пиктограммами и не требует дополнительных пояснений.
Блок Перемещение регулирующего стержня (см. рис. 2.2) описывается следующим динамическим уравнением:
t пр × x’’(t) + x’(t) = k пр × u(t) , (3.2)
где x(t) = z(t) / H АЗ - относительное положение нижнего конца регулирующего стержня (x = 0 - стержень полностью погружен в активную зону, а x = 1 - стержень полностью выведен из активной зоны);
k пр , t пр - относительная скорость перемещения регулирующего стержня и постоянная времени, соответственно.
При t = 0 регулирующий стержень неподвижен и погружен в активную зону наполовину, т.е. x (0) = 0,5.
Блок Характеристика регулирующего стержня (см. рис. 3.2) описывается следующей безинерционной нелинейной зависимостью:
rст(х) = 0.5× rст* × sin(a×x + b) , (3.3)
где:
r ст* - физический “вес” регулирующего стержня;
a, b - константы, которые необходимо определить из условий:

 rст(0) = -  0.5×
 rст*;
rст(1) = + 0.5×
rст*.

(к содержанию)